summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndrew Andrianov <andrew@ncrmnt.org>2015-12-08 09:20:11 (GMT)
committerAndrew Andrianov <andrew@ncrmnt.org>2015-12-18 12:15:06 (GMT)
commitffdd5523155204c2b9f5b6d18344b7148ed6db0c (patch)
tree6a8756b06afd1b3d7ca8eed53f0d4736e1b04da6 /debian/rules
parent7f949eafaf8167855b7749910e1aa304f5316edb (diff)
Add initial debian packaging info
Signed-off-by: Andrew Andrianov <andrew@ncrmnt.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..7dff29c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#DH_VERBOSE = 1
+
+# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+
+# main packaging script based on dh7 syntax
+%:
+ MAKELEVEL=0 dh $@ --with autotools-dev
+
+# Make sure we call ./bootstrap before running dh_auto_configure
+override_dh_auto_configure:
+ ./bootstrap && dh_auto_configure
+
+#Make sure to include bash completion file in the package
+override_dh_auto_install:
+ MAKELEVEL=0 dh_auto_install
+ install -D ct-ng.comp $$(pwd)/debian/crosstool-ng/etc/bash_completion.d/ct-ng.comp