summaryrefslogtreecommitdiff
path: root/kconfig/Makefile.am
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2020-12-09 09:13:29 (GMT)
committerChris Packham <judge.packham@gmail.com>2021-02-02 07:06:32 (GMT)
commit21095fab6712d3a082936b14b93cb6ff29c02872 (patch)
tree287fba5c166e21ee2e2d8183a1a189f708b86858 /kconfig/Makefile.am
parentb16baed494d3c3fb66eeaaf9d8c1dbc7c6c0479f (diff)
kconfig: Sync with upstream v5.0
This commit introduces the following upstream changes: 2648ca1859bb kconfig: clean generated *conf-cfg files d86271af6460 kconfig: rename generated .*conf-cfg to *conf-cfg ba97df45581f kbuild: use assignment instead of define ... endef for filechk_* rules a5003571e627 kconfig: remove unused "file" field of yylval union f222b7f43661 kconfig: surround dbg_sym_flags with #ifdef DEBUG to fix gconf warning 3b541978562a kconfig: split images.c out of qconf.cc/gconf.c to fix gconf warnings 9abe42371b44 kconfig: add static qualifiers to fix gconf warnings cbafbf7f551c kconfig: split the lexer out of zconf.y 558e78e3ce84 kconfig: split some C files out of zconf.y 0c874100108f kconfig: convert to SPDX License Identifier 979f2b2f7936 kconfig: remove keyword lookup table entirely 4b31a32caf0a kconfig: update current_pos in the second lexer 824fa3b3b5e3 kconfig: switch to ASSIGN_VAL state in the second lexer b3d1d9d3c362 kconfig: stop associating kconf_id with yylval caaebb3c6de3 kconfig: refactor end token rules f5451582c4e2 kconfig: stop supporting '.' and '/' in unquoted words 171a515d0803 kconfig: use T_WORD instead of T_VARIABLE for variables c3d228713b10 kconfig: use specific tokens instead of T_ASSIGN for assignments ce2164ab5831 kconfig: refactor scanning and parsing "option" properties 3c8f317d4cf1 kconfig: use distinct tokens for type and default properties a01e5d242d93 kconfig: remove redundant token defines 4b5ec81bfeda kconfig: rename depends_list to comment_option_list 1f31be9ec0a9 kconfig: loosen the order of "visible" and "depends on" in menu entry 94d4e1b6021b kconfig: remove redundant menu_block rule 4891796c6f83 kconfig: remove redundant if_block rule 2f60e46e605a kconfig: remove grammatically ambiguous option_error 6900ae9eeee3 kconfig: remove grammatically ambiguous "unexpected option" diagnostic 723679339d08 kconfig: warn no new line at end of file 0bcc547ec4b0 kconfig: clean up EOF handling in the lexer cc66bca775ee kconfig: fix ambiguous grammar in terms of new lines 21c5ecf60472 kconfig: refactor pattern matching in STRING state be3c8075978a kconfig: remove unneeded pattern matching to whitespaces 413cd19d81fd kconfig: require T_EOL to reduce visible statement fbac5977d81c kconfig: fix memory leak when EOF is encountered in quotation 77c1c0fa8b14 kconfig: fix file name and line number of warn_ignored_character() 0cbe3ac439bf kconfig: remove k_invalid from expr_parse_string() return type 2aabbed6774f kconfig: remove S_OTHER symbol type and correct dependency tracking 1508fec82e39 kconfig: split out code touching a file to conf_touch_dep() 0849d212e395 kconfig: rename conf_split_config() to conf_touch_deps() 75889e9be78f kconfig: remove unneeded setsym label in conf_read_simple() a9b722847872 scripts/kconfig/merge_config: don't redefine 'y' to 'm' Signed-off-by: Chris Packham <judge.packham@gmail.com>
Diffstat (limited to 'kconfig/Makefile.am')
-rw-r--r--kconfig/Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/kconfig/Makefile.am b/kconfig/Makefile.am
index 0523ea9..8245606 100644
--- a/kconfig/Makefile.am
+++ b/kconfig/Makefile.am
@@ -9,22 +9,23 @@ EXTRA_DIST = zconf.y zconf.l \
expr.h list.h lkc.h lkc_proto.h nconf.h lxdialog/dialog.h \
confdata.c expr.c kconf_id.c menu.c symbol.c util.c
-CLEANFILES = zconf.lex.c zconf.c
-BUILT_SOURCES = zconf.c zconf.lex.c
+CLEANFILES = zconf.lex.c zconf.tab.c
+BUILT_SOURCES = zconf.lex.c zconf.tab.c
-AM_LFLAGS = -L -Pzconf
-AM_YFLAGS = -l -b zconf -p zconf
+AM_LFLAGS = -L
+AM_YFLAGS = -t -l
AM_CPPFLAGS = -include config.h -DCONFIG_=\"CT_\"
AM_LIBTOOLFLAGS = --tag CC
-conf_SOURCES = conf.c zconf.c
+conf_SOURCES = conf.c confdata.c expr.c symbol.c preprocess.c zconf.lex.c zconf.tab.c
conf_LDADD = $(LIBINTL)
-nconf_SOURCES = nconf.c nconf.gui.c zconf.c
+nconf_SOURCES = nconf.c nconf.gui.c confdata.c expr.c symbol.c preprocess.c zconf.lex.c zconf.tab.c
nconf_CFLAGS = $(CURSES_CFLAGS)
nconf_LDADD = $(MENU_LIBS) $(PANEL_LIBS) $(CURSES_LIBS) $(LIBINTL)
-mconf_SOURCES = mconf.c zconf.c lxdialog/checklist.c lxdialog/inputbox.c \
+mconf_SOURCES = mconf.c confdata.c expr.c symbol.c preprocess.c zconf.lex.c zconf.tab.c \
+ lxdialog/checklist.c lxdialog/inputbox.c \
lxdialog/menubox.c lxdialog/textbox.c lxdialog/util.c \
lxdialog/yesno.c
mconf_LDADD = $(CURSES_LIBS) $(LIBINTL)
@@ -42,8 +43,8 @@ AM_V_LEX = $(am__v_LEX_@AM_V@)
am__v_LEX_ = $(am__v_LEX_@AM_DEFAULT_V@)
am__v_LEX_0 = @echo " LEX " $@;
-zconf.c: zconf.y
- $(AM_V_YACC)$(YACCCOMPILE) -o$@ $<
+zconf.tab.c: zconf.y
+ $(AM_V_YACC)$(YACCCOMPILE) -o$@ --defines=zconf.tab.h $<
zconf.lex.c: zconf.l
$(AM_V_LEX)$(LEXCOMPILE) -o$@ $<