summaryrefslogtreecommitdiff
path: root/kconfig/Makefile.am
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2020-12-10 06:51:50 (GMT)
committerChris Packham <judge.packham@gmail.com>2021-02-02 07:06:32 (GMT)
commitacce58834d83602b5c97cb01f04c9f540e40792b (patch)
treed672f90c8bd4276c41369265a54cbb60d0d5a521 /kconfig/Makefile.am
parent31695dd2b00fc3daac109324992901fdcd6068e5 (diff)
kconfig: Sync with upstream v5.5
This commit introduces the following upstream changes: 272a72103012 kconfig: don't crash on NULL expressions in expr_eq() 46b2afa6890d kconfig: be more helpful if pkg-config is missing 5d8b42aa7ccb kconfig: Add option to get the full help text with listnewconfig a64c0440dda1 kbuild: Wrap long "make help" text lines 521b29b6ff53 kconfig: split util.c out of parser.y 60bef52c7a68 merge_config.sh: ignore unwanted grep errors 54b8ae66ae1a kbuild: change *FLAGS_<basetarget>.o to take the path relative to $(obj) 1634f2bfdb84 kbuild: remove clean-dirs syntax cdfca821571d merge_config.sh: Check error codes from make Signed-off-by: Chris Packham <judge.packham@gmail.com>
Diffstat (limited to 'kconfig/Makefile.am')
-rw-r--r--kconfig/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/kconfig/Makefile.am b/kconfig/Makefile.am
index 2db2615..a6d47fc 100644
--- a/kconfig/Makefile.am
+++ b/kconfig/Makefile.am
@@ -17,14 +17,14 @@ AM_YFLAGS = -t -l
AM_CPPFLAGS = -include config.h -DCONFIG_=\"CT_\"
AM_LIBTOOLFLAGS = --tag CC
-conf_SOURCES = conf.c confdata.c expr.c symbol.c preprocess.c lexer.lex.c parser.tab.c
+conf_SOURCES = conf.c confdata.c expr.c symbol.c preprocess.c util.c lexer.lex.c parser.tab.c
conf_LDADD = $(LIBINTL)
-nconf_SOURCES = nconf.c nconf.gui.c confdata.c expr.c symbol.c preprocess.c lexer.lex.c parser.tab.c
+nconf_SOURCES = nconf.c nconf.gui.c confdata.c expr.c symbol.c preprocess.c util.c lexer.lex.c parser.tab.c
nconf_CFLAGS = $(CURSES_CFLAGS)
nconf_LDADD = $(MENU_LIBS) $(PANEL_LIBS) $(CURSES_LIBS) $(LIBINTL)
-mconf_SOURCES = mconf.c confdata.c expr.c symbol.c preprocess.c lexer.lex.c parser.tab.c \
+mconf_SOURCES = mconf.c confdata.c expr.c symbol.c preprocess.c util.c lexer.lex.c parser.tab.c \
lxdialog/checklist.c lxdialog/inputbox.c \
lxdialog/menubox.c lxdialog/textbox.c lxdialog/util.c \
lxdialog/yesno.c