summaryrefslogtreecommitdiff
path: root/packages/gcc/11.2.0
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2022-02-11 02:00:59 (GMT)
committerAlexey Neyman <stilor@att.net>2022-02-11 08:47:51 (GMT)
commit86c2982568de1ad4d4cc12a65b19231331484405 (patch)
tree2e0b3fb78c30877c0c152d59d0e0fff817b73822 /packages/gcc/11.2.0
parent1210b0c2f45e32ef0867ca00e16b6aadb6a81bf9 (diff)
Run patches thru `manage-packages -P`
This refreshes the line numbers, removes any fuzz (which would make any future forward ports easier) and standardizes the patch/file headers (which makes them easier to read). Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/gcc/11.2.0')
-rw-r--r--packages/gcc/11.2.0/0005-libstdc-Add-nostdinc-for-c-17-sources-PR100017.patch15
-rw-r--r--packages/gcc/11.2.0/0009-Darwin-aarch64-Initial-support-for-the-self-host-dri.patch21
2 files changed, 9 insertions, 27 deletions
diff --git a/packages/gcc/11.2.0/0005-libstdc-Add-nostdinc-for-c-17-sources-PR100017.patch b/packages/gcc/11.2.0/0005-libstdc-Add-nostdinc-for-c-17-sources-PR100017.patch
index 8851e98..4a4daf6 100644
--- a/packages/gcc/11.2.0/0005-libstdc-Add-nostdinc-for-c-17-sources-PR100017.patch
+++ b/packages/gcc/11.2.0/0005-libstdc-Add-nostdinc-for-c-17-sources-PR100017.patch
@@ -43,15 +43,13 @@ libstdc++-v3/ChangeLog:
* src/c++17/Makefile.am (AM_CXXFLAGS): Add -nostdinc++.
* src/c++17/Makefile.in: Regenerate.
---
- libstdc++-v3/src/c++17/Makefile.am | 2 +-
- libstdc++-v3/src/c++17/Makefile.in | 2 +-
+ libstdc++-v3/src/c++17/Makefile.am | 2 +-
+ libstdc++-v3/src/c++17/Makefile.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
-diff --git a/libstdc++-v3/src/c++17/Makefile.am b/libstdc++-v3/src/c++17/Makefile.am
-index f08553a1dd78..3d53f652fac9 100644
--- a/libstdc++-v3/src/c++17/Makefile.am
+++ b/libstdc++-v3/src/c++17/Makefile.am
-@@ -79,7 +79,7 @@ endif
+@@ -79,7 +79,7 @@
# OPTIMIZE_CXXFLAGS on the compile line so that -O2 can be overridden
# as the occasion calls for it.
AM_CXXFLAGS = \
@@ -60,11 +58,9 @@ index f08553a1dd78..3d53f652fac9 100644
$(glibcxx_lt_pic_flag) $(glibcxx_compiler_shared_flag) \
$(XTEMPLATE_FLAGS) $(VTV_CXXFLAGS) \
$(WARN_CXXFLAGS) $(OPTIMIZE_CXXFLAGS) $(CONFIG_CXXFLAGS) \
-diff --git a/libstdc++-v3/src/c++17/Makefile.in b/libstdc++-v3/src/c++17/Makefile.in
-index 63984ecd52ad..8c02be6514f8 100644
--- a/libstdc++-v3/src/c++17/Makefile.in
+++ b/libstdc++-v3/src/c++17/Makefile.in
-@@ -455,7 +455,7 @@ libc__17convenience_la_SOURCES = $(sources) $(inst_sources)
+@@ -455,7 +455,7 @@
# OPTIMIZE_CXXFLAGS on the compile line so that -O2 can be overridden
# as the occasion calls for it.
AM_CXXFLAGS = \
@@ -73,6 +69,3 @@ index 63984ecd52ad..8c02be6514f8 100644
$(glibcxx_lt_pic_flag) $(glibcxx_compiler_shared_flag) \
$(XTEMPLATE_FLAGS) $(VTV_CXXFLAGS) \
$(WARN_CXXFLAGS) $(OPTIMIZE_CXXFLAGS) $(CONFIG_CXXFLAGS) \
---
-2.34.1
-
diff --git a/packages/gcc/11.2.0/0009-Darwin-aarch64-Initial-support-for-the-self-host-dri.patch b/packages/gcc/11.2.0/0009-Darwin-aarch64-Initial-support-for-the-self-host-dri.patch
index b237d9d..ab73edb 100644
--- a/packages/gcc/11.2.0/0009-Darwin-aarch64-Initial-support-for-the-self-host-dri.patch
+++ b/packages/gcc/11.2.0/0009-Darwin-aarch64-Initial-support-for-the-self-host-dri.patch
@@ -14,18 +14,16 @@ gcc/ChangeLog:
* config/aarch64/host-aarch64-darwin.c: New file.
* config/aarch64/x-darwin: New file.
---
- gcc/config.host | 7 ++++-
- gcc/config/aarch64/host-aarch64-darwin.c | 33 ++++++++++++++++++++++++
- gcc/config/aarch64/x-darwin | 3 +++
+ gcc/config.host | 7 +++++-
+ gcc/config/aarch64/host-aarch64-darwin.c | 33 +++++++++++++++++++++++++++++++
+ gcc/config/aarch64/x-darwin | 3 ++
3 files changed, 42 insertions(+), 1 deletion(-)
create mode 100644 gcc/config/aarch64/host-aarch64-darwin.c
create mode 100644 gcc/config/aarch64/x-darwin
-diff --git a/gcc/config.host b/gcc/config.host
-index 0a02c33cc80..81ff7ed1043 100644
--- a/gcc/config.host
+++ b/gcc/config.host
-@@ -99,7 +99,8 @@ case ${host} in
+@@ -99,7 +99,8 @@
esac
case ${host} in
@@ -35,7 +33,7 @@ index 0a02c33cc80..81ff7ed1043 100644
case ${target} in
aarch64*-*-*)
host_extra_gcc_objs="driver-aarch64.o"
-@@ -251,6 +252,10 @@ case ${host} in
+@@ -251,6 +252,10 @@
host_extra_gcc_objs="${host_extra_gcc_objs} driver-mingw32.o"
host_lto_plugin_soname=liblto_plugin.dll
;;
@@ -46,9 +44,6 @@ index 0a02c33cc80..81ff7ed1043 100644
i[34567]86-*-darwin* | x86_64-*-darwin*)
out_host_hook_obj="${out_host_hook_obj} host-i386-darwin.o"
host_xmake_file="${host_xmake_file} i386/x-darwin"
-diff --git a/gcc/config/aarch64/host-aarch64-darwin.c b/gcc/config/aarch64/host-aarch64-darwin.c
-new file mode 100644
-index 00000000000..d70f2df3bf1
--- /dev/null
+++ b/gcc/config/aarch64/host-aarch64-darwin.c
@@ -0,0 +1,33 @@
@@ -85,15 +80,9 @@ index 00000000000..d70f2df3bf1
+ exists just to include the generic config/host-darwin.h. */
+
+const struct host_hooks host_hooks = HOST_HOOKS_INITIALIZER;
-diff --git a/gcc/config/aarch64/x-darwin b/gcc/config/aarch64/x-darwin
-new file mode 100644
-index 00000000000..6d788d5e89c
--- /dev/null
+++ b/gcc/config/aarch64/x-darwin
@@ -0,0 +1,3 @@
+host-aarch64-darwin.o : $(srcdir)/config/aarch64/host-aarch64-darwin.c
+ $(COMPILE) $<
+ $(POSTCOMPILE)
---
-2.34.1
-