summaryrefslogtreecommitdiff
path: root/packages/gcc/8.5.0
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2022-02-11 02:00:59 (GMT)
committerAlexey Neyman <stilor@att.net>2022-02-11 08:47:51 (GMT)
commit86c2982568de1ad4d4cc12a65b19231331484405 (patch)
tree2e0b3fb78c30877c0c152d59d0e0fff817b73822 /packages/gcc/8.5.0
parent1210b0c2f45e32ef0867ca00e16b6aadb6a81bf9 (diff)
Run patches thru `manage-packages -P`
This refreshes the line numbers, removes any fuzz (which would make any future forward ports easier) and standardizes the patch/file headers (which makes them easier to read). Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/gcc/8.5.0')
-rw-r--r--packages/gcc/8.5.0/0002-gcc-plugin-Win-Dont-need-undefined-extern-var-refs-nor-fpic.patch6
-rw-r--r--packages/gcc/8.5.0/0005-fix-m68k-uclinux.patch2
-rw-r--r--packages/gcc/8.5.0/0010-crystax.patch6
-rw-r--r--packages/gcc/8.5.0/0012-crystax.patch10
-rw-r--r--packages/gcc/8.5.0/0013-crystax.patch2
-rw-r--r--packages/gcc/8.5.0/0015-crystax.patch2
-rw-r--r--packages/gcc/8.5.0/0022-ARC-Update-fma-expansions.patch12
7 files changed, 16 insertions, 24 deletions
diff --git a/packages/gcc/8.5.0/0002-gcc-plugin-Win-Dont-need-undefined-extern-var-refs-nor-fpic.patch b/packages/gcc/8.5.0/0002-gcc-plugin-Win-Dont-need-undefined-extern-var-refs-nor-fpic.patch
index 20a88df..11cb9e0 100644
--- a/packages/gcc/8.5.0/0002-gcc-plugin-Win-Dont-need-undefined-extern-var-refs-nor-fpic.patch
+++ b/packages/gcc/8.5.0/0002-gcc-plugin-Win-Dont-need-undefined-extern-var-refs-nor-fpic.patch
@@ -53,7 +53,7 @@
if test x"$have_pic_shared" != x"yes" -o x"$ac_cv_search_dlopen" = x"no"; then
--- a/gcc/configure
+++ b/gcc/configure
-@@ -29805,6 +29805,9 @@
+@@ -29872,6 +29872,9 @@
pluginlibs=
plugin_check=yes
@@ -63,7 +63,7 @@
case "${host}" in
*-*-mingw*)
# Since plugin support under MinGW is not as straightforward as on
-@@ -29827,6 +29830,11 @@
+@@ -29894,6 +29897,11 @@
export_sym_check=
fi
;;
@@ -75,7 +75,7 @@
*)
if test x$build = x$host; then
export_sym_check="objdump${exeext} -T"
-@@ -29939,23 +29947,23 @@
+@@ -30006,23 +30014,23 @@
case "${host}" in
*-*-darwin*)
CFLAGS=`echo $CFLAGS | sed s/-mdynamic-no-pic//g`
diff --git a/packages/gcc/8.5.0/0005-fix-m68k-uclinux.patch b/packages/gcc/8.5.0/0005-fix-m68k-uclinux.patch
index 02b53bd..4dd3260 100644
--- a/packages/gcc/8.5.0/0005-fix-m68k-uclinux.patch
+++ b/packages/gcc/8.5.0/0005-fix-m68k-uclinux.patch
@@ -10,7 +10,7 @@ Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
--- a/libgcc/config.host
+++ b/libgcc/config.host
-@@ -847,7 +847,7 @@
+@@ -857,7 +857,7 @@
m68k*-*-openbsd*)
;;
m68k-*-uclinux*) # Motorola m68k/ColdFire running uClinux with uClibc
diff --git a/packages/gcc/8.5.0/0010-crystax.patch b/packages/gcc/8.5.0/0010-crystax.patch
index 0e3e95c..ab6c01e 100644
--- a/packages/gcc/8.5.0/0010-crystax.patch
+++ b/packages/gcc/8.5.0/0010-crystax.patch
@@ -57,7 +57,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
esac
aarch64_multilibs="${with_multilib_list}"
if test "$aarch64_multilibs" = "default"; then
-@@ -2133,6 +2137,17 @@
+@@ -2142,6 +2146,17 @@
tm_file="dbxelf.h elfos.h gnu-user.h linux.h linux-android.h glibc-stdint.h ${tm_file} mips/gnu-user.h mips/linux.h mips/linux-common.h"
extra_options="${extra_options} linux-android.opt"
case ${target} in
@@ -172,7 +172,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
: min >= -256 && max < 256 \
--- a/gcc/config/arm/arm.md
+++ b/gcc/config/arm/arm.md
-@@ -8640,7 +8640,7 @@
+@@ -8698,7 +8698,7 @@
(match_operand:SI 2 "const_int_operand" "") ; total range
(match_operand:SI 3 "" "") ; table label
(match_operand:SI 4 "" "")] ; Out of range label
@@ -450,7 +450,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
#if ((defined(_LIBOBJC) || defined(_LIBOBJC_WEAK)) \
--- a/libstdc++-v3/configure
+++ b/libstdc++-v3/configure
-@@ -78491,6 +78491,18 @@
+@@ -78672,6 +78672,18 @@
/* end confdefs.h. */
#include <sys/syscall.h>
int lk;
diff --git a/packages/gcc/8.5.0/0012-crystax.patch b/packages/gcc/8.5.0/0012-crystax.patch
index 2bf6cc7..332e59f 100644
--- a/packages/gcc/8.5.0/0012-crystax.patch
+++ b/packages/gcc/8.5.0/0012-crystax.patch
@@ -26,7 +26,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
--- a/gcc/config.in
+++ b/gcc/config.in
-@@ -2219,6 +2219,12 @@
+@@ -2233,6 +2233,12 @@
#endif
@@ -127,7 +127,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
--- a/gcc/configure
+++ b/gcc/configure
-@@ -943,6 +943,7 @@
+@@ -944,6 +944,7 @@
enable_fix_cortex_a53_843419
with_glibc_version
enable_gnu_unique_object
@@ -135,7 +135,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
enable_linker_build_id
enable_libssp
enable_default_ssp
-@@ -1684,6 +1685,9 @@
+@@ -1685,6 +1686,9 @@
--enable-gnu-unique-object
enable the use of the @gnu_unique_object ELF
extension on glibc systems
@@ -145,7 +145,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
--enable-linker-build-id
compiler will always pass --build-id to linker
--enable-libssp enable linking against libssp
-@@ -28319,6 +28323,38 @@
+@@ -28383,6 +28387,38 @@
$as_echo "#define HAVE_LD_EH_FRAME_HDR 1" >>confdefs.h
@@ -186,7 +186,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
$as_echo "$gcc_cv_ld_eh_frame_hdr" >&6; }
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -5140,6 +5140,35 @@
+@@ -5147,6 +5147,35 @@
if test x"$gcc_cv_ld_eh_frame_hdr" = xyes; then
AC_DEFINE(HAVE_LD_EH_FRAME_HDR, 1,
[Define if your linker supports .eh_frame_hdr.])
diff --git a/packages/gcc/8.5.0/0013-crystax.patch b/packages/gcc/8.5.0/0013-crystax.patch
index 3454df0..c695798 100644
--- a/packages/gcc/8.5.0/0013-crystax.patch
+++ b/packages/gcc/8.5.0/0013-crystax.patch
@@ -12,7 +12,7 @@ Date: Thu Aug 20 19:11:07 2015 +0300
--- a/gcc/config/i386/i386.c
+++ b/gcc/config/i386/i386.c
-@@ -15971,6 +15971,7 @@
+@@ -15895,6 +15895,7 @@
else if (!SYMBOL_REF_FAR_ADDR_P (op0)
&& (SYMBOL_REF_LOCAL_P (op0)
|| (HAVE_LD_PIE_COPYRELOC
diff --git a/packages/gcc/8.5.0/0015-crystax.patch b/packages/gcc/8.5.0/0015-crystax.patch
index 2424d2b..d62a57b 100644
--- a/packages/gcc/8.5.0/0015-crystax.patch
+++ b/packages/gcc/8.5.0/0015-crystax.patch
@@ -15,7 +15,7 @@ Date: Mon Apr 14 21:05:51 2014 -0700
--- a/gcc/config/arm/arm.c
+++ b/gcc/config/arm/arm.c
-@@ -22619,9 +22619,13 @@
+@@ -22671,9 +22671,13 @@
memsize = MEM_SIZE (x);
/* Only certain alignment specifiers are supported by the hardware. */
diff --git a/packages/gcc/8.5.0/0022-ARC-Update-fma-expansions.patch b/packages/gcc/8.5.0/0022-ARC-Update-fma-expansions.patch
index c2680d5..380618f 100644
--- a/packages/gcc/8.5.0/0022-ARC-Update-fma-expansions.patch
+++ b/packages/gcc/8.5.0/0022-ARC-Update-fma-expansions.patch
@@ -18,13 +18,11 @@ gcc/testsuite
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@261543 138bc75d-0d04-0410-961f-82ee72b054a4
---
- gcc/config/arc/fpu.md | 6 ++++++
- gcc/testsuite/gcc.target/arc/fma-1.c | 13 +++++++++++++
+ gcc/config/arc/fpu.md | 6 ++++++
+ gcc/testsuite/gcc.target/arc/fma-1.c | 13 +++++++++++++
2 files changed, 19 insertions(+)
create mode 100644 gcc/testsuite/gcc.target/arc/fma-1.c
-diff --git a/gcc/config/arc/fpu.md b/gcc/config/arc/fpu.md
-index 5c56f76c679..66a4d91616f 100644
--- a/gcc/config/arc/fpu.md
+++ b/gcc/config/arc/fpu.md
@@ -64,6 +64,9 @@
@@ -47,9 +45,6 @@ index 5c56f76c679..66a4d91616f 100644
}")
(define_insn "fmasf4_fpu"
-diff --git a/gcc/testsuite/gcc.target/arc/fma-1.c b/gcc/testsuite/gcc.target/arc/fma-1.c
-new file mode 100644
-index 00000000000..c195ad98127
--- /dev/null
+++ b/gcc/testsuite/gcc.target/arc/fma-1.c
@@ -0,0 +1,13 @@
@@ -66,6 +61,3 @@ index 00000000000..c195ad98127
+ return (float)3.0 * b + a;
+}
+/* { dg-final { scan-assembler "fsmadd" } } */
---
-2.16.2
-