summaryrefslogtreecommitdiff
path: root/packages/gcc
diff options
context:
space:
mode:
authorSergey Korolev <s.korolev@ndmsystems.com>2017-11-05 19:14:33 (GMT)
committerSergey Korolev <s.korolev@ndmsystems.com>2017-11-27 15:20:47 (GMT)
commit64b273db83d407cf4aae146ba8f76afe044ba3ec (patch)
treeaa3a5a9a4d41500f9c808f6b9a7bffd0acdd33b6 /packages/gcc
parentfd64d3775c311e44165afc8e0e5d95a3f310f0a5 (diff)
gcc 7.2.0: fix 972-crystax.patch offsets
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/7.2.0/972-crystax.patch36
1 files changed, 18 insertions, 18 deletions
diff --git a/packages/gcc/7.2.0/972-crystax.patch b/packages/gcc/7.2.0/972-crystax.patch
index b9077be..f68fe1e 100644
--- a/packages/gcc/7.2.0/972-crystax.patch
+++ b/packages/gcc/7.2.0/972-crystax.patch
@@ -11,10 +11,10 @@ Date: Mon Apr 14 15:59:47 2014 -0700
Signed-off-by: Dmitry Moskalchuk <dm@crystax.net>
diff --git a/gcc/config.in b/gcc/config.in
-index 115cb6163..933916833 100644
+index 3fda578..ebe222c 100644
--- a/gcc/config.in
+++ b/gcc/config.in
-@@ -2119,6 +2119,12 @@
+@@ -2180,6 +2180,12 @@
#endif
@@ -28,7 +28,7 @@ index 115cb6163..933916833 100644
efficiently supported by the host hardware. */
#ifndef USED_FOR_TARGET
diff --git a/gcc/config/alpha/elf.h b/gcc/config/alpha/elf.h
-index 093c38bba..54b3e0c91 100644
+index c109b07..1ad7363 100644
--- a/gcc/config/alpha/elf.h
+++ b/gcc/config/alpha/elf.h
@@ -168,5 +168,9 @@ extern int alpha_this_gpdisp_sequence_number;
@@ -42,7 +42,7 @@ index 093c38bba..54b3e0c91 100644
#endif
+#endif
diff --git a/gcc/config/freebsd.h b/gcc/config/freebsd.h
-index 5ded869d2..5f51ac81d 100644
+index a272455..29d5a1a 100644
--- a/gcc/config/freebsd.h
+++ b/gcc/config/freebsd.h
@@ -45,8 +45,12 @@ along with GCC; see the file COPYING3. If not see
@@ -59,7 +59,7 @@ index 5ded869d2..5f51ac81d 100644
#ifdef TARGET_LIBC_PROVIDES_SSP
#define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all" \
diff --git a/gcc/config/gnu-user.h b/gcc/config/gnu-user.h
-index b0bf40a95..d1874bc29 100644
+index 2787a3d..be47428 100644
--- a/gcc/config/gnu-user.h
+++ b/gcc/config/gnu-user.h
@@ -118,8 +118,12 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
@@ -76,7 +76,7 @@ index b0bf40a95..d1874bc29 100644
#undef LINK_GCC_C_SEQUENCE_SPEC
#define LINK_GCC_C_SEQUENCE_SPEC \
diff --git a/gcc/config/openbsd.h b/gcc/config/openbsd.h
-index 37ecfc43f..a5f1b9955 100644
+index 1048e31..47044c5 100644
--- a/gcc/config/openbsd.h
+++ b/gcc/config/openbsd.h
@@ -136,8 +136,12 @@ while (0)
@@ -93,10 +93,10 @@ index 37ecfc43f..a5f1b9955 100644
#undef LIB_SPEC
#define LIB_SPEC OBSD_LIB_SPEC
diff --git a/gcc/config/rs6000/sysv4.h b/gcc/config/rs6000/sysv4.h
-index cbf909722..eb2217fad 100644
+index de38629..06d586a 100644
--- a/gcc/config/rs6000/sysv4.h
+++ b/gcc/config/rs6000/sysv4.h
-@@ -789,7 +789,11 @@ ENDIAN_SELECT(" -mbig", " -mlittle", DEFAULT_ASM_ENDIAN)
+@@ -805,7 +805,11 @@ ENDIAN_SELECT(" -mbig", " -mlittle", DEFAULT_ASM_ENDIAN)
-dynamic-linker " GNU_USER_DYNAMIC_LINKER "}}"
#if defined(HAVE_LD_EH_FRAME_HDR)
@@ -110,10 +110,10 @@ index cbf909722..eb2217fad 100644
#define CPP_OS_LINUX_SPEC "-D__unix__ -D__gnu_linux__ -D__linux__ \
diff --git a/gcc/config/sol2.h b/gcc/config/sol2.h
-index 5160e1fda..7632a5081 100644
+index 1ae7f9f..98c9482 100644
--- a/gcc/config/sol2.h
+++ b/gcc/config/sol2.h
-@@ -347,7 +347,11 @@ along with GCC; see the file COPYING3. If not see
+@@ -367,7 +367,11 @@ along with GCC; see the file COPYING3. If not see
/* Solaris 11 build 135+ implements dl_iterate_phdr. GNU ld needs
--eh-frame-hdr to create the required .eh_frame_hdr sections. */
#if defined(HAVE_LD_EH_FRAME_HDR) && defined(TARGET_DL_ITERATE_PHDR)
@@ -126,10 +126,10 @@ index 5160e1fda..7632a5081 100644
#endif
diff --git a/gcc/configure b/gcc/configure
-index 1c6e3407c..28ad05004 100755
+index 1d39548..f63716a 100755
--- a/gcc/configure
+++ b/gcc/configure
-@@ -934,6 +934,7 @@ enable_fix_cortex_a53_835769
+@@ -939,6 +939,7 @@ enable_fix_cortex_a53_835769
enable_fix_cortex_a53_843419
with_glibc_version
enable_gnu_unique_object
@@ -137,7 +137,7 @@ index 1c6e3407c..28ad05004 100755
enable_linker_build_id
enable_default_ssp
with_long_double_128
-@@ -1670,6 +1671,9 @@ Optional Features:
+@@ -1676,6 +1677,9 @@ Optional Features:
--enable-gnu-unique-object
enable the use of the @gnu_unique_object ELF
extension on glibc systems
@@ -147,7 +147,7 @@ index 1c6e3407c..28ad05004 100755
--enable-linker-build-id
compiler will always pass --build-id to linker
--enable-default-ssp enable Stack Smashing Protection as default
-@@ -27703,6 +27707,38 @@ if test x"$gcc_cv_ld_eh_frame_hdr" = xyes; then
+@@ -28050,6 +28054,38 @@ if test x"$gcc_cv_ld_eh_frame_hdr" = xyes; then
$as_echo "#define HAVE_LD_EH_FRAME_HDR 1" >>confdefs.h
@@ -187,10 +187,10 @@ index 1c6e3407c..28ad05004 100755
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $gcc_cv_ld_eh_frame_hdr" >&5
$as_echo "$gcc_cv_ld_eh_frame_hdr" >&6; }
diff --git a/gcc/configure.ac b/gcc/configure.ac
-index 6c1dcd9ae..0cf7419e7 100644
+index 1d5a9d7..736a534 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -4828,6 +4828,35 @@ GCC_TARGET_TEMPLATE([HAVE_LD_EH_FRAME_HDR])
+@@ -4981,6 +4981,35 @@ GCC_TARGET_TEMPLATE([HAVE_LD_EH_FRAME_HDR])
if test x"$gcc_cv_ld_eh_frame_hdr" = xyes; then
AC_DEFINE(HAVE_LD_EH_FRAME_HDR, 1,
[Define if your linker supports .eh_frame_hdr.])
@@ -228,7 +228,7 @@ index 6c1dcd9ae..0cf7419e7 100644
diff --git a/gcc/testsuite/g++.dg/eh/spec3-static.C b/gcc/testsuite/g++.dg/eh/spec3-static.C
new file mode 100644
-index 000000000..15408effa
+index 0000000..15408ef
--- /dev/null
+++ b/gcc/testsuite/g++.dg/eh/spec3-static.C
@@ -0,0 +1,25 @@
@@ -258,7 +258,7 @@ index 000000000..15408effa
+ catch (A& a) { }
+}
diff --git a/libgcc/crtstuff.c b/libgcc/crtstuff.c
-index f3343fc4f..d42647779 100644
+index c01f94b..00cab57 100644
--- a/libgcc/crtstuff.c
+++ b/libgcc/crtstuff.c
@@ -88,7 +88,8 @@ call_ ## FUNC (void) \