summaryrefslogtreecommitdiff
path: root/packages/gdb/10.2/0003-allow-android.patch
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2021-09-15 08:20:47 (GMT)
committerChris Packham <judge.packham@gmail.com>2021-09-15 08:20:57 (GMT)
commitf7e3d756271001782dafcffc311e76f146334993 (patch)
tree066ff738b0063888f411241e75534cb9f5e84c91 /packages/gdb/10.2/0003-allow-android.patch
parente5aaa1ca7a7876861d3b3900251c67d280bfafdf (diff)
parent8099a7475083e04429990c53cd490cda9eb63d68 (diff)
Merge branch 'gdb10-arc-fixes' of https://github.com/foss-for-synopsys-dwc-arc-processors/crosstool-ng
Signed-off-by: Chris Packham <judge.packham@gmail.com>
Diffstat (limited to 'packages/gdb/10.2/0003-allow-android.patch')
-rw-r--r--packages/gdb/10.2/0003-allow-android.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/packages/gdb/10.2/0003-allow-android.patch b/packages/gdb/10.2/0003-allow-android.patch
new file mode 100644
index 0000000..1d662fa
--- /dev/null
+++ b/packages/gdb/10.2/0003-allow-android.patch
@@ -0,0 +1,45 @@
+---
+ gdbserver/configure | 11 -----------
+ gdbserver/configure.ac | 11 -----------
+ 2 files changed, 22 deletions(-)
+
+--- a/gdbserver/configure
++++ b/gdbserver/configure
+@@ -10069,17 +10069,6 @@
+
+
+ case "${target}" in
+- *-android*)
+- # Starting with NDK version 9, <elf.h> actually includes definitions
+- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
+- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
+- # leading to conflicts with the defintions from <linux/elf.h>.
+- # This makes it impossible for us to include both <elf.h> and
+- # <linux/elf.h>, which means that, in practice, we do not have
+- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
+- # Therefore, do not try to auto-detect availability, as it would
+- # get it wrong on this platform.
+- ;;
+ *)
+ ac_fn_c_check_type "$LINENO" "Elf32_auxv_t" "ac_cv_type_Elf32_auxv_t" "#include <elf.h>
+
+--- a/gdbserver/configure.ac
++++ b/gdbserver/configure.ac
+@@ -155,17 +155,6 @@
+ ])
+
+ case "${target}" in
+- *-android*)
+- # Starting with NDK version 9, <elf.h> actually includes definitions
+- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
+- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
+- # leading to conflicts with the defintions from <linux/elf.h>.
+- # This makes it impossible for us to include both <elf.h> and
+- # <linux/elf.h>, which means that, in practice, we do not have
+- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
+- # Therefore, do not try to auto-detect availability, as it would
+- # get it wrong on this platform.
+- ;;
+ *)
+ AC_CHECK_TYPES([Elf32_auxv_t, Elf64_auxv_t], [], [],
+ #include <elf.h>