summaryrefslogtreecommitdiff
path: root/packages/glibc-linaro
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/glibc-linaro
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/glibc-linaro')
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0000-sparc-nptl.patch (renamed from packages/glibc-linaro/2.20-2014.11/100-sparc-nptl.patch)8
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0001-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch (renamed from packages/glibc-linaro/2.20-2014.11/101-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch)31
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0002-fix-signed-shift-overlow.patch (renamed from packages/glibc-linaro/2.20-2014.11/102-fix-signed-shift-overlow.patch)23
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0003-dl-openat64-variadic.patch (renamed from packages/glibc-linaro/2.20-2014.11/103-dl-openat64-variadic.patch)6
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0004-unused-variables.patch (renamed from packages/glibc-linaro/2.20-2014.11/104-unused-variables.patch)45
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0005-misleading-indentation.patch (renamed from packages/glibc-linaro/2.20-2014.11/105-misleading-indentation.patch)8
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0006-dl-open-array-bounds.patch (renamed from packages/glibc-linaro/2.20-2014.11/106-dl-open-array-bounds.patch)10
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0007-Fix-combreloc-test-BSD-grep.patch (renamed from packages/glibc-linaro/2.20-2014.11/140-Fix-combreloc-test-BSD-grep.patch)18
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0008-fix-rpc_parse-format.patch (renamed from packages/glibc-linaro/2.20-2014.11/920-fix-rpc_parse-format.patch)8
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0009-explicit-boolean.patch (renamed from packages/glibc-linaro/2.20-2014.11/930-explicit-boolean.patch)8
-rw-r--r--packages/glibc-linaro/2.20-2014.11/0010-nis-bogus-conditional.patch (renamed from packages/glibc-linaro/2.20-2014.11/940-nis-bogus-conditional.patch)8
11 files changed, 80 insertions, 93 deletions
diff --git a/packages/glibc-linaro/2.20-2014.11/100-sparc-nptl.patch b/packages/glibc-linaro/2.20-2014.11/0000-sparc-nptl.patch
index 21f0337..4c5a10e 100644
--- a/packages/glibc-linaro/2.20-2014.11/100-sparc-nptl.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0000-sparc-nptl.patch
@@ -1,5 +1,7 @@
-diff --git a/sysdeps/sparc/sparc32/sem_trywait.c b/sysdeps/sparc/sparc32/sem_trywait.c
-index 7d0fc55..ad9b4ad 100644
+---
+ sysdeps/sparc/sparc32/sem_trywait.c | 1 +
+ 1 file changed, 1 insertion(+)
+
--- a/sysdeps/sparc/sparc32/sem_trywait.c
+++ b/sysdeps/sparc/sparc32/sem_trywait.c
@@ -22,6 +22,7 @@
@@ -10,5 +12,3 @@ index 7d0fc55..ad9b4ad 100644
#include <shlib-compat.h>
-
-
diff --git a/packages/glibc-linaro/2.20-2014.11/101-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch b/packages/glibc-linaro/2.20-2014.11/0001-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch
index 6fd663a..d92014e 100644
--- a/packages/glibc-linaro/2.20-2014.11/101-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0001-Suppress-GCC-6-warning-about-ambiguous-else-with-Wpa.patch
@@ -5,16 +5,13 @@ Subject: [PATCH] Suppress GCC 6 warning about ambiguous 'else' with
-Wparentheses
---
- ChangeLog | 5 +++++
- nis/nis_call.c | 20 +++++++++++---------
- stdlib/setenv.c | 26 ++++++++++++++------------
- 3 files changed, 30 insertions(+), 21 deletions(-)
+ nis/nis_call.c | 20 +++++++++++---------
+ stdlib/setenv.c | 24 +++++++++++++-----------
+ 2 files changed, 24 insertions(+), 20 deletions(-)
-diff --git a/nis/nis_call.c b/nis/nis_call.c
-index 3fa37e4..cb7839a 100644
--- a/nis/nis_call.c
+++ b/nis/nis_call.c
-@@ -680,16 +680,18 @@ nis_server_cache_add (const_nis_name name, int search_parent,
+@@ -680,16 +680,18 @@
/* Choose which entry should be evicted from the cache. */
loc = &nis_server_cache[0];
if (*loc != NULL)
@@ -42,11 +39,9 @@ index 3fa37e4..cb7839a 100644
old = *loc;
*loc = new;
-diff --git a/stdlib/setenv.c b/stdlib/setenv.c
-index da61ee0..e66045f 100644
--- a/stdlib/setenv.c
+++ b/stdlib/setenv.c
-@@ -278,18 +278,20 @@ unsetenv (const char *name)
+@@ -262,18 +262,20 @@
ep = __environ;
if (ep != NULL)
while (*ep != NULL)
@@ -54,7 +49,12 @@ index da61ee0..e66045f 100644
- {
- /* Found it. Remove this pointer by moving later ones back. */
- char **dp = ep;
--
++ {
++ if (!strncmp (*ep, name, len) && (*ep)[len] == '=')
++ {
++ /* Found it. Remove this pointer by moving later ones back. */
++ char **dp = ep;
+
- do
- dp[0] = dp[1];
- while (*dp++);
@@ -62,12 +62,6 @@ index da61ee0..e66045f 100644
- }
- else
- ++ep;
-+ {
-+ if (!strncmp (*ep, name, len) && (*ep)[len] == '=')
-+ {
-+ /* Found it. Remove this pointer by moving later ones back. */
-+ char **dp = ep;
-+
+ do
+ dp[0] = dp[1];
+ while (*dp++);
@@ -79,6 +73,3 @@ index da61ee0..e66045f 100644
UNLOCK;
---
-2.7.4
-
diff --git a/packages/glibc-linaro/2.20-2014.11/102-fix-signed-shift-overlow.patch b/packages/glibc-linaro/2.20-2014.11/0002-fix-signed-shift-overlow.patch
index ef49f83..c7cc330 100644
--- a/packages/glibc-linaro/2.20-2014.11/102-fix-signed-shift-overlow.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0002-fix-signed-shift-overlow.patch
@@ -12,11 +12,16 @@ Date: Tue Jul 21 22:50:29 2015 -0700
* string/strchrnul.c (STRCHRNUL):
Rewrite code to avoid issues with signed shift overflow.
-diff --git a/string/memrchr.c b/string/memrchr.c
-index 0c8fd84..86cd5b9 100644
+---
+ string/memrchr.c | 11 ++---------
+ string/rawmemchr.c | 11 ++---------
+ string/strchr.c | 9 ++-------
+ string/strchrnul.c | 9 ++-------
+ 4 files changed, 8 insertions(+), 32 deletions(-)
+
--- a/string/memrchr.c
+++ b/string/memrchr.c
-@@ -96,15 +96,8 @@ MEMRCHR
+@@ -96,15 +96,8 @@
The 1-bits make sure that carries propagate to the next 0-bit.
The 0-bits provide holes for carries to fall into. */
@@ -34,11 +39,9 @@ index 0c8fd84..86cd5b9 100644
/* Set up a longword, each of whose bytes is C. */
charmask = c | (c << 8);
-diff --git a/string/rawmemchr.c b/string/rawmemchr.c
-index 05b22be..228ca9d 100644
--- a/string/rawmemchr.c
+++ b/string/rawmemchr.c
-@@ -86,15 +86,8 @@ RAWMEMCHR (s, c_in)
+@@ -86,15 +86,8 @@
The 1-bits make sure that carries propagate to the next 0-bit.
The 0-bits provide holes for carries to fall into. */
@@ -56,11 +59,9 @@ index 05b22be..228ca9d 100644
/* Set up a longword, each of whose bytes is C. */
charmask = c | (c << 8);
-diff --git a/string/strchr.c b/string/strchr.c
-index 5f90075..f13b2b3 100644
--- a/string/strchr.c
+++ b/string/strchr.c
-@@ -60,13 +60,8 @@ strchr (const char *s, int c_in)
+@@ -60,13 +60,8 @@
The 1-bits make sure that carries propagate to the next 0-bit.
The 0-bits provide holes for carries to fall into. */
@@ -76,11 +77,9 @@ index 5f90075..f13b2b3 100644
/* Set up a longword, each of whose bytes is C. */
charmask = c | (c << 8);
-diff --git a/string/strchrnul.c b/string/strchrnul.c
-index 2678f1d..daf0b3f 100644
--- a/string/strchrnul.c
+++ b/string/strchrnul.c
-@@ -66,13 +66,8 @@ STRCHRNUL (s, c_in)
+@@ -66,13 +66,8 @@
The 1-bits make sure that carries propagate to the next 0-bit.
The 0-bits provide holes for carries to fall into. */
diff --git a/packages/glibc-linaro/2.20-2014.11/103-dl-openat64-variadic.patch b/packages/glibc-linaro/2.20-2014.11/0003-dl-openat64-variadic.patch
index fe94b96..552db12 100644
--- a/packages/glibc-linaro/2.20-2014.11/103-dl-openat64-variadic.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0003-dl-openat64-variadic.patch
@@ -177,8 +177,10 @@ Date: Tue Oct 20 11:54:09 2015 +0000
* wcsmbs/wcsnrtombs.c (__wcsnrtombs): Likewise.
* wcsmbs/wcsrtombs.c (__wcsrtombs): Likewise.
-diff --git a/sysdeps/unix/sysv/linux/dl-openat64.c b/sysdeps/unix/sysv/linux/dl-openat64.c
-index 7d100bb..7eea0ca 100644
+---
+ sysdeps/unix/sysv/linux/dl-openat64.c | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
--- a/sysdeps/unix/sysv/linux/dl-openat64.c
+++ b/sysdeps/unix/sysv/linux/dl-openat64.c
@@ -23,10 +23,7 @@
diff --git a/packages/glibc-linaro/2.20-2014.11/104-unused-variables.patch b/packages/glibc-linaro/2.20-2014.11/0004-unused-variables.patch
index 889c9bb..694bc61 100644
--- a/packages/glibc-linaro/2.20-2014.11/104-unused-variables.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0004-unused-variables.patch
@@ -19,8 +19,19 @@ Date: Fri Sep 18 20:27:20 2015 +0100
* timezone/private.h (time_t_min): Likewise. (time_t_max):
Likewise.
-diff --git a/resolv/base64.c b/resolv/base64.c
-index ea584ed..519e5d2 100644
+---
+ resolv/base64.c | 4 ----
+ sysdeps/ieee754/dbl-64/atnat2.h | 4 ----
+ sysdeps/ieee754/dbl-64/uexp.h | 2 +-
+ sysdeps/ieee754/dbl-64/upow.h | 2 --
+ sysdeps/ieee754/flt-32/e_log10f.c | 2 --
+ sysdeps/ieee754/flt-32/s_cosf.c | 2 --
+ sysdeps/ieee754/ldbl-128/e_lgammal_r.c | 1 -
+ sysdeps/ieee754/ldbl-128/s_erfl.c | 1 -
+ sysdeps/ieee754/ldbl-128/s_log1pl.c | 1 -
+ timezone/private.h | 10 ----------
+ 10 files changed, 1 insertion(+), 28 deletions(-)
+
--- a/resolv/base64.c
+++ b/resolv/base64.c
@@ -40,10 +40,6 @@
@@ -34,8 +45,6 @@ index ea584ed..519e5d2 100644
#include <sys/types.h>
#include <sys/param.h>
#include <sys/socket.h>
-diff --git a/sysdeps/ieee754/dbl-64/atnat2.h b/sysdeps/ieee754/dbl-64/atnat2.h
-index e0d65af..82943f9 100644
--- a/sysdeps/ieee754/dbl-64/atnat2.h
+++ b/sysdeps/ieee754/dbl-64/atnat2.h
@@ -65,10 +65,8 @@
@@ -60,8 +69,6 @@ index e0d65af..82943f9 100644
/**/ mtqpi = {{0x7f3321d2, 0xc002d97c} }, /* -3pi/4 */
/**/ u1 = {{0x00000000, 0x3c314c2a} }, /* 9.377e-19 */
/**/ u2 = {{0x00000000, 0x3bf955e4} }, /* 8.584e-20 */
-diff --git a/sysdeps/ieee754/dbl-64/uexp.h b/sysdeps/ieee754/dbl-64/uexp.h
-index 6817eaf..42b21f2 100644
--- a/sysdeps/ieee754/dbl-64/uexp.h
+++ b/sysdeps/ieee754/dbl-64/uexp.h
@@ -29,7 +29,7 @@
@@ -73,8 +80,6 @@ index 6817eaf..42b21f2 100644
err_0 = 1.000014, err_1 = 0.000016;
const static int4 bigint = 0x40862002,
badint = 0x40876000,smallint = 0x3C8fffff;
-diff --git a/sysdeps/ieee754/dbl-64/upow.h b/sysdeps/ieee754/dbl-64/upow.h
-index c8569a9..b4911e5 100644
--- a/sysdeps/ieee754/dbl-64/upow.h
+++ b/sysdeps/ieee754/dbl-64/upow.h
@@ -34,7 +34,6 @@
@@ -93,11 +98,9 @@ index c8569a9..b4911e5 100644
/**/ ln2a = {{0xfefa3800, 0x3fe62e42}}, /* ln(2) 43 bits */
/**/ ln2b = {{0x93c76730, 0x3d2ef357}}, /* ln(2)-ln2a */
/**/ bigu = {{0xfffffd2c, 0x4297ffff}}, /* 1.5*2**42 -724*2**-10 */
-diff --git a/sysdeps/ieee754/flt-32/e_log10f.c b/sysdeps/ieee754/flt-32/e_log10f.c
-index 96f0e81..1daeef7 100644
--- a/sysdeps/ieee754/flt-32/e_log10f.c
+++ b/sysdeps/ieee754/flt-32/e_log10f.c
-@@ -22,8 +22,6 @@ ivln10 = 4.3429449201e-01, /* 0x3ede5bd9 */
+@@ -22,8 +22,6 @@
log10_2hi = 3.0102920532e-01, /* 0x3e9a2080 */
log10_2lo = 7.9034151668e-07; /* 0x355427db */
@@ -106,11 +109,9 @@ index 96f0e81..1daeef7 100644
float
__ieee754_log10f(float x)
{
-diff --git a/sysdeps/ieee754/flt-32/s_cosf.c b/sysdeps/ieee754/flt-32/s_cosf.c
-index 864ab27..0affd40 100644
--- a/sysdeps/ieee754/flt-32/s_cosf.c
+++ b/sysdeps/ieee754/flt-32/s_cosf.c
-@@ -21,8 +21,6 @@ static char rcsid[] = "$NetBSD: s_cosf.c,v 1.4 1995/05/10 20:47:03 jtc Exp $";
+@@ -21,8 +21,6 @@
#include <math.h>
#include <math_private.h>
@@ -119,11 +120,9 @@ index 864ab27..0affd40 100644
#ifndef COSF
# define COSF_FUNC __cosf
#else
-diff --git a/sysdeps/ieee754/ldbl-128/e_lgammal_r.c b/sysdeps/ieee754/ldbl-128/e_lgammal_r.c
-index 500aacc..ab5a96e 100644
--- a/sysdeps/ieee754/ldbl-128/e_lgammal_r.c
+++ b/sysdeps/ieee754/ldbl-128/e_lgammal_r.c
-@@ -82,7 +82,6 @@ DIAG_IGNORE_NEEDS_COMMENT (4.6, "-Woverflow");
+@@ -74,7 +74,6 @@
static const long double PIL = 3.1415926535897932384626433832795028841972E0L;
static const long double MAXLGM = 1.0485738685148938358098967157129705071571E4928L;
static const long double one = 1.0L;
@@ -131,11 +130,9 @@ index 500aacc..ab5a96e 100644
static const long double huge = 1.0e4000L;
/* log gamma(x) = ( x - 0.5 ) * log(x) - x + LS2PI + 1/x P(1/x^2)
-diff --git a/sysdeps/ieee754/ldbl-128/s_erfl.c b/sysdeps/ieee754/ldbl-128/s_erfl.c
-index fa4609f..08c80a3 100644
--- a/sysdeps/ieee754/ldbl-128/s_erfl.c
+++ b/sysdeps/ieee754/ldbl-128/s_erfl.c
-@@ -140,7 +140,6 @@ deval (long double x, const long double *p, int n)
+@@ -140,7 +140,6 @@
static const long double
tiny = 1e-4931L,
@@ -143,11 +140,9 @@ index fa4609f..08c80a3 100644
one = 1.0L,
two = 2.0L,
/* 2/sqrt(pi) - 1 */
-diff --git a/sysdeps/ieee754/ldbl-128/s_log1pl.c b/sysdeps/ieee754/ldbl-128/s_log1pl.c
-index ff759bc..9609550 100644
--- a/sysdeps/ieee754/ldbl-128/s_log1pl.c
+++ b/sysdeps/ieee754/ldbl-128/s_log1pl.c
-@@ -117,7 +117,6 @@ static const long double C2 = 1.428606820309417232121458176568075500134E-6L;
+@@ -116,7 +116,6 @@
static const long double sqrth = 0.7071067811865475244008443621048490392848L;
/* ln (2^16384 * (1 - 2^-113)) */
@@ -155,11 +150,9 @@ index ff759bc..9609550 100644
static const long double zero = 0.0L;
long double
-diff --git a/timezone/private.h b/timezone/private.h
-index 4e8f4ae..ed19e06 100644
--- a/timezone/private.h
+++ b/timezone/private.h
-@@ -326,16 +326,6 @@ const char * scheck(const char * string, const char * format);
+@@ -326,16 +326,6 @@
#define TYPE_SIGNED(type) (((type) -1) < 0)
#endif /* !defined TYPE_SIGNED */
diff --git a/packages/glibc-linaro/2.20-2014.11/105-misleading-indentation.patch b/packages/glibc-linaro/2.20-2014.11/0005-misleading-indentation.patch
index 1dd8d85..8e08259 100644
--- a/packages/glibc-linaro/2.20-2014.11/105-misleading-indentation.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0005-misleading-indentation.patch
@@ -7,11 +7,13 @@ Date: Fri Dec 11 09:19:37 2015 -0800
* sysdeps/ieee754/flt-32/k_rem_pio2f.c (__kernel_rem_pio2f):
Fix indentation.
-diff --git a/sysdeps/ieee754/flt-32/k_rem_pio2f.c b/sysdeps/ieee754/flt-32/k_rem_pio2f.c
-index 0c7685c..392afdb 100644
+---
+ sysdeps/ieee754/flt-32/k_rem_pio2f.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
--- a/sysdeps/ieee754/flt-32/k_rem_pio2f.c
+++ b/sysdeps/ieee754/flt-32/k_rem_pio2f.c
-@@ -65,7 +65,9 @@ int __kernel_rem_pio2f(float *x, float *y, int e0, int nx, int prec, const int32
+@@ -65,7 +65,9 @@
/* compute q[0],q[1],...q[jk] */
for (i=0;i<=jk;i++) {
diff --git a/packages/glibc-linaro/2.20-2014.11/106-dl-open-array-bounds.patch b/packages/glibc-linaro/2.20-2014.11/0006-dl-open-array-bounds.patch
index 08a9076..83eb0b3 100644
--- a/packages/glibc-linaro/2.20-2014.11/106-dl-open-array-bounds.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0006-dl-open-array-bounds.patch
@@ -4,11 +4,13 @@ Date: Fri Apr 17 12:11:58 2015 -0700
Fuller check for invalid NSID in _dl_open.
-diff --git a/elf/dl-open.c b/elf/dl-open.c
-index 0dbe07f..2d0e082 100644
+---
+ elf/dl-open.c | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
--- a/elf/dl-open.c
+++ b/elf/dl-open.c
-@@ -211,7 +211,7 @@ dl_open_worker (void *a)
+@@ -211,7 +211,7 @@
struct link_map *l = _dl_find_dso_for_object ((ElfW(Addr)) caller_dlopen);
if (l)
@@ -17,7 +19,7 @@ index 0dbe07f..2d0e082 100644
if (args->nsid == __LM_ID_CALLER)
args->nsid = call_map->l_ns;
-@@ -619,8 +619,14 @@ no more namespaces available for dlmopen()"));
+@@ -627,8 +627,14 @@
/* Never allow loading a DSO in a namespace which is empty. Such
direct placements is only causing problems. Also don't allow
loading into a namespace used for auditing. */
diff --git a/packages/glibc-linaro/2.20-2014.11/140-Fix-combreloc-test-BSD-grep.patch b/packages/glibc-linaro/2.20-2014.11/0007-Fix-combreloc-test-BSD-grep.patch
index fdc3a60..f56a4ca 100644
--- a/packages/glibc-linaro/2.20-2014.11/140-Fix-combreloc-test-BSD-grep.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0007-Fix-combreloc-test-BSD-grep.patch
@@ -13,16 +13,13 @@ by configure as "not found". As a result, support for "-z combreloc"
Signed-off-by: Alexey Neyman <stilor@att.net>
---
- ChangeLog | 5 +++++
- configure | 2 +-
- configure.ac | 2 +-
- 3 files changed, 7 insertions(+), 2 deletions(-)
+ configure | 2 +-
+ configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
-diff --git a/configure b/configure
-index eecd0ac..0118bd1 100755
--- a/configure
+++ b/configure
-@@ -5804,7 +5804,7 @@ if { ac_try='${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS
+@@ -6025,7 +6025,7 @@
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; }
then
@@ -31,11 +28,9 @@ index eecd0ac..0118bd1 100755
libc_cv_z_combreloc=yes
else
libc_cv_z_combreloc=no
-diff --git a/configure.ac b/configure.ac
-index 4a77411..19f6d87 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1391,7 +1391,7 @@ dnl cross-platform since the gcc used can be a cross compiler. Without
+@@ -1397,7 +1397,7 @@
dnl introducing new options this is not easily doable. Instead use a tool
dnl which always is cross-platform: readelf. To detect whether -z combreloc
dnl look for a section named .rel.dyn.
@@ -44,6 +39,3 @@ index 4a77411..19f6d87 100644
libc_cv_z_combreloc=yes
else
libc_cv_z_combreloc=no
---
-2.9.3
-
diff --git a/packages/glibc-linaro/2.20-2014.11/920-fix-rpc_parse-format.patch b/packages/glibc-linaro/2.20-2014.11/0008-fix-rpc_parse-format.patch
index 37e58da..341d541 100644
--- a/packages/glibc-linaro/2.20-2014.11/920-fix-rpc_parse-format.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0008-fix-rpc_parse-format.patch
@@ -45,11 +45,13 @@ Date: Tue Nov 8 23:44:51 2016 +0000
[$(run-built-tests) = yes] (tests-special): Add $(rpcgen-tests).
[$(run-built-tests) = yes] ($(rpcgen-tests)): New rule.
-diff --git a/sunrpc/rpc_parse.c b/sunrpc/rpc_parse.c
-index 1a1df6d8c2..505a6554cf 100644
+---
+ sunrpc/rpc_parse.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/sunrpc/rpc_parse.c
+++ b/sunrpc/rpc_parse.c
-@@ -521,7 +521,7 @@ static void
+@@ -521,7 +521,7 @@
get_prog_declaration (declaration * dec, defkind dkind, int num /* arg number */ )
{
token tok;
diff --git a/packages/glibc-linaro/2.20-2014.11/930-explicit-boolean.patch b/packages/glibc-linaro/2.20-2014.11/0009-explicit-boolean.patch
index 780fae6..ff7cd87 100644
--- a/packages/glibc-linaro/2.20-2014.11/930-explicit-boolean.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0009-explicit-boolean.patch
@@ -7,11 +7,13 @@ Date: Fri Oct 14 12:53:27 2016 -0700
* sysdeps/ieee754/dbl-64/e_pow.c (checkint) Make conditions explicitly
boolean.
-diff --git a/sysdeps/ieee754/dbl-64/e_pow.c b/sysdeps/ieee754/dbl-64/e_pow.c
-index 663fa392c2..bd758b5979 100644
+---
+ sysdeps/ieee754/dbl-64/e_pow.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
--- a/sysdeps/ieee754/dbl-64/e_pow.c
+++ b/sysdeps/ieee754/dbl-64/e_pow.c
-@@ -466,15 +466,15 @@ checkint (double x)
+@@ -462,15 +462,15 @@
return (n & 1) ? -1 : 1; /* odd or even */
if (k > 20)
{
diff --git a/packages/glibc-linaro/2.20-2014.11/940-nis-bogus-conditional.patch b/packages/glibc-linaro/2.20-2014.11/0010-nis-bogus-conditional.patch
index 09b38cf..e728368 100644
--- a/packages/glibc-linaro/2.20-2014.11/940-nis-bogus-conditional.patch
+++ b/packages/glibc-linaro/2.20-2014.11/0010-nis-bogus-conditional.patch
@@ -47,11 +47,13 @@ Date: Wed Dec 21 23:44:01 2016 +0000
* nis/nss_nisplus/nisplus-alias.c (_nss_nisplus_getaliasbyname_r):
Compare name == NULL, not name != NULL.
-diff --git a/nis/nss_nisplus/nisplus-alias.c b/nis/nss_nisplus/nisplus-alias.c
-index 7f698b4e6d..cb5acce01d 100644
+---
+ nis/nss_nisplus/nisplus-alias.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/nis/nss_nisplus/nisplus-alias.c
+++ b/nis/nss_nisplus/nisplus-alias.c
-@@ -291,7 +291,7 @@ _nss_nisplus_getaliasbyname_r (const char *name, struct aliasent *alias,
+@@ -291,7 +291,7 @@
return status;
}