summaryrefslogtreecommitdiff
path: root/packages/glibc-ports
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2022-02-10 01:02:35 (GMT)
committerAlexey Neyman <stilor@att.net>2022-02-11 08:47:51 (GMT)
commita4cff7a0612fccb0e32529a10e53a836fa12d634 (patch)
tree814a1d575a571f5077d7024bee06efc3c227a5ff /packages/glibc-ports
parent5a0be8b4ec0f1b7ff4fe30c8caaa5285b4f11ae4 (diff)
glibc-2.12.1: backport a fix for 2-pass build
Otherwise, it tries to link against libgcc_eh which is not available until the final compiler (or previously, the pass-2 compiler) is built. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/glibc-ports')
-rw-r--r--packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch b/packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch
new file mode 100644
index 0000000..dc746c4
--- /dev/null
+++ b/packages/glibc-ports/2.12.1/0009-do-not-use-libgcc_eh.patch
@@ -0,0 +1,31 @@
+commit 95f5a9a866695da4e038aa4e6ccbbfd5d9cf63b7
+Author: Joseph Myers <joseph@codesourcery.com>
+Date: Tue Jul 3 19:14:59 2012 +0000
+
+ Avoid use of libgcc_s and libgcc_eh when building glibc.
+
+---
+ sysdeps/arm/eabi/Makefile | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+--- a/sysdeps/arm/eabi/Makefile
++++ b/sysdeps/arm/eabi/Makefile
+@@ -1,3 +1,6 @@
++gnulib-arch = $(elfobjdir)/libgcc-stubs.a
++static-gnulib-arch = $(elfobjdir)/libgcc-stubs.a
++
+ ifeq ($(subdir),csu)
+ aeabi_constants = aeabi_lcsts aeabi_sighandlers aeabi_math
+ aeabi_routines = aeabi_assert aeabi_localeconv aeabi_errno_addr \
+@@ -24,6 +27,11 @@
+ sysdep_routines += aeabi_unwind_cpp_pr1 find_exidx
+ shared-only-routines += aeabi_unwind_cpp_pr1
+ sysdep-rtld-routines += aeabi_unwind_cpp_pr1
++
++$(objpfx)libgcc-stubs.a: $(objpfx)aeabi_unwind_cpp_pr1.os
++ $(build-extra-lib)
++
++lib-noranlib: $(objpfx)libgcc-stubs.a
+ endif
+
+ ifeq ($(subdir),math)