summaryrefslogtreecommitdiff
path: root/packages/glibc/2.13/0041-initfini-ppc64.patch
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/glibc/2.13/0041-initfini-ppc64.patch
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/glibc/2.13/0041-initfini-ppc64.patch')
-rw-r--r--packages/glibc/2.13/0041-initfini-ppc64.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/glibc/2.13/0041-initfini-ppc64.patch b/packages/glibc/2.13/0041-initfini-ppc64.patch
new file mode 100644
index 0000000..c63c654
--- /dev/null
+++ b/packages/glibc/2.13/0041-initfini-ppc64.patch
@@ -0,0 +1,24 @@
+Prevent erroneous inline optimization of initfini.s on PowerPC64.
+
+The problem and the fix was reported there:
+http://sourceware.org/ml/libc-alpha/2012-01/msg00195.html
+Git commit:
+commit 1fe05ea95e1460e5e1cf1568a8ce3982f0f02de6
+Author: Ryan S. Arnold <rsa@us.ibm.com>
+Date: Tue May 3 17:26:17 2011 -0500
+
+---
+ sysdeps/powerpc/powerpc64/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/sysdeps/powerpc/powerpc64/Makefile
++++ b/sysdeps/powerpc/powerpc64/Makefile
+@@ -28,7 +28,7 @@
+ ifneq ($(elf),no)
+ # The initfini generation code doesn't work in the presence of -fPIC, so
+ # we use -fpic instead which is much better.
+-CFLAGS-initfini.s += -fpic -O1
++CFLAGS-initfini.s += -fpic -O1 -fno-inline
+ endif
+ endif
+