summaryrefslogtreecommitdiff
path: root/packages/ltrace
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/ltrace
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/ltrace')
-rw-r--r--packages/ltrace/0.5.3/0000-allow-cross-compile.patch (renamed from packages/ltrace/0.5.3/100-allow-cross-compile.patch)36
-rw-r--r--packages/ltrace/0.5.3/0001-alpha-support.patch14
-rw-r--r--packages/ltrace/0.5.3/0002-debian-ltrace_0.5.3-2.patch (renamed from packages/ltrace/0.5.3/120-debian-ltrace_0.5.3-2.patch)28
-rw-r--r--packages/ltrace/0.5.3/0003-add-sysdep.patch (renamed from packages/ltrace/0.5.3/130-add-sysdep.patch)12
-rw-r--r--packages/ltrace/0.5.3/0004-mips.patch (renamed from packages/ltrace/0.5.3/140-mips.patch)26
-rw-r--r--packages/ltrace/0.5.3/0005-mips-remove-CP.patch18
-rw-r--r--packages/ltrace/0.5.3/0006-allow-configurable-arch.patch (renamed from packages/ltrace/0.5.3/150-allow-configurable-arch.patch)24
-rw-r--r--packages/ltrace/0.5.3/0007-fix-missing-ptrace-defines.patch (renamed from packages/ltrace/0.5.3/160-fix-missing-ptrace-defines.patch)26
-rw-r--r--packages/ltrace/0.5.3/0008-lib-supcc.patch (renamed from packages/ltrace/0.5.3/170-lib-supcc.patch)12
-rw-r--r--packages/ltrace/0.5.3/0009-libltrace-genindex.patch15
-rw-r--r--packages/ltrace/0.5.3/0010-ar-configurable.patch (renamed from packages/ltrace/0.5.3/190-ar-configurable.patch)18
-rw-r--r--packages/ltrace/0.5.3/0011-configure-hostos.patch (renamed from packages/ltrace/0.5.3/200-configure-hostos.patch)9
-rw-r--r--packages/ltrace/0.5.3/110-alpha-support.patch11
-rw-r--r--packages/ltrace/0.5.3/140-mips-remove-CP.patch16
-rw-r--r--packages/ltrace/0.5.3/180-libltrace-genindex.patch12
-rw-r--r--packages/ltrace/0.7.3/0000-avoid-libstdc++.patch (renamed from packages/ltrace/0.7.3/001-avoid-libstdc++.patch)15
-rw-r--r--packages/ltrace/0.7.3/0001-printf-p.patch (renamed from packages/ltrace/0.7.3/002-printf-p.patch)10
-rw-r--r--packages/ltrace/0.7.3/0002-alpha-debug.h.patch (renamed from packages/ltrace/0.7.3/003-alpha-debug.h.patch)8
-rw-r--r--packages/ltrace/0.7.3/0003-compile-warning.patch (renamed from packages/ltrace/0.7.3/004-compile-warning.patch)17
-rw-r--r--packages/ltrace/0.7.3/0004-sparc-ftbfs.patch (renamed from packages/ltrace/0.7.3/005-sparc-ftbfs.patch)13
-rw-r--r--packages/ltrace/0.7.3/0005-unexpected-breakpoint.patch (renamed from packages/ltrace/0.7.3/006-unexpected-breakpoint.patch)10
-rw-r--r--packages/ltrace/0.7.3/0006-gcc-5.patch (renamed from packages/ltrace/0.7.3/007-gcc-5.patch)11
-rw-r--r--packages/ltrace/0.7.3/0007-glibc-2.24.patch (renamed from packages/ltrace/0.7.3/008-glibc-2.24.patch)11
23 files changed, 215 insertions, 157 deletions
diff --git a/packages/ltrace/0.5.3/100-allow-cross-compile.patch b/packages/ltrace/0.5.3/0000-allow-cross-compile.patch
index 58572cd..6515ebd 100644
--- a/packages/ltrace/0.5.3/100-allow-cross-compile.patch
+++ b/packages/ltrace/0.5.3/0000-allow-cross-compile.patch
@@ -2,27 +2,29 @@ This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
-Index: ltrace-0.5.3/common.h
-===================================================================
---- ltrace-0.5.3.orig/common.h 2009-10-23 23:13:45.700282578 -0700
-+++ ltrace-0.5.3/common.h 2009-10-23 23:14:13.550371553 -0700
+---
+ common.h | 4 ++++
+ configure | 11 ++++-------
+ debug.h | 4 +++-
+ 3 files changed, 11 insertions(+), 8 deletions(-)
+
+--- a/common.h
++++ b/common.h
@@ -1,3 +1,5 @@
+#ifndef COMMON_H
+#define COMMON_H
#include <sys/types.h>
#include <sys/time.h>
#include <stdio.h>
-@@ -251,3 +253,5 @@ extern void * sym2addr(Process *, struct
+@@ -251,3 +253,5 @@
#if 0 /* not yet */
extern int umoven(Process * proc, void * addr, int len, void * laddr);
#endif
+#endif
+
-Index: ltrace-0.5.3/configure
-===================================================================
---- ltrace-0.5.3.orig/configure 2009-10-23 23:13:45.630316494 -0700
-+++ ltrace-0.5.3/configure 2009-10-23 23:13:59.672869527 -0700
-@@ -30,7 +30,7 @@ int main () {
+--- a/configure
++++ b/configure
+@@ -30,7 +30,7 @@
return cplus_demangle();
}
EOF
@@ -31,7 +33,7 @@ Index: ltrace-0.5.3/configure
then
HAVE_LIBIBERTY=1
echo "yes"
-@@ -48,7 +48,7 @@ int main () {
+@@ -48,7 +48,7 @@
return __cxa_demangle();
}
EOF
@@ -40,7 +42,7 @@ Index: ltrace-0.5.3/configure
then
HAVE_LIBSUPC__=1
echo "yes"
-@@ -67,7 +67,7 @@ int main () {
+@@ -67,7 +67,7 @@
return 0;
}
EOF
@@ -49,7 +51,7 @@ Index: ltrace-0.5.3/configure
then
HAVE_ELF_C_READ_MMAP=1
echo "yes"
-@@ -77,15 +77,12 @@ else
+@@ -77,15 +77,12 @@
fi
rm -f conftest.c a.out
@@ -66,17 +68,15 @@ Index: ltrace-0.5.3/configure
sysconfdir='${prefix}/etc'
bindir='${prefix}/bin'
mandir='${prefix}/share/man'
-Index: ltrace-0.5.3/debug.h
-===================================================================
---- ltrace-0.5.3.orig/debug.h 2009-10-23 23:13:45.670276809 -0700
-+++ ltrace-0.5.3/debug.h 2009-10-23 23:14:26.440319785 -0700
+--- a/debug.h
++++ b/debug.h
@@ -1,3 +1,5 @@
+#ifndef DEBUG_H
+#define DEBUG_H
#include <features.h>
/* debug levels:
-@@ -14,4 +16,4 @@ void debug_(int level, const char *file,
+@@ -14,4 +16,4 @@
int xinfdump(long, void *, int);
# define debug(level, expr...) debug_(level, __FILE__, __LINE__, expr)
diff --git a/packages/ltrace/0.5.3/0001-alpha-support.patch b/packages/ltrace/0.5.3/0001-alpha-support.patch
new file mode 100644
index 0000000..8a7710c
--- /dev/null
+++ b/packages/ltrace/0.5.3/0001-alpha-support.patch
@@ -0,0 +1,14 @@
+---
+ sysdeps/linux-gnu/Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/sysdeps/linux-gnu/Makefile
++++ b/sysdeps/linux-gnu/Makefile
+@@ -2,6 +2,7 @@
+ -e s/i.86/i386/ \
+ -e s/sun4u/sparc64/ \
+ -e s/sparc64/sparc/ \
++ -e s/alpha.*/alpha/ \
+ -e s/arm.*/arm/ \
+ -e s/sa110/arm/ \
+ -e s/ppc64/ppc/ \
diff --git a/packages/ltrace/0.5.3/120-debian-ltrace_0.5.3-2.patch b/packages/ltrace/0.5.3/0002-debian-ltrace_0.5.3-2.patch
index 483c743..651230c 100644
--- a/packages/ltrace/0.5.3/120-debian-ltrace_0.5.3-2.patch
+++ b/packages/ltrace/0.5.3/0002-debian-ltrace_0.5.3-2.patch
@@ -1,7 +1,15 @@
Debian patch courtesy of the Debian ltrace maintainer Juan Cespedes <cespedes@debian.org>
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/breakpoint.c
-+++ ltrace-0.5.3/sysdeps/linux-gnu/breakpoint.c
+---
+ sysdeps/linux-gnu/arm/breakpoint.c | 7 +------
+ sysdeps/linux-gnu/breakpoint.c | 5 +++--
+ sysdeps/linux-gnu/ia64/breakpoint.c | 5 +----
+ sysdeps/linux-gnu/ia64/plt.c | 1 +
+ sysdeps/linux-gnu/ia64/regs.c | 1 -
+ 5 files changed, 6 insertions(+), 13 deletions(-)
+
+--- a/sysdeps/linux-gnu/breakpoint.c
++++ b/sysdeps/linux-gnu/breakpoint.c
@@ -6,8 +6,6 @@
#include "common.h"
#include "arch.h"
@@ -21,8 +29,8 @@ Debian patch courtesy of the Debian ltrace maintainer Juan Cespedes <cespedes@de
void
enable_breakpoint(pid_t pid, Breakpoint *sbp) {
unsigned int i, j;
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/arm/breakpoint.c
-+++ ltrace-0.5.3/sysdeps/linux-gnu/arm/breakpoint.c
+--- a/sysdeps/linux-gnu/arm/breakpoint.c
++++ b/sysdeps/linux-gnu/arm/breakpoint.c
@@ -24,10 +24,7 @@
#include <sys/ptrace.h>
@@ -44,16 +52,16 @@ Debian patch courtesy of the Debian ltrace maintainer Juan Cespedes <cespedes@de
debug(1, "arch_disable_breakpoint(%d,%p)", pid, sbp->addr);
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/ia64/plt.c
-+++ ltrace-0.5.3/sysdeps/linux-gnu/ia64/plt.c
+--- a/sysdeps/linux-gnu/ia64/plt.c
++++ b/sysdeps/linux-gnu/ia64/plt.c
@@ -1,4 +1,5 @@
#include <gelf.h>
+#include <sys/ptrace.h>
#include "common.h"
/* A bundle is 128 bits */
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/ia64/breakpoint.c
-+++ ltrace-0.5.3/sysdeps/linux-gnu/ia64/breakpoint.c
+--- a/sysdeps/linux-gnu/ia64/breakpoint.c
++++ b/sysdeps/linux-gnu/ia64/breakpoint.c
@@ -6,10 +6,7 @@
#include <sys/ptrace.h>
@@ -66,8 +74,8 @@ Debian patch courtesy of the Debian ltrace maintainer Juan Cespedes <cespedes@de
static long long
extract_bit_field(char *bundle, int from, int len) {
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/ia64/regs.c
-+++ ltrace-0.5.3/sysdeps/linux-gnu/ia64/regs.c
+--- a/sysdeps/linux-gnu/ia64/regs.c
++++ b/sysdeps/linux-gnu/ia64/regs.c
@@ -7,7 +7,6 @@
#include <asm/rse.h>
diff --git a/packages/ltrace/0.5.3/130-add-sysdep.patch b/packages/ltrace/0.5.3/0003-add-sysdep.patch
index 6fd8d26..8f17f9d 100644
--- a/packages/ltrace/0.5.3/130-add-sysdep.patch
+++ b/packages/ltrace/0.5.3/0003-add-sysdep.patch
@@ -2,11 +2,13 @@ This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
-Index: ltrace-0.5.3/Makefile.in
-===================================================================
---- ltrace-0.5.3.orig/Makefile.in 2009-10-23 22:06:08.130304691 -0700
-+++ ltrace-0.5.3/Makefile.in 2009-10-23 22:06:53.160369614 -0700
-@@ -39,6 +39,8 @@ ltrace: main.o libltrace.a
+---
+ Makefile.in | 2 ++
+ 1 file changed, 2 insertions(+)
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -39,6 +39,8 @@
libltrace.a: sysdeps/sysdep.o $(OBJ)
$(AR) rcv $@ $^
diff --git a/packages/ltrace/0.5.3/140-mips.patch b/packages/ltrace/0.5.3/0004-mips.patch
index b01b7a9..f477fa7 100644
--- a/packages/ltrace/0.5.3/140-mips.patch
+++ b/packages/ltrace/0.5.3/0004-mips.patch
@@ -2,20 +2,22 @@ This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
-Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/plt.c
-===================================================================
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/plt.c 2009-10-23 23:25:59.292780574 -0700
-+++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/plt.c 2009-10-23 23:26:22.671522220 -0700
+---
+ handle_event.c | 3 ++-
+ sysdeps/linux-gnu/mipsel/plt.c | 2 +-
+ sysdeps/linux-gnu/mipsel/regs.c | 1 -
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+--- a/sysdeps/linux-gnu/mipsel/plt.c
++++ b/sysdeps/linux-gnu/mipsel/plt.c
@@ -1,4 +1,4 @@
-#include <debug.h>
+#include "debug.h"
#include <gelf.h>
#include <sys/ptrace.h>
#include "common.h"
-Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/regs.c
-===================================================================
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/regs.c 2009-10-23 23:25:59.312777529 -0700
-+++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/regs.c 2009-10-23 23:26:08.190311896 -0700
+--- a/sysdeps/linux-gnu/mipsel/regs.c
++++ b/sysdeps/linux-gnu/mipsel/regs.c
@@ -4,7 +4,6 @@
#include <sys/types.h>
#include <sys/ptrace.h>
@@ -24,11 +26,9 @@ Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/regs.c
#include "common.h"
#include "mipsel.h"
-Index: ltrace-0.5.3/handle_event.c
-===================================================================
---- ltrace-0.5.3.orig/handle_event.c 2009-10-23 23:29:48.780274445 -0700
-+++ ltrace-0.5.3/handle_event.c 2009-10-23 23:37:32.260284055 -0700
-@@ -573,7 +573,8 @@ handle_breakpoint(Event *event) {
+--- a/handle_event.c
++++ b/handle_event.c
+@@ -573,7 +573,8 @@
void *old_addr;
struct library_symbol *sym= event->proc->callstack[i].c_un.libfunc;
assert(sym);
diff --git a/packages/ltrace/0.5.3/0005-mips-remove-CP.patch b/packages/ltrace/0.5.3/0005-mips-remove-CP.patch
new file mode 100644
index 0000000..5ba3340
--- /dev/null
+++ b/packages/ltrace/0.5.3/0005-mips-remove-CP.patch
@@ -0,0 +1,18 @@
+This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
+
+http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
+
+---
+ sysdeps/linux-gnu/mipsel/trace.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+--- a/sysdeps/linux-gnu/mipsel/trace.c
++++ b/sysdeps/linux-gnu/mipsel/trace.c
+@@ -127,7 +127,6 @@
+ return ret;
+ } else {
+ // If we need this, I think we can look at [sp+16] for arg_num==4.
+- CP;
+ return 0;
+ }
+ }
diff --git a/packages/ltrace/0.5.3/150-allow-configurable-arch.patch b/packages/ltrace/0.5.3/0006-allow-configurable-arch.patch
index 7208ca8..171d7dd 100644
--- a/packages/ltrace/0.5.3/150-allow-configurable-arch.patch
+++ b/packages/ltrace/0.5.3/0006-allow-configurable-arch.patch
@@ -4,9 +4,14 @@ the arm sysdeps.
Joachim Nilsson <jocke@vmlinux.org>
-diff -ru ltrace-0.5.3.orig/configure ltrace-0.5.3/configure
---- ltrace-0.5.3.orig/configure 2010-01-02 11:05:55.000000000 +0100
-+++ ltrace-0.5.3/configure 2010-01-02 20:49:11.000000000 +0100
+---
+ Makefile.in | 6 ++++--
+ configure | 2 +-
+ sysdeps/linux-gnu/Makefile | 2 +-
+ 3 files changed, 6 insertions(+), 4 deletions(-)
+
+--- a/configure
++++ b/configure
@@ -110,7 +110,7 @@
#
# Makefile.in -> Makefile
@@ -16,10 +21,8 @@ diff -ru ltrace-0.5.3.orig/configure ltrace-0.5.3/configure
for i in $x_subst_vars
do
-Only in ltrace-0.5.3: configure~
-diff -ru ltrace-0.5.3.orig/Makefile.in ltrace-0.5.3/Makefile.in
---- ltrace-0.5.3.orig/Makefile.in 2010-01-02 11:05:55.000000000 +0100
-+++ ltrace-0.5.3/Makefile.in 2010-01-03 01:28:41.000000000 +0100
+--- a/Makefile.in
++++ b/Makefile.in
@@ -1,10 +1,12 @@
#
# ltrace's Makefile.in
@@ -35,14 +38,11 @@ diff -ru ltrace-0.5.3.orig/Makefile.in ltrace-0.5.3/Makefile.in
TOPDIR = $(shell pwd)
prefix = @prefix@
-Only in ltrace-0.5.3: Makefile.in~
-diff -ru ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile ltrace-0.5.3/sysdeps/linux-gnu/Makefile
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile 2010-01-02 11:05:55.000000000 +0100
-+++ ltrace-0.5.3/sysdeps/linux-gnu/Makefile 2010-01-02 20:49:51.000000000 +0100
+--- a/sysdeps/linux-gnu/Makefile
++++ b/sysdeps/linux-gnu/Makefile
@@ -1,4 +1,4 @@
-ARCH := $(shell uname -m | sed \
+ARCH ?= $(shell uname -m | sed \
-e s/i.86/i386/ \
-e s/sun4u/sparc64/ \
-e s/sparc64/sparc/ \
-Only in ltrace-0.5.3/sysdeps/linux-gnu: Makefile~
diff --git a/packages/ltrace/0.5.3/160-fix-missing-ptrace-defines.patch b/packages/ltrace/0.5.3/0007-fix-missing-ptrace-defines.patch
index b57a166..f4e31d9 100644
--- a/packages/ltrace/0.5.3/160-fix-missing-ptrace-defines.patch
+++ b/packages/ltrace/0.5.3/0007-fix-missing-ptrace-defines.patch
@@ -5,9 +5,15 @@ The latter of which otherwise fails to build on Arm.
Joachim Nilsson <jocke@vmlinux.org>
-diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/events.c ltrace-0.5.3/sysdeps/linux-gnu/events.c
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/events.c 2009-07-25 17:13:02.000000000 +0200
-+++ ltrace-0.5.3/sysdeps/linux-gnu/events.c 2010-01-03 14:33:46.000000000 +0100
+---
+ sysdeps/linux-gnu/events.c | 3 +--
+ sysdeps/linux-gnu/ppc/plt.c | 1 +
+ sysdeps/linux-gnu/trace.c | 3 +--
+ sysdeps/linux-gnu/trace.h | 32 ++++++++++++++++++++++++++++++++
+ 4 files changed, 35 insertions(+), 4 deletions(-)
+
+--- a/sysdeps/linux-gnu/events.c
++++ b/sysdeps/linux-gnu/events.c
@@ -7,9 +7,8 @@
#include <errno.h>
#include <signal.h>
@@ -19,9 +25,8 @@ diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/events.c ltrace-0.5.3/sysdeps/linu
static Event event;
-diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.c ltrace-0.5.3/sysdeps/linux-gnu/trace.c
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.c 2009-07-25 17:13:02.000000000 +0200
-+++ ltrace-0.5.3/sysdeps/linux-gnu/trace.c 2010-01-03 14:33:38.000000000 +0100
+--- a/sysdeps/linux-gnu/trace.c
++++ b/sysdeps/linux-gnu/trace.c
@@ -5,10 +5,9 @@
#include <unistd.h>
#include <sys/types.h>
@@ -34,9 +39,8 @@ diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.c ltrace-0.5.3/sysdeps/linux
/* If the system headers did not provide the constants, hard-code the normal
values. */
-diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.h ltrace-0.5.3/sysdeps/linux-gnu/trace.h
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.h 1970-01-01 01:00:00.000000000 +0100
-+++ ltrace-0.5.3/sysdeps/linux-gnu/trace.h 2010-01-03 14:33:26.000000000 +0100
+--- /dev/null
++++ b/sysdeps/linux-gnu/trace.h
@@ -0,0 +1,32 @@
+/* If the system headers did not provide the constants, hard-code the normal values. */
+#ifndef __SYSDEPS_TRACE_H__
@@ -70,8 +74,8 @@ diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.h ltrace-0.5.3/sysdeps/linux
+
+#endif /* PTRACE_EVENT_FORK */
+#endif /* __SYSDEPS_TRACE_H__ */
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/ppc/plt.c 2009-07-25 09:13:02.000000000 -0600
-+++ ltrace-0.5.3/sysdeps/linux-gnu/ppc/plt.c 2010-09-28 18:30:07.091618190 -0600
+--- a/sysdeps/linux-gnu/ppc/plt.c
++++ b/sysdeps/linux-gnu/ppc/plt.c
@@ -1,5 +1,6 @@
#include <gelf.h>
#include "common.h"
diff --git a/packages/ltrace/0.5.3/170-lib-supcc.patch b/packages/ltrace/0.5.3/0008-lib-supcc.patch
index 8842b91..cbb1975 100644
--- a/packages/ltrace/0.5.3/170-lib-supcc.patch
+++ b/packages/ltrace/0.5.3/0008-lib-supcc.patch
@@ -1,8 +1,10 @@
-Index: ltrace-0.5.3/configure
-===================================================================
---- ltrace-0.5.3/configure
-+++ ltrace-0.5.3/configure
-@@ -78,7 +78,10 @@ fi
+---
+ configure | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+--- a/configure
++++ b/configure
+@@ -78,7 +78,10 @@
rm -f conftest.c a.out
CFLAGS='-g -O2'
diff --git a/packages/ltrace/0.5.3/0009-libltrace-genindex.patch b/packages/ltrace/0.5.3/0009-libltrace-genindex.patch
new file mode 100644
index 0000000..929738f
--- /dev/null
+++ b/packages/ltrace/0.5.3/0009-libltrace-genindex.patch
@@ -0,0 +1,15 @@
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -39,7 +39,7 @@
+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ libltrace.a: sysdeps/sysdep.o $(OBJ)
+- $(AR) rcv $@ $^
++ $(AR) rscv $@ $^
+
+ $(OBJ): sysdeps/sysdep.o
+
diff --git a/packages/ltrace/0.5.3/190-ar-configurable.patch b/packages/ltrace/0.5.3/0010-ar-configurable.patch
index 28856a3..99edbce 100644
--- a/packages/ltrace/0.5.3/190-ar-configurable.patch
+++ b/packages/ltrace/0.5.3/0010-ar-configurable.patch
@@ -1,6 +1,10 @@
-diff -ru ltrace-0.5.3.org/Makefile.in ltrace-0.5.3/Makefile.in
---- ltrace-0.5.3.org/Makefile.in 2011-08-21 18:55:15.000000000 +0200
-+++ ltrace-0.5.3/Makefile.in 2011-08-21 18:40:53.000000000 +0200
+---
+ Makefile.in | 1 +
+ configure | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+--- a/Makefile.in
++++ b/Makefile.in
@@ -15,6 +15,7 @@
mandir = @mandir@
docdir = $(prefix)/share/doc/ltrace
@@ -9,11 +13,9 @@ diff -ru ltrace-0.5.3.org/Makefile.in ltrace-0.5.3/Makefile.in
CC = @CC@
CFLAGS = -Wall @CFLAGS@
CPPFLAGS = -iquote $(TOPDIR) -iquote $(TOPDIR)/sysdeps/$(OS) -DSYSCONFDIR=\"$(sysconfdir)\" @CPPFLAGS@
-
-diff -ru ltrace-0.5.3.org/configure ltrace-0.5.3/configure
---- ltrace-0.5.3.org/configure 2011-08-21 18:55:15.000000000 +0200
-+++ ltrace-0.5.3/configure 2011-08-21 18:54:46.000000000 +0200
-@@ -113,7 +117,7 @@
+--- a/configure
++++ b/configure
+@@ -113,7 +113,7 @@
#
# Makefile.in -> Makefile
#
diff --git a/packages/ltrace/0.5.3/200-configure-hostos.patch b/packages/ltrace/0.5.3/0011-configure-hostos.patch
index 36563f4..9637212 100644
--- a/packages/ltrace/0.5.3/200-configure-hostos.patch
+++ b/packages/ltrace/0.5.3/0011-configure-hostos.patch
@@ -1,6 +1,9 @@
-diff -ru ltrace-0.5.3.org/configure ltrace-0.5.3/configure
---- ltrace-0.5.3.org/configure 2011-08-21 18:55:15.000000000 +0200
-+++ ltrace-0.5.3/configure 2011-08-21 18:54:46.000000000 +0200
+---
+ configure | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+--- a/configure
++++ b/configure
@@ -15,8 +15,12 @@
echo $PACKAGE_VERSION
diff --git a/packages/ltrace/0.5.3/110-alpha-support.patch b/packages/ltrace/0.5.3/110-alpha-support.patch
deleted file mode 100644
index 838b84b..0000000
--- a/packages/ltrace/0.5.3/110-alpha-support.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ru ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile ltrace-0.5.3/sysdeps/linux-gnu/Makefile
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile 2009-07-25 17:13:02.000000000 +0200
-+++ ltrace-0.5.3/sysdeps/linux-gnu/Makefile 2010-01-01 22:20:45.000000000 +0100
-@@ -2,6 +2,7 @@
- -e s/i.86/i386/ \
- -e s/sun4u/sparc64/ \
- -e s/sparc64/sparc/ \
-+ -e s/alpha.*/alpha/ \
- -e s/arm.*/arm/ \
- -e s/sa110/arm/ \
- -e s/ppc64/ppc/ \
diff --git a/packages/ltrace/0.5.3/140-mips-remove-CP.patch b/packages/ltrace/0.5.3/140-mips-remove-CP.patch
deleted file mode 100644
index 4532a8f..0000000
--- a/packages/ltrace/0.5.3/140-mips-remove-CP.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
-
-http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
-
-Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/trace.c
-===================================================================
---- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/trace.c 2009-10-23 23:15:59.822783128 -0700
-+++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/trace.c 2009-10-23 23:16:10.441268788 -0700
-@@ -127,7 +127,6 @@ gimme_arg(enum tof type, Process *proc,
- return ret;
- } else {
- // If we need this, I think we can look at [sp+16] for arg_num==4.
-- CP;
- return 0;
- }
- }
diff --git a/packages/ltrace/0.5.3/180-libltrace-genindex.patch b/packages/ltrace/0.5.3/180-libltrace-genindex.patch
deleted file mode 100644
index 0b1629b..0000000
--- a/packages/ltrace/0.5.3/180-libltrace-genindex.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru ltrace-0.5.3.org/Makefile.in ltrace-0.5.3/Makefile.in
---- ltrace-0.5.3.org/Makefile.in 2011-08-21 18:55:15.000000000 +0200
-+++ ltrace-0.5.3/Makefile.in 2011-08-21 18:40:53.000000000 +0200
-@@ -39,7 +40,7 @@
- $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
-
- libltrace.a: sysdeps/sysdep.o $(OBJ)
-- $(AR) rcv $@ $^
-+ $(AR) rscv $@ $^
-
- $(OBJ): sysdeps/sysdep.o
-
diff --git a/packages/ltrace/0.7.3/001-avoid-libstdc++.patch b/packages/ltrace/0.7.3/0000-avoid-libstdc++.patch
index 9cbf557..300fa3a 100644
--- a/packages/ltrace/0.7.3/001-avoid-libstdc++.patch
+++ b/packages/ltrace/0.7.3/0000-avoid-libstdc++.patch
@@ -5,8 +5,13 @@ Description: avoid warning from dpkg-shlibdeps:
Last-Update: 2013-12-30
---- a/configure.ac 2013-09-17 01:04:28.000000000 +0200
-+++ b/configure.ac 2013-12-30 12:24:20.000000000 +0100
+---
+ configure | 9 +++++++++
+ configure.ac | 9 +++++++++
+ 2 files changed, 18 insertions(+)
+
+--- a/configure.ac
++++ b/configure.ac
@@ -113,6 +113,15 @@
libstdcxx_LIBS=""])
AC_SUBST(libstdcxx_LIBS)
@@ -23,9 +28,9 @@ Last-Update: 2013-12-30
dnl Check security_get_boolean_active availability.
AC_CHECK_HEADERS(selinux/selinux.h)
---- a/configure 2013-09-17 01:07:46.000000000 +0100
-+++ b/configure 2013-12-30 12:34:23.000000000 +0100
-@@ -11826,6 +11826,15 @@
+--- a/configure
++++ b/configure
+@@ -11750,6 +11750,15 @@
diff --git a/packages/ltrace/0.7.3/002-printf-p.patch b/packages/ltrace/0.7.3/0001-printf-p.patch
index 10631d9..6f2b59f 100644
--- a/packages/ltrace/0.7.3/002-printf-p.patch
+++ b/packages/ltrace/0.7.3/0001-printf-p.patch
@@ -5,9 +5,13 @@ Forwarded: http://lists.alioth.debian.org/pipermail/ltrace-devel/2013-September/
Last-Update: 2014-01-02
---- ltrace-0.7.3.orig/printf.c
-+++ ltrace-0.7.3/printf.c
-@@ -168,7 +168,7 @@ form_next_param(struct param_enum *self,
+---
+ printf.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/printf.c
++++ b/printf.c
+@@ -168,7 +168,7 @@
type_init_pointer(infop, array, 1);
} else if (format_type == ARGTYPE_POINTER) {
diff --git a/packages/ltrace/0.7.3/003-alpha-debug.h.patch b/packages/ltrace/0.7.3/0002-alpha-debug.h.patch
index 237026d..f1f0fea 100644
--- a/packages/ltrace/0.7.3/003-alpha-debug.h.patch
+++ b/packages/ltrace/0.7.3/0002-alpha-debug.h.patch
@@ -5,8 +5,12 @@ Last-Update: 2014-01-02
Bug-Debian: http://bugs.debian.org/678721
---- ltrace-0.7.3.orig/sysdeps/linux-gnu/alpha/trace.c
-+++ ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c
+---
+ sysdeps/linux-gnu/alpha/trace.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+--- a/sysdeps/linux-gnu/alpha/trace.c
++++ b/sysdeps/linux-gnu/alpha/trace.c
@@ -29,7 +29,6 @@
#include "proc.h"
diff --git a/packages/ltrace/0.7.3/004-compile-warning.patch b/packages/ltrace/0.7.3/0003-compile-warning.patch
index ad65829..44592c6 100644
--- a/packages/ltrace/0.7.3/004-compile-warning.patch
+++ b/packages/ltrace/0.7.3/0003-compile-warning.patch
@@ -4,9 +4,14 @@ Last-Update: 2014-01-02
Forwarded: not-needed
---- ltrace-0.7.3.orig/value.c
-+++ ltrace-0.7.3/value.c
-@@ -284,7 +284,7 @@ value_init_deref(struct value *ret_val,
+---
+ lens_default.c | 2 +-
+ value.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/value.c
++++ b/value.c
+@@ -284,7 +284,7 @@
/* We need "long" to be long enough to hold platform
* pointers. */
@@ -15,9 +20,9 @@ Forwarded: not-needed
value_common_init(ret_val, valp->inferior, valp,
valp->type->u.ptr_info.info, 0);
---- ltrace-0.7.3.orig/lens_default.c
-+++ ltrace-0.7.3/lens_default.c
-@@ -344,7 +344,7 @@ format_array(FILE *stream, struct value
+--- a/lens_default.c
++++ b/lens_default.c
+@@ -344,7 +344,7 @@
{
/* We need "long" to be long enough to cover the whole address
* space. */
diff --git a/packages/ltrace/0.7.3/005-sparc-ftbfs.patch b/packages/ltrace/0.7.3/0004-sparc-ftbfs.patch
index 266a8e6..270e95e 100644
--- a/packages/ltrace/0.7.3/005-sparc-ftbfs.patch
+++ b/packages/ltrace/0.7.3/0004-sparc-ftbfs.patch
@@ -3,8 +3,13 @@ Description: fixes compilation on sparc
Last-Update: 2014-01-02
---- ltrace-0.7.3.orig/sysdeps/linux-gnu/sparc/plt.c
-+++ ltrace-0.7.3/sysdeps/linux-gnu/sparc/plt.c
+---
+ sysdeps/linux-gnu/sparc/plt.c | 3 ++-
+ sysdeps/linux-gnu/sparc/trace.c | 2 ++
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+--- a/sysdeps/linux-gnu/sparc/plt.c
++++ b/sysdeps/linux-gnu/sparc/plt.c
@@ -19,8 +19,9 @@
*/
@@ -16,8 +21,8 @@ Last-Update: 2014-01-02
GElf_Addr
arch_plt_sym_val(struct ltelf *lte, size_t ndx, GElf_Rela * rela) {
---- ltrace-0.7.3.orig/sysdeps/linux-gnu/sparc/trace.c
-+++ ltrace-0.7.3/sysdeps/linux-gnu/sparc/trace.c
+--- a/sysdeps/linux-gnu/sparc/trace.c
++++ b/sysdeps/linux-gnu/sparc/trace.c
@@ -26,8 +26,10 @@
#include <sys/wait.h>
#include <signal.h>
diff --git a/packages/ltrace/0.7.3/006-unexpected-breakpoint.patch b/packages/ltrace/0.7.3/0005-unexpected-breakpoint.patch
index 443bee4..5827cd8 100644
--- a/packages/ltrace/0.7.3/006-unexpected-breakpoint.patch
+++ b/packages/ltrace/0.7.3/0005-unexpected-breakpoint.patch
@@ -4,9 +4,13 @@ Description: continue after unexpected breakpoint
Last-Update: 2014-01-03
---- ltrace-0.7.3.orig/handle_event.c
-+++ ltrace-0.7.3/handle_event.c
-@@ -656,9 +656,12 @@ handle_breakpoint(Event *event)
+---
+ handle_event.c | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+--- a/handle_event.c
++++ b/handle_event.c
+@@ -656,9 +656,12 @@
if ((sbp = address2bpstruct(leader, brk_addr)) != NULL)
breakpoint_on_hit(sbp, event->proc);
diff --git a/packages/ltrace/0.7.3/007-gcc-5.patch b/packages/ltrace/0.7.3/0006-gcc-5.patch
index 4c62f85..78b935d 100644
--- a/packages/ltrace/0.7.3/007-gcc-5.patch
+++ b/packages/ltrace/0.7.3/0006-gcc-5.patch
@@ -7,11 +7,13 @@ Subject: Fix conditions in elf_read_u{16,32,64}
The condition seems to have it all mixed, using both a ! and a
comparison.
-diff --git a/ltrace-elf.c b/ltrace-elf.c
-index 29c204f..0ecdc38 100644
+---
+ ltrace-elf.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/ltrace-elf.c
+++ b/ltrace-elf.c
-@@ -219,7 +219,7 @@ need_data(Elf_Data *data, GElf_Xword offset, GElf_Xword size)
+@@ -218,7 +218,7 @@
int \
NAME(Elf_Data *data, GElf_Xword offset, uint##SIZE##_t *retp) \
{ \
@@ -20,6 +22,3 @@ index 29c204f..0ecdc38 100644
return -1; \
\
if (data->d_buf == NULL) /* NODATA section */ { \
---
-cgit v0.10.2
-
diff --git a/packages/ltrace/0.7.3/008-glibc-2.24.patch b/packages/ltrace/0.7.3/0007-glibc-2.24.patch
index 85b008b..037376f 100644
--- a/packages/ltrace/0.7.3/008-glibc-2.24.patch
+++ b/packages/ltrace/0.7.3/0007-glibc-2.24.patch
@@ -1,7 +1,10 @@
-diff -urpN ltrace-0.7.3.orig/sysdeps/linux-gnu/proc.c ltrace-0.7.3/sysdeps/linux-gnu/proc.c
---- ltrace-0.7.3.orig/sysdeps/linux-gnu/proc.c 2013-01-02 06:24:46.000000000 -0800
-+++ ltrace-0.7.3/sysdeps/linux-gnu/proc.c 2016-11-13 11:24:32.760365875 -0800
-@@ -240,14 +240,18 @@ process_tasks(pid_t pid, pid_t **ret_tas
+---
+ sysdeps/linux-gnu/proc.c | 16 ++++++++++------
+ 1 file changed, 10 insertions(+), 6 deletions(-)
+
+--- a/sysdeps/linux-gnu/proc.c
++++ b/sysdeps/linux-gnu/proc.c
+@@ -240,14 +240,18 @@
size_t alloc = 0;
while (1) {