summaryrefslogtreecommitdiff
path: root/packages/ltrace
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-05-20 04:58:46 (GMT)
committerAlexey Neyman <stilor@att.net>2017-07-08 17:57:56 (GMT)
commite7deac3aad394325f9e6fc6fda41d34ec94a59e0 (patch)
tree6ad88362f0bfa8385a91eb494009a4646aeb74b6 /packages/ltrace
parentb9af225f58e45c7fae7eb9d3689fe939243e7578 (diff)
Switch comp.libs/tools and debug to new framework.
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/ltrace')
-rw-r--r--packages/ltrace/0.5.3/100-allow-cross-compile.patch84
-rw-r--r--packages/ltrace/0.5.3/110-alpha-support.patch11
-rw-r--r--packages/ltrace/0.5.3/120-debian-ltrace_0.5.3-2.patch78
-rw-r--r--packages/ltrace/0.5.3/130-add-sysdep.patch17
-rw-r--r--packages/ltrace/0.5.3/140-mips-remove-CP.patch16
-rw-r--r--packages/ltrace/0.5.3/140-mips.patch40
-rw-r--r--packages/ltrace/0.5.3/150-allow-configurable-arch.patch48
-rw-r--r--packages/ltrace/0.5.3/160-fix-missing-ptrace-defines.patch81
-rw-r--r--packages/ltrace/0.5.3/170-lib-supcc.patch16
-rw-r--r--packages/ltrace/0.5.3/180-libltrace-genindex.patch12
-rw-r--r--packages/ltrace/0.5.3/190-ar-configurable.patch24
-rw-r--r--packages/ltrace/0.5.3/200-configure-hostos.patch18
-rw-r--r--packages/ltrace/0.5.3/version.desc1
-rw-r--r--packages/ltrace/0.7.3/001-avoid-libstdc++.patch43
-rw-r--r--packages/ltrace/0.7.3/002-printf-p.patch18
-rw-r--r--packages/ltrace/0.7.3/003-alpha-debug.h.patch17
-rw-r--r--packages/ltrace/0.7.3/004-compile-warning.patch28
-rw-r--r--packages/ltrace/0.7.3/005-sparc-ftbfs.patch31
-rw-r--r--packages/ltrace/0.7.3/006-unexpected-breakpoint.patch22
-rw-r--r--packages/ltrace/0.7.3/007-gcc-5.patch25
-rw-r--r--packages/ltrace/0.7.3/008-glibc-2.24.patch28
-rw-r--r--packages/ltrace/0.7.3/version.desc0
-rw-r--r--packages/ltrace/package.desc1
23 files changed, 659 insertions, 0 deletions
diff --git a/packages/ltrace/0.5.3/100-allow-cross-compile.patch b/packages/ltrace/0.5.3/100-allow-cross-compile.patch
new file mode 100644
index 0000000..58572cd
--- /dev/null
+++ b/packages/ltrace/0.5.3/100-allow-cross-compile.patch
@@ -0,0 +1,84 @@
+This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
+
+http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
+
+Index: ltrace-0.5.3/common.h
+===================================================================
+--- ltrace-0.5.3.orig/common.h 2009-10-23 23:13:45.700282578 -0700
++++ ltrace-0.5.3/common.h 2009-10-23 23:14:13.550371553 -0700
+@@ -1,3 +1,5 @@
++#ifndef COMMON_H
++#define COMMON_H
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <stdio.h>
+@@ -251,3 +253,5 @@ extern void * sym2addr(Process *, struct
+ #if 0 /* not yet */
+ extern int umoven(Process * proc, void * addr, int len, void * laddr);
+ #endif
++#endif
++
+Index: ltrace-0.5.3/configure
+===================================================================
+--- ltrace-0.5.3.orig/configure 2009-10-23 23:13:45.630316494 -0700
++++ ltrace-0.5.3/configure 2009-10-23 23:13:59.672869527 -0700
+@@ -30,7 +30,7 @@ int main () {
+ return cplus_demangle();
+ }
+ EOF
+-if gcc conftest.c -liberty 2>/dev/null
++if $CC conftest.c -liberty 2>/dev/null
+ then
+ HAVE_LIBIBERTY=1
+ echo "yes"
+@@ -48,7 +48,7 @@ int main () {
+ return __cxa_demangle();
+ }
+ EOF
+-if gcc conftest.c -lsupc++ 2>/dev/null
++if $CC conftest.c -lsupc++ 2>/dev/null
+ then
+ HAVE_LIBSUPC__=1
+ echo "yes"
+@@ -67,7 +67,7 @@ int main () {
+ return 0;
+ }
+ EOF
+-if gcc conftest.c 2>/dev/null
++if $CC conftest.c 2>/dev/null
+ then
+ HAVE_ELF_C_READ_MMAP=1
+ echo "yes"
+@@ -77,15 +77,12 @@ else
+ fi
+ rm -f conftest.c a.out
+
+-CC=gcc
+-CPPFLAGS=' -I /usr/include/libelf'
+ CFLAGS='-g -O2'
+ LIBS='-lelf -lsupc++ -liberty '
+-INSTALL='/usr/bin/install -c'
++INSTALL='install -c'
+ iquote='-iquote '
+ iquoteend=''
+
+-prefix=/usr/local
+ sysconfdir='${prefix}/etc'
+ bindir='${prefix}/bin'
+ mandir='${prefix}/share/man'
+Index: ltrace-0.5.3/debug.h
+===================================================================
+--- ltrace-0.5.3.orig/debug.h 2009-10-23 23:13:45.670276809 -0700
++++ ltrace-0.5.3/debug.h 2009-10-23 23:14:26.440319785 -0700
+@@ -1,3 +1,5 @@
++#ifndef DEBUG_H
++#define DEBUG_H
+ #include <features.h>
+
+ /* debug levels:
+@@ -14,4 +16,4 @@ void debug_(int level, const char *file,
+ int xinfdump(long, void *, int);
+
+ # define debug(level, expr...) debug_(level, __FILE__, __LINE__, expr)
+-
++#endif
diff --git a/packages/ltrace/0.5.3/110-alpha-support.patch b/packages/ltrace/0.5.3/110-alpha-support.patch
new file mode 100644
index 0000000..838b84b
--- /dev/null
+++ b/packages/ltrace/0.5.3/110-alpha-support.patch
@@ -0,0 +1,11 @@
+diff -ru ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile ltrace-0.5.3/sysdeps/linux-gnu/Makefile
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile 2009-07-25 17:13:02.000000000 +0200
++++ ltrace-0.5.3/sysdeps/linux-gnu/Makefile 2010-01-01 22:20:45.000000000 +0100
+@@ -2,6 +2,7 @@
+ -e s/i.86/i386/ \
+ -e s/sun4u/sparc64/ \
+ -e s/sparc64/sparc/ \
++ -e s/alpha.*/alpha/ \
+ -e s/arm.*/arm/ \
+ -e s/sa110/arm/ \
+ -e s/ppc64/ppc/ \
diff --git a/packages/ltrace/0.5.3/120-debian-ltrace_0.5.3-2.patch b/packages/ltrace/0.5.3/120-debian-ltrace_0.5.3-2.patch
new file mode 100644
index 0000000..483c743
--- /dev/null
+++ b/packages/ltrace/0.5.3/120-debian-ltrace_0.5.3-2.patch
@@ -0,0 +1,78 @@
+Debian patch courtesy of the Debian ltrace maintainer Juan Cespedes <cespedes@debian.org>
+
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/breakpoint.c
++++ ltrace-0.5.3/sysdeps/linux-gnu/breakpoint.c
+@@ -6,8 +6,6 @@
+ #include "common.h"
+ #include "arch.h"
+
+-static unsigned char break_insn[] = BREAKPOINT_VALUE;
+-
+ #ifdef ARCH_HAVE_ENABLE_BREAKPOINT
+ extern void arch_enable_breakpoint(pid_t, Breakpoint *);
+ void
+@@ -20,6 +18,9 @@
+ arch_enable_breakpoint(pid, sbp);
+ }
+ #else
++
++static unsigned char break_insn[] = BREAKPOINT_VALUE;
++
+ void
+ enable_breakpoint(pid_t pid, Breakpoint *sbp) {
+ unsigned int i, j;
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/arm/breakpoint.c
++++ ltrace-0.5.3/sysdeps/linux-gnu/arm/breakpoint.c
+@@ -24,10 +24,7 @@
+
+ #include <sys/ptrace.h>
+ #include "config.h"
+-#include "arch.h"
+-#include "options.h"
+-#include "output.h"
+-#include "debug.h"
++#include "common.h"
+
+ void
+ arch_enable_breakpoint(pid_t pid, Breakpoint *sbp) {
+@@ -59,8 +56,6 @@
+ void
+ arch_disable_breakpoint(pid_t pid, const Breakpoint *sbp) {
+ unsigned int i, j;
+- const unsigned char break_insn[] = BREAKPOINT_VALUE;
+- const unsigned char thumb_break_insn[] = THUMB_BREAKPOINT_VALUE;
+
+ debug(1, "arch_disable_breakpoint(%d,%p)", pid, sbp->addr);
+
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/ia64/plt.c
++++ ltrace-0.5.3/sysdeps/linux-gnu/ia64/plt.c
+@@ -1,4 +1,5 @@
+ #include <gelf.h>
++#include <sys/ptrace.h>
+ #include "common.h"
+
+ /* A bundle is 128 bits */
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/ia64/breakpoint.c
++++ ltrace-0.5.3/sysdeps/linux-gnu/ia64/breakpoint.c
+@@ -6,10 +6,7 @@
+
+ #include <sys/ptrace.h>
+ #include <string.h>
+-#include "arch.h"
+-#include "options.h"
+-#include "output.h"
+-#include "debug.h"
++#include "common.h"
+
+ static long long
+ extract_bit_field(char *bundle, int from, int len) {
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/ia64/regs.c
++++ ltrace-0.5.3/sysdeps/linux-gnu/ia64/regs.c
+@@ -7,7 +7,6 @@
+ #include <asm/rse.h>
+
+ #include <stddef.h>
+-#include "debug.h"
+ #include "common.h"
+
+ void *
diff --git a/packages/ltrace/0.5.3/130-add-sysdep.patch b/packages/ltrace/0.5.3/130-add-sysdep.patch
new file mode 100644
index 0000000..6fd8d26
--- /dev/null
+++ b/packages/ltrace/0.5.3/130-add-sysdep.patch
@@ -0,0 +1,17 @@
+This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
+
+http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
+
+Index: ltrace-0.5.3/Makefile.in
+===================================================================
+--- ltrace-0.5.3.orig/Makefile.in 2009-10-23 22:06:08.130304691 -0700
++++ ltrace-0.5.3/Makefile.in 2009-10-23 22:06:53.160369614 -0700
+@@ -39,6 +39,8 @@ ltrace: main.o libltrace.a
+ libltrace.a: sysdeps/sysdep.o $(OBJ)
+ $(AR) rcv $@ $^
+
++$(OBJ): sysdeps/sysdep.o
++
+ sysdeps/sysdep.o: dummy
+ $(MAKE) -C sysdeps/$(OS)
+
diff --git a/packages/ltrace/0.5.3/140-mips-remove-CP.patch b/packages/ltrace/0.5.3/140-mips-remove-CP.patch
new file mode 100644
index 0000000..4532a8f
--- /dev/null
+++ b/packages/ltrace/0.5.3/140-mips-remove-CP.patch
@@ -0,0 +1,16 @@
+This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
+
+http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
+
+Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/trace.c
+===================================================================
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/trace.c 2009-10-23 23:15:59.822783128 -0700
++++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/trace.c 2009-10-23 23:16:10.441268788 -0700
+@@ -127,7 +127,6 @@ gimme_arg(enum tof type, Process *proc,
+ return ret;
+ } else {
+ // If we need this, I think we can look at [sp+16] for arg_num==4.
+- CP;
+ return 0;
+ }
+ }
diff --git a/packages/ltrace/0.5.3/140-mips.patch b/packages/ltrace/0.5.3/140-mips.patch
new file mode 100644
index 0000000..b01b7a9
--- /dev/null
+++ b/packages/ltrace/0.5.3/140-mips.patch
@@ -0,0 +1,40 @@
+This patch is courtesy of OpenEmbedded, by Khem Raj <raj.khem@gmail.com>
+
+http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=b85b779688f0abc389e3c25d06b54de8b86385c1
+
+Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/plt.c
+===================================================================
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/plt.c 2009-10-23 23:25:59.292780574 -0700
++++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/plt.c 2009-10-23 23:26:22.671522220 -0700
+@@ -1,4 +1,4 @@
+-#include <debug.h>
++#include "debug.h"
+ #include <gelf.h>
+ #include <sys/ptrace.h>
+ #include "common.h"
+Index: ltrace-0.5.3/sysdeps/linux-gnu/mipsel/regs.c
+===================================================================
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/mipsel/regs.c 2009-10-23 23:25:59.312777529 -0700
++++ ltrace-0.5.3/sysdeps/linux-gnu/mipsel/regs.c 2009-10-23 23:26:08.190311896 -0700
+@@ -4,7 +4,6 @@
+ #include <sys/types.h>
+ #include <sys/ptrace.h>
+ #include <asm/ptrace.h>
+-#include <linux/user.h>
+
+ #include "common.h"
+ #include "mipsel.h"
+Index: ltrace-0.5.3/handle_event.c
+===================================================================
+--- ltrace-0.5.3.orig/handle_event.c 2009-10-23 23:29:48.780274445 -0700
++++ ltrace-0.5.3/handle_event.c 2009-10-23 23:37:32.260284055 -0700
+@@ -573,7 +573,8 @@ handle_breakpoint(Event *event) {
+ void *old_addr;
+ struct library_symbol *sym= event->proc->callstack[i].c_un.libfunc;
+ assert(sym);
+- old_addr = dict_find_entry(event->proc->breakpoints, sym2addr(event->proc, sym))->addr;
++ struct Breakpoint *tbp = dict_find_entry(event->proc->breakpoints, sym2addr(event->proc, sym));
++ old_addr = tbp->addr;
+ addr=sym2addr(event->proc,sym);
+ assert(old_addr !=0 && addr !=0);
+ if(addr != old_addr){
diff --git a/packages/ltrace/0.5.3/150-allow-configurable-arch.patch b/packages/ltrace/0.5.3/150-allow-configurable-arch.patch
new file mode 100644
index 0000000..7208ca8
--- /dev/null
+++ b/packages/ltrace/0.5.3/150-allow-configurable-arch.patch
@@ -0,0 +1,48 @@
+This patch is to ensure the proper ARCH is selected when cross compiling. Make
+sure to call the configure script with, e.g., HOST=arm ./configure to select
+the arm sysdeps.
+
+ Joachim Nilsson <jocke@vmlinux.org>
+
+diff -ru ltrace-0.5.3.orig/configure ltrace-0.5.3/configure
+--- ltrace-0.5.3.orig/configure 2010-01-02 11:05:55.000000000 +0100
++++ ltrace-0.5.3/configure 2010-01-02 20:49:11.000000000 +0100
+@@ -110,7 +110,7 @@
+ #
+ # Makefile.in -> Makefile
+ #
+-x_subst_vars='PACKAGE_VERSION HOST_OS INSTALL CC CPPFLAGS CFLAGS LDFLAGS LIBS iquote iquoteend prefix sysconfdir mandir docdir'
++x_subst_vars='PACKAGE_VERSION HOST HOST_OS INSTALL CC CPPFLAGS CFLAGS LDFLAGS LIBS iquote iquoteend prefix sysconfdir mandir docdir'
+
+ for i in $x_subst_vars
+ do
+Only in ltrace-0.5.3: configure~
+diff -ru ltrace-0.5.3.orig/Makefile.in ltrace-0.5.3/Makefile.in
+--- ltrace-0.5.3.orig/Makefile.in 2010-01-02 11:05:55.000000000 +0100
++++ ltrace-0.5.3/Makefile.in 2010-01-03 01:28:41.000000000 +0100
+@@ -1,10 +1,12 @@
+ #
+ # ltrace's Makefile.in
+ #
+-
++MY_TARGET = @HOST@
++ifdef MY_TARGET
++ARCH = $(MY_TARGET)
++endif
+ #OS := $(shell uname -s)
+ OS := @HOST_OS@
+-
+ TOPDIR = $(shell pwd)
+
+ prefix = @prefix@
+Only in ltrace-0.5.3: Makefile.in~
+diff -ru ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile ltrace-0.5.3/sysdeps/linux-gnu/Makefile
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile 2010-01-02 11:05:55.000000000 +0100
++++ ltrace-0.5.3/sysdeps/linux-gnu/Makefile 2010-01-02 20:49:51.000000000 +0100
+@@ -1,4 +1,4 @@
+-ARCH := $(shell uname -m | sed \
++ARCH ?= $(shell uname -m | sed \
+ -e s/i.86/i386/ \
+ -e s/sun4u/sparc64/ \
+ -e s/sparc64/sparc/ \
+Only in ltrace-0.5.3/sysdeps/linux-gnu: Makefile~
diff --git a/packages/ltrace/0.5.3/160-fix-missing-ptrace-defines.patch b/packages/ltrace/0.5.3/160-fix-missing-ptrace-defines.patch
new file mode 100644
index 0000000..b57a166
--- /dev/null
+++ b/packages/ltrace/0.5.3/160-fix-missing-ptrace-defines.patch
@@ -0,0 +1,81 @@
+This patch tries to fix the issue when PTRACE_EVENT_FORK is not found in the standard
+system headers. The begininngs of this was already in place in trace.c, this patch
+only takes that idea and puts it in a shared include file for trace.c *and* events.c.
+The latter of which otherwise fails to build on Arm.
+
+ Joachim Nilsson <jocke@vmlinux.org>
+
+diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/events.c ltrace-0.5.3/sysdeps/linux-gnu/events.c
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/events.c 2009-07-25 17:13:02.000000000 +0200
++++ ltrace-0.5.3/sysdeps/linux-gnu/events.c 2010-01-03 14:33:46.000000000 +0100
+@@ -7,9 +7,8 @@
+ #include <errno.h>
+ #include <signal.h>
+ #include <string.h>
+-#include <sys/ptrace.h>
+
+-#include "common.h"
++#include "trace.h"
+
+ static Event event;
+
+diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.c ltrace-0.5.3/sysdeps/linux-gnu/trace.c
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.c 2009-07-25 17:13:02.000000000 +0200
++++ ltrace-0.5.3/sysdeps/linux-gnu/trace.c 2010-01-03 14:33:38.000000000 +0100
+@@ -5,10 +5,9 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+-#include "ptrace.h"
+ #include <asm/unistd.h>
+
+-#include "common.h"
++#include "trace.h"
+
+ /* If the system headers did not provide the constants, hard-code the normal
+ values. */
+diff -ruN ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.h ltrace-0.5.3/sysdeps/linux-gnu/trace.h
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/trace.h 1970-01-01 01:00:00.000000000 +0100
++++ ltrace-0.5.3/sysdeps/linux-gnu/trace.h 2010-01-03 14:33:26.000000000 +0100
+@@ -0,0 +1,32 @@
++/* If the system headers did not provide the constants, hard-code the normal values. */
++#ifndef __SYSDEPS_TRACE_H__
++#define __SYSDEPS_TRACE_H__
++
++#include "ptrace.h"
++#include "common.h"
++
++#ifndef PTRACE_EVENT_FORK
++#warning PTRACE_EVENT_FORK not found... redefining.
++#define PTRACE_OLDSETOPTIONS 21
++#define PTRACE_SETOPTIONS 0x4200
++#define PTRACE_GETEVENTMSG 0x4201
++
++/* options set using PTRACE_SETOPTIONS */
++#define PTRACE_O_TRACESYSGOOD 0x00000001
++#define PTRACE_O_TRACEFORK 0x00000002
++#define PTRACE_O_TRACEVFORK 0x00000004
++#define PTRACE_O_TRACECLONE 0x00000008
++#define PTRACE_O_TRACEEXEC 0x00000010
++#define PTRACE_O_TRACEVFORKDONE 0x00000020
++#define PTRACE_O_TRACEEXIT 0x00000040
++
++/* Wait extended result codes for the above trace options. */
++#define PTRACE_EVENT_FORK 1
++#define PTRACE_EVENT_VFORK 2
++#define PTRACE_EVENT_CLONE 3
++#define PTRACE_EVENT_EXEC 4
++#define PTRACE_EVENT_VFORK_DONE 5
++#define PTRACE_EVENT_EXIT 6
++
++#endif /* PTRACE_EVENT_FORK */
++#endif /* __SYSDEPS_TRACE_H__ */
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/ppc/plt.c 2009-07-25 09:13:02.000000000 -0600
++++ ltrace-0.5.3/sysdeps/linux-gnu/ppc/plt.c 2010-09-28 18:30:07.091618190 -0600
+@@ -1,5 +1,6 @@
+ #include <gelf.h>
+ #include "common.h"
++#include "ptrace.h"
+
+ GElf_Addr
+ arch_plt_sym_val(struct ltelf *lte, size_t ndx, GElf_Rela * rela) {
diff --git a/packages/ltrace/0.5.3/170-lib-supcc.patch b/packages/ltrace/0.5.3/170-lib-supcc.patch
new file mode 100644
index 0000000..8842b91
--- /dev/null
+++ b/packages/ltrace/0.5.3/170-lib-supcc.patch
@@ -0,0 +1,16 @@
+Index: ltrace-0.5.3/configure
+===================================================================
+--- ltrace-0.5.3/configure
++++ ltrace-0.5.3/configure
+@@ -78,7 +78,10 @@ fi
+ rm -f conftest.c a.out
+
+ CFLAGS='-g -O2'
+-LIBS='-lelf -lsupc++ -liberty '
++LIBS='-lelf'
++[ -n "$HAVE_LIBSUPC__" ] && LIBS="$LIBS -lsupc++"
++[ -n "$HAVE_LIBIBERTY" ] && LIBS="$LIBS -liberty"
++
+ INSTALL='install -c'
+ iquote='-iquote '
+ iquoteend=''
diff --git a/packages/ltrace/0.5.3/180-libltrace-genindex.patch b/packages/ltrace/0.5.3/180-libltrace-genindex.patch
new file mode 100644
index 0000000..0b1629b
--- /dev/null
+++ b/packages/ltrace/0.5.3/180-libltrace-genindex.patch
@@ -0,0 +1,12 @@
+diff -ru ltrace-0.5.3.org/Makefile.in ltrace-0.5.3/Makefile.in
+--- ltrace-0.5.3.org/Makefile.in 2011-08-21 18:55:15.000000000 +0200
++++ ltrace-0.5.3/Makefile.in 2011-08-21 18:40:53.000000000 +0200
+@@ -39,7 +40,7 @@
+ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ libltrace.a: sysdeps/sysdep.o $(OBJ)
+- $(AR) rcv $@ $^
++ $(AR) rscv $@ $^
+
+ $(OBJ): sysdeps/sysdep.o
+
diff --git a/packages/ltrace/0.5.3/190-ar-configurable.patch b/packages/ltrace/0.5.3/190-ar-configurable.patch
new file mode 100644
index 0000000..28856a3
--- /dev/null
+++ b/packages/ltrace/0.5.3/190-ar-configurable.patch
@@ -0,0 +1,24 @@
+diff -ru ltrace-0.5.3.org/Makefile.in ltrace-0.5.3/Makefile.in
+--- ltrace-0.5.3.org/Makefile.in 2011-08-21 18:55:15.000000000 +0200
++++ ltrace-0.5.3/Makefile.in 2011-08-21 18:40:53.000000000 +0200
+@@ -15,6 +15,7 @@
+ mandir = @mandir@
+ docdir = $(prefix)/share/doc/ltrace
+
++AR = @AR@
+ CC = @CC@
+ CFLAGS = -Wall @CFLAGS@
+ CPPFLAGS = -iquote $(TOPDIR) -iquote $(TOPDIR)/sysdeps/$(OS) -DSYSCONFDIR=\"$(sysconfdir)\" @CPPFLAGS@
+
+diff -ru ltrace-0.5.3.org/configure ltrace-0.5.3/configure
+--- ltrace-0.5.3.org/configure 2011-08-21 18:55:15.000000000 +0200
++++ ltrace-0.5.3/configure 2011-08-21 18:54:46.000000000 +0200
+@@ -113,7 +117,7 @@
+ #
+ # Makefile.in -> Makefile
+ #
+-x_subst_vars='PACKAGE_VERSION HOST HOST_OS INSTALL CC CPPFLAGS CFLAGS LDFLAGS LIBS iquote iquoteend prefix sysconfdir mandir docdir'
++x_subst_vars='PACKAGE_VERSION HOST HOST_OS INSTALL AR CC CPPFLAGS CFLAGS LDFLAGS LIBS iquote iquoteend prefix sysconfdir mandir docdir'
+
+ for i in $x_subst_vars
+ do
diff --git a/packages/ltrace/0.5.3/200-configure-hostos.patch b/packages/ltrace/0.5.3/200-configure-hostos.patch
new file mode 100644
index 0000000..36563f4
--- /dev/null
+++ b/packages/ltrace/0.5.3/200-configure-hostos.patch
@@ -0,0 +1,18 @@
+diff -ru ltrace-0.5.3.org/configure ltrace-0.5.3/configure
+--- ltrace-0.5.3.org/configure 2011-08-21 18:55:15.000000000 +0200
++++ ltrace-0.5.3/configure 2011-08-21 18:54:46.000000000 +0200
+@@ -15,8 +15,12 @@
+ echo $PACKAGE_VERSION
+
+ echo -n "checking HOST_OS... "
+-HOST_OS=$( uname -s )
+-if [ "$HOST_OS" = "Linux" ]
++if [ -z "$HOST_OS" ] ; then
++ HOST_OS=$( uname -s )
++else
++ echo -n "using preset: "
++fi
++if [ "$HOST_OS" = "Linux" -o "$HOST_OS" = "linux" ]
+ then
+ HOST_OS="linux-gnu"
+ fi
diff --git a/packages/ltrace/0.5.3/version.desc b/packages/ltrace/0.5.3/version.desc
new file mode 100644
index 0000000..026d275
--- /dev/null
+++ b/packages/ltrace/0.5.3/version.desc
@@ -0,0 +1 @@
+obsolete="yes"
diff --git a/packages/ltrace/0.7.3/001-avoid-libstdc++.patch b/packages/ltrace/0.7.3/001-avoid-libstdc++.patch
new file mode 100644
index 0000000..9cbf557
--- /dev/null
+++ b/packages/ltrace/0.7.3/001-avoid-libstdc++.patch
@@ -0,0 +1,43 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: avoid warning from dpkg-shlibdeps:
+ package could avoid a useless dependency if ltrace was not
+ linked against libstdc++.so.6 (it uses none of the library's symbols)
+Last-Update: 2013-12-30
+
+
+--- a/configure.ac 2013-09-17 01:04:28.000000000 +0200
++++ b/configure.ac 2013-12-30 12:24:20.000000000 +0100
+@@ -113,6 +113,15 @@
+ libstdcxx_LIBS=""])
+ AC_SUBST(libstdcxx_LIBS)
+
++if test "x$liberty_LIBS" != "x"
++then
++ libsupcxx_LIBS=""
++ libstdcxx_LIBS=""
++elif test "x$libsupcxx_LIBS" != "x"
++then
++ libstdcxx_LIBS=""
++fi
++
+
+ dnl Check security_get_boolean_active availability.
+ AC_CHECK_HEADERS(selinux/selinux.h)
+--- a/configure 2013-09-17 01:07:46.000000000 +0100
++++ b/configure 2013-12-30 12:34:23.000000000 +0100
+@@ -11826,6 +11826,15 @@
+
+
+
++if test "x$liberty_LIBS" != "x"
++then
++ libsupcxx_LIBS=""
++ libstdcxx_LIBS=""
++elif test "x$libsupcxx_LIBS" != "x"
++then
++ libstdcxx_LIBS=""
++fi
++
+
+ for ac_header in selinux/selinux.h
+ do :
diff --git a/packages/ltrace/0.7.3/002-printf-p.patch b/packages/ltrace/0.7.3/002-printf-p.patch
new file mode 100644
index 0000000..10631d9
--- /dev/null
+++ b/packages/ltrace/0.7.3/002-printf-p.patch
@@ -0,0 +1,18 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: Prevent freeing static-alloc'd memory for %p and %n in printf
+Bug-Debian: http://bugs.debian.org/614994
+Forwarded: http://lists.alioth.debian.org/pipermail/ltrace-devel/2013-September/000953.html
+Last-Update: 2014-01-02
+
+
+--- ltrace-0.7.3.orig/printf.c
++++ ltrace-0.7.3/printf.c
+@@ -168,7 +168,7 @@ form_next_param(struct param_enum *self,
+ type_init_pointer(infop, array, 1);
+
+ } else if (format_type == ARGTYPE_POINTER) {
+- type_init_pointer(infop, elt_info, 1);
++ type_init_pointer(infop, elt_info, 0);
+
+ } else {
+ *infop = *type_get_simple(format_type);
diff --git a/packages/ltrace/0.7.3/003-alpha-debug.h.patch b/packages/ltrace/0.7.3/003-alpha-debug.h.patch
new file mode 100644
index 0000000..237026d
--- /dev/null
+++ b/packages/ltrace/0.7.3/003-alpha-debug.h.patch
@@ -0,0 +1,17 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: fixed FTBFS on alpha
+ don't include "debug.h" twice
+Last-Update: 2014-01-02
+Bug-Debian: http://bugs.debian.org/678721
+
+
+--- ltrace-0.7.3.orig/sysdeps/linux-gnu/alpha/trace.c
++++ ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c
+@@ -29,7 +29,6 @@
+
+ #include "proc.h"
+ #include "common.h"
+-#include "debug.h"
+
+ #if (!defined(PTRACE_PEEKUSER) && defined(PTRACE_PEEKUSR))
+ # define PTRACE_PEEKUSER PTRACE_PEEKUSR
diff --git a/packages/ltrace/0.7.3/004-compile-warning.patch b/packages/ltrace/0.7.3/004-compile-warning.patch
new file mode 100644
index 0000000..ad65829
--- /dev/null
+++ b/packages/ltrace/0.7.3/004-compile-warning.patch
@@ -0,0 +1,28 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: Fix compile warning
+Last-Update: 2014-01-02
+Forwarded: not-needed
+
+
+--- ltrace-0.7.3.orig/value.c
++++ ltrace-0.7.3/value.c
+@@ -284,7 +284,7 @@ value_init_deref(struct value *ret_val,
+
+ /* We need "long" to be long enough to hold platform
+ * pointers. */
+- typedef char assert__long_enough_long[-(sizeof(l) < sizeof(void *))];
++ (void)sizeof(char[1 - 2*(sizeof(l) < sizeof(void *))]);
+
+ value_common_init(ret_val, valp->inferior, valp,
+ valp->type->u.ptr_info.info, 0);
+--- ltrace-0.7.3.orig/lens_default.c
++++ ltrace-0.7.3/lens_default.c
+@@ -344,7 +344,7 @@ format_array(FILE *stream, struct value
+ {
+ /* We need "long" to be long enough to cover the whole address
+ * space. */
+- typedef char assert__long_enough_long[-(sizeof(long) < sizeof(void *))];
++ (void)sizeof(char[1 - 2*(sizeof(long) < sizeof(void *))]);
+ long l;
+ if (expr_eval_word(length, value, arguments, &l) < 0)
+ return -1;
diff --git a/packages/ltrace/0.7.3/005-sparc-ftbfs.patch b/packages/ltrace/0.7.3/005-sparc-ftbfs.patch
new file mode 100644
index 0000000..266a8e6
--- /dev/null
+++ b/packages/ltrace/0.7.3/005-sparc-ftbfs.patch
@@ -0,0 +1,31 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: fixes compilation on sparc
+Last-Update: 2014-01-02
+
+
+--- ltrace-0.7.3.orig/sysdeps/linux-gnu/sparc/plt.c
++++ ltrace-0.7.3/sysdeps/linux-gnu/sparc/plt.c
+@@ -19,8 +19,9 @@
+ */
+
+ #include <gelf.h>
++
+ #include "proc.h"
+-#include "common.h"
++#include "library.h"
+
+ GElf_Addr
+ arch_plt_sym_val(struct ltelf *lte, size_t ndx, GElf_Rela * rela) {
+--- ltrace-0.7.3.orig/sysdeps/linux-gnu/sparc/trace.c
++++ ltrace-0.7.3/sysdeps/linux-gnu/sparc/trace.c
+@@ -26,8 +26,10 @@
+ #include <sys/wait.h>
+ #include <signal.h>
+ #include <string.h>
++
+ #include "ptrace.h"
+ #include "proc.h"
++#include "backend.h"
+ #include "common.h"
+
+ void
diff --git a/packages/ltrace/0.7.3/006-unexpected-breakpoint.patch b/packages/ltrace/0.7.3/006-unexpected-breakpoint.patch
new file mode 100644
index 0000000..443bee4
--- /dev/null
+++ b/packages/ltrace/0.7.3/006-unexpected-breakpoint.patch
@@ -0,0 +1,22 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: continue after unexpected breakpoint
+ (instead of decrementing PC and execute int3 again and again)
+Last-Update: 2014-01-03
+
+
+--- ltrace-0.7.3.orig/handle_event.c
++++ ltrace-0.7.3/handle_event.c
+@@ -656,9 +656,12 @@ handle_breakpoint(Event *event)
+
+ if ((sbp = address2bpstruct(leader, brk_addr)) != NULL)
+ breakpoint_on_hit(sbp, event->proc);
+- else if (event->proc->state != STATE_IGNORED)
++ else if (event->proc->state != STATE_IGNORED) {
+ output_line(event->proc,
+ "unexpected breakpoint at %p", brk_addr);
++ continue_process(event->proc->pid);
++ return;
++ }
+
+ /* breakpoint_on_hit may delete its own breakpoint, so we have
+ * to look it up again. */
diff --git a/packages/ltrace/0.7.3/007-gcc-5.patch b/packages/ltrace/0.7.3/007-gcc-5.patch
new file mode 100644
index 0000000..4c62f85
--- /dev/null
+++ b/packages/ltrace/0.7.3/007-gcc-5.patch
@@ -0,0 +1,25 @@
+From 8c3674c86688a79a8689772c3d0c84d6e7aaa118 Mon Sep 17 00:00:00 2001
+From: Petr Machata <pmachata@redhat.com>
+Date: Tue, 8 Jan 2013 23:22:49 +0100
+Subject: Fix conditions in elf_read_u{16,32,64}
+
+- The calling convention of need_data is 0 on success, <0 on failure.
+ The condition seems to have it all mixed, using both a ! and a
+ comparison.
+
+diff --git a/ltrace-elf.c b/ltrace-elf.c
+index 29c204f..0ecdc38 100644
+--- a/ltrace-elf.c
++++ b/ltrace-elf.c
+@@ -219,7 +219,7 @@ need_data(Elf_Data *data, GElf_Xword offset, GElf_Xword size)
+ int \
+ NAME(Elf_Data *data, GElf_Xword offset, uint##SIZE##_t *retp) \
+ { \
+- if (!need_data(data, offset, SIZE / 8) < 0) \
++ if (need_data(data, offset, SIZE / 8) < 0) \
+ return -1; \
+ \
+ if (data->d_buf == NULL) /* NODATA section */ { \
+--
+cgit v0.10.2
+
diff --git a/packages/ltrace/0.7.3/008-glibc-2.24.patch b/packages/ltrace/0.7.3/008-glibc-2.24.patch
new file mode 100644
index 0000000..85b008b
--- /dev/null
+++ b/packages/ltrace/0.7.3/008-glibc-2.24.patch
@@ -0,0 +1,28 @@
+diff -urpN ltrace-0.7.3.orig/sysdeps/linux-gnu/proc.c ltrace-0.7.3/sysdeps/linux-gnu/proc.c
+--- ltrace-0.7.3.orig/sysdeps/linux-gnu/proc.c 2013-01-02 06:24:46.000000000 -0800
++++ ltrace-0.7.3/sysdeps/linux-gnu/proc.c 2016-11-13 11:24:32.760365875 -0800
+@@ -240,14 +240,18 @@ process_tasks(pid_t pid, pid_t **ret_tas
+ size_t alloc = 0;
+
+ while (1) {
+- struct dirent entry;
+ struct dirent *result;
+- if (readdir_r(d, &entry, &result) != 0) {
+- free(tasks);
+- return -1;
+- }
+- if (result == NULL)
++
++ errno = 0;
++ result = readdir(d);
++ if (result == NULL) {
++ if (errno) {
++ free(tasks);
++ closedir(d);
++ return -1;
++ }
+ break;
++ }
+ if (result->d_type == DT_DIR && all_digits(result->d_name)) {
+ pid_t npid = atoi(result->d_name);
+ if (n >= alloc) {
diff --git a/packages/ltrace/0.7.3/version.desc b/packages/ltrace/0.7.3/version.desc
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/packages/ltrace/0.7.3/version.desc
diff --git a/packages/ltrace/package.desc b/packages/ltrace/package.desc
new file mode 100644
index 0000000..d80e7ce
--- /dev/null
+++ b/packages/ltrace/package.desc
@@ -0,0 +1 @@
+repository="git git://git.debian.org/git/collab-maint/ltrace.git"