summaryrefslogtreecommitdiff
path: root/packages/mpfr
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/mpfr
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/mpfr')
-rw-r--r--packages/mpfr/2.4.2/0000-sin_cos_underflow.patch (renamed from packages/mpfr/2.4.2/100-sin_cos_underflow.patch)47
-rw-r--r--packages/mpfr/2.4.2/0001-longlong.h.patch (renamed from packages/mpfr/2.4.2/110-longlong.h.patch)36
-rw-r--r--packages/mpfr/2.4.2/0002-gmp5.patch80
-rw-r--r--packages/mpfr/2.4.2/120-gmp5.patch75
-rw-r--r--packages/mpfr/3.0.1/0000-asin_exprange.patch (renamed from packages/mpfr/3.0.1/110-asin_exprange.patch)39
-rw-r--r--packages/mpfr/3.0.1/0001-rec_sqrt-carry.patch (renamed from packages/mpfr/3.0.1/120-rec_sqrt-carry.patch)36
-rw-r--r--packages/mpfr/3.0.1/0002-atan-expo-range.patch (renamed from packages/mpfr/3.0.1/130-atan-expo-range.patch)43
-rw-r--r--packages/mpfr/3.0.1/0003-texp-zero.patch53
-rw-r--r--packages/mpfr/3.0.1/140-texp-zero.patch47
9 files changed, 243 insertions, 213 deletions
diff --git a/packages/mpfr/2.4.2/100-sin_cos_underflow.patch b/packages/mpfr/2.4.2/0000-sin_cos_underflow.patch
index 2721517..0e902df 100644
--- a/packages/mpfr/2.4.2/100-sin_cos_underflow.patch
+++ b/packages/mpfr/2.4.2/0000-sin_cos_underflow.patch
@@ -1,17 +1,23 @@
-diff -Naurd mpfr-2.4.2-a/PATCHES mpfr-2.4.2-b/PATCHES
---- mpfr-2.4.2-a/PATCHES 2009-12-07 13:37:12.000000000 +0000
-+++ mpfr-2.4.2-b/PATCHES 2009-12-07 13:37:12.000000000 +0000
+---
+ PATCHES | 1
+ VERSION | 2 -
+ mpfr.h | 2 -
+ sin_cos.c | 34 +++++++++++++++++----------------
+ tests/tsin_cos.c | 56 +++++++++++++++++++++++++++++++++++++++++++++++--------
+ version.c | 2 -
+ 6 files changed, 70 insertions(+), 27 deletions(-)
+
+--- /dev/null
++++ b/PATCHES
@@ -0,0 +1 @@
+sin_cos_underflow
-diff -Naurd mpfr-2.4.2-a/VERSION mpfr-2.4.2-b/VERSION
---- mpfr-2.4.2-a/VERSION 2009-11-30 02:43:08.000000000 +0000
-+++ mpfr-2.4.2-b/VERSION 2009-12-07 13:37:12.000000000 +0000
+--- a/VERSION
++++ b/VERSION
@@ -1 +1 @@
-2.4.2
+2.4.2-p1
-diff -Naurd mpfr-2.4.2-a/mpfr.h mpfr-2.4.2-b/mpfr.h
---- mpfr-2.4.2-a/mpfr.h 2009-11-30 02:43:08.000000000 +0000
-+++ mpfr-2.4.2-b/mpfr.h 2009-12-07 13:37:12.000000000 +0000
+--- a/mpfr.h
++++ b/mpfr.h
@@ -27,7 +27,7 @@
#define MPFR_VERSION_MAJOR 2
#define MPFR_VERSION_MINOR 4
@@ -21,9 +27,8 @@ diff -Naurd mpfr-2.4.2-a/mpfr.h mpfr-2.4.2-b/mpfr.h
/* Macros dealing with MPFR VERSION */
#define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-2.4.2-a/sin_cos.c mpfr-2.4.2-b/sin_cos.c
---- mpfr-2.4.2-a/sin_cos.c 2009-11-30 02:43:09.000000000 +0000
-+++ mpfr-2.4.2-b/sin_cos.c 2009-12-07 13:37:12.000000000 +0000
+--- a/sin_cos.c
++++ b/sin_cos.c
@@ -82,17 +82,19 @@
if (y != x)
/* y and x differ, thus we can safely try to compute y first */
@@ -87,9 +92,8 @@ diff -Naurd mpfr-2.4.2-a/sin_cos.c mpfr-2.4.2-b/sin_cos.c
MPFR_SAVE_EXPO_FREE (expo);
mpfr_check_range (y, inexy, rnd_mode);
mpfr_check_range (z, inexz, rnd_mode);
-diff -Naurd mpfr-2.4.2-a/tests/tsin_cos.c mpfr-2.4.2-b/tests/tsin_cos.c
---- mpfr-2.4.2-a/tests/tsin_cos.c 2009-11-30 02:43:08.000000000 +0000
-+++ mpfr-2.4.2-b/tests/tsin_cos.c 2009-12-07 13:37:12.000000000 +0000
+--- a/tests/tsin_cos.c
++++ b/tests/tsin_cos.c
@@ -382,23 +382,56 @@
consistency (void)
{
@@ -115,9 +119,7 @@ diff -Naurd mpfr-2.4.2-a/tests/tsin_cos.c mpfr-2.4.2-b/tests/tsin_cos.c
- mpfr_sin_cos (s2, c2, x, rnd);
- if (!(mpfr_equal_p (s1, s2) && mpfr_equal_p (c1, c2)))
+ if (i < 8 * GMP_RND_MAX)
- {
-- printf ("mpfr_sin_cos and mpfr_sin/mpfr_cos disagree on %s,\nx = ",
-- mpfr_print_rnd_mode (rnd));
++ {
+ int j = i / GMP_RND_MAX;
+ if (j & 1)
+ mpfr_set_emin (MPFR_EMIN_MIN);
@@ -149,7 +151,9 @@ diff -Naurd mpfr-2.4.2-a/tests/tsin_cos.c mpfr-2.4.2-b/tests/tsin_cos.c
+ flags_ref = flags_sin | flags_cos;
+ if (!(mpfr_equal_p (s1, s2) && mpfr_equal_p (c1, c2)) ||
+ inex != inex_ref || flags != flags_ref)
-+ {
+ {
+- printf ("mpfr_sin_cos and mpfr_sin/mpfr_cos disagree on %s,\nx = ",
+- mpfr_print_rnd_mode (rnd));
+ printf ("mpfr_sin_cos and mpfr_sin/mpfr_cos disagree on %s,"
+ " i = %d\nx = ", mpfr_print_rnd_mode (rnd), i);
mpfr_dump (x);
@@ -172,9 +176,8 @@ diff -Naurd mpfr-2.4.2-a/tests/tsin_cos.c mpfr-2.4.2-b/tests/tsin_cos.c
}
}
-diff -Naurd mpfr-2.4.2-a/version.c mpfr-2.4.2-b/version.c
---- mpfr-2.4.2-a/version.c 2009-11-30 02:43:08.000000000 +0000
-+++ mpfr-2.4.2-b/version.c 2009-12-07 13:37:12.000000000 +0000
+--- a/version.c
++++ b/version.c
@@ -25,5 +25,5 @@
const char *
mpfr_get_version (void)
diff --git a/packages/mpfr/2.4.2/110-longlong.h.patch b/packages/mpfr/2.4.2/0001-longlong.h.patch
index fa85d8e..da3929b 100644
--- a/packages/mpfr/2.4.2/110-longlong.h.patch
+++ b/packages/mpfr/2.4.2/0001-longlong.h.patch
@@ -1,17 +1,23 @@
-diff -Naurd mpfr-2.4.2-a/PATCHES mpfr-2.4.2-b/PATCHES
---- mpfr-2.4.2-a/PATCHES 2009-12-18 12:03:30.000000000 +0000
-+++ mpfr-2.4.2-b/PATCHES 2009-12-18 12:05:19.000000000 +0000
-@@ -0,0 +1 @@
+---
+ PATCHES | 1 +
+ VERSION | 2 +-
+ mpfr-longlong.h | 21 +++++++++++++++++++--
+ mpfr.h | 2 +-
+ version.c | 2 +-
+ 5 files changed, 23 insertions(+), 5 deletions(-)
+
+--- a/PATCHES
++++ b/PATCHES
+@@ -1 +1,2 @@
+longlong.h
-diff -Naurd mpfr-2.4.2-a/VERSION mpfr-2.4.2-b/VERSION
---- mpfr-2.4.2-a/VERSION 2009-12-07 13:37:12.000000000 +0000
-+++ mpfr-2.4.2-b/VERSION 2009-12-18 12:05:09.000000000 +0000
+ sin_cos_underflow
+--- a/VERSION
++++ b/VERSION
@@ -1 +1 @@
-2.4.2-p1
+2.4.2-p2
-diff -Naurd mpfr-2.4.2-a/mpfr-longlong.h mpfr-2.4.2-b/mpfr-longlong.h
---- mpfr-2.4.2-a/mpfr-longlong.h 2009-11-30 02:43:08.000000000 +0000
-+++ mpfr-2.4.2-b/mpfr-longlong.h 2009-12-18 12:04:29.000000000 +0000
+--- a/mpfr-longlong.h
++++ b/mpfr-longlong.h
@@ -1011,7 +1011,15 @@
#endif /* __m88000__ */
@@ -47,9 +53,8 @@ diff -Naurd mpfr-2.4.2-a/mpfr-longlong.h mpfr-2.4.2-b/mpfr-longlong.h
#define umul_ppmm(w1, w0, u, v) \
__asm__ ("dmultu %2,%3" : "=l" (w0), "=h" (w1) : "d" (u), "d" (v))
#else
-diff -Naurd mpfr-2.4.2-a/mpfr.h mpfr-2.4.2-b/mpfr.h
---- mpfr-2.4.2-a/mpfr.h 2009-12-07 13:37:12.000000000 +0000
-+++ mpfr-2.4.2-b/mpfr.h 2009-12-18 12:05:09.000000000 +0000
+--- a/mpfr.h
++++ b/mpfr.h
@@ -27,7 +27,7 @@
#define MPFR_VERSION_MAJOR 2
#define MPFR_VERSION_MINOR 4
@@ -59,9 +64,8 @@ diff -Naurd mpfr-2.4.2-a/mpfr.h mpfr-2.4.2-b/mpfr.h
/* Macros dealing with MPFR VERSION */
#define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-2.4.2-a/version.c mpfr-2.4.2-b/version.c
---- mpfr-2.4.2-a/version.c 2009-12-07 13:37:12.000000000 +0000
-+++ mpfr-2.4.2-b/version.c 2009-12-18 12:05:09.000000000 +0000
+--- a/version.c
++++ b/version.c
@@ -25,5 +25,5 @@
const char *
mpfr_get_version (void)
diff --git a/packages/mpfr/2.4.2/0002-gmp5.patch b/packages/mpfr/2.4.2/0002-gmp5.patch
new file mode 100644
index 0000000..ce01cc6
--- /dev/null
+++ b/packages/mpfr/2.4.2/0002-gmp5.patch
@@ -0,0 +1,80 @@
+---
+ PATCHES | 1 +
+ VERSION | 2 +-
+ configure | 3 +++
+ configure.in | 3 +++
+ mpfr-impl.h | 6 ++++++
+ mpfr.h | 2 +-
+ version.c | 2 +-
+ 7 files changed, 16 insertions(+), 3 deletions(-)
+
+--- a/PATCHES
++++ b/PATCHES
+@@ -1,2 +1,3 @@
++gmp5
+ longlong.h
+ sin_cos_underflow
+--- a/VERSION
++++ b/VERSION
+@@ -1 +1 @@
+-2.4.2-p2
++2.4.2-p3
+--- a/configure
++++ b/configure
+@@ -20449,6 +20449,9 @@
+ main ()
+ {
+
++#ifndef BITS_PER_MP_LIMB
++#define BITS_PER_MP_LIMB GMP_LIMB_BITS
++#endif
+ return BITS_PER_MP_LIMB == BYTES_PER_MP_LIMB * CHAR_BIT
+ && sizeof(mp_limb_t) == BYTES_PER_MP_LIMB ? 0 : 1;
+
+--- a/configure.in
++++ b/configure.in
+@@ -424,6 +424,9 @@
+ #include "gmp.h"
+ #include "gmp-impl.h"
+ ]], [[
++#ifndef BITS_PER_MP_LIMB
++#define BITS_PER_MP_LIMB GMP_LIMB_BITS
++#endif
+ return BITS_PER_MP_LIMB == BYTES_PER_MP_LIMB * CHAR_BIT
+ && sizeof(mp_limb_t) == BYTES_PER_MP_LIMB ? 0 : 1;
+ ]])], [AC_MSG_RESULT(yes)], [
+--- a/mpfr-impl.h
++++ b/mpfr-impl.h
+@@ -65,6 +65,12 @@
+ # ifndef __GMP_IMPL_H__
+ # include "gmp-impl.h"
+ # endif
++# ifndef BITS_PER_MP_LIMB
++# define BITS_PER_MP_LIMB GMP_LIMB_BITS
++# endif
++#ifndef mpn_sqr_n
++# define mpn_sqr_n mpn_sqr
++#endif
+ # ifdef MPFR_NEED_LONGLONG_H
+ # include "longlong.h"
+ # endif
+--- a/mpfr.h
++++ b/mpfr.h
+@@ -27,7 +27,7 @@
+ #define MPFR_VERSION_MAJOR 2
+ #define MPFR_VERSION_MINOR 4
+ #define MPFR_VERSION_PATCHLEVEL 2
+-#define MPFR_VERSION_STRING "2.4.2-p2"
++#define MPFR_VERSION_STRING "2.4.2-p3"
+
+ /* Macros dealing with MPFR VERSION */
+ #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
+--- a/version.c
++++ b/version.c
+@@ -25,5 +25,5 @@
+ const char *
+ mpfr_get_version (void)
+ {
+- return "2.4.2-p2";
++ return "2.4.2-p3";
+ }
diff --git a/packages/mpfr/2.4.2/120-gmp5.patch b/packages/mpfr/2.4.2/120-gmp5.patch
deleted file mode 100644
index 3ce4952..0000000
--- a/packages/mpfr/2.4.2/120-gmp5.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-diff -Naurd mpfr-2.4.2-a/PATCHES mpfr-2.4.2-b/PATCHES
---- mpfr-2.4.2-a/PATCHES 2010-01-11 15:27:18.000000000 +0000
-+++ mpfr-2.4.2-b/PATCHES 2010-01-11 15:30:31.000000000 +0000
-@@ -0,0 +1 @@
-+gmp5
-diff -Naurd mpfr-2.4.2-a/VERSION mpfr-2.4.2-b/VERSION
---- mpfr-2.4.2-a/VERSION 2009-12-18 12:05:09.000000000 +0000
-+++ mpfr-2.4.2-b/VERSION 2010-01-11 15:29:40.000000000 +0000
-@@ -1 +1 @@
--2.4.2-p2
-+2.4.2-p3
-diff -Naurd mpfr-2.4.2-a/configure mpfr-2.4.2-b/configure
---- mpfr-2.4.2-a/configure 2009-11-30 02:44:35.000000000 +0000
-+++ mpfr-2.4.2-b/configure 2010-01-11 15:28:56.000000000 +0000
-@@ -20449,6 +20449,9 @@
- main ()
- {
-
-+#ifndef BITS_PER_MP_LIMB
-+#define BITS_PER_MP_LIMB GMP_LIMB_BITS
-+#endif
- return BITS_PER_MP_LIMB == BYTES_PER_MP_LIMB * CHAR_BIT
- && sizeof(mp_limb_t) == BYTES_PER_MP_LIMB ? 0 : 1;
-
-diff -Naurd mpfr-2.4.2-a/configure.in mpfr-2.4.2-b/configure.in
---- mpfr-2.4.2-a/configure.in 2009-11-30 02:43:08.000000000 +0000
-+++ mpfr-2.4.2-b/configure.in 2009-11-30 02:43:08.000000000 +0000
-@@ -424,6 +424,9 @@
- #include "gmp.h"
- #include "gmp-impl.h"
- ]], [[
-+#ifndef BITS_PER_MP_LIMB
-+#define BITS_PER_MP_LIMB GMP_LIMB_BITS
-+#endif
- return BITS_PER_MP_LIMB == BYTES_PER_MP_LIMB * CHAR_BIT
- && sizeof(mp_limb_t) == BYTES_PER_MP_LIMB ? 0 : 1;
- ]])], [AC_MSG_RESULT(yes)], [
-diff -Naurd mpfr-2.4.2-a/mpfr-impl.h mpfr-2.4.2-b/mpfr-impl.h
---- mpfr-2.4.2-a/mpfr-impl.h 2009-11-30 02:43:08.000000000 +0000
-+++ mpfr-2.4.2-b/mpfr-impl.h 2010-01-11 15:28:01.000000000 +0000
-@@ -65,6 +65,12 @@
- # ifndef __GMP_IMPL_H__
- # include "gmp-impl.h"
- # endif
-+# ifndef BITS_PER_MP_LIMB
-+# define BITS_PER_MP_LIMB GMP_LIMB_BITS
-+# endif
-+#ifndef mpn_sqr_n
-+# define mpn_sqr_n mpn_sqr
-+#endif
- # ifdef MPFR_NEED_LONGLONG_H
- # include "longlong.h"
- # endif
-diff -Naurd mpfr-2.4.2-a/mpfr.h mpfr-2.4.2-b/mpfr.h
---- mpfr-2.4.2-a/mpfr.h 2009-12-18 12:05:09.000000000 +0000
-+++ mpfr-2.4.2-b/mpfr.h 2010-01-11 15:29:40.000000000 +0000
-@@ -27,7 +27,7 @@
- #define MPFR_VERSION_MAJOR 2
- #define MPFR_VERSION_MINOR 4
- #define MPFR_VERSION_PATCHLEVEL 2
--#define MPFR_VERSION_STRING "2.4.2-p2"
-+#define MPFR_VERSION_STRING "2.4.2-p3"
-
- /* Macros dealing with MPFR VERSION */
- #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-2.4.2-a/version.c mpfr-2.4.2-b/version.c
---- mpfr-2.4.2-a/version.c 2009-12-18 12:05:09.000000000 +0000
-+++ mpfr-2.4.2-b/version.c 2010-01-11 15:29:40.000000000 +0000
-@@ -25,5 +25,5 @@
- const char *
- mpfr_get_version (void)
- {
-- return "2.4.2-p2";
-+ return "2.4.2-p3";
- }
diff --git a/packages/mpfr/3.0.1/110-asin_exprange.patch b/packages/mpfr/3.0.1/0000-asin_exprange.patch
index d79a6f9..db153b1 100644
--- a/packages/mpfr/3.0.1/110-asin_exprange.patch
+++ b/packages/mpfr/3.0.1/0000-asin_exprange.patch
@@ -1,17 +1,23 @@
-diff -Naurd mpfr-3.0.1-a/PATCHES mpfr-3.0.1-b/PATCHES
---- mpfr-3.0.1-a/PATCHES 2011-04-12 10:50:02.000000000 +0000
-+++ mpfr-3.0.1-b/PATCHES 2011-04-12 10:50:02.000000000 +0000
+---
+ PATCHES | 1 +
+ VERSION | 2 +-
+ asin.c | 12 +++++++-----
+ mpfr.h | 2 +-
+ tests/tasin.c | 44 ++++++++++++++++++++++++++++++++++++++++++++
+ version.c | 2 +-
+ 6 files changed, 55 insertions(+), 8 deletions(-)
+
+--- /dev/null
++++ b/PATCHES
@@ -0,0 +1 @@
+asin_exprange
-diff -Naurd mpfr-3.0.1-a/VERSION mpfr-3.0.1-b/VERSION
---- mpfr-3.0.1-a/VERSION 2011-04-04 10:19:18.000000000 +0000
-+++ mpfr-3.0.1-b/VERSION 2011-04-12 10:50:02.000000000 +0000
+--- a/VERSION
++++ b/VERSION
@@ -1 +1 @@
-3.0.1
+3.0.1-p1
-diff -Naurd mpfr-3.0.1-a/asin.c mpfr-3.0.1-b/asin.c
---- mpfr-3.0.1-a/asin.c 2011-04-04 10:19:18.000000000 +0000
-+++ mpfr-3.0.1-b/asin.c 2011-04-12 10:50:02.000000000 +0000
+--- a/asin.c
++++ b/asin.c
@@ -63,11 +63,14 @@
compared = mpfr_cmp_ui (xp, 1);
@@ -52,9 +58,8 @@ diff -Naurd mpfr-3.0.1-a/asin.c mpfr-3.0.1-b/asin.c
MPFR_SAVE_EXPO_FREE (expo);
return mpfr_check_range (asin, inexact, rnd_mode);
-diff -Naurd mpfr-3.0.1-a/mpfr.h mpfr-3.0.1-b/mpfr.h
---- mpfr-3.0.1-a/mpfr.h 2011-04-04 10:19:18.000000000 +0000
-+++ mpfr-3.0.1-b/mpfr.h 2011-04-12 10:50:02.000000000 +0000
+--- a/mpfr.h
++++ b/mpfr.h
@@ -27,7 +27,7 @@
#define MPFR_VERSION_MAJOR 3
#define MPFR_VERSION_MINOR 0
@@ -64,9 +69,8 @@ diff -Naurd mpfr-3.0.1-a/mpfr.h mpfr-3.0.1-b/mpfr.h
/* Macros dealing with MPFR VERSION */
#define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-3.0.1-a/tests/tasin.c mpfr-3.0.1-b/tests/tasin.c
---- mpfr-3.0.1-a/tests/tasin.c 2011-04-04 10:19:17.000000000 +0000
-+++ mpfr-3.0.1-b/tests/tasin.c 2011-04-12 10:50:02.000000000 +0000
+--- a/tests/tasin.c
++++ b/tests/tasin.c
@@ -219,6 +219,49 @@
mpfr_clear (y);
}
@@ -125,9 +129,8 @@ diff -Naurd mpfr-3.0.1-a/tests/tasin.c mpfr-3.0.1-b/tests/tasin.c
test_generic (2, 100, 15);
-diff -Naurd mpfr-3.0.1-a/version.c mpfr-3.0.1-b/version.c
---- mpfr-3.0.1-a/version.c 2011-04-04 10:19:18.000000000 +0000
-+++ mpfr-3.0.1-b/version.c 2011-04-12 10:50:02.000000000 +0000
+--- a/version.c
++++ b/version.c
@@ -25,5 +25,5 @@
const char *
mpfr_get_version (void)
diff --git a/packages/mpfr/3.0.1/120-rec_sqrt-carry.patch b/packages/mpfr/3.0.1/0001-rec_sqrt-carry.patch
index 0367d84..2b1ddbc 100644
--- a/packages/mpfr/3.0.1/120-rec_sqrt-carry.patch
+++ b/packages/mpfr/3.0.1/0001-rec_sqrt-carry.patch
@@ -1,17 +1,23 @@
-diff -Naurd mpfr-3.0.1-a/PATCHES mpfr-3.0.1-b/PATCHES
---- mpfr-3.0.1-a/PATCHES 2011-05-04 11:18:33.000000000 +0000
-+++ mpfr-3.0.1-b/PATCHES 2011-05-04 11:18:33.000000000 +0000
-@@ -0,0 +1 @@
+---
+ PATCHES | 1 +
+ VERSION | 2 +-
+ mpfr.h | 2 +-
+ rec_sqrt.c | 21 +++++++++++++++++++--
+ version.c | 2 +-
+ 5 files changed, 23 insertions(+), 5 deletions(-)
+
+--- a/PATCHES
++++ b/PATCHES
+@@ -1 +1,2 @@
+rec_sqrt-carry
-diff -Naurd mpfr-3.0.1-a/VERSION mpfr-3.0.1-b/VERSION
---- mpfr-3.0.1-a/VERSION 2011-04-12 10:50:02.000000000 +0000
-+++ mpfr-3.0.1-b/VERSION 2011-05-04 11:18:33.000000000 +0000
+ asin_exprange
+--- a/VERSION
++++ b/VERSION
@@ -1 +1 @@
-3.0.1-p1
+3.0.1-p2
-diff -Naurd mpfr-3.0.1-a/mpfr.h mpfr-3.0.1-b/mpfr.h
---- mpfr-3.0.1-a/mpfr.h 2011-04-12 10:50:02.000000000 +0000
-+++ mpfr-3.0.1-b/mpfr.h 2011-05-04 11:18:33.000000000 +0000
+--- a/mpfr.h
++++ b/mpfr.h
@@ -27,7 +27,7 @@
#define MPFR_VERSION_MAJOR 3
#define MPFR_VERSION_MINOR 0
@@ -21,9 +27,8 @@ diff -Naurd mpfr-3.0.1-a/mpfr.h mpfr-3.0.1-b/mpfr.h
/* Macros dealing with MPFR VERSION */
#define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-3.0.1-a/rec_sqrt.c mpfr-3.0.1-b/rec_sqrt.c
---- mpfr-3.0.1-a/rec_sqrt.c 2011-04-04 10:19:18.000000000 +0000
-+++ mpfr-3.0.1-b/rec_sqrt.c 2011-05-04 11:18:33.000000000 +0000
+--- a/rec_sqrt.c
++++ b/rec_sqrt.c
@@ -375,20 +375,37 @@
MPFR_ASSERTD(un == ln + 1 || un == ln + 2);
/* the high un-ln limbs of u will overlap the low part of {x+ln,xn},
@@ -64,9 +69,8 @@ diff -Naurd mpfr-3.0.1-a/rec_sqrt.c mpfr-3.0.1-b/rec_sqrt.c
/* cy cannot be zero, since the most significant bit of Xh is 1,
and the correction is bounded by 2^{-h+3} */
MPFR_ASSERTD(cy == 0);
-diff -Naurd mpfr-3.0.1-a/version.c mpfr-3.0.1-b/version.c
---- mpfr-3.0.1-a/version.c 2011-04-12 10:50:02.000000000 +0000
-+++ mpfr-3.0.1-b/version.c 2011-05-04 11:18:33.000000000 +0000
+--- a/version.c
++++ b/version.c
@@ -25,5 +25,5 @@
const char *
mpfr_get_version (void)
diff --git a/packages/mpfr/3.0.1/130-atan-expo-range.patch b/packages/mpfr/3.0.1/0002-atan-expo-range.patch
index 251b837..060d8de 100644
--- a/packages/mpfr/3.0.1/130-atan-expo-range.patch
+++ b/packages/mpfr/3.0.1/0002-atan-expo-range.patch
@@ -1,17 +1,25 @@
-diff -Naurd mpfr-3.0.1-a/PATCHES mpfr-3.0.1-b/PATCHES
---- mpfr-3.0.1-a/PATCHES 2011-05-05 00:00:35.000000000 +0000
-+++ mpfr-3.0.1-b/PATCHES 2011-05-05 00:00:35.000000000 +0000
-@@ -0,0 +1 @@
+---
+ PATCHES | 1 +
+ VERSION | 2 +-
+ atan.c | 2 +-
+ mpfr.h | 2 +-
+ tests/tatan.c | 47 +++++++++++++++++++++++++++++++++++++++++++++++
+ version.c | 2 +-
+ 6 files changed, 52 insertions(+), 4 deletions(-)
+
+--- a/PATCHES
++++ b/PATCHES
+@@ -1,2 +1,3 @@
+atan-expo-range
-diff -Naurd mpfr-3.0.1-a/VERSION mpfr-3.0.1-b/VERSION
---- mpfr-3.0.1-a/VERSION 2011-05-04 11:18:33.000000000 +0000
-+++ mpfr-3.0.1-b/VERSION 2011-05-05 00:00:35.000000000 +0000
+ rec_sqrt-carry
+ asin_exprange
+--- a/VERSION
++++ b/VERSION
@@ -1 +1 @@
-3.0.1-p2
+3.0.1-p3
-diff -Naurd mpfr-3.0.1-a/atan.c mpfr-3.0.1-b/atan.c
---- mpfr-3.0.1-a/atan.c 2011-04-04 10:19:18.000000000 +0000
-+++ mpfr-3.0.1-b/atan.c 2011-05-05 00:00:35.000000000 +0000
+--- a/atan.c
++++ b/atan.c
@@ -431,5 +431,5 @@
MPFR_GROUP_CLEAR (group);
@@ -19,9 +27,8 @@ diff -Naurd mpfr-3.0.1-a/atan.c mpfr-3.0.1-b/atan.c
- return mpfr_check_range (arctgt, inexact, rnd_mode);
+ return mpfr_check_range (atan, inexact, rnd_mode);
}
-diff -Naurd mpfr-3.0.1-a/mpfr.h mpfr-3.0.1-b/mpfr.h
---- mpfr-3.0.1-a/mpfr.h 2011-05-04 11:18:33.000000000 +0000
-+++ mpfr-3.0.1-b/mpfr.h 2011-05-05 00:00:35.000000000 +0000
+--- a/mpfr.h
++++ b/mpfr.h
@@ -27,7 +27,7 @@
#define MPFR_VERSION_MAJOR 3
#define MPFR_VERSION_MINOR 0
@@ -31,9 +38,8 @@ diff -Naurd mpfr-3.0.1-a/mpfr.h mpfr-3.0.1-b/mpfr.h
/* Macros dealing with MPFR VERSION */
#define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-3.0.1-a/tests/tatan.c mpfr-3.0.1-b/tests/tatan.c
---- mpfr-3.0.1-a/tests/tatan.c 2011-04-04 10:19:17.000000000 +0000
-+++ mpfr-3.0.1-b/tests/tatan.c 2011-05-05 00:00:35.000000000 +0000
+--- a/tests/tatan.c
++++ b/tests/tatan.c
@@ -535,6 +535,52 @@
mpfr_clears (a, x, y, (mpfr_ptr) 0);
}
@@ -95,9 +101,8 @@ diff -Naurd mpfr-3.0.1-a/tests/tatan.c mpfr-3.0.1-b/tests/tatan.c
test_generic_atan (2, 200, 17);
test_generic_atan2 (2, 200, 17);
-diff -Naurd mpfr-3.0.1-a/version.c mpfr-3.0.1-b/version.c
---- mpfr-3.0.1-a/version.c 2011-05-04 11:18:33.000000000 +0000
-+++ mpfr-3.0.1-b/version.c 2011-05-05 00:00:35.000000000 +0000
+--- a/version.c
++++ b/version.c
@@ -25,5 +25,5 @@
const char *
mpfr_get_version (void)
diff --git a/packages/mpfr/3.0.1/0003-texp-zero.patch b/packages/mpfr/3.0.1/0003-texp-zero.patch
new file mode 100644
index 0000000..a761a5f
--- /dev/null
+++ b/packages/mpfr/3.0.1/0003-texp-zero.patch
@@ -0,0 +1,53 @@
+---
+ PATCHES | 1 +
+ VERSION | 2 +-
+ mpfr.h | 2 +-
+ tests/texp.c | 4 +++-
+ version.c | 2 +-
+ 5 files changed, 7 insertions(+), 4 deletions(-)
+
+--- a/PATCHES
++++ b/PATCHES
+@@ -1,3 +1,4 @@
++texp-zero
+ atan-expo-range
+ rec_sqrt-carry
+ asin_exprange
+--- a/VERSION
++++ b/VERSION
+@@ -1 +1 @@
+-3.0.1-p3
++3.0.1-p4
+--- a/mpfr.h
++++ b/mpfr.h
+@@ -27,7 +27,7 @@
+ #define MPFR_VERSION_MAJOR 3
+ #define MPFR_VERSION_MINOR 0
+ #define MPFR_VERSION_PATCHLEVEL 1
+-#define MPFR_VERSION_STRING "3.0.1-p3"
++#define MPFR_VERSION_STRING "3.0.1-p4"
+
+ /* Macros dealing with MPFR VERSION */
+ #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
+--- a/tests/texp.c
++++ b/tests/texp.c
+@@ -170,7 +170,9 @@
+ mpfr_set_prec (x, prec);
+ mpfr_set_prec (y, prec);
+ mpfr_set_prec (z, prec);
+- mpfr_urandomb (x, RANDS);
++ do
++ mpfr_urandomb (x, RANDS);
++ while (MPFR_IS_ZERO (x)); /* 0 is handled by mpfr_exp only */
+ rnd = RND_RAND ();
+ mpfr_exp_2 (y, x, rnd);
+ mpfr_exp_3 (z, x, rnd);
+--- a/version.c
++++ b/version.c
+@@ -25,5 +25,5 @@
+ const char *
+ mpfr_get_version (void)
+ {
+- return "3.0.1-p3";
++ return "3.0.1-p4";
+ }
diff --git a/packages/mpfr/3.0.1/140-texp-zero.patch b/packages/mpfr/3.0.1/140-texp-zero.patch
deleted file mode 100644
index fd74087..0000000
--- a/packages/mpfr/3.0.1/140-texp-zero.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff -Naurd mpfr-3.0.1-a/PATCHES mpfr-3.0.1-b/PATCHES
---- mpfr-3.0.1-a/PATCHES 2011-05-09 14:48:24.000000000 +0000
-+++ mpfr-3.0.1-b/PATCHES 2011-05-09 14:48:24.000000000 +0000
-@@ -0,0 +1 @@
-+texp-zero
-diff -Naurd mpfr-3.0.1-a/VERSION mpfr-3.0.1-b/VERSION
---- mpfr-3.0.1-a/VERSION 2011-05-05 00:00:35.000000000 +0000
-+++ mpfr-3.0.1-b/VERSION 2011-05-09 14:48:24.000000000 +0000
-@@ -1 +1 @@
--3.0.1-p3
-+3.0.1-p4
-diff -Naurd mpfr-3.0.1-a/mpfr.h mpfr-3.0.1-b/mpfr.h
---- mpfr-3.0.1-a/mpfr.h 2011-05-05 00:00:35.000000000 +0000
-+++ mpfr-3.0.1-b/mpfr.h 2011-05-09 14:48:24.000000000 +0000
-@@ -27,7 +27,7 @@
- #define MPFR_VERSION_MAJOR 3
- #define MPFR_VERSION_MINOR 0
- #define MPFR_VERSION_PATCHLEVEL 1
--#define MPFR_VERSION_STRING "3.0.1-p3"
-+#define MPFR_VERSION_STRING "3.0.1-p4"
-
- /* Macros dealing with MPFR VERSION */
- #define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
-diff -Naurd mpfr-3.0.1-a/tests/texp.c mpfr-3.0.1-b/tests/texp.c
---- mpfr-3.0.1-a/tests/texp.c 2011-04-04 10:19:17.000000000 +0000
-+++ mpfr-3.0.1-b/tests/texp.c 2011-05-09 14:48:24.000000000 +0000
-@@ -170,7 +170,9 @@
- mpfr_set_prec (x, prec);
- mpfr_set_prec (y, prec);
- mpfr_set_prec (z, prec);
-- mpfr_urandomb (x, RANDS);
-+ do
-+ mpfr_urandomb (x, RANDS);
-+ while (MPFR_IS_ZERO (x)); /* 0 is handled by mpfr_exp only */
- rnd = RND_RAND ();
- mpfr_exp_2 (y, x, rnd);
- mpfr_exp_3 (z, x, rnd);
-diff -Naurd mpfr-3.0.1-a/version.c mpfr-3.0.1-b/version.c
---- mpfr-3.0.1-a/version.c 2011-05-05 00:00:35.000000000 +0000
-+++ mpfr-3.0.1-b/version.c 2011-05-09 14:48:24.000000000 +0000
-@@ -25,5 +25,5 @@
- const char *
- mpfr_get_version (void)
- {
-- return "3.0.1-p3";
-+ return "3.0.1-p4";
- }