summaryrefslogtreecommitdiff
path: root/packages/newlib-linaro
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-05-27 07:01:49 (GMT)
committerAlexey Neyman <stilor@att.net>2017-07-08 17:57:56 (GMT)
commit57426168ad2c7e8367786ed466c86f6aeb49b3c3 (patch)
tree61510389772124cc07aff4ab8b53f4fc6ed9a460 /packages/newlib-linaro
parente7deac3aad394325f9e6fc6fda41d34ec94a59e0 (diff)
Convert the rest of packages to new framework
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/newlib-linaro')
-rw-r--r--packages/newlib-linaro/2.1.0-2014.09/100-fix-unaligned-access-memcpy-m68k.patch27
-rw-r--r--packages/newlib-linaro/2.1.0-2014.09/110-fix-eabihf.patch24
-rw-r--r--packages/newlib-linaro/2.1.0-2014.09/200-fix-mt-cflags.patch25
-rw-r--r--packages/newlib-linaro/2.1.0-2014.09/version.desc1
-rw-r--r--packages/newlib-linaro/2.2.0-2015.01/100-fix-unaligned-access-memcpy-m68k.patch27
-rw-r--r--packages/newlib-linaro/2.2.0-2015.01/110-fix-eabihf.patch24
-rw-r--r--packages/newlib-linaro/2.2.0-2015.01/200-fix-mt-cflags.patch25
-rw-r--r--packages/newlib-linaro/2.2.0-2015.01/version.desc1
-rw-r--r--packages/newlib-linaro/package.desc4
9 files changed, 158 insertions, 0 deletions
diff --git a/packages/newlib-linaro/2.1.0-2014.09/100-fix-unaligned-access-memcpy-m68k.patch b/packages/newlib-linaro/2.1.0-2014.09/100-fix-unaligned-access-memcpy-m68k.patch
new file mode 100644
index 0000000..1d0b49b
--- /dev/null
+++ b/packages/newlib-linaro/2.1.0-2014.09/100-fix-unaligned-access-memcpy-m68k.patch
@@ -0,0 +1,27 @@
+The m68k mcpu processor does not like unaligned access
+
+Disable at least mcpu32, m68010 and m68020. These processors certainly
+do not like unaligned accesses.
+
+Signed-off-by: Remy Bohmer <linux@bohmer.net>
+[yann.morin.1998@anciens.enib.fr: update for 1.19.0 from 1.18.0]
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
+[austinpmorton@gmail.com: update for 1.20.0 from 1.19.0]
+Signed-off-by: Austin Morton <austinpmorton@gmail.com>
+---
+ newlib/libc/machine/m68k/memcpy.S | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: newlib-1.20.0/newlib/libc/machine/m68k/memcpy.S
+===================================================================
+--- newlib-1.20.0.orig/newlib/libc/machine/m68k/memcpy.S
++++ newlib-1.20.0/newlib/libc/machine/m68k/memcpy.S
+@@ -15,7 +15,7 @@
+
+ #include "m68kasm.h"
+
+-#if defined (__mcoldfire__) || defined (__mc68010__) || defined (__mc68020__) || defined (__mc68030__) || defined (__mc68040__) || defined (__mc68060__)
++#if defined (__mcoldfire__) || defined (__mc68030__) || defined (__mc68040__) || defined (__mc68060__)
+ # define MISALIGNED_OK 1
+ #else
+ # define MISALIGNED_OK 0
diff --git a/packages/newlib-linaro/2.1.0-2014.09/110-fix-eabihf.patch b/packages/newlib-linaro/2.1.0-2014.09/110-fix-eabihf.patch
new file mode 100644
index 0000000..21a3149
--- /dev/null
+++ b/packages/newlib-linaro/2.1.0-2014.09/110-fix-eabihf.patch
@@ -0,0 +1,24 @@
+diff -urpN newlib-linaro-2.1.0-2014.09.orig/libgloss/arm/configure newlib-linaro-2.1.0-2014.09/libgloss/arm/configure
+--- newlib-linaro-2.1.0-2014.09.orig/libgloss/arm/configure 2017-04-11 00:41:25.484880978 -0700
++++ newlib-linaro-2.1.0-2014.09/libgloss/arm/configure 2017-04-11 00:43:12.341789130 -0700
+@@ -2531,7 +2531,7 @@ test "${CCASFLAGS+set}" = set || CCASFLA
+
+
+ case "${target}" in
+- *-*-elf | *-*-eabi | *-*-tirtos*)
++ *-*-elf | *-*-eabi* | *-*-tirtos*)
+ objtype=elf-
+ ;;
+ *-*-coff)
+diff -urpN newlib-linaro-2.1.0-2014.09.orig/libgloss/arm/configure.in newlib-linaro-2.1.0-2014.09/libgloss/arm/configure.in
+--- newlib-linaro-2.1.0-2014.09.orig/libgloss/arm/configure.in 2017-04-11 00:41:25.484880978 -0700
++++ newlib-linaro-2.1.0-2014.09/libgloss/arm/configure.in 2017-04-11 00:43:12.341789130 -0700
+@@ -49,7 +49,7 @@ AC_PROG_RANLIB
+ LIB_AM_PROG_AS
+
+ case "${target}" in
+- *-*-elf | *-*-eabi | *-*-tirtos*)
++ *-*-elf | *-*-eabi* | *-*-tirtos*)
+ objtype=elf-
+ ;;
+ *-*-coff)
diff --git a/packages/newlib-linaro/2.1.0-2014.09/200-fix-mt-cflags.patch b/packages/newlib-linaro/2.1.0-2014.09/200-fix-mt-cflags.patch
new file mode 100644
index 0000000..f64c170
--- /dev/null
+++ b/packages/newlib-linaro/2.1.0-2014.09/200-fix-mt-cflags.patch
@@ -0,0 +1,25 @@
+diff -urpN newlib-linaro-2.1.0-2014.09.orig/config/mt-d30v newlib-linaro-2.1.0-2014.09/config/mt-d30v
+--- newlib-linaro-2.1.0-2014.09.orig/config/mt-d30v 2017-04-11 00:51:28.188768929 -0700
++++ newlib-linaro-2.1.0-2014.09/config/mt-d30v 2017-04-11 00:55:51.142626761 -0700
+@@ -1,4 +1,4 @@
+ # Build libraries optimizing for space, not speed.
+ # Turn off warnings about symbols named the same as registers
+- CFLAGS_FOR_TARGET = -g -Os -Wa,-C
+- CXXFLAGS_FOR_TARGET = -g -Os -Wa,-C
++ CFLAGS_FOR_TARGET += -g -Os -Wa,-C
++ CXXFLAGS_FOR_TARGET += -g -Os -Wa,-C
+diff -urpN newlib-linaro-2.1.0-2014.09.orig/config/mt-gnu newlib-linaro-2.1.0-2014.09/config/mt-gnu
+--- newlib-linaro-2.1.0-2014.09.orig/config/mt-gnu 2017-04-11 00:51:28.188768929 -0700
++++ newlib-linaro-2.1.0-2014.09/config/mt-gnu 2017-04-11 00:55:51.142626761 -0700
+@@ -1 +1 @@
+-CXXFLAGS_FOR_TARGET = $(CXXFLAGS) -D_GNU_SOURCE
++CXXFLAGS_FOR_TARGET += $(CXXFLAGS) -D_GNU_SOURCE
+diff -urpN newlib-linaro-2.1.0-2014.09.orig/config/mt-ospace newlib-linaro-2.1.0-2014.09/config/mt-ospace
+--- newlib-linaro-2.1.0-2014.09.orig/config/mt-ospace 2017-04-11 00:51:28.188768929 -0700
++++ newlib-linaro-2.1.0-2014.09/config/mt-ospace 2017-04-11 00:55:51.142626761 -0700
+@@ -1,3 +1,3 @@
+ # Build libraries optimizing for space, not speed.
+- CFLAGS_FOR_TARGET = -g -Os
+- CXXFLAGS_FOR_TARGET = -g -Os
++ CFLAGS_FOR_TARGET += -g -Os
++ CXXFLAGS_FOR_TARGET += -g -Os
diff --git a/packages/newlib-linaro/2.1.0-2014.09/version.desc b/packages/newlib-linaro/2.1.0-2014.09/version.desc
new file mode 100644
index 0000000..026d275
--- /dev/null
+++ b/packages/newlib-linaro/2.1.0-2014.09/version.desc
@@ -0,0 +1 @@
+obsolete="yes"
diff --git a/packages/newlib-linaro/2.2.0-2015.01/100-fix-unaligned-access-memcpy-m68k.patch b/packages/newlib-linaro/2.2.0-2015.01/100-fix-unaligned-access-memcpy-m68k.patch
new file mode 100644
index 0000000..1d0b49b
--- /dev/null
+++ b/packages/newlib-linaro/2.2.0-2015.01/100-fix-unaligned-access-memcpy-m68k.patch
@@ -0,0 +1,27 @@
+The m68k mcpu processor does not like unaligned access
+
+Disable at least mcpu32, m68010 and m68020. These processors certainly
+do not like unaligned accesses.
+
+Signed-off-by: Remy Bohmer <linux@bohmer.net>
+[yann.morin.1998@anciens.enib.fr: update for 1.19.0 from 1.18.0]
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
+[austinpmorton@gmail.com: update for 1.20.0 from 1.19.0]
+Signed-off-by: Austin Morton <austinpmorton@gmail.com>
+---
+ newlib/libc/machine/m68k/memcpy.S | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: newlib-1.20.0/newlib/libc/machine/m68k/memcpy.S
+===================================================================
+--- newlib-1.20.0.orig/newlib/libc/machine/m68k/memcpy.S
++++ newlib-1.20.0/newlib/libc/machine/m68k/memcpy.S
+@@ -15,7 +15,7 @@
+
+ #include "m68kasm.h"
+
+-#if defined (__mcoldfire__) || defined (__mc68010__) || defined (__mc68020__) || defined (__mc68030__) || defined (__mc68040__) || defined (__mc68060__)
++#if defined (__mcoldfire__) || defined (__mc68030__) || defined (__mc68040__) || defined (__mc68060__)
+ # define MISALIGNED_OK 1
+ #else
+ # define MISALIGNED_OK 0
diff --git a/packages/newlib-linaro/2.2.0-2015.01/110-fix-eabihf.patch b/packages/newlib-linaro/2.2.0-2015.01/110-fix-eabihf.patch
new file mode 100644
index 0000000..1fa21cc
--- /dev/null
+++ b/packages/newlib-linaro/2.2.0-2015.01/110-fix-eabihf.patch
@@ -0,0 +1,24 @@
+diff -urpN newlib-linaro-2.2.0-2015.01.orig/libgloss/arm/configure newlib-linaro-2.2.0-2015.01/libgloss/arm/configure
+--- newlib-linaro-2.2.0-2015.01.orig/libgloss/arm/configure 2017-04-11 00:41:25.672882574 -0700
++++ newlib-linaro-2.2.0-2015.01/libgloss/arm/configure 2017-04-11 00:43:12.349789198 -0700
+@@ -2531,7 +2531,7 @@ test "${CCASFLAGS+set}" = set || CCASFLA
+
+
+ case "${target}" in
+- *-*-elf | *-*-eabi | *-*-tirtos*)
++ *-*-elf | *-*-eabi* | *-*-tirtos*)
+ objtype=elf-
+ ;;
+ *-*-coff)
+diff -urpN newlib-linaro-2.2.0-2015.01.orig/libgloss/arm/configure.in newlib-linaro-2.2.0-2015.01/libgloss/arm/configure.in
+--- newlib-linaro-2.2.0-2015.01.orig/libgloss/arm/configure.in 2017-04-11 00:41:25.672882574 -0700
++++ newlib-linaro-2.2.0-2015.01/libgloss/arm/configure.in 2017-04-11 00:43:12.349789198 -0700
+@@ -49,7 +49,7 @@ AC_PROG_RANLIB
+ LIB_AM_PROG_AS
+
+ case "${target}" in
+- *-*-elf | *-*-eabi | *-*-tirtos*)
++ *-*-elf | *-*-eabi* | *-*-tirtos*)
+ objtype=elf-
+ ;;
+ *-*-coff)
diff --git a/packages/newlib-linaro/2.2.0-2015.01/200-fix-mt-cflags.patch b/packages/newlib-linaro/2.2.0-2015.01/200-fix-mt-cflags.patch
new file mode 100644
index 0000000..68e935b
--- /dev/null
+++ b/packages/newlib-linaro/2.2.0-2015.01/200-fix-mt-cflags.patch
@@ -0,0 +1,25 @@
+diff -urpN newlib-linaro-2.2.0-2015.01.orig/config/mt-d30v newlib-linaro-2.2.0-2015.01/config/mt-d30v
+--- newlib-linaro-2.2.0-2015.01.orig/config/mt-d30v 2017-04-11 00:51:28.364770125 -0700
++++ newlib-linaro-2.2.0-2015.01/config/mt-d30v 2017-04-11 00:55:51.142626761 -0700
+@@ -1,4 +1,4 @@
+ # Build libraries optimizing for space, not speed.
+ # Turn off warnings about symbols named the same as registers
+- CFLAGS_FOR_TARGET = -g -Os -Wa,-C
+- CXXFLAGS_FOR_TARGET = -g -Os -Wa,-C
++ CFLAGS_FOR_TARGET += -g -Os -Wa,-C
++ CXXFLAGS_FOR_TARGET += -g -Os -Wa,-C
+diff -urpN newlib-linaro-2.2.0-2015.01.orig/config/mt-gnu newlib-linaro-2.2.0-2015.01/config/mt-gnu
+--- newlib-linaro-2.2.0-2015.01.orig/config/mt-gnu 2017-04-11 00:51:28.364770125 -0700
++++ newlib-linaro-2.2.0-2015.01/config/mt-gnu 2017-04-11 00:55:51.142626761 -0700
+@@ -1 +1 @@
+-CXXFLAGS_FOR_TARGET = $(CXXFLAGS) -D_GNU_SOURCE
++CXXFLAGS_FOR_TARGET += $(CXXFLAGS) -D_GNU_SOURCE
+diff -urpN newlib-linaro-2.2.0-2015.01.orig/config/mt-ospace newlib-linaro-2.2.0-2015.01/config/mt-ospace
+--- newlib-linaro-2.2.0-2015.01.orig/config/mt-ospace 2017-04-11 00:51:28.368770153 -0700
++++ newlib-linaro-2.2.0-2015.01/config/mt-ospace 2017-04-11 00:55:51.142626761 -0700
+@@ -1,3 +1,3 @@
+ # Build libraries optimizing for space, not speed.
+- CFLAGS_FOR_TARGET = -g -Os
+- CXXFLAGS_FOR_TARGET = -g -Os
++ CFLAGS_FOR_TARGET += -g -Os
++ CXXFLAGS_FOR_TARGET += -g -Os
diff --git a/packages/newlib-linaro/2.2.0-2015.01/version.desc b/packages/newlib-linaro/2.2.0-2015.01/version.desc
new file mode 100644
index 0000000..026d275
--- /dev/null
+++ b/packages/newlib-linaro/2.2.0-2015.01/version.desc
@@ -0,0 +1 @@
+obsolete="yes"
diff --git a/packages/newlib-linaro/package.desc b/packages/newlib-linaro/package.desc
new file mode 100644
index 0000000..d1bc373
--- /dev/null
+++ b/packages/newlib-linaro/package.desc
@@ -0,0 +1,4 @@
+origin="Linaro"
+master="newlib"
+repository="git https://git.linaro.org/toolchain/newlib.git"
+experimental="yes"