summaryrefslogtreecommitdiff
path: root/packages/newlib/1.17.0
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/newlib/1.17.0
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/newlib/1.17.0')
-rw-r--r--packages/newlib/1.17.0/0000-fix-eabihf.patch27
-rw-r--r--packages/newlib/1.17.0/0001-fix-mt-cflags.patch (renamed from packages/newlib/1.17.0/200-fix-mt-cflags.patch)21
-rw-r--r--packages/newlib/1.17.0/0002-fix-arm-build.patch (renamed from packages/newlib/1.17.0/999-fix-arm-build.patch)12
-rw-r--r--packages/newlib/1.17.0/110-fix-eabihf.patch24
4 files changed, 46 insertions, 38 deletions
diff --git a/packages/newlib/1.17.0/0000-fix-eabihf.patch b/packages/newlib/1.17.0/0000-fix-eabihf.patch
new file mode 100644
index 0000000..66d56a1
--- /dev/null
+++ b/packages/newlib/1.17.0/0000-fix-eabihf.patch
@@ -0,0 +1,27 @@
+---
+ libgloss/arm/configure | 2 +-
+ libgloss/arm/configure.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/libgloss/arm/configure
++++ b/libgloss/arm/configure
+@@ -2540,7 +2540,7 @@
+
+
+ case "${target}" in
+- *-*-elf | *-*-eabi)
++ *-*-elf | *-*-eabi*)
+ objtype=elf-
+ ;;
+ *-*-coff)
+--- a/libgloss/arm/configure.in
++++ b/libgloss/arm/configure.in
+@@ -49,7 +49,7 @@
+ LIB_AM_PROG_AS
+
+ case "${target}" in
+- *-*-elf | *-*-eabi)
++ *-*-elf | *-*-eabi*)
+ objtype=elf-
+ ;;
+ *-*-coff)
diff --git a/packages/newlib/1.17.0/200-fix-mt-cflags.patch b/packages/newlib/1.17.0/0001-fix-mt-cflags.patch
index f97ba15..9984a7e 100644
--- a/packages/newlib/1.17.0/200-fix-mt-cflags.patch
+++ b/packages/newlib/1.17.0/0001-fix-mt-cflags.patch
@@ -1,6 +1,11 @@
-diff -urpN newlib-1.17.0.orig/config/mt-d30v newlib-1.17.0/config/mt-d30v
---- newlib-1.17.0.orig/config/mt-d30v 2017-04-11 00:51:26.572757941 -0700
-+++ newlib-1.17.0/config/mt-d30v 2017-04-11 00:55:51.110626527 -0700
+---
+ config/mt-d30v | 4 ++--
+ config/mt-gnu | 2 +-
+ config/mt-ospace | 4 ++--
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+--- a/config/mt-d30v
++++ b/config/mt-d30v
@@ -1,4 +1,4 @@
# Build libraries optimizing for space, not speed.
# Turn off warnings about symbols named the same as registers
@@ -8,16 +13,14 @@ diff -urpN newlib-1.17.0.orig/config/mt-d30v newlib-1.17.0/config/mt-d30v
- CXXFLAGS_FOR_TARGET = -g -Os -Wa,-C
+ CFLAGS_FOR_TARGET += -g -Os -Wa,-C
+ CXXFLAGS_FOR_TARGET += -g -Os -Wa,-C
-diff -urpN newlib-1.17.0.orig/config/mt-gnu newlib-1.17.0/config/mt-gnu
---- newlib-1.17.0.orig/config/mt-gnu 2017-04-11 00:51:26.572757941 -0700
-+++ newlib-1.17.0/config/mt-gnu 2017-04-11 00:55:51.110626527 -0700
+--- a/config/mt-gnu
++++ b/config/mt-gnu
@@ -1,2 +1,2 @@
-CXXFLAGS_FOR_TARGET = $(CXXFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET) \
+CXXFLAGS_FOR_TARGET += $(CXXFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET) \
$(DEBUG_PREFIX_CFLAGS_FOR_TARGET) -D_GNU_SOURCE
-diff -urpN newlib-1.17.0.orig/config/mt-ospace newlib-1.17.0/config/mt-ospace
---- newlib-1.17.0.orig/config/mt-ospace 2017-04-11 00:51:26.572757941 -0700
-+++ newlib-1.17.0/config/mt-ospace 2017-04-11 00:55:51.110626527 -0700
+--- a/config/mt-ospace
++++ b/config/mt-ospace
@@ -1,3 +1,3 @@
# Build libraries optimizing for space, not speed.
- CFLAGS_FOR_TARGET = -g -Os
diff --git a/packages/newlib/1.17.0/999-fix-arm-build.patch b/packages/newlib/1.17.0/0002-fix-arm-build.patch
index 154a92f..6b8170c 100644
--- a/packages/newlib/1.17.0/999-fix-arm-build.patch
+++ b/packages/newlib/1.17.0/0002-fix-arm-build.patch
@@ -1,6 +1,9 @@
-diff -urpN newlib-1.17.0.orig/libgloss/arm/linux-syscalls0.S newlib-1.17.0/libgloss/arm/linux-syscalls0.S
---- newlib-1.17.0.orig/libgloss/arm/linux-syscalls0.S 2017-04-10 23:18:30.559142019 -0700
-+++ newlib-1.17.0/libgloss/arm/linux-syscalls0.S 2017-04-10 23:35:06.422568832 -0700
+---
+ libgloss/arm/linux-syscalls0.S | 44 -----------------------------------------
+ 1 file changed, 44 deletions(-)
+
+--- a/libgloss/arm/linux-syscalls0.S
++++ b/libgloss/arm/linux-syscalls0.S
@@ -19,47 +19,6 @@
#define GLOBAL(name) .global name; FUNC(name)
#define SIZE(name) .size name, .-name
@@ -49,7 +52,7 @@ diff -urpN newlib-1.17.0.orig/libgloss/arm/linux-syscalls0.S newlib-1.17.0/libgl
# define SYSCALL4(name) \
GLOBAL(_ ## name); \
swi #SYS_ ## name; \
-@@ -78,9 +37,6 @@ FUNC(_syscall3)
+@@ -78,9 +37,6 @@
#define SYSCALL0(name) SYSCALL3(name)
#define SYSCALL3(name) SYSCALL4(name)
@@ -59,4 +62,3 @@ diff -urpN newlib-1.17.0.orig/libgloss/arm/linux-syscalls0.S newlib-1.17.0/libgl
#define SYSCALL1(name) SYSCALL3(name)
#define SYSCALL2(name) SYSCALL3(name)
#define SYSCALL5(name) SYSCALL6(name)
-Binary files newlib-1.17.0.orig/libgloss/arm/.linux-syscalls0.S.swp and newlib-1.17.0/libgloss/arm/.linux-syscalls0.S.swp differ
diff --git a/packages/newlib/1.17.0/110-fix-eabihf.patch b/packages/newlib/1.17.0/110-fix-eabihf.patch
deleted file mode 100644
index d896ad0..0000000
--- a/packages/newlib/1.17.0/110-fix-eabihf.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -urpN newlib-1.17.0.orig/libgloss/arm/configure newlib-1.17.0/libgloss/arm/configure
---- newlib-1.17.0.orig/libgloss/arm/configure 2017-04-11 00:41:23.720866007 -0700
-+++ newlib-1.17.0/libgloss/arm/configure 2017-04-11 00:43:12.265788484 -0700
-@@ -2540,7 +2540,7 @@ test "${CCASFLAGS+set}" = set || CCASFLA
-
-
- case "${target}" in
-- *-*-elf | *-*-eabi)
-+ *-*-elf | *-*-eabi*)
- objtype=elf-
- ;;
- *-*-coff)
-diff -urpN newlib-1.17.0.orig/libgloss/arm/configure.in newlib-1.17.0/libgloss/arm/configure.in
---- newlib-1.17.0.orig/libgloss/arm/configure.in 2017-04-11 00:41:23.720866007 -0700
-+++ newlib-1.17.0/libgloss/arm/configure.in 2017-04-11 00:43:12.265788484 -0700
-@@ -49,7 +49,7 @@ AC_PROG_RANLIB
- LIB_AM_PROG_AS
-
- case "${target}" in
-- *-*-elf | *-*-eabi)
-+ *-*-elf | *-*-eabi*)
- objtype=elf-
- ;;
- *-*-coff)