summaryrefslogtreecommitdiff
path: root/packages/strace/4.10
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/strace/4.10
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/strace/4.10')
-rw-r--r--packages/strace/4.10/0000-aarch64_rt_sigreturn.patch (renamed from packages/strace/4.10/001_aarch64_rt_sigreturn.patch)8
-rw-r--r--packages/strace/4.10/0001-arm_mmap2.patch (renamed from packages/strace/4.10/002_arm_mmap2.patch)6
-rw-r--r--packages/strace/4.10/0002-aarch64_arch_regs.patch (renamed from packages/strace/4.10/003_aarch64_arch_regs.patch)13
-rw-r--r--packages/strace/4.10/0003-stat64-v.test.patch (renamed from packages/strace/4.10/004_stat64-v.test.patch)10
-rw-r--r--packages/strace/4.10/0004-select_test.patch (renamed from packages/strace/4.10/005_select_test.patch)9
-rw-r--r--packages/strace/4.10/0005-fix_aarch64_ioctl_decoding.patch (renamed from packages/strace/4.10/006_fix_aarch64_ioctl_decoding.patch)15
-rw-r--r--packages/strace/4.10/0006-fix_bexecve64_test.patch (renamed from packages/strace/4.10/007_fix_bexecve64_test.patch)4
-rw-r--r--packages/strace/4.10/0007-decode_mips_indirect_syscall.patch (renamed from packages/strace/4.10/008_decode_mips_indirect_syscall.patch)26
-rw-r--r--packages/strace/4.10/0008-upstream-musl_includes.patch (renamed from packages/strace/4.10/009-upstream-musl_includes.patch)8
-rw-r--r--packages/strace/4.10/0009-use-host-ioctl.patch (renamed from packages/strace/4.10/010-use-host-ioctl.patch)37
10 files changed, 81 insertions, 55 deletions
diff --git a/packages/strace/4.10/001_aarch64_rt_sigreturn.patch b/packages/strace/4.10/0000-aarch64_rt_sigreturn.patch
index 6b7bbe3..e99891d 100644
--- a/packages/strace/4.10/001_aarch64_rt_sigreturn.patch
+++ b/packages/strace/4.10/0000-aarch64_rt_sigreturn.patch
@@ -6,11 +6,13 @@ Date: Wed Mar 11 14:32:25 2015 +0000
* sigreturn.c (sys_sigreturn) [AARCH64]: Fix personality check.
-diff --git a/sigreturn.c b/sigreturn.c
-index 648bd0a..c253a0c 100644
+---
+ sigreturn.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/sigreturn.c
+++ b/sigreturn.c
-@@ -23,7 +23,7 @@ sys_sigreturn(struct tcb *tcp)
+@@ -23,7 +23,7 @@
# define OFFSETOF_STRUCT_UCONTEXT_UC_SIGMASK (5 * 4 + SIZEOF_STRUCT_SIGCONTEXT)
const long addr =
# ifdef AARCH64
diff --git a/packages/strace/4.10/002_arm_mmap2.patch b/packages/strace/4.10/0001-arm_mmap2.patch
index 41953e2..d244c0e 100644
--- a/packages/strace/4.10/002_arm_mmap2.patch
+++ b/packages/strace/4.10/0001-arm_mmap2.patch
@@ -7,8 +7,10 @@ Date: Mon Mar 9 16:55:06 2015 +0100
* syscallent.h (mmap2): Decode with sys_mmap_4koff, not
sys_mmap_pgoff.
-diff --git a/linux/arm/syscallent.h b/linux/arm/syscallent.h
-index 52aed9e..b66a5a2 100644
+---
+ linux/arm/syscallent.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/linux/arm/syscallent.h
+++ b/linux/arm/syscallent.h
@@ -218,7 +218,7 @@
diff --git a/packages/strace/4.10/003_aarch64_arch_regs.patch b/packages/strace/4.10/0002-aarch64_arch_regs.patch
index e5153b5..e4066d9 100644
--- a/packages/strace/4.10/003_aarch64_arch_regs.patch
+++ b/packages/strace/4.10/0002-aarch64_arch_regs.patch
@@ -6,11 +6,14 @@ Date: Thu Mar 12 11:54:08 2015 +0100
* Makefile.am (EXTRA_DIST): Add linux/aarch64/arch_regs.h.
-diff --git a/Makefile.am b/Makefile.am
-index 2030f9b..48fe1d7 100644
+---
+ Makefile.am | 1 +
+ linux/aarch64/arch_regs.h | 2 ++
+ 2 files changed, 3 insertions(+)
+
--- a/Makefile.am
+++ b/Makefile.am
-@@ -164,6 +164,7 @@ EXTRA_DIST = \
+@@ -164,6 +164,7 @@
linux/32/syscallent.h \
linux/64/ioctls_inc.h \
linux/64/syscallent.h \
@@ -18,8 +21,8 @@ index 2030f9b..48fe1d7 100644
linux/aarch64/errnoent1.h \
linux/aarch64/ioctls_arch0.h \
linux/aarch64/ioctls_arch1.h \
---- a/linux/aarch64/arch_regs.h 2015-06-09 03:27:46.170000000 +0000
-+++ b/linux/aarch64/arch_regs.h 2015-07-01 21:23:17.025202308 +0000
+--- /dev/null
++++ b/linux/aarch64/arch_regs.h
@@ -0,0 +1,2 @@
+extern uint64_t *const aarch64_sp_ptr;
+extern uint32_t *const arm_sp_ptr;
diff --git a/packages/strace/4.10/004_stat64-v.test.patch b/packages/strace/4.10/0003-stat64-v.test.patch
index 53383e3..acb098b 100644
--- a/packages/strace/4.10/004_stat64-v.test.patch
+++ b/packages/strace/4.10/0003-stat64-v.test.patch
@@ -13,8 +13,10 @@ Date: Mon Mar 16 17:18:40 2015 +0000
Reported-by: Andreas Schwab <schwab@suse.de>
-diff --git a/tests/stat.c b/tests/stat.c
-index 21e37fb..2b04010 100644
+---
+ tests/stat.c | 24 ++++++++++++++----------
+ 1 file changed, 14 insertions(+), 10 deletions(-)
+
--- a/tests/stat.c
+++ b/tests/stat.c
@@ -14,22 +14,22 @@
@@ -58,7 +60,7 @@ index 21e37fb..2b04010 100644
static void
print_ftype(unsigned int mode)
-@@ -115,7 +115,7 @@ main(int ac, const char **av)
+@@ -115,7 +115,7 @@
assert(stat(av[1], &stb) == 0);
#endif
@@ -67,7 +69,7 @@ index 21e37fb..2b04010 100644
printf("st_dev=makedev\\(%u, %u\\)",
(unsigned int) major(stb.st_dev),
(unsigned int) minor(stb.st_dev));
-@@ -159,11 +159,15 @@ main(int ac, const char **av)
+@@ -159,11 +159,15 @@
printf("(, st_flags=[0-9]+)?");
printf("(, st_fstype=[^,]*)?");
printf("(, st_gen=[0-9]+)?");
diff --git a/packages/strace/4.10/005_select_test.patch b/packages/strace/4.10/0004-select_test.patch
index cb56ec6..a778392 100644
--- a/packages/strace/4.10/005_select_test.patch
+++ b/packages/strace/4.10/0004-select_test.patch
@@ -8,8 +8,11 @@ Date: Thu Mar 12 16:47:38 2015 +0100
and pselect6 syscalls.
* tests/select.test: Probe for both select and pselect6 syscall.
-diff --git a/tests/select.awk b/tests/select.awk
-index 142504a..688cefe 100644
+---
+ tests/select.awk | 6 +++---
+ tests/select.test | 7 +++++--
+ 2 files changed, 8 insertions(+), 5 deletions(-)
+
--- a/tests/select.awk
+++ b/tests/select.awk
@@ -1,7 +1,7 @@
@@ -23,8 +26,6 @@ index 142504a..688cefe 100644
r[4] = "^\\+\\+\\+ exited with 0 \\+\\+\\+$"
lines = 4
fail = 0
-diff --git a/tests/select.test b/tests/select.test
-index bd3066b..5d5fe54 100755
--- a/tests/select.test
+++ b/tests/select.test
@@ -6,13 +6,16 @@
diff --git a/packages/strace/4.10/006_fix_aarch64_ioctl_decoding.patch b/packages/strace/4.10/0005-fix_aarch64_ioctl_decoding.patch
index a270349..9f4c053 100644
--- a/packages/strace/4.10/006_fix_aarch64_ioctl_decoding.patch
+++ b/packages/strace/4.10/0005-fix_aarch64_ioctl_decoding.patch
@@ -9,29 +9,28 @@ Date: Thu Mar 12 18:07:00 2015 +0100
* linux/aarch64/ioctls_arch0.h: Rename from ioctls_arch1.h.
* linux/aarch64/ioctls_arch1.h: Rename from ioctls_arch0.h.
-diff --git a/linux/aarch64/ioctls_arch0.h b/linux/aarch64/ioctls_arch0.h
-index 6a674cc..b722d22 100644
+---
+ linux/aarch64/ioctls_arch0.h | 2 +-
+ linux/aarch64/ioctls_arch1.h | 2 +-
+ linux/aarch64/ioctls_inc0.h | 2 +-
+ linux/aarch64/ioctls_inc1.h | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
--- a/linux/aarch64/ioctls_arch0.h
+++ b/linux/aarch64/ioctls_arch0.h
@@ -1 +1 @@
-/* Generated by ioctls_gen.sh from definitions found in $linux/arch/arm64/include/ tree. */
+#include "arm/ioctls_arch0.h"
-diff --git a/linux/aarch64/ioctls_arch1.h b/linux/aarch64/ioctls_arch1.h
-index b722d22..6a674cc 100644
--- a/linux/aarch64/ioctls_arch1.h
+++ b/linux/aarch64/ioctls_arch1.h
@@ -1 +1 @@
-#include "arm/ioctls_arch0.h"
+/* Generated by ioctls_gen.sh from definitions found in $linux/arch/arm64/include/ tree. */
-diff --git a/linux/aarch64/ioctls_inc0.h b/linux/aarch64/ioctls_inc0.h
-index f9939fa..46c11b1 100644
--- a/linux/aarch64/ioctls_inc0.h
+++ b/linux/aarch64/ioctls_inc0.h
@@ -1 +1 @@
-#include "64/ioctls_inc.h"
+#include "arm/ioctls_inc0.h"
-diff --git a/linux/aarch64/ioctls_inc1.h b/linux/aarch64/ioctls_inc1.h
-index 46c11b1..f9939fa 100644
--- a/linux/aarch64/ioctls_inc1.h
+++ b/linux/aarch64/ioctls_inc1.h
@@ -1 +1 @@
diff --git a/packages/strace/4.10/007_fix_bexecve64_test.patch b/packages/strace/4.10/0006-fix_bexecve64_test.patch
index 6dc9b46..f5b255b 100644
--- a/packages/strace/4.10/007_fix_bexecve64_test.patch
+++ b/packages/strace/4.10/0006-fix_bexecve64_test.patch
@@ -1,5 +1,9 @@
commit b704e8fbb4d9cf90ac56f3c889de5b779c444db4
(loosely based on)
+---
+ tests/bexecve.test | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
--- a/tests/bexecve.test
+++ b/tests/bexecve.test
@@ -24,13 +24,14 @@
diff --git a/packages/strace/4.10/008_decode_mips_indirect_syscall.patch b/packages/strace/4.10/0007-decode_mips_indirect_syscall.patch
index d2d7217..8921dda 100644
--- a/packages/strace/4.10/008_decode_mips_indirect_syscall.patch
+++ b/packages/strace/4.10/0007-decode_mips_indirect_syscall.patch
@@ -1,8 +1,12 @@
commit f34b97f89dd3893ef3652a6899487771402fc13c
-Index: strace-4.10/linux/mips/syscallent-o32.h
-===================================================================
---- strace-4.10.orig/linux/mips/syscallent-o32.h
-+++ strace-4.10/linux/mips/syscallent-o32.h
+---
+ linux/mips/syscallent-o32.h | 2 +-
+ linux/syscall.h | 1 +
+ syscall.c | 24 ++++++++++++++++++++++++
+ 3 files changed, 26 insertions(+), 1 deletion(-)
+
+--- a/linux/mips/syscallent-o32.h
++++ b/linux/mips/syscallent-o32.h
@@ -1,6 +1,6 @@
#if defined LINUX_MIPSO32
/* For an O32 strace, decode the o32 syscalls. */
@@ -11,11 +15,9 @@ Index: strace-4.10/linux/mips/syscallent-o32.h
[4001] = { 1, TP|SE, sys_exit, "exit" },
[4002] = { 0, TP, sys_fork, "fork" },
[4003] = { 3, TD, sys_read, "read" },
-Index: strace-4.10/syscall.c
-===================================================================
---- strace-4.10.orig/syscall.c
-+++ strace-4.10/syscall.c
-@@ -606,6 +606,25 @@ decode_ipc_subcall(struct tcb *tcp)
+--- a/syscall.c
++++ b/syscall.c
+@@ -606,6 +606,25 @@
}
#endif
@@ -41,7 +43,7 @@ Index: strace-4.10/syscall.c
int
printargs(struct tcb *tcp)
{
-@@ -1774,6 +1793,11 @@ trace_syscall_entering(struct tcb *tcp)
+@@ -1774,6 +1793,11 @@
goto ret;
}
@@ -53,8 +55,8 @@ Index: strace-4.10/syscall.c
if ( sys_execve == tcp->s_ent->sys_func
# if defined(SPARC) || defined(SPARC64)
|| sys_execv == tcp->s_ent->sys_func
---- strace-4.10.orig/linux/syscall.h 2015-02-06 01:23:05.000000000 +0000
-+++ strace-4.10/linux/syscall.h 2015-07-09 14:36:49.372494628 +0100
+--- a/linux/syscall.h
++++ b/linux/syscall.h
@@ -277,6 +277,7 @@
int sys_symlinkat();
int sys_sync_file_range();
diff --git a/packages/strace/4.10/009-upstream-musl_includes.patch b/packages/strace/4.10/0008-upstream-musl_includes.patch
index c68f8d8..87717ca 100644
--- a/packages/strace/4.10/009-upstream-musl_includes.patch
+++ b/packages/strace/4.10/0008-upstream-musl_includes.patch
@@ -1,5 +1,13 @@
commit 3460dc486d333231998de0f19918204aacee9ae3
commit d34e00b293942b1012ddc49ed3ab379a32337611
+---
+ evdev.c | 2 ++
+ ioctl.c | 2 +-
+ ioctlsort.c | 2 +-
+ mknod.c | 1 +
+ printmode.c | 1 +
+ 5 files changed, 6 insertions(+), 2 deletions(-)
+
--- a/evdev.c
+++ b/evdev.c
@@ -28,6 +28,8 @@
diff --git a/packages/strace/4.10/010-use-host-ioctl.patch b/packages/strace/4.10/0009-use-host-ioctl.patch
index e9c34d3..857c7c0 100644
--- a/packages/strace/4.10/010-use-host-ioctl.patch
+++ b/packages/strace/4.10/0009-use-host-ioctl.patch
@@ -1,6 +1,12 @@
-diff -urpN strace-4.10.orig/ioctl_iocdef.c strace-4.10/ioctl_iocdef.c
---- strace-4.10.orig/ioctl_iocdef.c 1969-12-31 16:00:00.000000000 -0800
-+++ strace-4.10/ioctl_iocdef.c 2017-01-14 15:05:49.505335680 -0800
+---
+ Makefile.am | 14 ++++++++++++--
+ Makefile.in | 14 ++++++++++++--
+ ioctl_iocdef.c | 43 +++++++++++++++++++++++++++++++++++++++++++
+ ioctlsort.c | 3 ++-
+ 4 files changed, 69 insertions(+), 5 deletions(-)
+
+--- /dev/null
++++ b/ioctl_iocdef.c
@@ -0,0 +1,43 @@
+/*
+ * Copyright (c) 2017 Alexey Neyman <stilor@att.net>
@@ -45,9 +51,8 @@ diff -urpN strace-4.10.orig/ioctl_iocdef.c strace-4.10/ioctl_iocdef.c
+
+DEFINE HOST_IOC_SIZESHIFT _IOC_SIZESHIFT
+DEFINE HOST_IOC_DIRSHIFT _IOC_DIRSHIFT
-diff -urpN strace-4.10.orig/ioctlsort.c strace-4.10/ioctlsort.c
---- strace-4.10.orig/ioctlsort.c 2015-02-15 18:35:58.000000000 -0800
-+++ strace-4.10/ioctlsort.c 2017-01-14 15:20:30.597371979 -0800
+--- a/ioctlsort.c
++++ b/ioctlsort.c
@@ -33,7 +33,8 @@
#include <stdio.h>
#include <stdlib.h>
@@ -58,10 +63,9 @@ diff -urpN strace-4.10.orig/ioctlsort.c strace-4.10/ioctlsort.c
struct ioctlent {
const char *info;
-diff -urpN strace-4.10.orig/Makefile.am strace-4.10/Makefile.am
---- strace-4.10.orig/Makefile.am 2015-03-05 18:19:01.000000000 -0800
-+++ strace-4.10/Makefile.am 2017-01-14 15:07:28.978244260 -0800
-@@ -159,6 +159,7 @@ EXTRA_DIST = \
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -159,6 +159,7 @@
debian/strace64.manpages \
debian/watch \
errnoent.sh \
@@ -69,7 +73,7 @@ diff -urpN strace-4.10.orig/Makefile.am strace-4.10/Makefile.am
ioctlsort.c \
linux/32/ioctls_inc.h \
linux/32/syscallent.h \
-@@ -416,15 +417,24 @@ ioctlsort_LDFLAGS = $(AM_LDFLAGS) $(LDFL
+@@ -417,15 +418,24 @@
ioctls_inc_h = $(wildcard $(srcdir)/$(OS)/$(ARCH)/ioctls_inc*.h)
ioctlent_h = $(patsubst $(srcdir)/$(OS)/$(ARCH)/ioctls_inc%,ioctlent%,$(ioctls_inc_h))
BUILT_SOURCES += $(ioctlent_h)
@@ -96,10 +100,9 @@ diff -urpN strace-4.10.orig/Makefile.am strace-4.10/Makefile.am
$(ioctlsort_CC) $(ioctlsort_DEFS) $(ioctlsort_INCLUDES) $(ioctlsort_CPPFLAGS) $(ioctlsort_CFLAGS) -DIOCTLSORT_INC=\"$<\" -c -o $@ $(srcdir)/ioctlsort.c
ioctls_all%.h: $(srcdir)/$(OS)/$(ARCH)/ioctls_inc%.h $(srcdir)/$(OS)/$(ARCH)/ioctls_arch%.h
-diff -urpN strace-4.10.orig/Makefile.in strace-4.10/Makefile.in
---- strace-4.10.orig/Makefile.in 2015-03-06 07:16:46.000000000 -0800
-+++ strace-4.10/Makefile.in 2017-01-14 15:23:06.718794409 -0800
-@@ -687,6 +687,7 @@ EXTRA_DIST = \
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -687,6 +687,7 @@
debian/strace64.manpages \
debian/watch \
errnoent.sh \
@@ -107,7 +110,7 @@ diff -urpN strace-4.10.orig/Makefile.in strace-4.10/Makefile.in
ioctlsort.c \
linux/32/ioctls_inc.h \
linux/32/syscallent.h \
-@@ -921,7 +922,7 @@ ioctlsort_CFLAGS = $(AM_CFLAGS) $(CFLAGS
+@@ -921,7 +922,7 @@
ioctlsort_LDFLAGS = $(AM_LDFLAGS) $(LDFLAGS_FOR_BUILD)
ioctls_inc_h = $(wildcard $(srcdir)/$(OS)/$(ARCH)/ioctls_inc*.h)
ioctlent_h = $(patsubst $(srcdir)/$(OS)/$(ARCH)/ioctls_inc%,ioctlent%,$(ioctls_inc_h))
@@ -116,7 +119,7 @@ diff -urpN strace-4.10.orig/Makefile.in strace-4.10/Makefile.in
@MAINTAINER_MODE_TRUE@gen_changelog_start_date = 2009-07-08 20:00
all: $(BUILT_SOURCES) config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive
-@@ -3414,13 +3415,22 @@ news-check: NEWS
+@@ -3414,13 +3415,22 @@
exit 1; \
fi