summaryrefslogtreecommitdiff
path: root/packages/strace/4.10
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-05-20 04:58:46 (GMT)
committerAlexey Neyman <stilor@att.net>2017-07-08 17:57:56 (GMT)
commite7deac3aad394325f9e6fc6fda41d34ec94a59e0 (patch)
tree6ad88362f0bfa8385a91eb494009a4646aeb74b6 /packages/strace/4.10
parentb9af225f58e45c7fae7eb9d3689fe939243e7578 (diff)
Switch comp.libs/tools and debug to new framework.
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/strace/4.10')
-rw-r--r--packages/strace/4.10/001_aarch64_rt_sigreturn.patch21
-rw-r--r--packages/strace/4.10/002_arm_mmap2.patch22
-rw-r--r--packages/strace/4.10/003_aarch64_arch_regs.patch25
-rw-r--r--packages/strace/4.10/004_stat64-v.test.patch87
-rw-r--r--packages/strace/4.10/005_select_test.patch48
-rw-r--r--packages/strace/4.10/006_fix_aarch64_ioctl_decoding.patch39
-rw-r--r--packages/strace/4.10/007_fix_bexecve64_test.patch20
-rw-r--r--packages/strace/4.10/008_decode_mips_indirect_syscall.patch65
-rw-r--r--packages/strace/4.10/009-upstream-musl_includes.patch55
-rw-r--r--packages/strace/4.10/010-use-host-ioctl.patch142
-rw-r--r--packages/strace/4.10/version.desc1
11 files changed, 525 insertions, 0 deletions
diff --git a/packages/strace/4.10/001_aarch64_rt_sigreturn.patch b/packages/strace/4.10/001_aarch64_rt_sigreturn.patch
new file mode 100644
index 0000000..6b7bbe3
--- /dev/null
+++ b/packages/strace/4.10/001_aarch64_rt_sigreturn.patch
@@ -0,0 +1,21 @@
+commit d76d3069526c348e6fe5d40bbbceb2ae4a928d16
+Author: Dmitry V. Levin <ldv@altlinux.org>
+Date: Wed Mar 11 14:32:25 2015 +0000
+
+ aarch64: fix rt_sigreturn decoding
+
+ * sigreturn.c (sys_sigreturn) [AARCH64]: Fix personality check.
+
+diff --git a/sigreturn.c b/sigreturn.c
+index 648bd0a..c253a0c 100644
+--- a/sigreturn.c
++++ b/sigreturn.c
+@@ -23,7 +23,7 @@ sys_sigreturn(struct tcb *tcp)
+ # define OFFSETOF_STRUCT_UCONTEXT_UC_SIGMASK (5 * 4 + SIZEOF_STRUCT_SIGCONTEXT)
+ const long addr =
+ # ifdef AARCH64
+- current_personality == 0 ?
++ current_personality == 1 ?
+ (*aarch64_sp_ptr + SIZEOF_STRUCT_SIGINFO +
+ offsetof(struct ucontext, uc_sigmask)) :
+ # endif
diff --git a/packages/strace/4.10/002_arm_mmap2.patch b/packages/strace/4.10/002_arm_mmap2.patch
new file mode 100644
index 0000000..41953e2
--- /dev/null
+++ b/packages/strace/4.10/002_arm_mmap2.patch
@@ -0,0 +1,22 @@
+commit dbadf7bcc8995612d5ef737047b909e868387e37
+Author: Andreas Schwab <schwab@suse.de>
+Date: Mon Mar 9 16:55:06 2015 +0100
+
+ Fix decoding of mmap2 for arm
+
+ * syscallent.h (mmap2): Decode with sys_mmap_4koff, not
+ sys_mmap_pgoff.
+
+diff --git a/linux/arm/syscallent.h b/linux/arm/syscallent.h
+index 52aed9e..b66a5a2 100644
+--- a/linux/arm/syscallent.h
++++ b/linux/arm/syscallent.h
+@@ -218,7 +218,7 @@
+ [189] = { 5, 0, sys_putpmsg, "putpmsg" },
+ [190] = { 0, TP, sys_vfork, "vfork" },
+ [191] = { 2, 0, sys_getrlimit, "ugetrlimit" },
+-[192] = { 6, TD|TM|SI, sys_mmap_pgoff, "mmap2" },
++[192] = { 6, TD|TM|SI, sys_mmap_4koff, "mmap2" },
+ [193] = { 4, TF, sys_truncate64, "truncate64" },
+ [194] = { 4, TD, sys_ftruncate64, "ftruncate64" },
+ [195] = { 2, TF, sys_stat64, "stat64" },
diff --git a/packages/strace/4.10/003_aarch64_arch_regs.patch b/packages/strace/4.10/003_aarch64_arch_regs.patch
new file mode 100644
index 0000000..e5153b5
--- /dev/null
+++ b/packages/strace/4.10/003_aarch64_arch_regs.patch
@@ -0,0 +1,25 @@
+commit 64fc9cedc475b2fc0d940509dc4232b02b5f83ec
+Author: Andreas Schwab <schwab@suse.de>
+Date: Thu Mar 12 11:54:08 2015 +0100
+
+ Distribute linux/aarch64/arch_regs.h
+
+ * Makefile.am (EXTRA_DIST): Add linux/aarch64/arch_regs.h.
+
+diff --git a/Makefile.am b/Makefile.am
+index 2030f9b..48fe1d7 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -164,6 +164,7 @@ EXTRA_DIST = \
+ linux/32/syscallent.h \
+ linux/64/ioctls_inc.h \
+ linux/64/syscallent.h \
++ linux/aarch64/arch_regs.h \
+ linux/aarch64/errnoent1.h \
+ linux/aarch64/ioctls_arch0.h \
+ linux/aarch64/ioctls_arch1.h \
+--- a/linux/aarch64/arch_regs.h 2015-06-09 03:27:46.170000000 +0000
++++ b/linux/aarch64/arch_regs.h 2015-07-01 21:23:17.025202308 +0000
+@@ -0,0 +1,2 @@
++extern uint64_t *const aarch64_sp_ptr;
++extern uint32_t *const arm_sp_ptr;
diff --git a/packages/strace/4.10/004_stat64-v.test.patch b/packages/strace/4.10/004_stat64-v.test.patch
new file mode 100644
index 0000000..53383e3
--- /dev/null
+++ b/packages/strace/4.10/004_stat64-v.test.patch
@@ -0,0 +1,87 @@
+commit f79252f072a193bdff435afeaa6b6cd6d5c79947
+Author: Dmitry V. Levin <ldv@altlinux.org>
+Date: Mon Mar 16 17:18:40 2015 +0000
+
+ stat64-v.test: add newfstatat syscall support
+
+ Newer architectures have no stat syscall, so stat() is implemented there
+ using newfstatat syscall.
+
+ * tests/stat.c (STAT_FNAME): Rename to STAT_PREFIX. Update callers.
+ [_FILE_OFFSET_BITS == 64] (STAT_PREFIX): Add newfstatat support.
+ (main) [!NR_stat]: Add newfstatat support.
+
+ Reported-by: Andreas Schwab <schwab@suse.de>
+
+diff --git a/tests/stat.c b/tests/stat.c
+index 21e37fb..2b04010 100644
+--- a/tests/stat.c
++++ b/tests/stat.c
+@@ -14,22 +14,22 @@
+ # include <sys/types.h>
+ #endif
+
+-#undef STAT_FNAME
++#undef STAT_PREFIX
+ #undef NR_stat
+
+ #if defined _FILE_OFFSET_BITS && _FILE_OFFSET_BITS == 64
+ # include <sys/stat.h>
+-# define STAT_FNAME "stat(64)?"
++# define STAT_PREFIX "(stat(64)?\\(|newfstatat\\(AT_FDCWD, )"
+ #else
+ # include <sys/syscall.h>
+ # if defined __NR_stat
+ # define NR_stat __NR_stat
+-# define STAT_FNAME "stat"
++# define STAT_PREFIX "stat\\("
+ # elif defined __NR_newstat
+ # define NR_stat __NR_newstat
+-# define STAT_FNAME "newstat"
++# define STAT_PREFIX "newstat\\("
+ # endif
+-# ifdef STAT_FNAME
++# ifdef STAT_PREFIX
+ /* for S_IFMT */
+ # define stat libc_stat
+ # define stat64 libc_stat64
+@@ -57,10 +57,10 @@
+ # define off_t __kernel_off_t
+ # define loff_t __kernel_loff_t
+ # include <asm/stat.h>
+-# endif /* STAT_FNAME */
++# endif /* STAT_PREFIX */
+ #endif /* _FILE_OFFSET_BITS */
+
+-#ifdef STAT_FNAME
++#ifdef STAT_PREFIX
+
+ static void
+ print_ftype(unsigned int mode)
+@@ -115,7 +115,7 @@ main(int ac, const char **av)
+ assert(stat(av[1], &stb) == 0);
+ #endif
+
+- printf(STAT_FNAME "\\(\"%s\", \\{", av[1]);
++ printf(STAT_PREFIX "\"%s\", \\{", av[1]);
+ printf("st_dev=makedev\\(%u, %u\\)",
+ (unsigned int) major(stb.st_dev),
+ (unsigned int) minor(stb.st_dev));
+@@ -159,11 +159,15 @@ main(int ac, const char **av)
+ printf("(, st_flags=[0-9]+)?");
+ printf("(, st_fstype=[^,]*)?");
+ printf("(, st_gen=[0-9]+)?");
+- printf("\\}\\) += 0\n");
++ printf("\\}");
++#ifndef NR_stat
++ printf("(, 0)?");
++#endif
++ printf("\\) += 0\n");
+ return 0;
+ }
+
+-#else /* !STAT_FNAME */
++#else /* !STAT_PREFIX */
+ int main(void)
+ {
+ return 77;
diff --git a/packages/strace/4.10/005_select_test.patch b/packages/strace/4.10/005_select_test.patch
new file mode 100644
index 0000000..cb56ec6
--- /dev/null
+++ b/packages/strace/4.10/005_select_test.patch
@@ -0,0 +1,48 @@
+commit 95336102eb836ba69a2b51a3bbe733abd63bbe77
+Author: Andreas Schwab <schwab@suse.de>
+Date: Thu Mar 12 16:47:38 2015 +0100
+
+ tests/select.test: handle architectures using pselect6 syscall
+
+ * tests/select.awk (BEGIN): Update regexps to match both select
+ and pselect6 syscalls.
+ * tests/select.test: Probe for both select and pselect6 syscall.
+
+diff --git a/tests/select.awk b/tests/select.awk
+index 142504a..688cefe 100644
+--- a/tests/select.awk
++++ b/tests/select.awk
+@@ -1,7 +1,7 @@
+ BEGIN {
+- r[1] = "^select\\(2, \\[0 1\\], \\[0 1\\], \\[0 1\\], NULL\\) += 1 \\(\\)$"
+- r[2] = "^select\\(-1, NULL, 0x[0-9a-f]+, NULL, NULL\\) += -1 "
+- r[3] = "^select\\(1025, \\[0\\], \\[\\], NULL, \\{0, 100\\}\\) += 0 \\(Timeout\\)$"
++ r[1] = "^p?select6?\\(2, \\[0 1\\], \\[0 1\\], \\[0 1\\], NULL(, 0)?\\) += 1 \\(\\)$"
++ r[2] = "^p?select6?\\(-1, NULL, 0x[0-9a-f]+, NULL, NULL(, 0)?\\) += -1 "
++ r[3] = "^p?select6?\\(1025, \\[0\\], \\[\\], NULL, \\{0, 100(000)?\\}(, 0)?\\) += 0 \\(Timeout\\)$"
+ r[4] = "^\\+\\+\\+ exited with 0 \\+\\+\\+$"
+ lines = 4
+ fail = 0
+diff --git a/tests/select.test b/tests/select.test
+index bd3066b..5d5fe54 100755
+--- a/tests/select.test
++++ b/tests/select.test
+@@ -6,13 +6,16 @@
+
+ check_prog awk
+
+-$STRACE -eselect -h > /dev/null ||
++syscall=
++$STRACE -epselect6 -h > /dev/null && syscall=$syscall,pselect6
++$STRACE -eselect -h > /dev/null && syscall=$syscall,select
++test -n "$syscall" ||
+ skip_ 'select syscall is not supported on this architecture'
+
+ ./select ||
+ framework_skip_ 'select syscall does not behave as expected'
+
+-args='-eselect ./select'
++args="-e$syscall ./select"
+ $STRACE -o "$LOG" $args || {
+ cat "$LOG"
+ fail_ "$STRACE $args failed"
diff --git a/packages/strace/4.10/006_fix_aarch64_ioctl_decoding.patch b/packages/strace/4.10/006_fix_aarch64_ioctl_decoding.patch
new file mode 100644
index 0000000..a270349
--- /dev/null
+++ b/packages/strace/4.10/006_fix_aarch64_ioctl_decoding.patch
@@ -0,0 +1,39 @@
+commit 0e3811d7914f209858cf4e445221fd65644cc94b
+Author: Andreas Schwab <schwab@suse.de>
+Date: Thu Mar 12 18:07:00 2015 +0100
+
+ aarch64: fix ioctl decoding
+
+ * linux/aarch64/ioctls_inc0.h: Rename from ioctls_inc1.h.
+ * linux/aarch64/ioctls_inc1.h: Rename from ioctls_inc0.h.
+ * linux/aarch64/ioctls_arch0.h: Rename from ioctls_arch1.h.
+ * linux/aarch64/ioctls_arch1.h: Rename from ioctls_arch0.h.
+
+diff --git a/linux/aarch64/ioctls_arch0.h b/linux/aarch64/ioctls_arch0.h
+index 6a674cc..b722d22 100644
+--- a/linux/aarch64/ioctls_arch0.h
++++ b/linux/aarch64/ioctls_arch0.h
+@@ -1 +1 @@
+-/* Generated by ioctls_gen.sh from definitions found in $linux/arch/arm64/include/ tree. */
++#include "arm/ioctls_arch0.h"
+diff --git a/linux/aarch64/ioctls_arch1.h b/linux/aarch64/ioctls_arch1.h
+index b722d22..6a674cc 100644
+--- a/linux/aarch64/ioctls_arch1.h
++++ b/linux/aarch64/ioctls_arch1.h
+@@ -1 +1 @@
+-#include "arm/ioctls_arch0.h"
++/* Generated by ioctls_gen.sh from definitions found in $linux/arch/arm64/include/ tree. */
+diff --git a/linux/aarch64/ioctls_inc0.h b/linux/aarch64/ioctls_inc0.h
+index f9939fa..46c11b1 100644
+--- a/linux/aarch64/ioctls_inc0.h
++++ b/linux/aarch64/ioctls_inc0.h
+@@ -1 +1 @@
+-#include "64/ioctls_inc.h"
++#include "arm/ioctls_inc0.h"
+diff --git a/linux/aarch64/ioctls_inc1.h b/linux/aarch64/ioctls_inc1.h
+index 46c11b1..f9939fa 100644
+--- a/linux/aarch64/ioctls_inc1.h
++++ b/linux/aarch64/ioctls_inc1.h
+@@ -1 +1 @@
+-#include "arm/ioctls_inc0.h"
++#include "64/ioctls_inc.h"
diff --git a/packages/strace/4.10/007_fix_bexecve64_test.patch b/packages/strace/4.10/007_fix_bexecve64_test.patch
new file mode 100644
index 0000000..6dc9b46
--- /dev/null
+++ b/packages/strace/4.10/007_fix_bexecve64_test.patch
@@ -0,0 +1,20 @@
+commit b704e8fbb4d9cf90ac56f3c889de5b779c444db4
+(loosely based on)
+--- a/tests/bexecve.test
++++ b/tests/bexecve.test
+@@ -24,13 +24,14 @@
+ }
+
+ pattern='Process [1-9][0-9]* detached'
++pattern_personality='\[ Process PID=[1-9][0-9]* runs in .* mode. \]'
+
+ LC_ALL=C grep -x "$pattern" "$LOG" > /dev/null || {
+ cat "$LOG"
+ fail_ "$what: unexpected output"
+ }
+
+-if LC_ALL=C grep -v -x "$pattern" "$LOG" > /dev/null; then
++if LC_ALL=C grep -E -v -x "($pattern|$pattern_personality)" "$LOG" > /dev/null; then
+ cat "$LOG"
+ fail_ "$what: unexpected output"
+ fi
diff --git a/packages/strace/4.10/008_decode_mips_indirect_syscall.patch b/packages/strace/4.10/008_decode_mips_indirect_syscall.patch
new file mode 100644
index 0000000..d2d7217
--- /dev/null
+++ b/packages/strace/4.10/008_decode_mips_indirect_syscall.patch
@@ -0,0 +1,65 @@
+commit f34b97f89dd3893ef3652a6899487771402fc13c
+Index: strace-4.10/linux/mips/syscallent-o32.h
+===================================================================
+--- strace-4.10.orig/linux/mips/syscallent-o32.h
++++ strace-4.10/linux/mips/syscallent-o32.h
+@@ -1,6 +1,6 @@
+ #if defined LINUX_MIPSO32
+ /* For an O32 strace, decode the o32 syscalls. */
+-[4000] = { MA, 0, printargs, "syscall" }, /* start of Linux o32 */
++[4000] = { MA, 0, sys_syscall, "syscall" }, /* start of Linux o32 */
+ [4001] = { 1, TP|SE, sys_exit, "exit" },
+ [4002] = { 0, TP, sys_fork, "fork" },
+ [4003] = { 3, TD, sys_read, "read" },
+Index: strace-4.10/syscall.c
+===================================================================
+--- strace-4.10.orig/syscall.c
++++ strace-4.10/syscall.c
+@@ -606,6 +606,25 @@ decode_ipc_subcall(struct tcb *tcp)
+ }
+ #endif
+
++#ifdef LINUX_MIPSO32
++static void
++decode_mips_subcall(struct tcb *tcp)
++{
++ if (!SCNO_IS_VALID(tcp->u_arg[0]))
++ return;
++ tcp->scno = tcp->u_arg[0];
++ tcp->qual_flg = qual_flags[tcp->scno];
++ tcp->s_ent = &sysent[tcp->scno];
++ memmove(&tcp->u_arg[0], &tcp->u_arg[1],
++ sizeof(tcp->u_arg) - sizeof(tcp->u_arg[0]));
++}
++
++int sys_syscall(struct tcb *tcp)
++{
++ return printargs(tcp);
++}
++#endif
++
+ int
+ printargs(struct tcb *tcp)
+ {
+@@ -1774,6 +1793,11 @@ trace_syscall_entering(struct tcb *tcp)
+ goto ret;
+ }
+
++#ifdef LINUX_MIPSO32
++ if (sys_syscall == tcp->s_ent->sys_func)
++ decode_mips_subcall(tcp);
++#endif
++
+ if ( sys_execve == tcp->s_ent->sys_func
+ # if defined(SPARC) || defined(SPARC64)
+ || sys_execv == tcp->s_ent->sys_func
+--- strace-4.10.orig/linux/syscall.h 2015-02-06 01:23:05.000000000 +0000
++++ strace-4.10/linux/syscall.h 2015-07-09 14:36:49.372494628 +0100
+@@ -277,6 +277,7 @@
+ int sys_symlinkat();
+ int sys_sync_file_range();
+ int sys_sync_file_range2();
++int sys_syscall();
+ int sys_sysctl();
+ int sys_sysinfo();
+ int sys_syslog();
diff --git a/packages/strace/4.10/009-upstream-musl_includes.patch b/packages/strace/4.10/009-upstream-musl_includes.patch
new file mode 100644
index 0000000..c68f8d8
--- /dev/null
+++ b/packages/strace/4.10/009-upstream-musl_includes.patch
@@ -0,0 +1,55 @@
+commit 3460dc486d333231998de0f19918204aacee9ae3
+commit d34e00b293942b1012ddc49ed3ab379a32337611
+--- a/evdev.c
++++ b/evdev.c
+@@ -28,6 +28,8 @@
+
+ #include "defs.h"
+
++#include <linux/ioctl.h>
++
+ #ifdef HAVE_LINUX_INPUT_H
+ #include <linux/input.h>
+ #include "xlat/evdev_abs.h"
+--- a/ioctl.c
++++ b/ioctl.c
+@@ -29,7 +29,7 @@
+ */
+
+ #include "defs.h"
+-#include <asm/ioctl.h>
++#include <linux/ioctl.h>
+ #include "xlat/ioctl_dirs.h"
+
+ #ifdef HAVE_LINUX_INPUT_H
+--- a/ioctlsort.c
++++ b/ioctlsort.c
+@@ -33,7 +33,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <asm/ioctl.h>
++#include <linux/ioctl.h>
+
+ struct ioctlent {
+ const char *info;
+--- a/mknod.c
++++ b/mknod.c
+@@ -1,6 +1,7 @@
+ #include "defs.h"
+
+ #include <fcntl.h>
++#include <sys/stat.h>
+
+ #ifdef MAJOR_IN_SYSMACROS
+ # include <sys/sysmacros.h>
+--- a/printmode.c
++++ b/printmode.c
+@@ -1,6 +1,7 @@
+ #include "defs.h"
+
+ #include <fcntl.h>
++#include <sys/stat.h>
+
+ #include "xlat/modetypes.h"
+
diff --git a/packages/strace/4.10/010-use-host-ioctl.patch b/packages/strace/4.10/010-use-host-ioctl.patch
new file mode 100644
index 0000000..e9c34d3
--- /dev/null
+++ b/packages/strace/4.10/010-use-host-ioctl.patch
@@ -0,0 +1,142 @@
+diff -urpN strace-4.10.orig/ioctl_iocdef.c strace-4.10/ioctl_iocdef.c
+--- strace-4.10.orig/ioctl_iocdef.c 1969-12-31 16:00:00.000000000 -0800
++++ strace-4.10/ioctl_iocdef.c 2017-01-14 15:05:49.505335680 -0800
+@@ -0,0 +1,43 @@
++/*
++ * Copyright (c) 2017 Alexey Neyman <stilor@att.net>
++ * All rights reserved.
++ *
++ * Redistribution and use in source and binary forms, with or without
++ * modification, are permitted provided that the following conditions
++ * are met:
++ * 1. Redistributions of source code must retain the above copyright
++ * notice, this list of conditions and the following disclaimer.
++ * 2. Redistributions in binary form must reproduce the above copyright
++ * notice, this list of conditions and the following disclaimer in the
++ * documentation and/or other materials provided with the distribution.
++ * 3. The name of the author may not be used to endorse or promote products
++ * derived from this software without specific prior written permission.
++ *
++ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
++ * IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
++ * OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
++ * IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
++ * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
++ * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
++ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
++ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
++ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
++ * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
++ */
++
++/*
++ * This file is *PREPROCESSED*, not *COMPILED* for host and the result
++ * is included into ioctlsort (which is compiled for build). Since some
++ * of these values are used in structure initializers, they cannot be
++ * defined as 'const unsigned int' - instead, they have to be macros.
++ * Hence, the result of preprocessing will be run through sed to change
++ * 'DEFINE' into '#define'
++ */
++#include <linux/ioctl.h>
++
++DEFINE HOST_IOC_NONE _IOC_NONE
++DEFINE HOST_IOC_READ _IOC_READ
++DEFINE HOST_IOC_WRITE _IOC_WRITE
++
++DEFINE HOST_IOC_SIZESHIFT _IOC_SIZESHIFT
++DEFINE HOST_IOC_DIRSHIFT _IOC_DIRSHIFT
+diff -urpN strace-4.10.orig/ioctlsort.c strace-4.10/ioctlsort.c
+--- strace-4.10.orig/ioctlsort.c 2015-02-15 18:35:58.000000000 -0800
++++ strace-4.10/ioctlsort.c 2017-01-14 15:20:30.597371979 -0800
+@@ -33,7 +33,8 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <linux/ioctl.h>
++
++#include "ioctl_iocdef.h"
+
+ struct ioctlent {
+ const char *info;
+diff -urpN strace-4.10.orig/Makefile.am strace-4.10/Makefile.am
+--- strace-4.10.orig/Makefile.am 2015-03-05 18:19:01.000000000 -0800
++++ strace-4.10/Makefile.am 2017-01-14 15:07:28.978244260 -0800
+@@ -159,6 +159,7 @@ EXTRA_DIST = \
+ debian/strace64.manpages \
+ debian/watch \
+ errnoent.sh \
++ ioctl_iocdef.c \
+ ioctlsort.c \
+ linux/32/ioctls_inc.h \
+ linux/32/syscallent.h \
+@@ -416,15 +417,24 @@ ioctlsort_LDFLAGS = $(AM_LDFLAGS) $(LDFL
+ ioctls_inc_h = $(wildcard $(srcdir)/$(OS)/$(ARCH)/ioctls_inc*.h)
+ ioctlent_h = $(patsubst $(srcdir)/$(OS)/$(ARCH)/ioctls_inc%,ioctlent%,$(ioctls_inc_h))
+ BUILT_SOURCES += $(ioctlent_h)
+-CLEANFILES = $(ioctlent_h)
++CLEANFILES = $(ioctlent_h) ioctl_iocdef.h
+
+ ioctlent%.h: ioctlsort%
+ ./$< > $@
+
++# Need to pick up <linux/ioctl.h> definitions *for host* while compiling
++# ioctlsort *for build*, hence this magic.
++ioctl_iocdef.i: $(srcdir)/ioctl_iocdef.c
++ $(CPP) -P $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
++ $(strace_CPPFLAGS) $(CPPFLAGS) $< -o $@
++
++ioctl_iocdef.h: ioctl_iocdef.i
++ sed -n 's/^DEFINE HOST/#define /p' $< > $@
++
+ ioctlsort%$(BUILD_EXEEXT): ioctlsort%.o
+ $(ioctlsort_CC) $(ioctlsort_CFLAGS) $(ioctlsort_LDFLAGS) $< -o $@
+
+-ioctlsort%.o: ioctls_all%.h $(srcdir)/ioctlsort.c
++ioctlsort%.o: ioctls_all%.h ioctl_iocdef.h $(srcdir)/ioctlsort.c
+ $(ioctlsort_CC) $(ioctlsort_DEFS) $(ioctlsort_INCLUDES) $(ioctlsort_CPPFLAGS) $(ioctlsort_CFLAGS) -DIOCTLSORT_INC=\"$<\" -c -o $@ $(srcdir)/ioctlsort.c
+
+ ioctls_all%.h: $(srcdir)/$(OS)/$(ARCH)/ioctls_inc%.h $(srcdir)/$(OS)/$(ARCH)/ioctls_arch%.h
+diff -urpN strace-4.10.orig/Makefile.in strace-4.10/Makefile.in
+--- strace-4.10.orig/Makefile.in 2015-03-06 07:16:46.000000000 -0800
++++ strace-4.10/Makefile.in 2017-01-14 15:23:06.718794409 -0800
+@@ -687,6 +687,7 @@ EXTRA_DIST = \
+ debian/strace64.manpages \
+ debian/watch \
+ errnoent.sh \
++ ioctl_iocdef.c \
+ ioctlsort.c \
+ linux/32/ioctls_inc.h \
+ linux/32/syscallent.h \
+@@ -921,7 +922,7 @@ ioctlsort_CFLAGS = $(AM_CFLAGS) $(CFLAGS
+ ioctlsort_LDFLAGS = $(AM_LDFLAGS) $(LDFLAGS_FOR_BUILD)
+ ioctls_inc_h = $(wildcard $(srcdir)/$(OS)/$(ARCH)/ioctls_inc*.h)
+ ioctlent_h = $(patsubst $(srcdir)/$(OS)/$(ARCH)/ioctls_inc%,ioctlent%,$(ioctls_inc_h))
+-CLEANFILES = $(ioctlent_h)
++CLEANFILES = $(ioctlent_h) ioctl_iocdef.h
+ @MAINTAINER_MODE_TRUE@gen_changelog_start_date = 2009-07-08 20:00
+ all: $(BUILT_SOURCES) config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
+@@ -3414,13 +3415,22 @@ news-check: NEWS
+ exit 1; \
+ fi
+
++# Need to pick up <linux/ioctl.h> definitions *for host* while compiling
++# ioctlsort *for build*, hence this magic.
++ioctl_iocdef.i: $(srcdir)/ioctl_iocdef.c
++ $(CPP) -P $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
++ $(strace_CPPFLAGS) $(CPPFLAGS) $< -o $@
++
++ioctl_iocdef.h: ioctl_iocdef.i
++ sed -n 's/^DEFINE HOST/#define /p' $< > $@
++
+ ioctlent%.h: ioctlsort%
+ ./$< > $@
+
+ ioctlsort%$(BUILD_EXEEXT): ioctlsort%.o
+ $(ioctlsort_CC) $(ioctlsort_CFLAGS) $(ioctlsort_LDFLAGS) $< -o $@
+
+-ioctlsort%.o: ioctls_all%.h $(srcdir)/ioctlsort.c
++ioctlsort%.o: ioctls_all%.h ioctl_iocdef.h $(srcdir)/ioctlsort.c
+ $(ioctlsort_CC) $(ioctlsort_DEFS) $(ioctlsort_INCLUDES) $(ioctlsort_CPPFLAGS) $(ioctlsort_CFLAGS) -DIOCTLSORT_INC=\"$<\" -c -o $@ $(srcdir)/ioctlsort.c
+
+ ioctls_all%.h: $(srcdir)/$(OS)/$(ARCH)/ioctls_inc%.h $(srcdir)/$(OS)/$(ARCH)/ioctls_arch%.h
diff --git a/packages/strace/4.10/version.desc b/packages/strace/4.10/version.desc
new file mode 100644
index 0000000..026d275
--- /dev/null
+++ b/packages/strace/4.10/version.desc
@@ -0,0 +1 @@
+obsolete="yes"