summaryrefslogtreecommitdiff
path: root/packages/strace/4.11
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/strace/4.11
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/strace/4.11')
-rw-r--r--packages/strace/4.11/0000-use-host-ioctl.patch (renamed from packages/strace/4.11/010-use-host-ioctl.patch)37
1 files changed, 20 insertions, 17 deletions
diff --git a/packages/strace/4.11/010-use-host-ioctl.patch b/packages/strace/4.11/0000-use-host-ioctl.patch
index 5155200..99f8c4c 100644
--- a/packages/strace/4.11/010-use-host-ioctl.patch
+++ b/packages/strace/4.11/0000-use-host-ioctl.patch
@@ -1,6 +1,12 @@
-diff -urpN strace-4.11.orig/ioctl_iocdef.c strace-4.11/ioctl_iocdef.c
---- strace-4.11.orig/ioctl_iocdef.c 1969-12-31 16:00:00.000000000 -0800
-+++ strace-4.11/ioctl_iocdef.c 2017-01-14 15:31:16.925139193 -0800
+---
+ Makefile.am | 14 ++++++++++++--
+ Makefile.in | 14 ++++++++++++--
+ ioctl_iocdef.c | 43 +++++++++++++++++++++++++++++++++++++++++++
+ ioctlsort.c | 3 ++-
+ 4 files changed, 69 insertions(+), 5 deletions(-)
+
+--- /dev/null
++++ b/ioctl_iocdef.c
@@ -0,0 +1,43 @@
+/*
+ * Copyright (c) 2017 Alexey Neyman <stilor@att.net>
@@ -45,9 +51,8 @@ diff -urpN strace-4.11.orig/ioctl_iocdef.c strace-4.11/ioctl_iocdef.c
+
+DEFINE HOST_IOC_SIZESHIFT _IOC_SIZESHIFT
+DEFINE HOST_IOC_DIRSHIFT _IOC_DIRSHIFT
-diff -urpN strace-4.11.orig/ioctlsort.c strace-4.11/ioctlsort.c
---- strace-4.11.orig/ioctlsort.c 2015-03-28 15:37:30.000000000 -0700
-+++ strace-4.11/ioctlsort.c 2017-01-14 15:32:13.373831957 -0800
+--- a/ioctlsort.c
++++ b/ioctlsort.c
@@ -33,7 +33,8 @@
#include <stdio.h>
#include <stdlib.h>
@@ -58,10 +63,9 @@ diff -urpN strace-4.11.orig/ioctlsort.c strace-4.11/ioctlsort.c
struct ioctlent {
const char *info;
-diff -urpN strace-4.11.orig/Makefile.am strace-4.11/Makefile.am
---- strace-4.11.orig/Makefile.am 2015-12-17 09:56:48.000000000 -0800
-+++ strace-4.11/Makefile.am 2017-01-14 15:33:39.186837242 -0800
-@@ -239,6 +239,7 @@ EXTRA_DIST = \
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -239,6 +239,7 @@
debian/watch \
errnoent.sh \
generate_sen.sh \
@@ -69,7 +73,7 @@ diff -urpN strace-4.11.orig/Makefile.am strace-4.11/Makefile.am
ioctlsort.c \
linux/32/ioctls_inc.h \
linux/32/ioctls_inc_align32.h \
-@@ -666,17 +667,26 @@ ioctlent_h = $(patsubst $(srcdir)/$(OS)/
+@@ -666,17 +667,26 @@
ioctlent%.h: ioctlsort%
./$< > $@
@@ -98,10 +102,9 @@ diff -urpN strace-4.11.orig/Makefile.am strace-4.11/Makefile.am
DISTCLEANFILES = gnu/stubs-32.h gnu/stubs-x32.h
# defines mpers_source_files
-diff -urpN strace-4.11.orig/Makefile.in strace-4.11/Makefile.in
---- strace-4.11.orig/Makefile.in 2015-12-21 15:24:05.000000000 -0800
-+++ strace-4.11/Makefile.in 2017-01-14 15:34:34.803440359 -0800
-@@ -848,6 +848,7 @@ EXTRA_DIST = \
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -848,6 +848,7 @@
debian/watch \
errnoent.sh \
generate_sen.sh \
@@ -109,7 +112,7 @@ diff -urpN strace-4.11.orig/Makefile.in strace-4.11/Makefile.in
ioctlsort.c \
linux/32/ioctls_inc.h \
linux/32/ioctls_inc_align32.h \
-@@ -1243,7 +1244,7 @@ ioctlent_h = $(patsubst $(srcdir)/$(OS)/
+@@ -1243,7 +1244,7 @@
BUILT_SOURCES = $(ioctlent_h) native_printer_decls.h \
native_printer_defs.h printers.h sen.h sys_func.h .version \
$(am__append_7) $(am__append_11)
@@ -118,7 +121,7 @@ diff -urpN strace-4.11.orig/Makefile.in strace-4.11/Makefile.in
native_printer_defs.h printers.h sen.h sys_func.h \
$(am__append_8) $(am__append_12)
DISTCLEANFILES = gnu/stubs-32.h gnu/stubs-x32.h
-@@ -4829,13 +4830,22 @@ news-check: NEWS
+@@ -4829,13 +4830,22 @@
exit 1; \
fi