summaryrefslogtreecommitdiff
path: root/packages/strace/4.12
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2021-09-21 07:56:07 (GMT)
committerChris Packham <judge.packham@gmail.com>2021-09-21 09:24:31 (GMT)
commite4394bf9bb684bf267a35f9efd59057e74c10784 (patch)
tree9fda0ff59ea2ddca0c2b674a8df01192d04ea08d /packages/strace/4.12
parentbb4d2a458cccee9664062190df492b23fb3cd8d2 (diff)
strace: Remove obsolete versions
The following versions were marked obsolete in crosstool-ng-1.24.0, remove them. - strace-4.10 - strace-4.11 - strace-4.12 - strace-4.13 - strace-4.14 - strace-4.5.20 - strace-4.6 - strace-4.7 - strace-4.8 - strace-4.9 Signed-off-by: Chris Packham <judge.packham@gmail.com>
Diffstat (limited to 'packages/strace/4.12')
-rw-r--r--packages/strace/4.12/0000-use-host-ioctl.patch148
-rw-r--r--packages/strace/4.12/chksum4
-rw-r--r--packages/strace/4.12/version.desc1
3 files changed, 0 insertions, 153 deletions
diff --git a/packages/strace/4.12/0000-use-host-ioctl.patch b/packages/strace/4.12/0000-use-host-ioctl.patch
deleted file mode 100644
index 932ccda..0000000
--- a/packages/strace/4.12/0000-use-host-ioctl.patch
+++ /dev/null
@@ -1,148 +0,0 @@
----
- Makefile.am | 14 ++++++++++++--
- Makefile.in | 14 ++++++++++++--
- ioctl_iocdef.c | 43 +++++++++++++++++++++++++++++++++++++++++++
- ioctlsort.c | 3 ++-
- 4 files changed, 69 insertions(+), 5 deletions(-)
-
---- /dev/null
-+++ b/ioctl_iocdef.c
-@@ -0,0 +1,43 @@
-+/*
-+ * Copyright (c) 2017 Alexey Neyman <stilor@att.net>
-+ * All rights reserved.
-+ *
-+ * Redistribution and use in source and binary forms, with or without
-+ * modification, are permitted provided that the following conditions
-+ * are met:
-+ * 1. Redistributions of source code must retain the above copyright
-+ * notice, this list of conditions and the following disclaimer.
-+ * 2. Redistributions in binary form must reproduce the above copyright
-+ * notice, this list of conditions and the following disclaimer in the
-+ * documentation and/or other materials provided with the distribution.
-+ * 3. The name of the author may not be used to endorse or promote products
-+ * derived from this software without specific prior written permission.
-+ *
-+ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
-+ * IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
-+ * OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
-+ * IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
-+ * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
-+ * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
-+ * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-+ */
-+
-+/*
-+ * This file is *PREPROCESSED*, not *COMPILED* for host and the result
-+ * is included into ioctlsort (which is compiled for build). Since some
-+ * of these values are used in structure initializers, they cannot be
-+ * defined as 'const unsigned int' - instead, they have to be macros.
-+ * Hence, the result of preprocessing will be run through sed to change
-+ * 'DEFINE' into '#define'
-+ */
-+#include <linux/ioctl.h>
-+
-+DEFINE HOST_IOC_NONE _IOC_NONE
-+DEFINE HOST_IOC_READ _IOC_READ
-+DEFINE HOST_IOC_WRITE _IOC_WRITE
-+
-+DEFINE HOST_IOC_SIZESHIFT _IOC_SIZESHIFT
-+DEFINE HOST_IOC_DIRSHIFT _IOC_DIRSHIFT
---- a/ioctlsort.c
-+++ b/ioctlsort.c
-@@ -33,7 +33,8 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
--#include <linux/ioctl.h>
-+
-+#include "ioctl_iocdef.h"
-
- struct ioctlent {
- const char *info;
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -274,6 +274,7 @@
- debian/watch \
- errnoent.sh \
- generate_sen.sh \
-+ ioctl_iocdef.c \
- ioctlsort.c \
- linux/32/ioctls_inc.h \
- linux/32/ioctls_inc_align32.h \
-@@ -712,10 +713,19 @@
- ioctlent%.h: ioctlsort%
- ./$< > $@
-
-+# Need to pick up <linux/ioctl.h> definitions *for host* while compiling
-+# ioctlsort *for build*, hence this magic.
-+ioctl_iocdef.i: $(srcdir)/ioctl_iocdef.c
-+ $(CPP) -P $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
-+ $(strace_CPPFLAGS) $(CPPFLAGS) $< -o $@
-+
-+ioctl_iocdef.h: ioctl_iocdef.i
-+ sed -n 's/^DEFINE HOST/#define /p' $< > $@
-+
- ioctlsort%$(BUILD_EXEEXT): ioctlsort%.o
- $(ioctlsort_CC) $(ioctlsort_CFLAGS) $(ioctlsort_LDFLAGS) $< -o $@
-
--ioctlsort%.o: ioctls_all%.h $(srcdir)/ioctlsort.c
-+ioctlsort%.o: ioctls_all%.h ioctl_iocdef.h $(srcdir)/ioctlsort.c
- $(ioctlsort_CC) $(ioctlsort_DEFS) $(ioctlsort_INCLUDES) $(ioctlsort_CPPFLAGS) $(ioctlsort_CFLAGS) -DIOCTLSORT_INC=\"$<\" -c -o $@ $(srcdir)/ioctlsort.c
-
- ioctls_all%.h: $(srcdir)/$(OS)/$(ARCH)/ioctls_inc%.h $(srcdir)/$(OS)/$(ARCH)/ioctls_arch%.h
-@@ -723,7 +733,7 @@
-
- BUILT_SOURCES = $(ioctl_redefs_h) $(ioctlent_h) \
- native_printer_decls.h native_printer_defs.h printers.h sen.h sys_func.h .version
--CLEANFILES = $(ioctl_redefs_h) $(ioctlent_h) $(mpers_preproc_files) \
-+CLEANFILES = $(ioctl_redefs_h) $(ioctlent_h) ioctl_iocdef.h $(mpers_preproc_files) \
- native_printer_decls.h native_printer_defs.h printers.h sen.h sys_func.h
- DISTCLEANFILES = gnu/stubs-32.h gnu/stubs-x32.h
-
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -952,6 +952,7 @@
- debian/watch \
- errnoent.sh \
- generate_sen.sh \
-+ ioctl_iocdef.c \
- ioctlsort.c \
- linux/32/ioctls_inc.h \
- linux/32/ioctls_inc_align32.h \
-@@ -1351,7 +1352,7 @@
- BUILT_SOURCES = $(ioctl_redefs_h) $(ioctlent_h) native_printer_decls.h \
- native_printer_defs.h printers.h sen.h sys_func.h .version \
- $(am__append_7) $(am__append_11)
--CLEANFILES = $(ioctl_redefs_h) $(ioctlent_h) $(mpers_preproc_files) \
-+CLEANFILES = $(ioctl_redefs_h) $(ioctlent_h) octl_iocdef.h $(mpers_preproc_files) \
- native_printer_decls.h native_printer_defs.h printers.h sen.h \
- sys_func.h $(am__append_8) $(am__append_12)
- DISTCLEANFILES = gnu/stubs-32.h gnu/stubs-x32.h
-@@ -5506,13 +5507,22 @@
- rm -f $<-t
- mv $@-t $@
-
-+# Need to pick up <linux/ioctl.h> definitions *for host* while compiling
-+# ioctlsort *for build*, hence this magic.
-+ioctl_iocdef.i: $(srcdir)/ioctl_iocdef.c
-+ $(CPP) -P $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
-+ $(strace_CPPFLAGS) $(CPPFLAGS) $< -o $@
-+
-+ioctl_iocdef.h: ioctl_iocdef.i
-+ sed -n 's/^DEFINE HOST/#define /p' $< > $@
-+
- ioctlent%.h: ioctlsort%
- ./$< > $@
-
- ioctlsort%$(BUILD_EXEEXT): ioctlsort%.o
- $(ioctlsort_CC) $(ioctlsort_CFLAGS) $(ioctlsort_LDFLAGS) $< -o $@
-
--ioctlsort%.o: ioctls_all%.h $(srcdir)/ioctlsort.c
-+ioctlsort%.o: ioctls_all%.h ioctl_iocdef.h $(srcdir)/ioctlsort.c
- $(ioctlsort_CC) $(ioctlsort_DEFS) $(ioctlsort_INCLUDES) $(ioctlsort_CPPFLAGS) $(ioctlsort_CFLAGS) -DIOCTLSORT_INC=\"$<\" -c -o $@ $(srcdir)/ioctlsort.c
-
- ioctls_all%.h: $(srcdir)/$(OS)/$(ARCH)/ioctls_inc%.h $(srcdir)/$(OS)/$(ARCH)/ioctls_arch%.h
diff --git a/packages/strace/4.12/chksum b/packages/strace/4.12/chksum
deleted file mode 100644
index 79656cc..0000000
--- a/packages/strace/4.12/chksum
+++ /dev/null
@@ -1,4 +0,0 @@
-md5 strace-4.12.tar.xz efb8611fc332e71ec419c53f59faa93e
-sha1 strace-4.12.tar.xz 30d79bc07e46a8672decb945e458447c1b66e496
-sha256 strace-4.12.tar.xz 51144b78cb9ba22211b95a5aafe0af3694c0d575b25975d80ca9dd4dfd7c1e59
-sha512 strace-4.12.tar.xz 1df57c5d684cebee370bbd88f11cb568ffbe178b38060384920083da83888a78244483b3464c79fc0cccf6f14bb09538cf84bc1fd1fc43b959c7d4724548afb8
diff --git a/packages/strace/4.12/version.desc b/packages/strace/4.12/version.desc
deleted file mode 100644
index fcfe389..0000000
--- a/packages/strace/4.12/version.desc
+++ /dev/null
@@ -1 +0,0 @@
-obsolete='yes'