summaryrefslogtreecommitdiff
path: root/packages/strace/4.14
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/strace/4.14
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/strace/4.14')
-rw-r--r--packages/strace/4.14/0000-use-host-ioctl.patch (renamed from packages/strace/4.14/010-use-host-ioctl.patch)39
1 files changed, 21 insertions, 18 deletions
diff --git a/packages/strace/4.14/010-use-host-ioctl.patch b/packages/strace/4.14/0000-use-host-ioctl.patch
index 2c7671f..5e90362 100644
--- a/packages/strace/4.14/010-use-host-ioctl.patch
+++ b/packages/strace/4.14/0000-use-host-ioctl.patch
@@ -1,6 +1,12 @@
-diff -urpN strace-4.14.orig/ioctl_iocdef.c strace-4.14/ioctl_iocdef.c
---- strace-4.14.orig/ioctl_iocdef.c 1969-12-31 16:00:00.000000000 -0800
-+++ strace-4.14/ioctl_iocdef.c 2017-01-14 15:50:38.748425119 -0800
+---
+ Makefile.am | 14 ++++++++++++--
+ Makefile.in | 14 ++++++++++++--
+ ioctl_iocdef.c | 43 +++++++++++++++++++++++++++++++++++++++++++
+ ioctlsort.c | 3 ++-
+ 4 files changed, 69 insertions(+), 5 deletions(-)
+
+--- /dev/null
++++ b/ioctl_iocdef.c
@@ -0,0 +1,43 @@
+/*
+ * Copyright (c) 2017 Alexey Neyman <stilor@att.net>
@@ -45,9 +51,8 @@ diff -urpN strace-4.14.orig/ioctl_iocdef.c strace-4.14/ioctl_iocdef.c
+
+DEFINE HOST_IOC_SIZESHIFT _IOC_SIZESHIFT
+DEFINE HOST_IOC_DIRSHIFT _IOC_DIRSHIFT
-diff -urpN strace-4.14.orig/ioctlsort.c strace-4.14/ioctlsort.c
---- strace-4.14.orig/ioctlsort.c 2015-03-28 15:37:30.000000000 -0700
-+++ strace-4.14/ioctlsort.c 2017-01-14 15:50:38.748425119 -0800
+--- a/ioctlsort.c
++++ b/ioctlsort.c
@@ -33,7 +33,8 @@
#include <stdio.h>
#include <stdlib.h>
@@ -58,10 +63,9 @@ diff -urpN strace-4.14.orig/ioctlsort.c strace-4.14/ioctlsort.c
struct ioctlent {
const char *info;
-diff -urpN strace-4.14.orig/Makefile.am strace-4.14/Makefile.am
---- strace-4.14.orig/Makefile.am 2016-09-05 12:52:57.000000000 -0700
-+++ strace-4.14/Makefile.am 2017-01-14 15:50:38.748425119 -0800
-@@ -289,6 +289,7 @@ EXTRA_DIST = \
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -289,6 +289,7 @@
debian/watch \
errnoent.sh \
generate_sen.sh \
@@ -69,7 +73,7 @@ diff -urpN strace-4.14.orig/Makefile.am strace-4.14/Makefile.am
ioctlsort.c \
linux/32/ioctls_inc.h \
linux/32/ioctls_inc_align32.h \
-@@ -739,10 +740,19 @@ ioctl_redefs%.h: ioctlent%.h ioctlent0.h
+@@ -739,10 +740,19 @@
ioctlent%.h: ioctlsort%
./$< > $@
@@ -90,7 +94,7 @@ diff -urpN strace-4.14.orig/Makefile.am strace-4.14/Makefile.am
$(ioctlsort_CC) $(ioctlsort_DEFS) $(ioctlsort_INCLUDES) $(ioctlsort_CPPFLAGS) $(ioctlsort_CFLAGS) -DIOCTLSORT_INC=\"$<\" -c -o $@ $(srcdir)/ioctlsort.c
ioctls_all%.h: $(srcdir)/$(OS)/$(ARCH)/ioctls_inc%.h $(srcdir)/$(OS)/$(ARCH)/ioctls_arch%.h
-@@ -750,7 +760,7 @@ ioctls_all%.h: $(srcdir)/$(OS)/$(ARCH)/i
+@@ -750,7 +760,7 @@
BUILT_SOURCES = $(ioctl_redefs_h) $(ioctlent_h) \
native_printer_decls.h native_printer_defs.h printers.h sen.h sys_func.h .version
@@ -99,10 +103,9 @@ diff -urpN strace-4.14.orig/Makefile.am strace-4.14/Makefile.am
native_printer_decls.h native_printer_defs.h printers.h sen.h sys_func.h
DISTCLEANFILES = gnu/stubs-32.h gnu/stubs-x32.h
-diff -urpN strace-4.14.orig/Makefile.in strace-4.14/Makefile.in
---- strace-4.14.orig/Makefile.in 2016-10-04 12:13:20.000000000 -0700
-+++ strace-4.14/Makefile.in 2017-01-14 15:50:38.752425155 -0800
-@@ -995,6 +995,7 @@ EXTRA_DIST = \
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -995,6 +995,7 @@
debian/watch \
errnoent.sh \
generate_sen.sh \
@@ -110,7 +113,7 @@ diff -urpN strace-4.14.orig/Makefile.in strace-4.14/Makefile.in
ioctlsort.c \
linux/32/ioctls_inc.h \
linux/32/ioctls_inc_align32.h \
-@@ -1406,7 +1407,7 @@ ioctl_redefs_h = $(filter-out ioctl_rede
+@@ -1406,7 +1407,7 @@
BUILT_SOURCES = $(ioctl_redefs_h) $(ioctlent_h) native_printer_decls.h \
native_printer_defs.h printers.h sen.h sys_func.h .version \
$(am__append_7) $(am__append_11)
@@ -119,7 +122,7 @@ diff -urpN strace-4.14.orig/Makefile.in strace-4.14/Makefile.in
native_printer_decls.h native_printer_defs.h printers.h sen.h \
sys_func.h $(am__append_8) $(am__append_12)
DISTCLEANFILES = gnu/stubs-32.h gnu/stubs-x32.h
-@@ -5896,13 +5897,22 @@ ioctl_redefs%.h: ioctlent%.h ioctlent0.h
+@@ -5896,13 +5897,22 @@
rm -f $<-t
mv $@-t $@