summaryrefslogtreecommitdiff
path: root/packages/strace/4.5.18
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-05-20 04:58:46 (GMT)
committerAlexey Neyman <stilor@att.net>2017-07-08 17:57:56 (GMT)
commite7deac3aad394325f9e6fc6fda41d34ec94a59e0 (patch)
tree6ad88362f0bfa8385a91eb494009a4646aeb74b6 /packages/strace/4.5.18
parentb9af225f58e45c7fae7eb9d3689fe939243e7578 (diff)
Switch comp.libs/tools and debug to new framework.
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/strace/4.5.18')
-rw-r--r--packages/strace/4.5.18/110-dont-use-REG_SYSCALL-for-sh.patch11
-rw-r--r--packages/strace/4.5.18/130-fix-disabled-largefile-syscalls.patch22
-rw-r--r--packages/strace/4.5.18/140-statfs64-check.patch53
-rw-r--r--packages/strace/4.5.18/160-fix-check-for-linux-netlink.patch19
-rw-r--r--packages/strace/4.5.18/160-undef-syscall.patch42
-rw-r--r--packages/strace/4.5.18/170-no_cachectl.patch35
-rw-r--r--packages/strace/4.5.18/180-arm-EABI-syscalls.patch23
-rw-r--r--packages/strace/4.5.18/900-autoreconf.patch99
-rw-r--r--packages/strace/4.5.18/version.desc1
9 files changed, 305 insertions, 0 deletions
diff --git a/packages/strace/4.5.18/110-dont-use-REG_SYSCALL-for-sh.patch b/packages/strace/4.5.18/110-dont-use-REG_SYSCALL-for-sh.patch
new file mode 100644
index 0000000..ebbf69a
--- /dev/null
+++ b/packages/strace/4.5.18/110-dont-use-REG_SYSCALL-for-sh.patch
@@ -0,0 +1,11 @@
+diff -dur strace-4.5.16.orig/process.c strace-4.5.16/process.c
+--- strace-4.5.16.orig/process.c 2007-01-11 23:08:38.000000000 +0100
++++ strace-4.5.16/process.c 2007-07-14 19:19:58.000000000 +0200
+@@ -2685,7 +2685,6 @@
+ { 4*REG_GBR, "4*REG_GBR" },
+ { 4*REG_MACH, "4*REG_MACH" },
+ { 4*REG_MACL, "4*REG_MACL" },
+- { 4*REG_SYSCALL, "4*REG_SYSCALL" },
+ { 4*REG_FPUL, "4*REG_FPUL" },
+ { 4*REG_FPREG0, "4*REG_FPREG0" },
+ { 4*(REG_FPREG0+1), "4*REG_FPREG1" },
diff --git a/packages/strace/4.5.18/130-fix-disabled-largefile-syscalls.patch b/packages/strace/4.5.18/130-fix-disabled-largefile-syscalls.patch
new file mode 100644
index 0000000..2f47dc9
--- /dev/null
+++ b/packages/strace/4.5.18/130-fix-disabled-largefile-syscalls.patch
@@ -0,0 +1,22 @@
+diff -dur strace-4.5.16.orig/syscall.c strace-4.5.16/syscall.c
+--- strace-4.5.16.orig/syscall.c 2007-07-14 19:21:44.000000000 +0200
++++ strace-4.5.16/syscall.c 2007-07-14 19:22:49.000000000 +0200
+@@ -125,6 +125,18 @@
+ #define TP TRACE_PROCESS
+ #define TS TRACE_SIGNAL
+
++#ifndef HAVE_STATFS64
++/*
++ * Ugly hacks for systems that do not have LFS
++ */
++
++#define sys_truncate64 sys_truncate
++#define sys_ftruncate64 sys_ftruncate
++#define sys_getdents64 sys_getdents
++#define sys_statfs64 sys_statfs
++#define sys_fstatfs64 sys_fstatfs
++#endif
++
+ static const struct sysent sysent0[] = {
+ #include "syscallent.h"
+ };
diff --git a/packages/strace/4.5.18/140-statfs64-check.patch b/packages/strace/4.5.18/140-statfs64-check.patch
new file mode 100644
index 0000000..758966b
--- /dev/null
+++ b/packages/strace/4.5.18/140-statfs64-check.patch
@@ -0,0 +1,53 @@
+diff -dur strace-4.5.16.orig/acinclude.m4 strace-4.5.16/acinclude.m4
+--- strace-4.5.16.orig/acinclude.m4 2004-04-14 04:21:01.000000000 +0200
++++ strace-4.5.16/acinclude.m4 2007-07-14 19:25:25.000000000 +0200
+@@ -210,6 +210,26 @@
+ fi
+ ])
+
++dnl ### A macro to determine whether statfs64 is defined.
++AC_DEFUN([AC_STATFS64],
++[AC_MSG_CHECKING(for statfs64 in sys/(statfs|vfs).h)
++AC_CACHE_VAL(ac_cv_type_statfs64,
++[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#ifdef LINUX
++#include <linux/types.h>
++#include <sys/statfs.h>
++#else
++#include <sys/vfs.h>
++#endif]], [[struct statfs64 st;]])],[ac_cv_type_statfs64=yes],[ac_cv_type_statfs64=no])])
++AC_MSG_RESULT($ac_cv_type_statfs64)
++if test "$ac_cv_type_statfs64" = yes
++then
++ AC_DEFINE([HAVE_STATFS64], 1,
++[Define if statfs64 is available in sys/statfs.h or sys/vfs.h.])
++fi
++])
++
++
++
+ dnl ### A macro to determine if off_t is a long long
+ AC_DEFUN([AC_OFF_T_IS_LONG_LONG],
+ [AC_MSG_CHECKING(for long long off_t)
+diff -dur strace-4.5.16.orig/configure.ac strace-4.5.16/configure.ac
+--- strace-4.5.16.orig/configure.ac 2007-01-11 12:37:55.000000000 +0100
++++ strace-4.5.16/configure.ac 2007-07-14 19:25:25.000000000 +0200
+@@ -169,6 +169,7 @@
+ struct stat.st_level,
+ struct stat.st_rdev])
+ AC_STAT64
++AC_STATFS64
+
+ AC_TYPE_SIGNAL
+ AC_TYPE_UID_T
+diff -dur strace-4.5.16.orig/file.c strace-4.5.16/file.c
+--- strace-4.5.16.orig/file.c 2007-01-15 21:25:52.000000000 +0100
++++ strace-4.5.16/file.c 2007-07-14 19:25:25.000000000 +0200
+@@ -1636,7 +1636,7 @@
+ return 0;
+ }
+
+-#ifdef LINUX
++#ifdef HAVE_STATFS64
+ static void
+ printstatfs64(tcp, addr)
+ struct tcb *tcp;
diff --git a/packages/strace/4.5.18/160-fix-check-for-linux-netlink.patch b/packages/strace/4.5.18/160-fix-check-for-linux-netlink.patch
new file mode 100644
index 0000000..e12b4e4
--- /dev/null
+++ b/packages/strace/4.5.18/160-fix-check-for-linux-netlink.patch
@@ -0,0 +1,19 @@
+Dmitry V. Levin [Tue, 3 Nov 2009 16:49:49 +0000]
+
+Fix check for linux/netlink.h on Linux 2.6.32-rc5+
+
+* configure.ac (AC_CHECK_HEADERS): In check for linux/netlink.h, include
+ sys/socket.h instead of linux/socket.h beforehand.
+
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -197,7 +197,7 @@ AC_CHECK_HEADERS([ \
+ ], [], [])
+ AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
+ [], [], [#include <stddef.h>
+-#include <linux/socket.h>])
++#include <sys/socket.h>])
+ AC_CHECK_HEADERS([asm/sigcontext.h], [], [], [#include <signal.h>])
+ AC_CHECK_TYPES([struct sigcontext_struct],,, [#include <signal.h>])
+ AC_CHECK_HEADERS([netinet/tcp.h netinet/udp.h],,, [#include <netinet/in.h>])
diff --git a/packages/strace/4.5.18/160-undef-syscall.patch b/packages/strace/4.5.18/160-undef-syscall.patch
new file mode 100644
index 0000000..c7dcb07
--- /dev/null
+++ b/packages/strace/4.5.18/160-undef-syscall.patch
@@ -0,0 +1,42 @@
+diff -dur strace-4.5.16.orig/linux/syscallent.h strace-4.5.16/linux/syscallent.h
+--- strace-4.5.16.orig/linux/syscallent.h 2006-10-16 03:17:52.000000000 +0200
++++ strace-4.5.16/linux/syscallent.h 2007-07-14 19:30:16.000000000 +0200
+@@ -130,7 +130,11 @@
+ { 2, TF, sys_statfs, "statfs" }, /* 99 */
+ { 2, TD, sys_fstatfs, "fstatfs" }, /* 100 */
+ { 3, 0, sys_ioperm, "ioperm" }, /* 101 */
+- { 2, TD, sys_socketcall, "socketcall", SYS_socketcall }, /* 102 */
++ { 2, TD, sys_socketcall, "socketcall"
++#ifdef __NR_socketcall
++ , SYS_socketcall
++#endif
++ }, /* 102 */
+ { 3, 0, sys_syslog, "syslog" }, /* 103 */
+ { 3, 0, sys_setitimer, "setitimer" }, /* 104 */
+ { 2, 0, sys_getitimer, "getitimer" }, /* 105 */
+@@ -145,7 +149,11 @@
+ { 4, TP, sys_wait4, "wait4", SYS_wait4 }, /* 114 */
+ { 1, 0, sys_swapoff, "swapoff" }, /* 115 */
+ { 1, 0, sys_sysinfo, "sysinfo" }, /* 116 */
+- { 6, 0, sys_ipc, "ipc", SYS_ipc }, /* 117 */
++ { 6, 0, sys_ipc, "ipc"
++#ifdef __NR_ipc
++ , SYS_ipc
++#endif
++ }, /* 117 */
+ { 1, TD, sys_fsync, "fsync" }, /* 118 */
+ { 1, TS, sys_sigreturn, "sigreturn" }, /* 119 */
+ { 5, TP, sys_clone, "clone", SYS_clone }, /* 120 */
+@@ -282,7 +290,11 @@
+ { 3, 0, sys_io_cancel, "io_cancel" }, /* 249 */
+ { 5, 0, sys_fadvise64, "fadvise64" }, /* 250 */
+ { 5, 0, printargs, "SYS_251" }, /* 251 */
+- { 1, TP, sys_exit, "exit_group", __NR_exit_group }, /* 252 */
++ { 1, TP, sys_exit, "exit_group"
++#ifdef __NR_exit_group
++ , __NR_exit_group
++#endif
++ }, /* 252 */
+ { 4, 0, printargs, "lookup_dcookie"}, /* 253 */
+ { 1, 0, sys_epoll_create, "epoll_create" }, /* 254 */
+ { 4, TD, sys_epoll_ctl, "epoll_ctl" }, /* 255 */
diff --git a/packages/strace/4.5.18/170-no_cachectl.patch b/packages/strace/4.5.18/170-no_cachectl.patch
new file mode 100644
index 0000000..a8fab23
--- /dev/null
+++ b/packages/strace/4.5.18/170-no_cachectl.patch
@@ -0,0 +1,35 @@
+This patch is needed on newer uclibc becuase the uclibc header generation
+mechanism generates the sysnum.h properly NR_cacheflush is defined for ARM
+but there is no cachectl.h file which is exported to userspace. Strace
+assumes that if SYS_cacheflush is defined than it icludes asm/cachectl.h
+which breaks the build for ARM now.
+
+This patch adds a check for ARM architecture.
+
+-Khem
+
+Here is error
+
+| if ccache arm-angstrom-linux-uclibcgnueabi-gcc -march=armv5te -mtune=arm926ej-s -DHAVE_CONFIG_H -I. -I. -I. -Ilinux/arm -I./linux/arm -Ilinux -I./linux -isystem/home/kraj/work/oe/build/uclibc/tmp-omap5912osk/staging/arm-angstrom-linux-uclibcgnueabi/usr/include -Wall -isystem/home/kraj/work/oe/build/uclibc/tmp-omap5912osk/staging/arm-angstrom-linux-uclibcgnueabi/usr/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -MT term.o -MD -MP -MF ".deps/term.Tpo" -c -o term.o term.c; \
+| then mv -f ".deps/term.Tpo" ".deps/term.Po"; else rm -f ".deps/term.Tpo"; exit 1; fi
+| system.c:69:26: error: asm/cachectl.h: No such file or directory
+| make[1]: *** [system.o] Error 1
+| make[1]: *** Waiting for unfinished jobs....
+| signal.c: In function 'sys_sigreturn':
+| signal.c:1221: warning: passing argument 4 of 'ptrace' makes integer from pointer without a cast
+| make[1]: Leaving directory `/home/kraj/work/oe/build/uclibc/tmp-omap5912osk/work/armv5te-angstrom-linux-uclibcgnueabi/strace-4.5.14-r5/strace-4.5.14'
+| make: *** [all] Error 2
+| FATAL: oe_runmake failed
+
+Index: strace-4.5.14/system.c
+===================================================================
+--- strace-4.5.14.orig/system.c 2008-05-15 20:23:16.000000000 -0700
++++ strace-4.5.14/system.c 2008-05-15 20:24:03.000000000 -0700
+@@ -65,7 +65,7 @@
+ #include <linux/capability.h>
+ #endif
+
+-#ifdef SYS_cacheflush
++#if defined SYS_cacheflush && !defined ARM
+ #include <asm/cachectl.h>
+ #endif
diff --git a/packages/strace/4.5.18/180-arm-EABI-syscalls.patch b/packages/strace/4.5.18/180-arm-EABI-syscalls.patch
new file mode 100644
index 0000000..1f28450
--- /dev/null
+++ b/packages/strace/4.5.18/180-arm-EABI-syscalls.patch
@@ -0,0 +1,23 @@
+Patch from upstream:
+http://strace.cvs.sourceforge.net/viewvc/strace/strace/linux/arm/syscallent.h?r1=1.17&r2=1.18&sortby=file
+
+2008-11-13 Kirill A. Shutemov <kirill@shutemov.name>
+
+ * linux/arm/syscallent.h: Fix build on ARM EABI which does not
+ provide syscalls socketcall and ipc.
+
+--- strace-4.5.18.orig/linux/arm/syscallent.h 2008/12/29 20:04:15 1.17
++++ strace-4.5.18/linux/arm/syscallent.h 2009/01/01 23:20:38 1.18
+@@ -431,6 +431,7 @@
+ { 5, 0, printargs, "SYS_398" }, /* 398 */
+ { 5, 0, printargs, "SYS_399" }, /* 399 */
+
++#ifndef __ARM_EABI__
+ #if SYS_socket_subcall != 400
+ #error fix me
+ #endif
+@@ -481,3 +482,4 @@
+ { 4, TI, sys_shmdt, "shmdt" }, /* 440 */
+ { 4, TI, sys_shmget, "shmget" }, /* 441 */
+ { 4, TI, sys_shmctl, "shmctl" }, /* 442 */
++#endif
diff --git a/packages/strace/4.5.18/900-autoreconf.patch b/packages/strace/4.5.18/900-autoreconf.patch
new file mode 100644
index 0000000..cff775f
--- /dev/null
+++ b/packages/strace/4.5.18/900-autoreconf.patch
@@ -0,0 +1,99 @@
+diff -ruN strace-4.5.19.orig/config.h.in strace-4.5.19/config.h.in
+--- strace-4.5.19.orig/config.h.in 2009-10-21 19:41:12.000000000 +0200
++++ strace-4.5.19/config.h.in 2010-01-01 10:39:36.000000000 +0100
+@@ -143,6 +143,9 @@
+ /* Define if stat64 is available in asm/stat.h. */
+ #undef HAVE_STAT64
+
++/* Define if statfs64 is available in sys/statfs.h or sys/vfs.h. */
++#undef HAVE_STATFS64
++
+ /* Define to 1 if stdbool.h conforms to C99. */
+ #undef HAVE_STDBOOL_H
+
+diff -dur strace-4.5.16.orig/configure strace-4.5.16/configure
+--- strace-4.5.16.orig/configure 2007-01-11 23:23:33.000000000 +0100
++++ strace-4.5.16/configure 2007-07-14 19:18:43.000000000 +0200
+@@ -5994,6 +5994,73 @@
+
+ fi
+
++echo "$as_me:$LINENO: checking for statfs64 in sys/(statfs|vfs).h" >&5
++echo $ECHO_N "checking for statfs64 in sys/(statfs|vfs).h... $ECHO_C" >&6
++if test "${ac_cv_type_statfs64+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#ifdef LINUX
++#include <linux/types.h>
++#include <sys/statfs.h>
++#else
++#include <sys/vfs.h>
++#endif
++int
++main ()
++{
++struct statfs64 st;
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext
++if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
++ (eval $ac_compile) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest.$ac_objext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_type_statfs64=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_type_statfs64=no
++fi
++rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
++fi
++
++echo "$as_me:$LINENO: result: $ac_cv_type_statfs64" >&5
++echo "${ECHO_T}$ac_cv_type_statfs64" >&6
++if test "$ac_cv_type_statfs64" = yes
++then
++
++cat >>confdefs.h <<\_ACEOF
++#define HAVE_STATFS64 1
++_ACEOF
++
++fi
++
+
+ { echo "$as_me:$LINENO: checking return type of signal handlers" >&5
+ echo $ECHO_N "checking return type of signal handlers... $ECHO_C" >&6; }
+@@ -7580,7 +7647,7 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <stddef.h>
+-#include <linux/socket.h>
++#include <sys/socket.h>
+
+ #include <$ac_header>
+ _ACEOF
diff --git a/packages/strace/4.5.18/version.desc b/packages/strace/4.5.18/version.desc
new file mode 100644
index 0000000..026d275
--- /dev/null
+++ b/packages/strace/4.5.18/version.desc
@@ -0,0 +1 @@
+obsolete="yes"