summaryrefslogtreecommitdiff
path: root/packages/strace/5.14
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2022-02-16 07:44:22 (GMT)
committerChris Packham <judge.packham@gmail.com>2022-02-23 07:19:10 (GMT)
commit71fad07b71df1243175937907c4f94283958c3b9 (patch)
tree517306ae6530397545af19c66dba19f245687b46 /packages/strace/5.14
parent3a80ddda77eaa027a74927ec459c57fb4f01115f (diff)
strace: Remove 5.0 to 5.14
strace maintains backwards compatibility with older kernels so there is no need to keep multiple versions of strace. Versions 5.0 to 5.14 weren't present in the crosstool-ng-1.24 release so remove them directly instead of marking them as obsolete. Signed-off-by: Chris Packham <judge.packham@gmail.com>
Diffstat (limited to 'packages/strace/5.14')
-rw-r--r--packages/strace/5.14/0000-Avoid-relying-on-presence-of-ipx.h.patch135
-rw-r--r--packages/strace/5.14/chksum4
-rw-r--r--packages/strace/5.14/version.desc0
3 files changed, 0 insertions, 139 deletions
diff --git a/packages/strace/5.14/0000-Avoid-relying-on-presence-of-ipx.h.patch b/packages/strace/5.14/0000-Avoid-relying-on-presence-of-ipx.h.patch
deleted file mode 100644
index 69421a5..0000000
--- a/packages/strace/5.14/0000-Avoid-relying-on-presence-of-ipx.h.patch
+++ /dev/null
@@ -1,135 +0,0 @@
-From d8eb6a06192d982977b3ff12b6d1ca69beaa7bb3 Mon Sep 17 00:00:00 2001
-From: Eugene Syromyatnikov <evgsyr@gmail.com>
-Date: Wed, 3 Nov 2021 00:48:59 +0100
-Subject: [PATCH] Avoid relying on presence of ipx.h
-
-After Linux has broken UAPI in commit v5.15-rc1~157^2~207, it is well
-possible that neither kernel nor libc (such as musl, for example)
-provides an IPX-related header. Avoid relying on its presence
-in the strace's code and conditionalise the relevant checks in the tests.
-
-* configure.ac (AC_CHECK_HEADERS): Add linux/ipx.h.
-* src/net.c: Remove <netipx/ipx.h>/<linux/ipx.h> includes.
-* src/sockaddr.c: Likewise.
-(IPX_NODE_LEN): New macro constant.
-(struct sockaddr_ipx): New type definition.
-* src/xlat/sock_ipx_options.in (IPX_TYPE): Provide a fallback value.
-* tests/net-sockaddr.c [!HAVE_LINUX_IPX_H]: Do not include
-<linux/ipx.h>.
-[!HAVE_LINUX_IPX_H && HAVE_NETIPX_IPX_H]: Include <netipx/ipx.h>.
-[!(HAVE_LINUX_IPX_H || defined HAVE_NETIPX_IPX_H)] (check_ipx): Do not
-define.
-(main) [!(HAVE_LINUX_IPX_H || defined HAVE_NETIPX_IPX_H)]: Do not call
-check_ipx.
-
-Closes: https://github.com/strace/strace/issues/201
----
- configure.ac | 1 +
- src/net.c | 5 -----
- src/sockaddr.c | 16 ++++++++++------
- src/xlat/sock_ipx_options.in | 2 +-
- tests/net-sockaddr.c | 10 +++++++++-
- 5 files changed, 21 insertions(+), 13 deletions(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -423,6 +423,7 @@
- elf.h
- gcov.h
- iconv.h
-+ linux/ipx.h
- mqueue.h
- netinet/sctp.h
- netipx/ipx.h
---- a/src/net.c
-+++ b/src/net.c
-@@ -28,11 +28,6 @@
- #include <arpa/inet.h>
- #include <net/if.h>
- #include <asm/types.h>
--#ifdef HAVE_NETIPX_IPX_H
--# include <netipx/ipx.h>
--#else
--# include <linux/ipx.h>
--#endif
-
- #include <linux/ip_vs.h>
- #include "netlink.h"
---- a/src/sockaddr.c
-+++ b/src/sockaddr.c
-@@ -24,12 +24,6 @@
- #include <linux/if_ether.h>
- #include <linux/x25.h>
-
--#ifdef HAVE_NETIPX_IPX_H
--# include <netipx/ipx.h>
--#else
--# include <linux/ipx.h>
--#endif
--
- #include "xlat/addrfams.h"
- #include "xlat/arp_hardware_types.h"
- #include "xlat/ethernet_protocols.h"
-@@ -42,6 +36,16 @@
-
- #define SIZEOF_SA_FAMILY sizeof_field(struct sockaddr, sa_family)
-
-+#define IPX_NODE_LEN 6
-+struct sockaddr_ipx {
-+ uint16_t sipx_family;
-+ uint16_t sipx_port;
-+ uint32_t sipx_network;
-+ unsigned char sipx_node[IPX_NODE_LEN];
-+ uint8_t sipx_type;
-+ unsigned char sipx_zero;
-+};
-+
- const size_t arp_hardware_types_size = ARRAY_SIZE(arp_hardware_types) - 1;
- const size_t ethernet_protocols_size = ARRAY_SIZE(ethernet_protocols) - 1;
-
---- a/src/xlat/sock_ipx_options.in
-+++ b/src/xlat/sock_ipx_options.in
-@@ -1 +1 @@
--IPX_TYPE
-+IPX_TYPE 1
---- a/tests/net-sockaddr.c
-+++ b/tests/net-sockaddr.c
-@@ -24,7 +24,11 @@
- #include <linux/if_ether.h>
- #include <linux/if_packet.h>
- #include <linux/x25.h>
--#include <linux/ipx.h>
-+#if defined HAVE_LINUX_IPX_H
-+# include <linux/ipx.h>
-+#elif defined HAVE_NETIPX_IPX_H
-+# include <netipx/ipx.h>
-+#endif
- #ifdef HAVE_BLUETOOTH_BLUETOOTH_H
- # include <bluetooth/bluetooth.h>
- # include <bluetooth/hci.h>
-@@ -269,6 +273,7 @@
- printf("connect(-1, %p, %u) = %d EBADF (%m)\n", in6, len, ret);
- }
-
-+#if defined HAVE_LINUX_IPX_H || defined HAVE_NETIPX_IPX_H
- static void
- check_ipx(void)
- {
-@@ -295,6 +300,7 @@
- c_ipx.sipx_node[4], c_ipx.sipx_node[5],
- c_ipx.sipx_type, len, ret);
- }
-+#endif /* HAVE_LINUX_IPX_H || defined HAVE_NETIPX_IPX_H */
-
- /* for a bit more compact AX.25 address definitions */
- #define AX25_ADDR(c_, s_) \
-@@ -773,7 +779,9 @@
- check_un();
- check_in();
- check_in6();
-+#if defined HAVE_LINUX_IPX_H || defined HAVE_NETIPX_IPX_H
- check_ipx();
-+#endif
- check_ax25();
- check_x25();
- check_nl();
diff --git a/packages/strace/5.14/chksum b/packages/strace/5.14/chksum
deleted file mode 100644
index 4797e24..0000000
--- a/packages/strace/5.14/chksum
+++ /dev/null
@@ -1,4 +0,0 @@
-md5 strace-5.14.tar.xz 36c1c17f31855617b7898d2fd5abb9e2
-sha1 strace-5.14.tar.xz 6625b01b18c3940cd926c85e4d1feb10f162973d
-sha256 strace-5.14.tar.xz 901bee6db5e17debad4530dd9ffb4dc9a96c4a656edbe1c3141b7cb307b11e73
-sha512 strace-5.14.tar.xz 3e147521773d900167809db9feeb148e8ba116f90dd634311941ea335eb7bd8b73ab9e641bd2dcfe899ab41c19a841e203dc771ec3000ae01452d22ecdc43c5a
diff --git a/packages/strace/5.14/version.desc b/packages/strace/5.14/version.desc
deleted file mode 100644
index e69de29..0000000
--- a/packages/strace/5.14/version.desc
+++ /dev/null