summaryrefslogtreecommitdiff
path: root/packages/strace
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2022-02-11 02:00:59 (GMT)
committerAlexey Neyman <stilor@att.net>2022-02-11 08:47:51 (GMT)
commit86c2982568de1ad4d4cc12a65b19231331484405 (patch)
tree2e0b3fb78c30877c0c152d59d0e0fff817b73822 /packages/strace
parent1210b0c2f45e32ef0867ca00e16b6aadb6a81bf9 (diff)
Run patches thru `manage-packages -P`
This refreshes the line numbers, removes any fuzz (which would make any future forward ports easier) and standardizes the patch/file headers (which makes them easier to read). Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/strace')
-rw-r--r--packages/strace/4.26/0000-mips-o32-fix-build.patch13
-rw-r--r--packages/strace/5.14/0000-Avoid-relying-on-presence-of-ipx.h.patch (renamed from packages/strace/5.14/0001-Avoid-relying-on-presence-of-ipx.h.patch)31
2 files changed, 16 insertions, 28 deletions
diff --git a/packages/strace/4.26/0000-mips-o32-fix-build.patch b/packages/strace/4.26/0000-mips-o32-fix-build.patch
index d3c828e..afb1f40 100644
--- a/packages/strace/4.26/0000-mips-o32-fix-build.patch
+++ b/packages/strace/4.26/0000-mips-o32-fix-build.patch
@@ -17,11 +17,14 @@ Date: Tue Jan 8 19:23:44 2019 +0000
Reported-by: Baruch Siach <baruch@tkos.co.il>
Fixes: v4.26~61 "Refactor stack pointers"
-diff --git a/linux/mips/get_syscall_args.c b/linux/mips/get_syscall_args.c
-index 387aa852..e2889f98 100644
+---
+ linux/mips/get_syscall_args.c | 26 ++++++++++++++++++++++++++
+ syscall.c | 27 ++-------------------------
+ 2 files changed, 28 insertions(+), 25 deletions(-)
+
--- a/linux/mips/get_syscall_args.c
+++ b/linux/mips/get_syscall_args.c
-@@ -37,3 +37,29 @@ arch_get_syscall_args(struct tcb *tcp)
+@@ -37,3 +37,29 @@
#endif
return 1;
}
@@ -51,11 +54,9 @@ index 387aa852..e2889f98 100644
+ }
+}
+#endif /* SYS_syscall_subcall */
-diff --git a/syscall.c b/syscall.c
-index d78f51dd..51fcc721 100644
--- a/syscall.c
+++ b/syscall.c
-@@ -349,31 +349,8 @@ decode_ipc_subcall(struct tcb *tcp)
+@@ -349,31 +349,8 @@
#endif /* SYS_ipc_subcall */
#ifdef SYS_syscall_subcall
diff --git a/packages/strace/5.14/0001-Avoid-relying-on-presence-of-ipx.h.patch b/packages/strace/5.14/0000-Avoid-relying-on-presence-of-ipx.h.patch
index 93955eb..69421a5 100644
--- a/packages/strace/5.14/0001-Avoid-relying-on-presence-of-ipx.h.patch
+++ b/packages/strace/5.14/0000-Avoid-relying-on-presence-of-ipx.h.patch
@@ -24,18 +24,16 @@ check_ipx.
Closes: https://github.com/strace/strace/issues/201
---
- configure.ac | 1 +
- src/net.c | 5 -----
- src/sockaddr.c | 16 ++++++++++------
- src/xlat/sock_ipx_options.in | 2 +-
- tests/net-sockaddr.c | 10 +++++++++-
+ configure.ac | 1 +
+ src/net.c | 5 -----
+ src/sockaddr.c | 16 ++++++++++------
+ src/xlat/sock_ipx_options.in | 2 +-
+ tests/net-sockaddr.c | 10 +++++++++-
5 files changed, 21 insertions(+), 13 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index 2771c0f82..3c7fcb91e 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -423,6 +423,7 @@ AC_CHECK_HEADERS(m4_normalize([
+@@ -423,6 +423,7 @@
elf.h
gcov.h
iconv.h
@@ -43,8 +41,6 @@ index 2771c0f82..3c7fcb91e 100644
mqueue.h
netinet/sctp.h
netipx/ipx.h
-diff --git a/src/net.c b/src/net.c
-index b23911a97..bbc52e15f 100644
--- a/src/net.c
+++ b/src/net.c
@@ -28,11 +28,6 @@
@@ -59,8 +55,6 @@ index b23911a97..bbc52e15f 100644
#include <linux/ip_vs.h>
#include "netlink.h"
-diff --git a/src/sockaddr.c b/src/sockaddr.c
-index 8b2b0afaf..66aa04d59 100644
--- a/src/sockaddr.c
+++ b/src/sockaddr.c
@@ -24,12 +24,6 @@
@@ -93,15 +87,11 @@ index 8b2b0afaf..66aa04d59 100644
const size_t arp_hardware_types_size = ARRAY_SIZE(arp_hardware_types) - 1;
const size_t ethernet_protocols_size = ARRAY_SIZE(ethernet_protocols) - 1;
-diff --git a/src/xlat/sock_ipx_options.in b/src/xlat/sock_ipx_options.in
-index eba97fd71..b09be117e 100644
--- a/src/xlat/sock_ipx_options.in
+++ b/src/xlat/sock_ipx_options.in
@@ -1 +1 @@
-IPX_TYPE
+IPX_TYPE 1
-diff --git a/tests/net-sockaddr.c b/tests/net-sockaddr.c
-index f1f9b01cd..c8049fd68 100644
--- a/tests/net-sockaddr.c
+++ b/tests/net-sockaddr.c
@@ -24,7 +24,11 @@
@@ -117,7 +107,7 @@ index f1f9b01cd..c8049fd68 100644
#ifdef HAVE_BLUETOOTH_BLUETOOTH_H
# include <bluetooth/bluetooth.h>
# include <bluetooth/hci.h>
-@@ -269,6 +273,7 @@ check_in6(void)
+@@ -269,6 +273,7 @@
printf("connect(-1, %p, %u) = %d EBADF (%m)\n", in6, len, ret);
}
@@ -125,7 +115,7 @@ index f1f9b01cd..c8049fd68 100644
static void
check_ipx(void)
{
-@@ -295,6 +300,7 @@ check_ipx(void)
+@@ -295,6 +300,7 @@
c_ipx.sipx_node[4], c_ipx.sipx_node[5],
c_ipx.sipx_type, len, ret);
}
@@ -133,7 +123,7 @@ index f1f9b01cd..c8049fd68 100644
/* for a bit more compact AX.25 address definitions */
#define AX25_ADDR(c_, s_) \
-@@ -773,7 +779,9 @@ main(void)
+@@ -773,7 +779,9 @@
check_un();
check_in();
check_in6();
@@ -143,6 +133,3 @@ index f1f9b01cd..c8049fd68 100644
check_ax25();
check_x25();
check_nl();
---
-2.33.1
-