summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 92ee910..6c224c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,8 @@ SUBDIRS = kconfig
bin_SCRIPTS = ct-ng
CLEANFILES = ct-ng bash-completion/ct-ng docs/ct-ng.1
EXTRA_DIST = bootstrap ct-ng.in bash-completion/ct-ng.in \
- docs/ct-ng.1.in packages maintainer
+ config/configure.in.in \
+ docs/ct-ng.1.in packages maintainer testing
if INSTALL_BASH_COMPLETION
compdir = @BASH_COMPLETION_DIR@
@@ -18,7 +19,8 @@ endif
man1_MANS = docs/ct-ng.1
# paths.sh generated by configure
-nobase_dist_pkgdata_DATA = $(verbatim_data) paths.sh
+nobase_dist_pkgdata_DATA = $(verbatim_data)
+nobase_nodist_pkgdata_DATA = paths.sh
# ct-ng, as renamed by the installation
ctng_progname = `echo ct-ng | sed '$(transform)'`
@@ -76,12 +78,16 @@ endif
uninstall-hook:
rm -f $(DESTDIR)$(man1dir)/$(ctng_progname).1.gz
-dist-hook: fetch-docs gen-tarball-version
+dist-hook: fetch-docs create-symlinks gen-tarball-version
.PHONY: fetch-docs
fetch-docs: maintainer/download-docs.sh
$< $(top_distdir) $(USER_MANUAL_FILES)
+.PHONY: create-symlinks
+create-symlinks:
+ ln -s COPYING $(top_distdir)/LICENSE
+
.PHONY: gen-tarball-version
gen-tarball-version:
echo $(VERSION) > $(distdir)/.tarball-version