summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bd7ccb4..20d5b42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,11 @@ AC_CONFIG_AUX_DIR([scripts])
AC_CONFIG_MACRO_DIR([m4])
# TBD try to use gnu strictness? Just add the missing files?
-AM_INIT_AUTOMAKE([-Wall -Werror foreign no-dist-gzip dist-xz dist-bzip2 subdir-objects])
+# Set automake defaults:
+# - Tarballs are compressed with xz and bzip2
+# - Object files are generated in a subdirectory (new default in automake)
+# - Request new tar format (old, tar-v7, breaks on long paths we have)
+AM_INIT_AUTOMAKE([-Wall -Werror foreign no-dist-gzip dist-xz dist-bzip2 subdir-objects tar-pax])
#--------------------------------------------------------------------
# Allow dummy --{en,dis}able-{static,shared}