summaryrefslogtreecommitdiff
path: root/kconfig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kconfig/Makefile.am')
-rw-r--r--kconfig/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/kconfig/Makefile.am b/kconfig/Makefile.am
index 66df802..1b4a06c 100644
--- a/kconfig/Makefile.am
+++ b/kconfig/Makefile.am
@@ -1,9 +1,8 @@
-## Process this file with automake to produce Makefile.in
## vim: set noet :
## TBD install into lib/crosstool-ng/kconfig?
## TBD turn off program renaming for these? Or account for it in ct-ng script?
-pkglibexec_PROGRAMS = conf nconf
+pkglibexec_PROGRAMS = conf nconf mconf
AM_LFLAGS = -L -Pzconf
AM_YFLAGS = -l -b zconf -p zconf
@@ -18,6 +17,11 @@ nconf_SOURCES = nconf.c nconf.gui.c zconf.c
nconf_CFLAGS = $(CURSES_CFLAGS)
nconf_LDADD = $(MENU_LIBS) $(PANEL_LIBS) $(CURSES_LIBS)
+mconf_SOURCES = mconf.c zconf.c lxdialog/checklist.c lxdialog/inputbox.c \
+ lxdialog/menubox.c lxdialog/textbox.c lxdialog/util.c \
+ lxdialog/yesno.c
+mconf_LDADD = $(CURSES_LIBS)
+
# automake's support for yacc/lex/gperf is too idiosyncratic. It doesn't
# support a common pattern of including lex-generated file into yacc, nor does
# it support using a different base name for the generated C files.