summaryrefslogtreecommitdiff
path: root/packages/gcc/9.4.0
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gcc/9.4.0')
-rw-r--r--packages/gcc/9.4.0/0000-libtool-leave-framework-alone.patch2
-rw-r--r--packages/gcc/9.4.0/0001-uclibc-conf.patch2
-rw-r--r--packages/gcc/9.4.0/0002-gcc-plugin-Win-Dont-need-undefined-extern-var-refs-nor-fpic.patch18
-rw-r--r--packages/gcc/9.4.0/0003-gcc-plugin-POSIX-include-sys-select-h.patch2
-rw-r--r--packages/gcc/9.4.0/0005-fix-m68k-uclinux.patch2
-rw-r--r--packages/gcc/9.4.0/0006-libgfortran-missing-include.patch4
-rw-r--r--packages/gcc/9.4.0/0009-bionic-ndk.patch2
-rw-r--r--packages/gcc/9.4.0/0010-crystax.patch32
-rw-r--r--packages/gcc/9.4.0/0012-crystax.patch31
-rw-r--r--packages/gcc/9.4.0/0013-crystax.patch2
-rw-r--r--packages/gcc/9.4.0/0014-crystax.patch2
-rw-r--r--packages/gcc/9.4.0/0015-crystax.patch2
-rw-r--r--packages/gcc/9.4.0/0017-crystax.patch2
-rw-r--r--packages/gcc/9.4.0/0018-isl-0.20.patch2
14 files changed, 52 insertions, 53 deletions
diff --git a/packages/gcc/9.4.0/0000-libtool-leave-framework-alone.patch b/packages/gcc/9.4.0/0000-libtool-leave-framework-alone.patch
index b5804ea..1a86e41 100644
--- a/packages/gcc/9.4.0/0000-libtool-leave-framework-alone.patch
+++ b/packages/gcc/9.4.0/0000-libtool-leave-framework-alone.patch
@@ -4,7 +4,7 @@
--- a/libtool-ldflags
+++ b/libtool-ldflags
-@@ -36,6 +36,11 @@ prev_arg=
+@@ -36,6 +36,11 @@
for arg
do
case $arg in
diff --git a/packages/gcc/9.4.0/0001-uclibc-conf.patch b/packages/gcc/9.4.0/0001-uclibc-conf.patch
index a9ae872..aef750a 100644
--- a/packages/gcc/9.4.0/0001-uclibc-conf.patch
+++ b/packages/gcc/9.4.0/0001-uclibc-conf.patch
@@ -4,7 +4,7 @@
--- a/contrib/regression/objs-gcc.sh
+++ b/contrib/regression/objs-gcc.sh
-@@ -106,6 +106,10 @@ if [ $H_REAL_TARGET = $H_REAL_HOST -a $H
+@@ -106,6 +106,10 @@
then
make all-gdb all-dejagnu all-ld || exit 1
make install-gdb install-dejagnu install-ld || exit 1
diff --git a/packages/gcc/9.4.0/0002-gcc-plugin-Win-Dont-need-undefined-extern-var-refs-nor-fpic.patch b/packages/gcc/9.4.0/0002-gcc-plugin-Win-Dont-need-undefined-extern-var-refs-nor-fpic.patch
index 18fe931..0f2c7c1 100644
--- a/packages/gcc/9.4.0/0002-gcc-plugin-Win-Dont-need-undefined-extern-var-refs-nor-fpic.patch
+++ b/packages/gcc/9.4.0/0002-gcc-plugin-Win-Dont-need-undefined-extern-var-refs-nor-fpic.patch
@@ -6,7 +6,7 @@
--- a/config/gcc-plugin.m4
+++ b/config/gcc-plugin.m4
-@@ -21,6 +21,9 @@ AC_DEFUN([GCC_ENABLE_PLUGINS],
+@@ -21,6 +21,9 @@
pluginlibs=
plugin_check=yes
@@ -16,7 +16,7 @@
case "${host}" in
*-*-mingw*)
# Since plugin support under MinGW is not as straightforward as on
-@@ -43,6 +46,11 @@ AC_DEFUN([GCC_ENABLE_PLUGINS],
+@@ -43,6 +46,11 @@
export_sym_check=
fi
;;
@@ -28,7 +28,7 @@
*)
if test x$build = x$host; then
export_sym_check="objdump${exeext} -T"
-@@ -94,17 +102,17 @@ AC_DEFUN([GCC_ENABLE_PLUGINS],
+@@ -94,17 +102,17 @@
case "${host}" in
*-*-darwin*)
CFLAGS=`echo $CFLAGS | sed s/-mdynamic-no-pic//g`
@@ -53,7 +53,7 @@
if test x"$have_pic_shared" != x"yes" -o x"$ac_cv_search_dlopen" = x"no"; then
--- a/gcc/configure
+++ b/gcc/configure
-@@ -29862,6 +29862,9 @@ fi
+@@ -29898,6 +29898,9 @@
pluginlibs=
plugin_check=yes
@@ -63,7 +63,7 @@
case "${host}" in
*-*-mingw*)
# Since plugin support under MinGW is not as straightforward as on
-@@ -29884,6 +29887,11 @@ fi
+@@ -29920,6 +29923,11 @@
export_sym_check=
fi
;;
@@ -75,7 +75,7 @@
*)
if test x$build = x$host; then
export_sym_check="objdump${exeext} -T"
-@@ -29996,23 +30004,23 @@ fi
+@@ -30032,23 +30040,23 @@
case "${host}" in
*-*-darwin*)
CFLAGS=`echo $CFLAGS | sed s/-mdynamic-no-pic//g`
@@ -108,7 +108,7 @@
}
--- a/libcc1/configure
+++ b/libcc1/configure
-@@ -14785,6 +14785,9 @@ fi
+@@ -14802,6 +14802,9 @@
pluginlibs=
plugin_check=yes
@@ -118,7 +118,7 @@
case "${host}" in
*-*-mingw*)
# Since plugin support under MinGW is not as straightforward as on
-@@ -14807,6 +14810,11 @@ fi
+@@ -14824,6 +14827,11 @@
export_sym_check=
fi
;;
@@ -130,7 +130,7 @@
*)
if test x$build = x$host; then
export_sym_check="objdump${exeext} -T"
-@@ -14919,23 +14927,23 @@ fi
+@@ -14936,23 +14944,23 @@
case "${host}" in
*-*-darwin*)
CFLAGS=`echo $CFLAGS | sed s/-mdynamic-no-pic//g`
diff --git a/packages/gcc/9.4.0/0003-gcc-plugin-POSIX-include-sys-select-h.patch b/packages/gcc/9.4.0/0003-gcc-plugin-POSIX-include-sys-select-h.patch
index 3040e23..5f9a07a 100644
--- a/packages/gcc/9.4.0/0003-gcc-plugin-POSIX-include-sys-select-h.patch
+++ b/packages/gcc/9.4.0/0003-gcc-plugin-POSIX-include-sys-select-h.patch
@@ -4,7 +4,7 @@
--- a/libcc1/connection.cc
+++ b/libcc1/connection.cc
-@@ -21,6 +21,7 @@ along with GCC; see the file COPYING3.
+@@ -21,6 +21,7 @@
#include <string>
#include <unistd.h>
#include <sys/types.h>
diff --git a/packages/gcc/9.4.0/0005-fix-m68k-uclinux.patch b/packages/gcc/9.4.0/0005-fix-m68k-uclinux.patch
index 62bea0e..67d22db 100644
--- a/packages/gcc/9.4.0/0005-fix-m68k-uclinux.patch
+++ b/packages/gcc/9.4.0/0005-fix-m68k-uclinux.patch
@@ -10,7 +10,7 @@ Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
--- a/libgcc/config.host
+++ b/libgcc/config.host
-@@ -875,7 +875,7 @@ m68k*-*-netbsdelf*)
+@@ -885,7 +885,7 @@
m68k*-*-openbsd*)
;;
m68k-*-uclinux*) # Motorola m68k/ColdFire running uClinux with uClibc
diff --git a/packages/gcc/9.4.0/0006-libgfortran-missing-include.patch b/packages/gcc/9.4.0/0006-libgfortran-missing-include.patch
index f93524b..d4917ee 100644
--- a/packages/gcc/9.4.0/0006-libgfortran-missing-include.patch
+++ b/packages/gcc/9.4.0/0006-libgfortran-missing-include.patch
@@ -4,11 +4,11 @@
--- a/libgfortran/io/close.c
+++ b/libgfortran/io/close.c
-@@ -29,6 +29,7 @@ see the files COPYING3 and COPYING.RUNTI
+@@ -29,6 +29,7 @@
#if !HAVE_UNLINK_OPEN_FILE
#include <string.h>
#endif
+#include <stdlib.h>
typedef enum
- { CLOSE_DELETE, CLOSE_KEEP, CLOSE_UNSPECIFIED }
+ { CLOSE_INVALID = - 1, CLOSE_DELETE, CLOSE_KEEP, CLOSE_UNSPECIFIED }
diff --git a/packages/gcc/9.4.0/0009-bionic-ndk.patch b/packages/gcc/9.4.0/0009-bionic-ndk.patch
index 090172d..474dd8c 100644
--- a/packages/gcc/9.4.0/0009-bionic-ndk.patch
+++ b/packages/gcc/9.4.0/0009-bionic-ndk.patch
@@ -29,7 +29,7 @@ Date: Tue Apr 25 19:02:18 2017 -0700
namespace std _GLIBCXX_VISIBILITY(default)
{
_GLIBCXX_BEGIN_NAMESPACE_VERSION
-@@ -41,17 +53,17 @@ _GLIBCXX_BEGIN_NAMESPACE_VERSION
+@@ -41,17 +53,17 @@
// NB: Offsets into ctype<char>::_M_table force a particular size
// on the mask type. Because of this, we don't use an enum.
typedef char mask;
diff --git a/packages/gcc/9.4.0/0010-crystax.patch b/packages/gcc/9.4.0/0010-crystax.patch
index 8ac327a..2b67aed 100644
--- a/packages/gcc/9.4.0/0010-crystax.patch
+++ b/packages/gcc/9.4.0/0010-crystax.patch
@@ -37,7 +37,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
-@@ -1022,14 +1022,18 @@ aarch64*-*-freebsd*)
+@@ -1023,14 +1023,18 @@
tm_defines="${tm_defines} TARGET_DEFAULT_ASYNC_UNWIND_TABLES=1"
;;
aarch64*-*-linux*)
@@ -57,7 +57,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
esac
aarch64_multilibs="${with_multilib_list}"
if test "$aarch64_multilibs" = "default"; then
-@@ -2272,6 +2276,17 @@ mips*-*-linux*) # Linux MIPS, either
+@@ -2273,6 +2277,17 @@
tm_file="dbxelf.h elfos.h gnu-user.h linux.h linux-android.h glibc-stdint.h ${tm_file} mips/gnu-user.h mips/linux.h mips/linux-common.h"
extra_options="${extra_options} linux-android.opt"
case ${target} in
@@ -157,7 +157,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
#define MUSL_DYNAMIC_LINKER "/lib/ld-musl-aarch64%{mbig-endian:_be}%{mabi=ilp32:_ilp32}.so.1"
--- a/gcc/config/arm/arm.h
+++ b/gcc/config/arm/arm.h
-@@ -1856,12 +1856,13 @@ enum arm_auto_incmodes
+@@ -1856,12 +1856,13 @@
#define CASE_VECTOR_PC_RELATIVE ((TARGET_THUMB2 \
|| (TARGET_THUMB1 \
@@ -174,7 +174,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
: min >= -256 && max < 256 \
--- a/gcc/config/arm/arm.md
+++ b/gcc/config/arm/arm.md
-@@ -8920,7 +8920,7 @@
+@@ -8987,7 +8987,7 @@
(match_operand:SI 2 "const_int_operand" "") ; total range
(match_operand:SI 3 "" "") ; table label
(match_operand:SI 4 "" "")] ; Out of range label
@@ -185,7 +185,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
enum insn_code code;
--- a/gcc/config/arm/arm.opt
+++ b/gcc/config/arm/arm.opt
-@@ -202,6 +202,10 @@ mthumb-interwork
+@@ -202,6 +202,10 @@
Target Report Mask(INTERWORK)
Support calls between Thumb and ARM instruction sets.
@@ -250,7 +250,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
LINUX_OR_ANDROID_LD (GNU_USER_TARGET_LIB_SPEC, \
--- a/gcc/config/i386/gnu-user.h
+++ b/gcc/config/i386/gnu-user.h
-@@ -65,9 +65,14 @@ along with GCC; see the file COPYING3.
+@@ -65,9 +65,14 @@
When the -shared link option is used a final link is not being
done. */
@@ -268,7 +268,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
#define SUBTARGET_EXTRA_SPECS \
--- a/gcc/config/i386/gnu-user64.h
+++ b/gcc/config/i386/gnu-user64.h
-@@ -46,6 +46,11 @@ see the files COPYING3 and COPYING.RUNTI
+@@ -46,6 +46,11 @@
#define SPEC_X32 "mx32"
#endif
@@ -282,7 +282,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
%{" SPEC_64 ":--64} \
--- a/gcc/config/i386/linux-common.h
+++ b/gcc/config/i386/linux-common.h
-@@ -36,7 +36,13 @@ along with GCC; see the file COPYING3.
+@@ -36,7 +36,13 @@
#undef CC1_SPEC
#define CC1_SPEC \
LINUX_OR_ANDROID_CC (GNU_USER_TARGET_CC1_SPEC, \
@@ -377,7 +377,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
+ LINUX_DRIVER_SELF_SPECS
--- a/gcc/config/mips/gnu-user.h
+++ b/gcc/config/mips/gnu-user.h
-@@ -36,6 +36,7 @@ along with GCC; see the file COPYING3.
+@@ -36,6 +36,7 @@
/* The GNU C++ standard library requires this. */ \
if (c_dialect_cxx ()) \
builtin_define ("_GNU_SOURCE"); \
@@ -385,7 +385,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
} while (0)
#undef SUBTARGET_CPP_SPEC
-@@ -71,7 +72,8 @@ along with GCC; see the file COPYING3.
+@@ -71,7 +72,8 @@
#undef SUBTARGET_ASM_SPEC
#define SUBTARGET_ASM_SPEC \
@@ -395,7 +395,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
/* The MIPS assembler has different syntax for .set. We set it to
.dummy to trap any errors. */
-@@ -120,7 +122,7 @@ extern const char *host_detect_local_cpu
+@@ -120,7 +122,7 @@
#endif
#define LINUX_DRIVER_SELF_SPECS \
@@ -406,7 +406,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
specs handling by removing a redundant option. */ \
--- a/gcc/config/mips/linux-common.h
+++ b/gcc/config/mips/linux-common.h
-@@ -38,7 +38,7 @@ along with GCC; see the file COPYING3.
+@@ -38,7 +38,7 @@
#undef SUBTARGET_CC1_SPEC
#define SUBTARGET_CC1_SPEC \
LINUX_OR_ANDROID_CC (GNU_USER_TARGET_CC1_SPEC, \
@@ -430,7 +430,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
+MULTILIB_REQUIRED = mabi=32/mips32 mabi=32/mips32r2 mabi=32/mips32r6 mips64r2 mips64r6
--- a/libgcc/gthr-posix.h
+++ b/libgcc/gthr-posix.h
-@@ -32,6 +32,19 @@ see the files COPYING3 and COPYING.RUNTI
+@@ -32,6 +32,19 @@
#define __GTHREADS 1
#define __GTHREADS_CXX0X 1
@@ -452,7 +452,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
#if ((defined(_LIBOBJC) || defined(_LIBOBJC_WEAK)) \
--- a/libstdc++-v3/configure
+++ b/libstdc++-v3/configure
-@@ -78982,6 +78982,18 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_
+@@ -78984,6 +78984,18 @@
/* end confdefs.h. */
#include <sys/syscall.h>
int lk;
@@ -494,7 +494,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
namespace std _GLIBCXX_VISIBILITY(default)
{
_GLIBCXX_BEGIN_NAMESPACE_VERSION
-@@ -1104,7 +1118,7 @@ _GLIBCXX_BEGIN_NAMESPACE_VERSION
+@@ -1104,7 +1118,7 @@
* @return @a __hi.
*/
virtual const char*
@@ -503,7 +503,7 @@ Date: Wed Jul 29 11:28:29 2015 +0300
{
if (__builtin_expect(__hi != __lo, true))
__builtin_memcpy(__to, __lo, __hi - __lo);
-@@ -1167,7 +1181,7 @@ _GLIBCXX_BEGIN_NAMESPACE_VERSION
+@@ -1167,7 +1181,7 @@
private:
void _M_narrow_init() const;
diff --git a/packages/gcc/9.4.0/0012-crystax.patch b/packages/gcc/9.4.0/0012-crystax.patch
index 1363d29..ec0faf6 100644
--- a/packages/gcc/9.4.0/0012-crystax.patch
+++ b/packages/gcc/9.4.0/0012-crystax.patch
@@ -16,17 +16,16 @@ Date: Mon Apr 14 15:59:47 2014 -0700
gcc/config/freebsd.h | 4 +++
gcc/config/gnu-user.h | 4 +++
gcc/config/openbsd.h | 4 +++
- gcc/config/rs6000/sysv4.h | 6 ++++-
gcc/config/sol2.h | 4 +++
gcc/configure | 36 +++++++++++++++++++++++++++++++++
gcc/configure.ac | 29 ++++++++++++++++++++++++++
gcc/testsuite/g++.dg/eh/spec3-static.C | 25 ++++++++++++++++++++++
libgcc/crtstuff.c | 11 ++++++----
- 11 files changed, 128 insertions(+), 5 deletions(-)
+ 10 files changed, 123 insertions(+), 4 deletions(-)
--- a/gcc/config.in
+++ b/gcc/config.in
-@@ -2197,6 +2197,12 @@
+@@ -2204,6 +2204,12 @@
#endif
@@ -41,7 +40,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
#ifndef USED_FOR_TARGET
--- a/gcc/config/alpha/elf.h
+++ b/gcc/config/alpha/elf.h
-@@ -142,5 +142,9 @@ extern int alpha_this_gpdisp_sequence_nu
+@@ -142,5 +142,9 @@
I imagine that other systems will catch up. In the meantime, it
doesn't harm to make sure that the data exists to be used later. */
#if defined(HAVE_LD_EH_FRAME_HDR)
@@ -53,7 +52,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
+#endif
--- a/gcc/config/freebsd.h
+++ b/gcc/config/freebsd.h
-@@ -45,8 +45,12 @@ along with GCC; see the file COPYING3.
+@@ -45,8 +45,12 @@
#define LIB_SPEC FBSD_LIB_SPEC
#if defined(HAVE_LD_EH_FRAME_HDR)
@@ -68,7 +67,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
#define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all" \
--- a/gcc/config/gnu-user.h
+++ b/gcc/config/gnu-user.h
-@@ -106,8 +106,12 @@ see the files COPYING3 and COPYING.RUNTI
+@@ -106,8 +106,12 @@
#define LIB_SPEC GNU_USER_TARGET_LIB_SPEC
#if defined(HAVE_LD_EH_FRAME_HDR)
@@ -83,7 +82,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
"%{static|static-pie:--start-group} %G %{!nolibc:%L} \
--- a/gcc/config/openbsd.h
+++ b/gcc/config/openbsd.h
-@@ -136,8 +136,12 @@ while (0)
+@@ -136,8 +136,12 @@
#define LIB_SPEC OBSD_LIB_SPEC
#if defined(HAVE_LD_EH_FRAME_HDR)
@@ -98,7 +97,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
#define LIB_SPEC OBSD_LIB_SPEC
--- a/gcc/config/sol2.h
+++ b/gcc/config/sol2.h
-@@ -434,7 +434,11 @@ along with GCC; see the file COPYING3.
+@@ -434,7 +434,11 @@
/* Solaris 11 build 135+ implements dl_iterate_phdr. GNU ld needs
--eh-frame-hdr to create the required .eh_frame_hdr sections. */
#if defined(HAVE_LD_EH_FRAME_HDR) && defined(TARGET_DL_ITERATE_PHDR)
@@ -112,7 +111,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
--- a/gcc/configure
+++ b/gcc/configure
-@@ -986,6 +986,7 @@ enable_fix_cortex_a53_835769
+@@ -986,6 +986,7 @@
enable_fix_cortex_a53_843419
with_glibc_version
enable_gnu_unique_object
@@ -120,7 +119,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
enable_linker_build_id
enable_libssp
enable_default_ssp
-@@ -1737,6 +1738,9 @@ Optional Features:
+@@ -1737,6 +1738,9 @@
--enable-gnu-unique-object
enable the use of the @gnu_unique_object ELF
extension on glibc systems
@@ -130,7 +129,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
--enable-linker-build-id
compiler will always pass --build-id to linker
--enable-libssp enable linking against libssp
-@@ -28349,6 +28353,38 @@ if test x"$gcc_cv_ld_eh_frame_hdr" = xye
+@@ -28382,6 +28386,38 @@
$as_echo "#define HAVE_LD_EH_FRAME_HDR 1" >>confdefs.h
@@ -171,7 +170,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
$as_echo "$gcc_cv_ld_eh_frame_hdr" >&6; }
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -5171,6 +5171,35 @@ GCC_TARGET_TEMPLATE([HAVE_LD_EH_FRAME_HD
+@@ -5176,6 +5176,35 @@
if test x"$gcc_cv_ld_eh_frame_hdr" = xyes; then
AC_DEFINE(HAVE_LD_EH_FRAME_HDR, 1,
[Define if your linker supports .eh_frame_hdr.])
@@ -237,7 +236,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
+}
--- a/libgcc/crtstuff.c
+++ b/libgcc/crtstuff.c
-@@ -88,7 +88,8 @@ call_ ## FUNC (void) \
+@@ -88,7 +88,8 @@
#if defined(OBJECT_FORMAT_ELF) \
&& !defined(OBJECT_FORMAT_FLAT) \
&& defined(HAVE_LD_EH_FRAME_HDR) \
@@ -247,7 +246,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
&& defined(BSD_DL_ITERATE_PHDR_AVAILABLE)
#include <link.h>
# define USE_PT_GNU_EH_FRAME
-@@ -97,7 +98,8 @@ call_ ## FUNC (void) \
+@@ -97,7 +98,8 @@
#if defined(OBJECT_FORMAT_ELF) \
&& !defined(OBJECT_FORMAT_FLAT) \
&& defined(HAVE_LD_EH_FRAME_HDR) && defined(TARGET_DL_ITERATE_PHDR) \
@@ -257,7 +256,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
&& defined(__sun__) && defined(__svr4__)
#include <link.h>
# define USE_PT_GNU_EH_FRAME
-@@ -106,7 +108,8 @@ call_ ## FUNC (void) \
+@@ -106,7 +108,8 @@
#if defined(OBJECT_FORMAT_ELF) \
&& !defined(OBJECT_FORMAT_FLAT) \
&& defined(HAVE_LD_EH_FRAME_HDR) \
@@ -267,7 +266,7 @@ Date: Mon Apr 14 15:59:47 2014 -0700
&& defined(__GLIBC__) && __GLIBC__ >= 2
#include <link.h>
/* uClibc pretends to be glibc 2.2 and DT_CONFIG is defined in its link.h.
-@@ -121,7 +124,7 @@ call_ ## FUNC (void) \
+@@ -121,7 +124,7 @@
#if defined(OBJECT_FORMAT_ELF) \
&& !defined(OBJECT_FORMAT_FLAT) \
&& defined(HAVE_LD_EH_FRAME_HDR) \
diff --git a/packages/gcc/9.4.0/0013-crystax.patch b/packages/gcc/9.4.0/0013-crystax.patch
index e7fdd6e..a4bac50 100644
--- a/packages/gcc/9.4.0/0013-crystax.patch
+++ b/packages/gcc/9.4.0/0013-crystax.patch
@@ -12,7 +12,7 @@ Date: Thu Aug 20 19:11:07 2015 +0300
--- a/gcc/config/i386/i386.c
+++ b/gcc/config/i386/i386.c
-@@ -15635,6 +15635,7 @@ legitimate_pic_address_disp_p (rtx disp)
+@@ -15674,6 +15674,7 @@
else if (!SYMBOL_REF_FAR_ADDR_P (op0)
&& (SYMBOL_REF_LOCAL_P (op0)
|| (HAVE_LD_PIE_COPYRELOC
diff --git a/packages/gcc/9.4.0/0014-crystax.patch b/packages/gcc/9.4.0/0014-crystax.patch
index 5acc6b9..8f2eb43 100644
--- a/packages/gcc/9.4.0/0014-crystax.patch
+++ b/packages/gcc/9.4.0/0014-crystax.patch
@@ -12,7 +12,7 @@ Date: Fri Aug 21 17:41:59 2015 +0300
--- a/libgcc/gthr.h
+++ b/libgcc/gthr.h
-@@ -145,7 +145,11 @@ see the files COPYING3 and COPYING.RUNTI
+@@ -145,7 +145,11 @@
#define GTHREAD_USE_WEAK 1
#endif
#endif
diff --git a/packages/gcc/9.4.0/0015-crystax.patch b/packages/gcc/9.4.0/0015-crystax.patch
index a0bad24..63d0efb 100644
--- a/packages/gcc/9.4.0/0015-crystax.patch
+++ b/packages/gcc/9.4.0/0015-crystax.patch
@@ -15,7 +15,7 @@ Date: Mon Apr 14 21:05:51 2014 -0700
--- a/gcc/config/arm/arm.c
+++ b/gcc/config/arm/arm.c
-@@ -22862,9 +22862,13 @@ arm_print_operand (FILE *stream, rtx x,
+@@ -22868,9 +22868,13 @@
memsize = MEM_SIZE (x);
/* Only certain alignment specifiers are supported by the hardware. */
diff --git a/packages/gcc/9.4.0/0017-crystax.patch b/packages/gcc/9.4.0/0017-crystax.patch
index 1a46aed..28284ff 100644
--- a/packages/gcc/9.4.0/0017-crystax.patch
+++ b/packages/gcc/9.4.0/0017-crystax.patch
@@ -24,7 +24,7 @@ Date: Tue Aug 25 09:36:42 2015 +0300
#endif /* GCC_AARCH64_LINUX_ANDROID_H */
--- a/gcc/config/mips/linux-common.h
+++ b/gcc/config/mips/linux-common.h
-@@ -65,3 +65,7 @@ along with GCC; see the file COPYING3.
+@@ -65,3 +65,7 @@
/* The default value isn't sufficient in 64-bit mode. */
#define STACK_CHECK_PROTECT (TARGET_64BIT ? 16 * 1024 : 12 * 1024)
diff --git a/packages/gcc/9.4.0/0018-isl-0.20.patch b/packages/gcc/9.4.0/0018-isl-0.20.patch
index de188b1..3e14966 100644
--- a/packages/gcc/9.4.0/0018-isl-0.20.patch
+++ b/packages/gcc/9.4.0/0018-isl-0.20.patch
@@ -15,7 +15,7 @@ Date: Mon Sep 24 22:50:11 2018 -0700
--- a/gcc/graphite.h
+++ b/gcc/graphite.h
-@@ -26,6 +26,8 @@ along with GCC; see the file COPYING3.
+@@ -26,6 +26,8 @@
#include <isl/options.h>
#include <isl/ctx.h>
#include <isl/val.h>