summaryrefslogtreecommitdiff
path: root/packages/gdb/8.1
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gdb/8.1')
-rw-r--r--packages/gdb/8.1/0000-musl_fix.patch33
-rw-r--r--packages/gdb/8.1/0001-uclibc-no-gettimeofday-clobber.patch33
-rw-r--r--packages/gdb/8.1/0002-xtensa-make-sure-ar_base-is-initialized.patch30
-rw-r--r--packages/gdb/8.1/0003-WIP-end-of-prologue-detection-hack.patch26
-rw-r--r--packages/gdb/8.1/0004-allow-android.patch45
-rw-r--r--packages/gdb/8.1/chksum8
-rw-r--r--packages/gdb/8.1/version.desc0
7 files changed, 0 insertions, 175 deletions
diff --git a/packages/gdb/8.1/0000-musl_fix.patch b/packages/gdb/8.1/0000-musl_fix.patch
deleted file mode 100644
index 6829780..0000000
--- a/packages/gdb/8.1/0000-musl_fix.patch
+++ /dev/null
@@ -1,33 +0,0 @@
----
- gdb/linux-nat.c | 5 +++++
- gdb/stopcode.h | 4 ++++
- 2 files changed, 9 insertions(+)
-
---- a/gdb/linux-nat.c
-+++ b/gdb/linux-nat.c
-@@ -17,6 +17,7 @@
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>. */
-
-+#include "stopcode.h"
- #include "defs.h"
- #include "inferior.h"
- #include "infrun.h"
-@@ -71,6 +72,10 @@
- #define SPUFS_MAGIC 0x23c9b64e
- #endif
-
-+#ifndef __SIGRTMIN
-+#define __SIGRTMIN SIGRTMIN
-+#endif
-+
- /* This comment documents high-level logic of this file.
-
- Waiting for events in sync mode
---- /dev/null
-+++ b/gdb/stopcode.h
-@@ -0,0 +1,4 @@
-+#ifndef W_STOPCODE
-+#define W_STOPCODE(sig) ((sig) << 8 | 0x7f)
-+#endif
-+
diff --git a/packages/gdb/8.1/0001-uclibc-no-gettimeofday-clobber.patch b/packages/gdb/8.1/0001-uclibc-no-gettimeofday-clobber.patch
deleted file mode 100644
index c8b4a5e..0000000
--- a/packages/gdb/8.1/0001-uclibc-no-gettimeofday-clobber.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Improve gnulib in gdb's guess work, gettimeofday() works in uClibcm promise.
-
-This patch helps building x86_64-unknown-linux-uclibc toolchains, the final
-gdb-native step otherwise fails when linking the libinproctrace.so
-
-Signed-off-by: Joachim Nilsson <troglobit@gmail.com>
-Signed-off-by: Alexey Neyman <stilor@att.net>
-
----
- gdb/gnulib/configure | 1 +
- gdb/gnulib/import/m4/gettimeofday.m4 | 1 +
- 2 files changed, 2 insertions(+)
-
---- a/gdb/gnulib/configure
-+++ b/gdb/gnulib/configure
-@@ -16790,6 +16790,7 @@
- case "$host_os" in
- # Guess all is fine on glibc systems.
- *-gnu*) gl_cv_func_gettimeofday_clobber="guessing no" ;;
-+ *-uclibc*) gl_cv_func_gettimeofday_clobber="guessing no" ;;
- # If we don't know, assume the worst.
- *) gl_cv_func_gettimeofday_clobber="guessing yes" ;;
- esac
---- a/gdb/gnulib/import/m4/gettimeofday.m4
-+++ b/gdb/gnulib/import/m4/gettimeofday.m4
-@@ -111,6 +111,7 @@
- case "$host_os" in
- # Guess all is fine on glibc systems.
- *-gnu*) gl_cv_func_gettimeofday_clobber="guessing no" ;;
-+ *-uclibc*) gl_cv_func_gettimeofday_clobber="guessing no" ;;
- # If we don't know, assume the worst.
- *) gl_cv_func_gettimeofday_clobber="guessing yes" ;;
- esac
diff --git a/packages/gdb/8.1/0002-xtensa-make-sure-ar_base-is-initialized.patch b/packages/gdb/8.1/0002-xtensa-make-sure-ar_base-is-initialized.patch
deleted file mode 100644
index 4a046fd..0000000
--- a/packages/gdb/8.1/0002-xtensa-make-sure-ar_base-is-initialized.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 208ea73d38c9c16cf983b6419f58050dbadcb6a9 Mon Sep 17 00:00:00 2001
-From: Max Filippov <jcmvbkbc@gmail.com>
-Date: Sun, 7 Jun 2015 22:43:49 +0300
-Subject: [PATCH 2/2] xtensa: make sure ar_base is initialized
-
-ar_base is uninitialized for cores w/o windowed registers as their
-regmap doesn't have register 0x0100.
-Check that ar_base is initialized and if not initialize it with a0_base.
-
-gdb/
- * xtensa-tdep.c (xtensa_derive_tdep): Make sure ar_base is
- initialized.
-
-Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
----
- gdb/xtensa-tdep.c | 3 +++
- 1 file changed, 3 insertions(+)
-
---- a/gdb/xtensa-tdep.c
-+++ b/gdb/xtensa-tdep.c
-@@ -3157,6 +3157,9 @@
- tdep->num_regs = n;
- }
-
-+ if (tdep->ar_base == -1)
-+ tdep->ar_base = tdep->a0_base;
-+
- /* Number of pseudo registers. */
- tdep->num_pseudo_regs = n - tdep->num_regs;
-
diff --git a/packages/gdb/8.1/0003-WIP-end-of-prologue-detection-hack.patch b/packages/gdb/8.1/0003-WIP-end-of-prologue-detection-hack.patch
deleted file mode 100644
index 90cfc51..0000000
--- a/packages/gdb/8.1/0003-WIP-end-of-prologue-detection-hack.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 7f8eacbb468575fb67db7fd1155a3aedaa91911b Mon Sep 17 00:00:00 2001
-From: Max Filippov <jcmvbkbc@gmail.com>
-Date: Sun, 7 Jun 2015 23:15:39 +0300
-Subject: [PATCH] WIP: *end of prologue* detection hack
-
-see
- http://www.esp8266.com/viewtopic.php?p=18461#p18461
- http://www.esp8266.com/viewtopic.php?p=19026#p19026
- http://www.esp8266.com/viewtopic.php?p=19683#p19683
-
-Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
----
- gdb/xtensa-tdep.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/gdb/xtensa-tdep.c
-+++ b/gdb/xtensa-tdep.c
-@@ -2401,7 +2401,7 @@
- /* Find out, if we have an information about the prologue from DWARF. */
- prologue_sal = find_pc_line (start, 0);
- if (prologue_sal.line != 0) /* Found debug info. */
-- body_pc = prologue_sal.end;
-+ body_pc = prologue_sal.end + 40;
-
- /* If we are going to analyze the prologue in general without knowing about
- the current PC, make the best assumtion for the end of the prologue. */
diff --git a/packages/gdb/8.1/0004-allow-android.patch b/packages/gdb/8.1/0004-allow-android.patch
deleted file mode 100644
index cd47494..0000000
--- a/packages/gdb/8.1/0004-allow-android.patch
+++ /dev/null
@@ -1,45 +0,0 @@
----
- gdb/gdbserver/configure | 11 -----------
- gdb/gdbserver/configure.ac | 11 -----------
- 2 files changed, 22 deletions(-)
-
---- a/gdb/gdbserver/configure
-+++ b/gdb/gdbserver/configure
-@@ -7565,17 +7565,6 @@
-
-
- case "${target}" in
-- *-android*)
-- # Starting with NDK version 9, <elf.h> actually includes definitions
-- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
-- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
-- # leading to conflicts with the defintions from <linux/elf.h>.
-- # This makes it impossible for us to include both <elf.h> and
-- # <linux/elf.h>, which means that, in practice, we do not have
-- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
-- # Therefore, do not try to auto-detect availability, as it would
-- # get it wrong on this platform.
-- ;;
- *)
- ac_fn_c_check_type "$LINENO" "Elf32_auxv_t" "ac_cv_type_Elf32_auxv_t" "#include <elf.h>
-
---- a/gdb/gdbserver/configure.ac
-+++ b/gdb/gdbserver/configure.ac
-@@ -195,17 +195,6 @@
- ])
-
- case "${target}" in
-- *-android*)
-- # Starting with NDK version 9, <elf.h> actually includes definitions
-- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
-- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
-- # leading to conflicts with the defintions from <linux/elf.h>.
-- # This makes it impossible for us to include both <elf.h> and
-- # <linux/elf.h>, which means that, in practice, we do not have
-- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
-- # Therefore, do not try to auto-detect availability, as it would
-- # get it wrong on this platform.
-- ;;
- *)
- AC_CHECK_TYPES([Elf32_auxv_t, Elf64_auxv_t], [], [],
- #include <elf.h>
diff --git a/packages/gdb/8.1/chksum b/packages/gdb/8.1/chksum
deleted file mode 100644
index c75924e..0000000
--- a/packages/gdb/8.1/chksum
+++ /dev/null
@@ -1,8 +0,0 @@
-md5 gdb-8.1.tar.xz f46487561f9a16916a8102316f7fd105
-sha1 gdb-8.1.tar.xz 641861f7d3f22b6a23bc3e801f0ff29a78375490
-sha256 gdb-8.1.tar.xz af61a0263858e69c5dce51eab26662ff3d2ad9aa68da9583e8143b5426be4b34
-sha512 gdb-8.1.tar.xz ffd82f415d7652d62dad1716c307836f594217a363429609beb7d70239e8bf06b73b393345b0e000796228e56681ed7656ac3c8be05e91d6d652ab0d5b1dc357
-md5 gdb-8.1.tar.gz 0c85ecbb43569ec43b1c9230622e84ab
-sha1 gdb-8.1.tar.gz b28d9349ccd45c0aa208cda3a1ecf7e17eca0552
-sha256 gdb-8.1.tar.gz e54a2322da050e4b00785370a282b9b8f0b25861ec7cfbbce0115e253eea910e
-sha512 gdb-8.1.tar.gz 4a51e491061f97708ec1cebf9973ea451f9b9499ee2b898fa1631dbe78ffecec9c09e8a95f04c888dee4664957583b1982efd468088878b203a125bbcf9ee516
diff --git a/packages/gdb/8.1/version.desc b/packages/gdb/8.1/version.desc
deleted file mode 100644
index e69de29..0000000
--- a/packages/gdb/8.1/version.desc
+++ /dev/null