summaryrefslogtreecommitdiff
path: root/packages/gdb/8.2
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gdb/8.2')
-rw-r--r--packages/gdb/8.2/0000-musl_fix.patch33
-rw-r--r--packages/gdb/8.2/0001-uclibc-no-gettimeofday-clobber.patch33
-rw-r--r--packages/gdb/8.2/0002-xtensa-make-sure-ar_base-is-initialized.patch30
-rw-r--r--packages/gdb/8.2/0003-WIP-end-of-prologue-detection-hack.patch26
-rw-r--r--packages/gdb/8.2/0004-allow-android.patch45
-rw-r--r--packages/gdb/8.2/chksum8
-rw-r--r--packages/gdb/8.2/version.desc0
7 files changed, 0 insertions, 175 deletions
diff --git a/packages/gdb/8.2/0000-musl_fix.patch b/packages/gdb/8.2/0000-musl_fix.patch
deleted file mode 100644
index 6829780..0000000
--- a/packages/gdb/8.2/0000-musl_fix.patch
+++ /dev/null
@@ -1,33 +0,0 @@
----
- gdb/linux-nat.c | 5 +++++
- gdb/stopcode.h | 4 ++++
- 2 files changed, 9 insertions(+)
-
---- a/gdb/linux-nat.c
-+++ b/gdb/linux-nat.c
-@@ -17,6 +17,7 @@
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>. */
-
-+#include "stopcode.h"
- #include "defs.h"
- #include "inferior.h"
- #include "infrun.h"
-@@ -71,6 +72,10 @@
- #define SPUFS_MAGIC 0x23c9b64e
- #endif
-
-+#ifndef __SIGRTMIN
-+#define __SIGRTMIN SIGRTMIN
-+#endif
-+
- /* This comment documents high-level logic of this file.
-
- Waiting for events in sync mode
---- /dev/null
-+++ b/gdb/stopcode.h
-@@ -0,0 +1,4 @@
-+#ifndef W_STOPCODE
-+#define W_STOPCODE(sig) ((sig) << 8 | 0x7f)
-+#endif
-+
diff --git a/packages/gdb/8.2/0001-uclibc-no-gettimeofday-clobber.patch b/packages/gdb/8.2/0001-uclibc-no-gettimeofday-clobber.patch
deleted file mode 100644
index 3bb6c20..0000000
--- a/packages/gdb/8.2/0001-uclibc-no-gettimeofday-clobber.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Improve gnulib in gdb's guess work, gettimeofday() works in uClibcm promise.
-
-This patch helps building x86_64-unknown-linux-uclibc toolchains, the final
-gdb-native step otherwise fails when linking the libinproctrace.so
-
-Signed-off-by: Joachim Nilsson <troglobit@gmail.com>
-Signed-off-by: Alexey Neyman <stilor@att.net>
-
----
- gdb/gnulib/configure | 1 +
- gdb/gnulib/import/m4/gettimeofday.m4 | 1 +
- 2 files changed, 2 insertions(+)
-
---- a/gdb/gnulib/configure
-+++ b/gdb/gnulib/configure
-@@ -17214,6 +17214,7 @@
- case "$host_os" in
- # Guess all is fine on glibc systems.
- *-gnu*) gl_cv_func_gettimeofday_clobber="guessing no" ;;
-+ *-uclibc*) gl_cv_func_gettimeofday_clobber="guessing no" ;;
- # If we don't know, assume the worst.
- *) gl_cv_func_gettimeofday_clobber="guessing yes" ;;
- esac
---- a/gdb/gnulib/import/m4/gettimeofday.m4
-+++ b/gdb/gnulib/import/m4/gettimeofday.m4
-@@ -111,6 +111,7 @@
- case "$host_os" in
- # Guess all is fine on glibc systems.
- *-gnu*) gl_cv_func_gettimeofday_clobber="guessing no" ;;
-+ *-uclibc*) gl_cv_func_gettimeofday_clobber="guessing no" ;;
- # If we don't know, assume the worst.
- *) gl_cv_func_gettimeofday_clobber="guessing yes" ;;
- esac
diff --git a/packages/gdb/8.2/0002-xtensa-make-sure-ar_base-is-initialized.patch b/packages/gdb/8.2/0002-xtensa-make-sure-ar_base-is-initialized.patch
deleted file mode 100644
index 8c0ffa1..0000000
--- a/packages/gdb/8.2/0002-xtensa-make-sure-ar_base-is-initialized.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 208ea73d38c9c16cf983b6419f58050dbadcb6a9 Mon Sep 17 00:00:00 2001
-From: Max Filippov <jcmvbkbc@gmail.com>
-Date: Sun, 7 Jun 2015 22:43:49 +0300
-Subject: [PATCH 2/2] xtensa: make sure ar_base is initialized
-
-ar_base is uninitialized for cores w/o windowed registers as their
-regmap doesn't have register 0x0100.
-Check that ar_base is initialized and if not initialize it with a0_base.
-
-gdb/
- * xtensa-tdep.c (xtensa_derive_tdep): Make sure ar_base is
- initialized.
-
-Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
----
- gdb/xtensa-tdep.c | 3 +++
- 1 file changed, 3 insertions(+)
-
---- a/gdb/xtensa-tdep.c
-+++ b/gdb/xtensa-tdep.c
-@@ -3151,6 +3151,9 @@
- if (tdep->num_regs == 0)
- tdep->num_regs = tdep->num_nopriv_regs;
-
-+ if (tdep->ar_base == -1)
-+ tdep->ar_base = tdep->a0_base;
-+
- /* Number of pseudo registers. */
- tdep->num_pseudo_regs = n - tdep->num_regs;
-
diff --git a/packages/gdb/8.2/0003-WIP-end-of-prologue-detection-hack.patch b/packages/gdb/8.2/0003-WIP-end-of-prologue-detection-hack.patch
deleted file mode 100644
index dca5a2f..0000000
--- a/packages/gdb/8.2/0003-WIP-end-of-prologue-detection-hack.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 7f8eacbb468575fb67db7fd1155a3aedaa91911b Mon Sep 17 00:00:00 2001
-From: Max Filippov <jcmvbkbc@gmail.com>
-Date: Sun, 7 Jun 2015 23:15:39 +0300
-Subject: [PATCH] WIP: *end of prologue* detection hack
-
-see
- http://www.esp8266.com/viewtopic.php?p=18461#p18461
- http://www.esp8266.com/viewtopic.php?p=19026#p19026
- http://www.esp8266.com/viewtopic.php?p=19683#p19683
-
-Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
----
- gdb/xtensa-tdep.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/gdb/xtensa-tdep.c
-+++ b/gdb/xtensa-tdep.c
-@@ -2399,7 +2399,7 @@
- /* Find out, if we have an information about the prologue from DWARF. */
- prologue_sal = find_pc_line (start, 0);
- if (prologue_sal.line != 0) /* Found debug info. */
-- body_pc = prologue_sal.end;
-+ body_pc = prologue_sal.end + 40;
-
- /* If we are going to analyze the prologue in general without knowing about
- the current PC, make the best assumtion for the end of the prologue. */
diff --git a/packages/gdb/8.2/0004-allow-android.patch b/packages/gdb/8.2/0004-allow-android.patch
deleted file mode 100644
index c14d3df..0000000
--- a/packages/gdb/8.2/0004-allow-android.patch
+++ /dev/null
@@ -1,45 +0,0 @@
----
- gdb/gdbserver/configure | 11 -----------
- gdb/gdbserver/configure.ac | 11 -----------
- 2 files changed, 22 deletions(-)
-
---- a/gdb/gdbserver/configure
-+++ b/gdb/gdbserver/configure
-@@ -7645,17 +7645,6 @@
-
-
- case "${target}" in
-- *-android*)
-- # Starting with NDK version 9, <elf.h> actually includes definitions
-- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
-- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
-- # leading to conflicts with the defintions from <linux/elf.h>.
-- # This makes it impossible for us to include both <elf.h> and
-- # <linux/elf.h>, which means that, in practice, we do not have
-- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
-- # Therefore, do not try to auto-detect availability, as it would
-- # get it wrong on this platform.
-- ;;
- *)
- ac_fn_c_check_type "$LINENO" "Elf32_auxv_t" "ac_cv_type_Elf32_auxv_t" "#include <elf.h>
-
---- a/gdb/gdbserver/configure.ac
-+++ b/gdb/gdbserver/configure.ac
-@@ -193,17 +193,6 @@
- ])
-
- case "${target}" in
-- *-android*)
-- # Starting with NDK version 9, <elf.h> actually includes definitions
-- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
-- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
-- # leading to conflicts with the defintions from <linux/elf.h>.
-- # This makes it impossible for us to include both <elf.h> and
-- # <linux/elf.h>, which means that, in practice, we do not have
-- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
-- # Therefore, do not try to auto-detect availability, as it would
-- # get it wrong on this platform.
-- ;;
- *)
- AC_CHECK_TYPES([Elf32_auxv_t, Elf64_auxv_t], [], [],
- #include <elf.h>
diff --git a/packages/gdb/8.2/chksum b/packages/gdb/8.2/chksum
deleted file mode 100644
index c384f48..0000000
--- a/packages/gdb/8.2/chksum
+++ /dev/null
@@ -1,8 +0,0 @@
-md5 gdb-8.2.tar.xz b5a49dbff00d9a87fbe114d14b3101c0
-sha1 gdb-8.2.tar.xz ee66294d87a109f88a459d0da5d0bb2da5135f45
-sha256 gdb-8.2.tar.xz c3a441a29c7c89720b734e5a9c6289c0a06be7e0c76ef538f7bbcef389347c39
-sha512 gdb-8.2.tar.xz 11cc481bebc51eb6db73249ecb62b8c07455cf3db169f4860b3a83114849fbd2b5860a2db64488ba6c5909cf07b255c04770f1e36059eae6bee16d2a3581be90
-md5 gdb-8.2.tar.gz 0783c6d86775c5aff06cccc8a3d7cad8
-sha1 gdb-8.2.tar.gz 86711a2d14b420b6d7d20418e98c60178fd5a1e0
-sha256 gdb-8.2.tar.gz 847e4b65e5a7b872e86019dd59659029e2b06cae962e0ef345f169dcb4b851b8
-sha512 gdb-8.2.tar.gz 2ce38e6c5e550cb2f9529abd4dd9bf1fcd172fed783cc15cd86950c1eb00f3dfde300942aa4e61d5683ba07e7601de3704e844735a5f26d435ece3ae1d8511fe
diff --git a/packages/gdb/8.2/version.desc b/packages/gdb/8.2/version.desc
deleted file mode 100644
index e69de29..0000000
--- a/packages/gdb/8.2/version.desc
+++ /dev/null