summaryrefslogtreecommitdiff
path: root/packages/glibc-ports/2.13/0008-alpha-fix-rtld-fPIC.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/glibc-ports/2.13/0008-alpha-fix-rtld-fPIC.patch')
-rw-r--r--packages/glibc-ports/2.13/0008-alpha-fix-rtld-fPIC.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/glibc-ports/2.13/0008-alpha-fix-rtld-fPIC.patch b/packages/glibc-ports/2.13/0008-alpha-fix-rtld-fPIC.patch
new file mode 100644
index 0000000..53a0992
--- /dev/null
+++ b/packages/glibc-ports/2.13/0008-alpha-fix-rtld-fPIC.patch
@@ -0,0 +1,19 @@
+2009-05-26 Aurelien Jarno <aurelien@aurel32.net>
+
+ * sysdeps/alpha/Makefile (CFLAGS-rtld.c): add $(PIC-ccflag).
+
+ sysdeps/alpha/Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+--- a/sysdeps/alpha/Makefile
++++ b/sysdeps/alpha/Makefile
+@@ -35,7 +35,8 @@
+
+ ifeq ($(subdir),elf)
+ # The ld.so startup code cannot use literals until it self-relocates.
+-CFLAGS-rtld.c = -mbuild-constants
++# It uses more than 64k for the small data area.
++CFLAGS-rtld.c = -mbuild-constants $(PIC-ccflag)
+ endif
+
+ # Build everything with full IEEE math support, and with dynamic rounding;