summaryrefslogtreecommitdiff
path: root/packages/glibc-ports/2.14.1
diff options
context:
space:
mode:
Diffstat (limited to 'packages/glibc-ports/2.14.1')
-rw-r--r--packages/glibc-ports/2.14.1/0000-Fix-ARM-build-with-GCC-trunk.patch (renamed from packages/glibc-ports/2.14.1/090-Fix-ARM-build-with-GCC-trunk.patch)20
-rw-r--r--packages/glibc-ports/2.14.1/0001-m68k-sys-user.patch (renamed from packages/glibc-ports/2.14.1/330-m68k-sys-user.patch)9
-rw-r--r--packages/glibc-ports/2.14.1/0002-alpha-cache-shape.patch (renamed from packages/glibc-ports/2.14.1/440-alpha-cache-shape.patch)11
-rw-r--r--packages/glibc-ports/2.14.1/0003-alpha-fix-gcc-4.1-warnings.patch (renamed from packages/glibc-ports/2.14.1/460-alpha-fix-gcc-4.1-warnings.patch)7
-rw-r--r--packages/glibc-ports/2.14.1/0004-alpha-fix-rtld-fPIC.patch (renamed from packages/glibc-ports/2.14.1/530-alpha-fix-rtld-fPIC.patch)7
-rw-r--r--packages/glibc-ports/2.14.1/0005-arm-cirrus-ep93xx-maverick-crunch-fpu.patch (renamed from packages/glibc-ports/2.14.1/570-arm-cirrus-ep93xx-maverick-crunch-fpu.patch)69
-rw-r--r--packages/glibc-ports/2.14.1/0006-nptl-lowlevellock.patch (renamed from packages/glibc-ports/2.14.1/580-nptl-lowlevellock.patch)9
-rw-r--r--packages/glibc-ports/2.14.1/0007-fpu-cw-mips.patch (renamed from packages/glibc-ports/2.14.1/610-fpu-cw-mips.patch)9
8 files changed, 77 insertions, 64 deletions
diff --git a/packages/glibc-ports/2.14.1/090-Fix-ARM-build-with-GCC-trunk.patch b/packages/glibc-ports/2.14.1/0000-Fix-ARM-build-with-GCC-trunk.patch
index 259b285..af8d28a 100644
--- a/packages/glibc-ports/2.14.1/090-Fix-ARM-build-with-GCC-trunk.patch
+++ b/packages/glibc-ports/2.14.1/0000-Fix-ARM-build-with-GCC-trunk.patch
@@ -17,14 +17,16 @@ Tested that this fixes the build for ARM.
* sysdeps/unix/sysv/linux/arm/unwind-resume.c (libgcc_s_resume):
Likewise.
---
- sysdeps/unix/sysv/linux/arm/unwind-forcedunwind.c | 3 ++-
- sysdeps/unix/sysv/linux/arm/unwind-resume.c | 3 ++-
- 3 files changed, 11 insertions(+), 2 deletions(-)
+ sysdeps/unix/sysv/linux/arm/eabi/nptl/unwind-forcedunwind.c | 3 ++-
+ sysdeps/unix/sysv/linux/arm/eabi/nptl/unwind-resume.c | 3 ++-
+ sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedunwind.c | 3 ++-
+ sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c | 3 ++-
+ 4 files changed, 8 insertions(+), 4 deletions(-)
--- a/sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedunwind.c
+++ b/sysdeps/unix/sysv/linux/arm/nptl/unwind-forcedunwind.c
@@ -23,7 +23,8 @@
#include <pthreadP.h>
-
+
static void *libgcc_s_handle;
-static void (*libgcc_s_resume) (struct _Unwind_Exception *exc);
+static void (*libgcc_s_resume) (struct _Unwind_Exception *exc)
@@ -32,15 +34,12 @@ Tested that this fixes the build for ARM.
static _Unwind_Reason_Code (*libgcc_s_personality)
(int, _Unwind_Action, _Unwind_Exception_Class, struct _Unwind_Exception *,
struct _Unwind_Context *);
- static _Unwind_Reason_Code (*libgcc_s_forcedunwind)
-diff --git a/sysdeps/unix/sysv/linux/arm/unwind-resume.c b/sysdeps/unix/sysv/linux/arm/unwind-resume.c
-index bff3e2b..1f1eb71 100644
--- a/sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c
+++ b/sysdeps/unix/sysv/linux/arm/nptl/unwind-resume.c
@@ -21,7 +21,8 @@
#include <stdio.h>
#include <unwind.h>
-
+
-static void (*libgcc_s_resume) (struct _Unwind_Exception *exc);
+static void (*libgcc_s_resume) (struct _Unwind_Exception *exc)
+ __attribute_used__;
@@ -51,7 +50,7 @@ index bff3e2b..1f1eb71 100644
+++ b/sysdeps/unix/sysv/linux/arm/eabi/nptl/unwind-forcedunwind.c
@@ -23,7 +23,8 @@
#include <pthreadP.h>
-
+
static void *libgcc_s_handle;
-static void (*libgcc_s_resume) (struct _Unwind_Exception *exc);
+static void (*libgcc_s_resume) (struct _Unwind_Exception *exc)
@@ -64,9 +63,10 @@ index bff3e2b..1f1eb71 100644
@@ -21,7 +21,8 @@
#include <stdio.h>
#include <unwind.h>
-
+
-static void (*libgcc_s_resume) (struct _Unwind_Exception *exc);
+static void (*libgcc_s_resume) (struct _Unwind_Exception *exc)
+ __attribute_used__;
static _Unwind_Reason_Code (*libgcc_s_personality)
(_Unwind_State, struct _Unwind_Exception *, struct _Unwind_Context *);
+
diff --git a/packages/glibc-ports/2.14.1/330-m68k-sys-user.patch b/packages/glibc-ports/2.14.1/0001-m68k-sys-user.patch
index 6476b5c..a03b08d 100644
--- a/packages/glibc-ports/2.14.1/330-m68k-sys-user.patch
+++ b/packages/glibc-ports/2.14.1/0001-m68k-sys-user.patch
@@ -1,8 +1,11 @@
copied from kernel as it is sanitized now
-diff -durN glibc-ports-2.14.1.orig/sysdeps/unix/sysv/linux/m68k/sys/user.h glibc-ports-2.14.1/sysdeps/unix/sysv/linux/m68k/sys/user.h
---- glibc-ports-2.14.1.orig/sysdeps/unix/sysv/linux/m68k/sys/user.h 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/unix/sysv/linux/m68k/sys/user.h 2009-11-13 00:50:31.000000000 +0100
+---
+ sysdeps/unix/sysv/linux/m68k/sys/user.h | 87 ++++++++++++++++++++++++++++++++
+ 1 file changed, 87 insertions(+)
+
+--- a/sysdeps/unix/sysv/linux/m68k/sys/user.h
++++ b/sysdeps/unix/sysv/linux/m68k/sys/user.h
@@ -1,3 +1,90 @@
+#ifndef _SYS_USER_H
+#define _SYS_USER_H
diff --git a/packages/glibc-ports/2.14.1/440-alpha-cache-shape.patch b/packages/glibc-ports/2.14.1/0002-alpha-cache-shape.patch
index 989bfd7..ca608bc 100644
--- a/packages/glibc-ports/2.14.1/440-alpha-cache-shape.patch
+++ b/packages/glibc-ports/2.14.1/0002-alpha-cache-shape.patch
@@ -5,9 +5,12 @@ duplication for static builds with dl-sysdep and dl-support. since dl-sysdep
is both shared/static, there is no point in hooking dl-support anymore, so we
can punt it.
-diff -durN glibc-ports-2.14.1.orig/sysdeps/unix/sysv/linux/alpha/dl-support.c glibc-ports-2.14.1/sysdeps/unix/sysv/linux/alpha/dl-support.c
---- glibc-ports-2.14.1.orig/sysdeps/unix/sysv/linux/alpha/dl-support.c 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/unix/sysv/linux/alpha/dl-support.c 2009-11-13 00:50:53.000000000 +0100
-@@ -1,2 +1,1 @@
+---
+ sysdeps/unix/sysv/linux/alpha/dl-support.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+--- a/sysdeps/unix/sysv/linux/alpha/dl-support.c
++++ b/sysdeps/unix/sysv/linux/alpha/dl-support.c
+@@ -1,2 +1 @@
-#include "dl-auxv.h"
#include <elf/dl-support.c>
diff --git a/packages/glibc-ports/2.14.1/460-alpha-fix-gcc-4.1-warnings.patch b/packages/glibc-ports/2.14.1/0003-alpha-fix-gcc-4.1-warnings.patch
index 2ed4118..fef37a5 100644
--- a/packages/glibc-ports/2.14.1/460-alpha-fix-gcc-4.1-warnings.patch
+++ b/packages/glibc-ports/2.14.1/0003-alpha-fix-gcc-4.1-warnings.patch
@@ -13,12 +13,11 @@ make[3]: *** [/tmp/buildd/glibc-2.3.6/build-tree/alpha-libc/misc/ioperm.o] Error
Hrm. gcc puts .arch ev4 into the .s, and this overrides -mev6 for as.
I cannot really think of anything better than
- ports/sysdeps/unix/sysv/linux/alpha/ioperm.c | 8 ++++----
+ sysdeps/unix/sysv/linux/alpha/ioperm.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
-diff -durN glibc-ports-2.14.1.orig/sysdeps/unix/sysv/linux/alpha/ioperm.c glibc-ports-2.14.1/sysdeps/unix/sysv/linux/alpha/ioperm.c
---- glibc-ports-2.14.1.orig/sysdeps/unix/sysv/linux/alpha/ioperm.c 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/unix/sysv/linux/alpha/ioperm.c 2009-11-13 00:50:57.000000000 +0100
+--- a/sysdeps/unix/sysv/linux/alpha/ioperm.c
++++ b/sysdeps/unix/sysv/linux/alpha/ioperm.c
@@ -178,13 +178,13 @@
static inline void
stb_mb(unsigned char val, unsigned long addr)
diff --git a/packages/glibc-ports/2.14.1/530-alpha-fix-rtld-fPIC.patch b/packages/glibc-ports/2.14.1/0004-alpha-fix-rtld-fPIC.patch
index 56bc532..53a0992 100644
--- a/packages/glibc-ports/2.14.1/530-alpha-fix-rtld-fPIC.patch
+++ b/packages/glibc-ports/2.14.1/0004-alpha-fix-rtld-fPIC.patch
@@ -2,12 +2,11 @@
* sysdeps/alpha/Makefile (CFLAGS-rtld.c): add $(PIC-ccflag).
- ports/sysdeps/alpha/Makefile | 3 ++-
+ sysdeps/alpha/Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
-diff -durN glibc-ports-2.14.1.orig/sysdeps/alpha/Makefile glibc-ports-2.14.1/sysdeps/alpha/Makefile
---- glibc-ports-2.14.1.orig/sysdeps/alpha/Makefile 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/alpha/Makefile 2009-11-13 00:51:13.000000000 +0100
+--- a/sysdeps/alpha/Makefile
++++ b/sysdeps/alpha/Makefile
@@ -35,7 +35,8 @@
ifeq ($(subdir),elf)
diff --git a/packages/glibc-ports/2.14.1/570-arm-cirrus-ep93xx-maverick-crunch-fpu.patch b/packages/glibc-ports/2.14.1/0005-arm-cirrus-ep93xx-maverick-crunch-fpu.patch
index 80032ed..855dde2 100644
--- a/packages/glibc-ports/2.14.1/570-arm-cirrus-ep93xx-maverick-crunch-fpu.patch
+++ b/packages/glibc-ports/2.14.1/0005-arm-cirrus-ep93xx-maverick-crunch-fpu.patch
@@ -1,9 +1,22 @@
http://yann.poupet.free.fr/ep93xx/
Add support for the Maverick Crunch FPU on Cirrus EP93XX processor series
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/bits/endian.h glibc-ports-2.14.1/sysdeps/arm/bits/endian.h
---- glibc-ports-2.14.1.orig/sysdeps/arm/bits/endian.h 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/bits/endian.h 2009-11-13 00:51:22.000000000 +0100
+---
+ sysdeps/arm/bits/endian.h | 2 -
+ sysdeps/arm/fpu/__longjmp.S | 26 +++++++++++++
+ sysdeps/arm/fpu/bits/fenv.h | 41 ++++++++++++++++++++
+ sysdeps/arm/fpu/bits/setjmp.h | 4 ++
+ sysdeps/arm/fpu/fegetround.c | 12 ++++++
+ sysdeps/arm/fpu/fesetround.c | 16 ++++++++
+ sysdeps/arm/fpu/fpu_control.h | 78 ++++++++++++++++++++++++++++++++++++++-
+ sysdeps/arm/fpu/jmpbuf-offsets.h | 4 ++
+ sysdeps/arm/fpu/setjmp.S | 30 +++++++++++++++
+ sysdeps/arm/gccframe.h | 4 ++
+ sysdeps/arm/gmp-mparam.h | 2 -
+ 11 files changed, 216 insertions(+), 3 deletions(-)
+
+--- a/sysdeps/arm/bits/endian.h
++++ b/sysdeps/arm/bits/endian.h
@@ -12,7 +12,7 @@
/* FPA floating point units are always big-endian, irrespective of the
CPU endianness. VFP floating point units use the same endianness
@@ -13,9 +26,8 @@ diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/bits/endian.h glibc-ports-2.14.1/
#define __FLOAT_WORD_ORDER __BYTE_ORDER
#else
#define __FLOAT_WORD_ORDER __BIG_ENDIAN
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/__longjmp.S glibc-ports-2.14.1/sysdeps/arm/fpu/__longjmp.S
---- glibc-ports-2.14.1.orig/sysdeps/arm/fpu/__longjmp.S 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/fpu/__longjmp.S 2009-11-13 00:51:22.000000000 +0100
+--- a/sysdeps/arm/fpu/__longjmp.S
++++ b/sysdeps/arm/fpu/__longjmp.S
@@ -30,7 +30,33 @@
movs r0, r1 /* get the return value in place */
moveq r0, #1 /* can't let setjmp() return zero! */
@@ -50,9 +62,8 @@ diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/__longjmp.S glibc-ports-2.14.
LOADREGS(ia, ip, {v1-v6, sl, fp, sp, pc})
END (__longjmp)
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/bits/fenv.h glibc-ports-2.14.1/sysdeps/arm/fpu/bits/fenv.h
---- glibc-ports-2.14.1.orig/sysdeps/arm/fpu/bits/fenv.h 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/fpu/bits/fenv.h 2009-11-13 00:51:22.000000000 +0100
+--- a/sysdeps/arm/fpu/bits/fenv.h
++++ b/sysdeps/arm/fpu/bits/fenv.h
@@ -20,6 +20,45 @@
# error "Never use <bits/fenv.h> directly; include <fenv.h> instead."
#endif
@@ -108,9 +119,8 @@ diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/bits/fenv.h glibc-ports-2.14.
/* Type representing exception flags. */
typedef unsigned long int fexcept_t;
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/bits/setjmp.h glibc-ports-2.14.1/sysdeps/arm/fpu/bits/setjmp.h
---- glibc-ports-2.14.1.orig/sysdeps/arm/fpu/bits/setjmp.h 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/fpu/bits/setjmp.h 2009-11-13 00:51:22.000000000 +0100
+--- a/sysdeps/arm/fpu/bits/setjmp.h
++++ b/sysdeps/arm/fpu/bits/setjmp.h
@@ -28,7 +28,11 @@
#ifndef _ASM
/* Jump buffer contains v1-v6, sl, fp, sp and pc. Other registers are not
@@ -123,9 +133,8 @@ diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/bits/setjmp.h glibc-ports-2.1
+#endif
#endif
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/fegetround.c glibc-ports-2.14.1/sysdeps/arm/fpu/fegetround.c
---- glibc-ports-2.14.1.orig/sysdeps/arm/fpu/fegetround.c 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/fpu/fegetround.c 2009-11-13 00:51:22.000000000 +0100
+--- a/sysdeps/arm/fpu/fegetround.c
++++ b/sysdeps/arm/fpu/fegetround.c
@@ -18,9 +18,21 @@
02111-1307 USA. */
@@ -148,9 +157,8 @@ diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/fegetround.c glibc-ports-2.14
+
+#endif
}
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/fesetround.c glibc-ports-2.14.1/sysdeps/arm/fpu/fesetround.c
---- glibc-ports-2.14.1.orig/sysdeps/arm/fpu/fesetround.c 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/fpu/fesetround.c 2009-11-13 00:51:22.000000000 +0100
+--- a/sysdeps/arm/fpu/fesetround.c
++++ b/sysdeps/arm/fpu/fesetround.c
@@ -18,12 +18,28 @@
02111-1307 USA. */
@@ -180,9 +188,8 @@ diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/fesetround.c glibc-ports-2.14
}
libm_hidden_def (fesetround)
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/fpu_control.h glibc-ports-2.14.1/sysdeps/arm/fpu/fpu_control.h
---- glibc-ports-2.14.1.orig/sysdeps/arm/fpu/fpu_control.h 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/fpu/fpu_control.h 2009-11-13 00:51:22.000000000 +0100
+--- a/sysdeps/arm/fpu/fpu_control.h
++++ b/sysdeps/arm/fpu/fpu_control.h
@@ -1,5 +1,6 @@
/* FPU control word definitions. ARM version.
- Copyright (C) 1996, 1997, 1998, 2000 Free Software Foundation, Inc.
@@ -278,9 +285,8 @@ diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/fpu_control.h glibc-ports-2.1
+#endif
+
#endif /* _FPU_CONTROL_H */
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/jmpbuf-offsets.h glibc-ports-2.14.1/sysdeps/arm/fpu/jmpbuf-offsets.h
---- glibc-ports-2.14.1.orig/sysdeps/arm/fpu/jmpbuf-offsets.h 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/fpu/jmpbuf-offsets.h 2009-11-13 00:51:22.000000000 +0100
+--- a/sysdeps/arm/fpu/jmpbuf-offsets.h
++++ b/sysdeps/arm/fpu/jmpbuf-offsets.h
@@ -17,4 +17,8 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@@ -290,9 +296,8 @@ diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/jmpbuf-offsets.h glibc-ports-
+#else
#define __JMP_BUF_SP 20
+#endif
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/setjmp.S glibc-ports-2.14.1/sysdeps/arm/fpu/setjmp.S
---- glibc-ports-2.14.1.orig/sysdeps/arm/fpu/setjmp.S 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/fpu/setjmp.S 2009-11-13 00:51:22.000000000 +0100
+--- a/sysdeps/arm/fpu/setjmp.S
++++ b/sysdeps/arm/fpu/setjmp.S
@@ -24,11 +24,41 @@
ENTRY (__sigsetjmp)
@@ -335,9 +340,8 @@ diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/fpu/setjmp.S glibc-ports-2.14.1/s
/* Make a tail call to __sigjmp_save; it takes the same args. */
B PLTJMP(C_SYMBOL_NAME(__sigjmp_save))
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/gccframe.h glibc-ports-2.14.1/sysdeps/arm/gccframe.h
---- glibc-ports-2.14.1.orig/sysdeps/arm/gccframe.h 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/gccframe.h 2009-11-13 00:51:22.000000000 +0100
+--- a/sysdeps/arm/gccframe.h
++++ b/sysdeps/arm/gccframe.h
@@ -17,6 +17,10 @@
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA. */
@@ -349,9 +353,8 @@ diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/gccframe.h glibc-ports-2.14.1/sys
+#endif
#include <sysdeps/generic/gccframe.h>
-diff -durN glibc-ports-2.14.1.orig/sysdeps/arm/gmp-mparam.h glibc-ports-2.14.1/sysdeps/arm/gmp-mparam.h
---- glibc-ports-2.14.1.orig/sysdeps/arm/gmp-mparam.h 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/arm/gmp-mparam.h 2009-11-13 00:51:22.000000000 +0100
+--- a/sysdeps/arm/gmp-mparam.h
++++ b/sysdeps/arm/gmp-mparam.h
@@ -29,7 +29,7 @@
#if defined(__ARMEB__)
# define IEEE_DOUBLE_MIXED_ENDIAN 0
diff --git a/packages/glibc-ports/2.14.1/580-nptl-lowlevellock.patch b/packages/glibc-ports/2.14.1/0006-nptl-lowlevellock.patch
index 62b74d8..55fc78f 100644
--- a/packages/glibc-ports/2.14.1/580-nptl-lowlevellock.patch
+++ b/packages/glibc-ports/2.14.1/0006-nptl-lowlevellock.patch
@@ -9,9 +9,12 @@ In file included from ../nptl/sysdeps/unix/sysv/linux/libc-lowlevellock.c:21:
../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:31: error: for each function it appears in.)
../nptl/sysdeps/unix/sysv/linux/lowlevellock.c:31: error: 'header' undeclared (first use in this function)
-diff -durN glibc-ports-2.14.1.orig/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h glibc-ports-2.14.1/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h
---- glibc-ports-2.14.1.orig/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h 2009-11-13 00:51:23.000000000 +0100
+---
+ sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h
++++ b/sysdeps/unix/sysv/linux/arm/nptl/lowlevellock.h
@@ -25,6 +25,7 @@
#include <atomic.h>
#include <sysdep.h>
diff --git a/packages/glibc-ports/2.14.1/610-fpu-cw-mips.patch b/packages/glibc-ports/2.14.1/0007-fpu-cw-mips.patch
index 4b8365a..5cb8d71 100644
--- a/packages/glibc-ports/2.14.1/610-fpu-cw-mips.patch
+++ b/packages/glibc-ports/2.14.1/0007-fpu-cw-mips.patch
@@ -1,8 +1,11 @@
http://sourceware.org/ml/libc-alpha/2002-10/msg00392.html
-diff -durN glibc-ports-2.14.1.orig/sysdeps/mips/fpu_control.h glibc-ports-2.14.1/sysdeps/mips/fpu_control.h
---- glibc-ports-2.14.1.orig/sysdeps/mips/fpu_control.h 2009-05-16 10:36:20.000000000 +0200
-+++ glibc-ports-2.14.1/sysdeps/mips/fpu_control.h 2009-11-13 00:51:31.000000000 +0100
+---
+ sysdeps/mips/fpu_control.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/sysdeps/mips/fpu_control.h
++++ b/sysdeps/mips/fpu_control.h
@@ -86,7 +86,7 @@
#define _FPU_RC_UP 0x2
#define _FPU_RC_DOWN 0x3