summaryrefslogtreecommitdiff
path: root/packages/glibc/2.24
diff options
context:
space:
mode:
Diffstat (limited to 'packages/glibc/2.24')
-rw-r--r--packages/glibc/2.24/0000-sh-fix-gcc6.patch (renamed from packages/glibc/2.24/110-sh-fix-gcc6.patch)9
-rw-r--r--packages/glibc/2.24/0001-Fix-build-with-enable-static-nss.patch (renamed from packages/glibc/2.24/120-Fix-build-with-enable-static-nss.patch)12
-rw-r--r--packages/glibc/2.24/0002-Fix-combreloc-test-BSD-grep.patch (renamed from packages/glibc/2.24/140-Fix-combreloc-test-BSD-grep.patch)18
-rw-r--r--packages/glibc/2.24/0003-typedef-caddr.patch (renamed from packages/glibc/2.24/910-typedef-caddr.patch)12
-rw-r--r--packages/glibc/2.24/0004-fix-rpc_parse-format.patch (renamed from packages/glibc/2.24/920-fix-rpc_parse-format.patch)8
-rw-r--r--packages/glibc/2.24/0005-explicit-boolean.patch (renamed from packages/glibc/2.24/930-explicit-boolean.patch)8
-rw-r--r--packages/glibc/2.24/0006-nis-bogus-conditional.patch (renamed from packages/glibc/2.24/940-nis-bogus-conditional.patch)8
-rw-r--r--packages/glibc/2.24/0007-regexp-common.patch (renamed from packages/glibc/2.24/997-regexp-common.patch)6
8 files changed, 36 insertions, 45 deletions
diff --git a/packages/glibc/2.24/110-sh-fix-gcc6.patch b/packages/glibc/2.24/0000-sh-fix-gcc6.patch
index cacf390..ef9e31c 100644
--- a/packages/glibc/2.24/110-sh-fix-gcc6.patch
+++ b/packages/glibc/2.24/0000-sh-fix-gcc6.patch
@@ -7,14 +7,12 @@ Subject: [PATCH] sh: conditional is false in dl-conflict.c
Signed-off-by: Alexey Neyman <stilor@att.net>
---
- sysdeps/sh/dl-machine.h | 2 +-
+ sysdeps/sh/dl-machine.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/sysdeps/sh/dl-machine.h b/sysdeps/sh/dl-machine.h
-index 449deea..2b468af 100644
--- a/sysdeps/sh/dl-machine.h
+++ b/sysdeps/sh/dl-machine.h
-@@ -389,7 +389,7 @@ elf_machine_rela (struct link_map *map, const Elf32_Rela *reloc,
+@@ -389,7 +389,7 @@
break;
case R_SH_DIR32:
{
@@ -23,6 +21,3 @@ index 449deea..2b468af 100644
/* This is defined in rtld.c, but nowhere in the static
libc.a; make the reference weak so static programs can
still link. This declaration cannot be done when
---
-2.9.3
-
diff --git a/packages/glibc/2.24/120-Fix-build-with-enable-static-nss.patch b/packages/glibc/2.24/0001-Fix-build-with-enable-static-nss.patch
index 59ab087..32c1ca2 100644
--- a/packages/glibc/2.24/120-Fix-build-with-enable-static-nss.patch
+++ b/packages/glibc/2.24/0001-Fix-build-with-enable-static-nss.patch
@@ -8,15 +8,12 @@ Subject: [PATCH] Fix build with --enable-static-nss
Signed-off-by: Alexey Neyman <stilor@att.net>
---
- ChangeLog | 5 +++++
- nss/nsswitch.c | 2 +-
- 2 files changed, 6 insertions(+), 1 deletion(-)
+ nss/nsswitch.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/nss/nsswitch.c b/nss/nsswitch.c
-index 0a65f6a..8f31658 100644
--- a/nss/nsswitch.c
+++ b/nss/nsswitch.c
-@@ -94,7 +94,7 @@ static name_database *service_table;
+@@ -94,7 +94,7 @@
static name_database_entry *defconfig_entries;
@@ -25,6 +22,3 @@ index 0a65f6a..8f31658 100644
/* Nonzero if this is the nscd process. */
static bool is_nscd;
/* The callback passed to the init functions when nscd is used. */
---
-2.9.3
-
diff --git a/packages/glibc/2.24/140-Fix-combreloc-test-BSD-grep.patch b/packages/glibc/2.24/0002-Fix-combreloc-test-BSD-grep.patch
index fdc3a60..1108df6 100644
--- a/packages/glibc/2.24/140-Fix-combreloc-test-BSD-grep.patch
+++ b/packages/glibc/2.24/0002-Fix-combreloc-test-BSD-grep.patch
@@ -13,16 +13,13 @@ by configure as "not found". As a result, support for "-z combreloc"
Signed-off-by: Alexey Neyman <stilor@att.net>
---
- ChangeLog | 5 +++++
- configure | 2 +-
- configure.ac | 2 +-
- 3 files changed, 7 insertions(+), 2 deletions(-)
+ configure | 2 +-
+ configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
-diff --git a/configure b/configure
-index eecd0ac..0118bd1 100755
--- a/configure
+++ b/configure
-@@ -5804,7 +5804,7 @@ if { ac_try='${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS
+@@ -5532,7 +5532,7 @@
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; }
then
@@ -31,11 +28,9 @@ index eecd0ac..0118bd1 100755
libc_cv_z_combreloc=yes
else
libc_cv_z_combreloc=no
-diff --git a/configure.ac b/configure.ac
-index 4a77411..19f6d87 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1391,7 +1391,7 @@ dnl cross-platform since the gcc used can be a cross compiler. Without
+@@ -1246,7 +1246,7 @@
dnl introducing new options this is not easily doable. Instead use a tool
dnl which always is cross-platform: readelf. To detect whether -z combreloc
dnl look for a section named .rel.dyn.
@@ -44,6 +39,3 @@ index 4a77411..19f6d87 100644
libc_cv_z_combreloc=yes
else
libc_cv_z_combreloc=no
---
-2.9.3
-
diff --git a/packages/glibc/2.24/910-typedef-caddr.patch b/packages/glibc/2.24/0003-typedef-caddr.patch
index fc7979b..980939b 100644
--- a/packages/glibc/2.24/910-typedef-caddr.patch
+++ b/packages/glibc/2.24/0003-typedef-caddr.patch
@@ -1,8 +1,11 @@
-diff -urN glibc-2.23-orig/posix/sys/types.h glibc-2.23/posix/sys/types.h
---- glibc-2.23-orig/posix/sys/types.h 2016-02-18 12:54:00.000000000 -0500
-+++ glibc-2.23/posix/sys/types.h 2017-01-06 11:40:05.842147165 -0500
+---
+ posix/sys/types.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+--- a/posix/sys/types.h
++++ b/posix/sys/types.h
@@ -113,7 +113,10 @@
- #ifdef __USE_MISC
+ #ifdef __USE_MISC
# ifndef __daddr_t_defined
typedef __daddr_t daddr_t;
+# if ! defined(caddr_t) && ! defined(__caddr_t_defined)
@@ -12,4 +15,3 @@ diff -urN glibc-2.23-orig/posix/sys/types.h glibc-2.23/posix/sys/types.h
# define __daddr_t_defined
# endif
#endif
-
diff --git a/packages/glibc/2.24/920-fix-rpc_parse-format.patch b/packages/glibc/2.24/0004-fix-rpc_parse-format.patch
index 37e58da..341d541 100644
--- a/packages/glibc/2.24/920-fix-rpc_parse-format.patch
+++ b/packages/glibc/2.24/0004-fix-rpc_parse-format.patch
@@ -45,11 +45,13 @@ Date: Tue Nov 8 23:44:51 2016 +0000
[$(run-built-tests) = yes] (tests-special): Add $(rpcgen-tests).
[$(run-built-tests) = yes] ($(rpcgen-tests)): New rule.
-diff --git a/sunrpc/rpc_parse.c b/sunrpc/rpc_parse.c
-index 1a1df6d8c2..505a6554cf 100644
+---
+ sunrpc/rpc_parse.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/sunrpc/rpc_parse.c
+++ b/sunrpc/rpc_parse.c
-@@ -521,7 +521,7 @@ static void
+@@ -521,7 +521,7 @@
get_prog_declaration (declaration * dec, defkind dkind, int num /* arg number */ )
{
token tok;
diff --git a/packages/glibc/2.24/930-explicit-boolean.patch b/packages/glibc/2.24/0005-explicit-boolean.patch
index 780fae6..98dc50d 100644
--- a/packages/glibc/2.24/930-explicit-boolean.patch
+++ b/packages/glibc/2.24/0005-explicit-boolean.patch
@@ -7,11 +7,13 @@ Date: Fri Oct 14 12:53:27 2016 -0700
* sysdeps/ieee754/dbl-64/e_pow.c (checkint) Make conditions explicitly
boolean.
-diff --git a/sysdeps/ieee754/dbl-64/e_pow.c b/sysdeps/ieee754/dbl-64/e_pow.c
-index 663fa392c2..bd758b5979 100644
+---
+ sysdeps/ieee754/dbl-64/e_pow.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
--- a/sysdeps/ieee754/dbl-64/e_pow.c
+++ b/sysdeps/ieee754/dbl-64/e_pow.c
-@@ -466,15 +466,15 @@ checkint (double x)
+@@ -466,15 +466,15 @@
return (n & 1) ? -1 : 1; /* odd or even */
if (k > 20)
{
diff --git a/packages/glibc/2.24/940-nis-bogus-conditional.patch b/packages/glibc/2.24/0006-nis-bogus-conditional.patch
index 09b38cf..e728368 100644
--- a/packages/glibc/2.24/940-nis-bogus-conditional.patch
+++ b/packages/glibc/2.24/0006-nis-bogus-conditional.patch
@@ -47,11 +47,13 @@ Date: Wed Dec 21 23:44:01 2016 +0000
* nis/nss_nisplus/nisplus-alias.c (_nss_nisplus_getaliasbyname_r):
Compare name == NULL, not name != NULL.
-diff --git a/nis/nss_nisplus/nisplus-alias.c b/nis/nss_nisplus/nisplus-alias.c
-index 7f698b4e6d..cb5acce01d 100644
+---
+ nis/nss_nisplus/nisplus-alias.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/nis/nss_nisplus/nisplus-alias.c
+++ b/nis/nss_nisplus/nisplus-alias.c
-@@ -291,7 +291,7 @@ _nss_nisplus_getaliasbyname_r (const char *name, struct aliasent *alias,
+@@ -291,7 +291,7 @@
return status;
}
diff --git a/packages/glibc/2.24/997-regexp-common.patch b/packages/glibc/2.24/0007-regexp-common.patch
index 7764c99..89e8371 100644
--- a/packages/glibc/2.24/997-regexp-common.patch
+++ b/packages/glibc/2.24/0007-regexp-common.patch
@@ -32,8 +32,10 @@ Date: Fri Jun 23 14:38:46 2017 -0700
(loc2): Likewise.
(locs): Likewise.
-diff --git a/misc/regexp.c b/misc/regexp.c
-index 19d76c0c37..eaea7c3b89 100644
+---
+ misc/regexp.c | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
--- a/misc/regexp.c
+++ b/misc/regexp.c
@@ -29,14 +29,15 @@