summaryrefslogtreecommitdiff
path: root/packages/glibc/2.25
diff options
context:
space:
mode:
Diffstat (limited to 'packages/glibc/2.25')
-rw-r--r--packages/glibc/2.25/0000-sh-fix-gcc6.patch (renamed from packages/glibc/2.25/110-sh-fix-gcc6.patch)9
-rw-r--r--packages/glibc/2.25/0001-Fix-build-with-enable-static-nss.patch (renamed from packages/glibc/2.25/120-Fix-build-with-enable-static-nss.patch)12
-rw-r--r--packages/glibc/2.25/0002-Fix-combreloc-test-BSD-grep.patch (renamed from packages/glibc/2.25/140-Fix-combreloc-test-BSD-grep.patch)18
-rw-r--r--packages/glibc/2.25/0003-typedef-caddr.patch (renamed from packages/glibc/2.25/910-typedef-caddr.patch)12
-rw-r--r--packages/glibc/2.25/0004-sh4-trap-divdi3.patch (renamed from packages/glibc/2.25/960-sh4-trap-divdi3.patch)49
-rw-r--r--packages/glibc/2.25/0005-sparc-extra-plt-call.patch (renamed from packages/glibc/2.25/961-sparc-extra-plt-call.patch)23
-rw-r--r--packages/glibc/2.25/0006-regexp-common.patch (renamed from packages/glibc/2.25/997-regexp-common.patch)6
7 files changed, 49 insertions, 80 deletions
diff --git a/packages/glibc/2.25/110-sh-fix-gcc6.patch b/packages/glibc/2.25/0000-sh-fix-gcc6.patch
index cacf390..ef9e31c 100644
--- a/packages/glibc/2.25/110-sh-fix-gcc6.patch
+++ b/packages/glibc/2.25/0000-sh-fix-gcc6.patch
@@ -7,14 +7,12 @@ Subject: [PATCH] sh: conditional is false in dl-conflict.c
Signed-off-by: Alexey Neyman <stilor@att.net>
---
- sysdeps/sh/dl-machine.h | 2 +-
+ sysdeps/sh/dl-machine.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/sysdeps/sh/dl-machine.h b/sysdeps/sh/dl-machine.h
-index 449deea..2b468af 100644
--- a/sysdeps/sh/dl-machine.h
+++ b/sysdeps/sh/dl-machine.h
-@@ -389,7 +389,7 @@ elf_machine_rela (struct link_map *map, const Elf32_Rela *reloc,
+@@ -389,7 +389,7 @@
break;
case R_SH_DIR32:
{
@@ -23,6 +21,3 @@ index 449deea..2b468af 100644
/* This is defined in rtld.c, but nowhere in the static
libc.a; make the reference weak so static programs can
still link. This declaration cannot be done when
---
-2.9.3
-
diff --git a/packages/glibc/2.25/120-Fix-build-with-enable-static-nss.patch b/packages/glibc/2.25/0001-Fix-build-with-enable-static-nss.patch
index 59ab087..32c1ca2 100644
--- a/packages/glibc/2.25/120-Fix-build-with-enable-static-nss.patch
+++ b/packages/glibc/2.25/0001-Fix-build-with-enable-static-nss.patch
@@ -8,15 +8,12 @@ Subject: [PATCH] Fix build with --enable-static-nss
Signed-off-by: Alexey Neyman <stilor@att.net>
---
- ChangeLog | 5 +++++
- nss/nsswitch.c | 2 +-
- 2 files changed, 6 insertions(+), 1 deletion(-)
+ nss/nsswitch.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/nss/nsswitch.c b/nss/nsswitch.c
-index 0a65f6a..8f31658 100644
--- a/nss/nsswitch.c
+++ b/nss/nsswitch.c
-@@ -94,7 +94,7 @@ static name_database *service_table;
+@@ -94,7 +94,7 @@
static name_database_entry *defconfig_entries;
@@ -25,6 +22,3 @@ index 0a65f6a..8f31658 100644
/* Nonzero if this is the nscd process. */
static bool is_nscd;
/* The callback passed to the init functions when nscd is used. */
---
-2.9.3
-
diff --git a/packages/glibc/2.25/140-Fix-combreloc-test-BSD-grep.patch b/packages/glibc/2.25/0002-Fix-combreloc-test-BSD-grep.patch
index fdc3a60..43a2b67 100644
--- a/packages/glibc/2.25/140-Fix-combreloc-test-BSD-grep.patch
+++ b/packages/glibc/2.25/0002-Fix-combreloc-test-BSD-grep.patch
@@ -13,16 +13,13 @@ by configure as "not found". As a result, support for "-z combreloc"
Signed-off-by: Alexey Neyman <stilor@att.net>
---
- ChangeLog | 5 +++++
- configure | 2 +-
- configure.ac | 2 +-
- 3 files changed, 7 insertions(+), 2 deletions(-)
+ configure | 2 +-
+ configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
-diff --git a/configure b/configure
-index eecd0ac..0118bd1 100755
--- a/configure
+++ b/configure
-@@ -5804,7 +5804,7 @@ if { ac_try='${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS
+@@ -5804,7 +5804,7 @@
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; }
then
@@ -31,11 +28,9 @@ index eecd0ac..0118bd1 100755
libc_cv_z_combreloc=yes
else
libc_cv_z_combreloc=no
-diff --git a/configure.ac b/configure.ac
-index 4a77411..19f6d87 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1391,7 +1391,7 @@ dnl cross-platform since the gcc used can be a cross compiler. Without
+@@ -1391,7 +1391,7 @@
dnl introducing new options this is not easily doable. Instead use a tool
dnl which always is cross-platform: readelf. To detect whether -z combreloc
dnl look for a section named .rel.dyn.
@@ -44,6 +39,3 @@ index 4a77411..19f6d87 100644
libc_cv_z_combreloc=yes
else
libc_cv_z_combreloc=no
---
-2.9.3
-
diff --git a/packages/glibc/2.25/910-typedef-caddr.patch b/packages/glibc/2.25/0003-typedef-caddr.patch
index fc7979b..980939b 100644
--- a/packages/glibc/2.25/910-typedef-caddr.patch
+++ b/packages/glibc/2.25/0003-typedef-caddr.patch
@@ -1,8 +1,11 @@
-diff -urN glibc-2.23-orig/posix/sys/types.h glibc-2.23/posix/sys/types.h
---- glibc-2.23-orig/posix/sys/types.h 2016-02-18 12:54:00.000000000 -0500
-+++ glibc-2.23/posix/sys/types.h 2017-01-06 11:40:05.842147165 -0500
+---
+ posix/sys/types.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+--- a/posix/sys/types.h
++++ b/posix/sys/types.h
@@ -113,7 +113,10 @@
- #ifdef __USE_MISC
+ #ifdef __USE_MISC
# ifndef __daddr_t_defined
typedef __daddr_t daddr_t;
+# if ! defined(caddr_t) && ! defined(__caddr_t_defined)
@@ -12,4 +15,3 @@ diff -urN glibc-2.23-orig/posix/sys/types.h glibc-2.23/posix/sys/types.h
# define __daddr_t_defined
# endif
#endif
-
diff --git a/packages/glibc/2.25/960-sh4-trap-divdi3.patch b/packages/glibc/2.25/0004-sh4-trap-divdi3.patch
index 99fad46..33b6b15 100644
--- a/packages/glibc/2.25/960-sh4-trap-divdi3.patch
+++ b/packages/glibc/2.25/0004-sh4-trap-divdi3.patch
@@ -80,9 +80,20 @@ Date: Wed Mar 15 15:44:59 2017 -0300
* sysdeps/wordsize-32/symbol-hacks.h: Definitions move to ...
* sysdeps/wordsize-32/divdi3-symbol-hacks.h: ... here.
-diff --git a/sysdeps/i386/symbol-hacks.h b/sysdeps/i386/symbol-hacks.h
-new file mode 100644
-index 0000000000..36a13c83f7
+---
+ sysdeps/i386/symbol-hacks.h | 21 ++++++++++++++
+ sysdeps/m68k/symbol-hacks.h | 21 ++++++++++++++
+ sysdeps/powerpc/powerpc32/symbol-hacks.h | 21 ++++++++++++++
+ sysdeps/s390/s390-32/symbol-hacks.h | 21 ++++++++++++++
+ sysdeps/unix/sysv/linux/i386/Makefile | 5 +++
+ sysdeps/unix/sysv/linux/m68k/Makefile | 5 +++
+ sysdeps/unix/sysv/linux/powerpc/powerpc32/Makefile | 8 +++++
+ sysdeps/unix/sysv/linux/s390/s390-32/Makefile | 8 +++++
+ sysdeps/wordsize-32/Makefile | 7 ----
+ sysdeps/wordsize-32/divdi3-symbol-hacks.h | 31 +++++++++++++++++++++
+ sysdeps/wordsize-32/symbol-hacks.h | 31 ---------------------
+ 11 files changed, 141 insertions(+), 38 deletions(-)
+
--- /dev/null
+++ b/sysdeps/i386/symbol-hacks.h
@@ -0,0 +1,21 @@
@@ -107,9 +118,6 @@ index 0000000000..36a13c83f7
+#include <sysdeps/wordsize-32/divdi3-symbol-hacks.h>
+
+#include_next "symbol-hacks.h"
-diff --git a/sysdeps/m68k/symbol-hacks.h b/sysdeps/m68k/symbol-hacks.h
-new file mode 100644
-index 0000000000..e449d29810
--- /dev/null
+++ b/sysdeps/m68k/symbol-hacks.h
@@ -0,0 +1,21 @@
@@ -134,9 +142,6 @@ index 0000000000..e449d29810
+#include <sysdeps/wordsize-32/divdi3-symbol-hacks.h>
+
+#include_next "symbol-hacks.h"
-diff --git a/sysdeps/powerpc/powerpc32/symbol-hacks.h b/sysdeps/powerpc/powerpc32/symbol-hacks.h
-new file mode 100644
-index 0000000000..dbb3141621
--- /dev/null
+++ b/sysdeps/powerpc/powerpc32/symbol-hacks.h
@@ -0,0 +1,21 @@
@@ -161,9 +166,6 @@ index 0000000000..dbb3141621
+#include <sysdeps/wordsize-32/divdi3-symbol-hacks.h>
+
+#include_next "symbol-hacks.h"
-diff --git a/sysdeps/s390/s390-32/symbol-hacks.h b/sysdeps/s390/s390-32/symbol-hacks.h
-new file mode 100644
-index 0000000000..585c42365a
--- /dev/null
+++ b/sysdeps/s390/s390-32/symbol-hacks.h
@@ -0,0 +1,21 @@
@@ -188,11 +190,9 @@ index 0000000000..585c42365a
+#include <sysdeps/wordsize-32/divdi3-symbol-hacks.h>
+
+#include_next "symbol-hacks.h"
-diff --git a/sysdeps/unix/sysv/linux/i386/Makefile b/sysdeps/unix/sysv/linux/i386/Makefile
-index 6aac0dfe15..4080b8c966 100644
--- a/sysdeps/unix/sysv/linux/i386/Makefile
+++ b/sysdeps/unix/sysv/linux/i386/Makefile
-@@ -26,6 +26,11 @@ endif
+@@ -55,6 +55,11 @@
ifeq ($(subdir),csu)
sysdep-dl-routines += sysdep
@@ -204,11 +204,9 @@ index 6aac0dfe15..4080b8c966 100644
endif
ifeq ($(subdir),nptl)
-diff --git a/sysdeps/unix/sysv/linux/m68k/Makefile b/sysdeps/unix/sysv/linux/m68k/Makefile
-index 5c50ce6927..ce1f696a6f 100644
--- a/sysdeps/unix/sysv/linux/m68k/Makefile
+++ b/sysdeps/unix/sysv/linux/m68k/Makefile
-@@ -4,6 +4,11 @@ m68k-syntax-flag = -DMOTOROLA_SYNTAX
+@@ -4,6 +4,11 @@
ifeq ($(subdir),csu)
sysdep_routines += m68k-helpers
@@ -220,8 +218,6 @@ index 5c50ce6927..ce1f696a6f 100644
endif
ifeq ($(subdir),misc)
-diff --git a/sysdeps/unix/sysv/linux/powerpc/powerpc32/Makefile b/sysdeps/unix/sysv/linux/powerpc/powerpc32/Makefile
-index 3d6c150582..1f45659ed1 100644
--- a/sysdeps/unix/sysv/linux/powerpc/powerpc32/Makefile
+++ b/sysdeps/unix/sysv/linux/powerpc/powerpc32/Makefile
@@ -1,2 +1,10 @@
@@ -235,11 +231,9 @@ index 3d6c150582..1f45659ed1 100644
+CPPFLAGS-divdi3.c = -Din_divdi3_c
+endif
+endif
-diff --git a/sysdeps/unix/sysv/linux/s390/s390-32/Makefile b/sysdeps/unix/sysv/linux/s390/s390-32/Makefile
-index da3b3c76b4..fd8cf92633 100644
--- a/sysdeps/unix/sysv/linux/s390/s390-32/Makefile
+++ b/sysdeps/unix/sysv/linux/s390/s390-32/Makefile
-@@ -21,3 +21,11 @@ endif
+@@ -21,3 +21,11 @@
ifeq ($(subdir),stdlib)
sysdep_routines += __makecontext_ret
endif
@@ -251,9 +245,6 @@ index da3b3c76b4..fd8cf92633 100644
+CPPFLAGS-divdi3.c = -Din_divdi3_c
+endif
+endif
-diff --git a/sysdeps/wordsize-32/Makefile b/sysdeps/wordsize-32/Makefile
-deleted file mode 100644
-index 82beac44ed..0000000000
--- a/sysdeps/wordsize-32/Makefile
+++ /dev/null
@@ -1,7 +0,0 @@
@@ -264,9 +255,6 @@ index 82beac44ed..0000000000
-CPPFLAGS-divdi3.c = -Din_divdi3_c
-endif
-endif
-diff --git a/sysdeps/wordsize-32/divdi3-symbol-hacks.h b/sysdeps/wordsize-32/divdi3-symbol-hacks.h
-new file mode 100644
-index 0000000000..6c90cb796d
--- /dev/null
+++ b/sysdeps/wordsize-32/divdi3-symbol-hacks.h
@@ -0,0 +1,31 @@
@@ -301,9 +289,6 @@ index 0000000000..6c90cb796d
+asm ("__moddi3 = __moddi3_internal");
+asm ("__umoddi3 = __umoddi3_internal");
+#endif
-diff --git a/sysdeps/wordsize-32/symbol-hacks.h b/sysdeps/wordsize-32/symbol-hacks.h
-deleted file mode 100644
-index 0aec1e0b97..0000000000
--- a/sysdeps/wordsize-32/symbol-hacks.h
+++ /dev/null
@@ -1,31 +0,0 @@
diff --git a/packages/glibc/2.25/961-sparc-extra-plt-call.patch b/packages/glibc/2.25/0005-sparc-extra-plt-call.patch
index 3781cf0..7b01b83 100644
--- a/packages/glibc/2.25/961-sparc-extra-plt-call.patch
+++ b/packages/glibc/2.25/0005-sparc-extra-plt-call.patch
@@ -22,11 +22,16 @@ Date: Thu Mar 16 09:15:57 2017 -0300
* sysdeps/sparc/sparc32/sparcv9/udiv.S (.udiv): Likewise.
* sysdeps/sparc/sparc32/udiv.S (.udiv): Likewise.
-diff --git a/sysdeps/sparc/sparc32/Makefile b/sysdeps/sparc/sparc32/Makefile
-index da205898cf..14d6e03c6f 100644
+---
+ sysdeps/sparc/sparc32/Makefile | 6 ++++++
+ sysdeps/sparc/sparc32/sparcv8/udiv.S | 1 +
+ sysdeps/sparc/sparc32/sparcv9/udiv.S | 1 +
+ sysdeps/sparc/sparc32/udiv.S | 1 +
+ 4 files changed, 9 insertions(+)
+
--- a/sysdeps/sparc/sparc32/Makefile
+++ b/sysdeps/sparc/sparc32/Makefile
-@@ -47,3 +47,9 @@ $(divrem:%=$(sysdep_dir)/sparc/sparc32/%.S): $(sysdep_dir)/sparc/sparc32/divrem.
+@@ -47,3 +47,9 @@
mv -f $@-tmp $@
sysdep-realclean := $(sysdep-realclean) $(divrem:%=sysdeps/sparc/sparc32/%.S)
@@ -36,29 +41,23 @@ index da205898cf..14d6e03c6f 100644
+# the exported libc one to __wrap_.udiv and use linker option --wrap to make any
+# call to .udiv to call the wrapper symbol.
+libc.so-gnulib += -Wl,--wrap=.udiv
-diff --git a/sysdeps/sparc/sparc32/sparcv8/udiv.S b/sysdeps/sparc/sparc32/sparcv8/udiv.S
-index d71954351e..e9cab4e4ef 100644
--- a/sysdeps/sparc/sparc32/sparcv8/udiv.S
+++ b/sysdeps/sparc/sparc32/sparcv8/udiv.S
-@@ -13,3 +13,4 @@ ENTRY(.udiv)
+@@ -13,3 +13,4 @@
udiv %o0, %o1, %o0
END(.udiv)
+strong_alias (.udiv, __wrap_.udiv)
-diff --git a/sysdeps/sparc/sparc32/sparcv9/udiv.S b/sysdeps/sparc/sparc32/sparcv9/udiv.S
-index de79899756..368f85ede2 100644
--- a/sysdeps/sparc/sparc32/sparcv9/udiv.S
+++ b/sysdeps/sparc/sparc32/sparcv9/udiv.S
-@@ -15,3 +15,4 @@ ENTRY(.udiv)
+@@ -15,3 +15,4 @@
udiv %o0, %o1, %o0
END(.udiv)
+strong_alias (.udiv, __wrap_.udiv)
-diff --git a/sysdeps/sparc/sparc32/udiv.S b/sysdeps/sparc/sparc32/udiv.S
-index 8dfff66158..ade0afdf40 100644
--- a/sysdeps/sparc/sparc32/udiv.S
+++ b/sysdeps/sparc/sparc32/udiv.S
-@@ -344,3 +344,4 @@ LOC(got_result):
+@@ -344,3 +344,4 @@
mov %o2, %o0
END(.udiv)
diff --git a/packages/glibc/2.25/997-regexp-common.patch b/packages/glibc/2.25/0006-regexp-common.patch
index 7764c99..89e8371 100644
--- a/packages/glibc/2.25/997-regexp-common.patch
+++ b/packages/glibc/2.25/0006-regexp-common.patch
@@ -32,8 +32,10 @@ Date: Fri Jun 23 14:38:46 2017 -0700
(loc2): Likewise.
(locs): Likewise.
-diff --git a/misc/regexp.c b/misc/regexp.c
-index 19d76c0c37..eaea7c3b89 100644
+---
+ misc/regexp.c | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
--- a/misc/regexp.c
+++ b/misc/regexp.c
@@ -29,14 +29,15 @@