summaryrefslogtreecommitdiff
path: root/packages/uClibc-ng/1.0.21
diff options
context:
space:
mode:
Diffstat (limited to 'packages/uClibc-ng/1.0.21')
-rw-r--r--packages/uClibc-ng/1.0.21/110-has-lfs.patch31
-rw-r--r--packages/uClibc-ng/1.0.21/120-module.patch50
-rw-r--r--packages/uClibc-ng/1.0.21/500-no-install-D.patch30
-rw-r--r--packages/uClibc-ng/1.0.21/600-prefer-multilib.patch46
-rw-r--r--packages/uClibc-ng/1.0.21/700-features.h-c11.patch61
-rw-r--r--packages/uClibc-ng/1.0.21/version.desc1
6 files changed, 219 insertions, 0 deletions
diff --git a/packages/uClibc-ng/1.0.21/110-has-lfs.patch b/packages/uClibc-ng/1.0.21/110-has-lfs.patch
new file mode 100644
index 0000000..c5b90de
--- /dev/null
+++ b/packages/uClibc-ng/1.0.21/110-has-lfs.patch
@@ -0,0 +1,31 @@
+From 2a40d18badc4f0bff8c2e02507cd8d59cfeb3e7c Mon Sep 17 00:00:00 2001
+From: Alexey Neyman <stilor@att.net>
+Date: Mon, 23 Jan 2017 14:21:54 -0800
+Subject: [PATCH] Restore UCLIBC_HAS_LFS as "always enabled".
+
+Otherwise, buildroot rejects uClibc-ng in an external toolchain.
+
+Signed-off-by: Alexey Neyman <stilor@att.net>
+---
+ extra/Configs/Config.in | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/extra/Configs/Config.in b/extra/Configs/Config.in
+index a9d62f5..b2cf977 100644
+--- a/extra/Configs/Config.in
++++ b/extra/Configs/Config.in
+@@ -566,6 +566,11 @@ config UCLIBC_HAS_SYSLOG
+ Support sending messages to the system logger.
+ This requires socket-support.
+
++config UCLIBC_HAS_LFS
++ def_bool y
++ help
++ Large file support (always enabled; config symbol retained for
++ feature test to be compatible with uClibc).
+ choice
+ prompt "Malloc Implementation"
+ default MALLOC if ! ARCH_USE_MMU
+--
+2.9.3
+
diff --git a/packages/uClibc-ng/1.0.21/120-module.patch b/packages/uClibc-ng/1.0.21/120-module.patch
new file mode 100644
index 0000000..2e8a989
--- /dev/null
+++ b/packages/uClibc-ng/1.0.21/120-module.patch
@@ -0,0 +1,50 @@
+commit 03884934b32c79da545ef38a42835a6c257b125d
+Author: Waldemar Brodkorb <wbx@uclibc-ng.org>
+Date: Tue Dec 27 09:24:24 2016 +0100
+
+ add init_module/delete_module syscall wrappers
+
+ Add the wrappers unconditionally, because kmod package
+ still uses them.
+
+diff --git a/libc/sysdeps/linux/common/Makefile.in b/libc/sysdeps/linux/common/Makefile.in
+index 595074c..faed6fd 100644
+--- a/libc/sysdeps/linux/common/Makefile.in
++++ b/libc/sysdeps/linux/common/Makefile.in
+@@ -31,6 +31,7 @@ CSRC-$(UCLIBC_LINUX_SPECIFIC) += \
+ ioperm.c \
+ iopl.c \
+ modify_ldt.c \
++ module.c \
+ personality.c \
+ pipe2.c \
+ ppoll.c \
+diff --git a/libc/sysdeps/linux/common/module.c b/libc/sysdeps/linux/common/module.c
+new file mode 100644
+index 0000000..146a43e
+--- /dev/null
++++ b/libc/sysdeps/linux/common/module.c
+@@ -0,0 +1,23 @@
++/*
++ * init_module()/delete_module() for uClibc
++ *
++ * Copyright (C) 2000-2006 Erik Andersen <andersen@uclibc.org>
++ *
++ * Licensed under the LGPL v2.1, see the file COPYING.LIB in this tarball.
++ */
++
++#include <sys/syscall.h>
++
++#ifdef __NR_init_module
++int init_module(void *first, void *second, void *third, void *fourth, void *fifth);
++/* This may have 5 arguments (for old 2.0 kernels) or 2 arguments
++ * (for 2.2 and 2.4 kernels). Use the greatest common denominator,
++ * and let the kernel cope with whatever it gets. It's good at that. */
++_syscall5(int, init_module, void *, first, void *, second, void *, third,
++ void *, fourth, void *, fifth)
++#endif
++
++#ifdef __NR_delete_module
++int delete_module(const char *name, unsigned int flags);
++_syscall2(int, delete_module, const char *, name, unsigned int, flags)
++#endif
diff --git a/packages/uClibc-ng/1.0.21/500-no-install-D.patch b/packages/uClibc-ng/1.0.21/500-no-install-D.patch
new file mode 100644
index 0000000..83d3ff6
--- /dev/null
+++ b/packages/uClibc-ng/1.0.21/500-no-install-D.patch
@@ -0,0 +1,30 @@
+diff -urpN uClibc-ng-1.0.22.orig/utils/Makefile.in uClibc-ng-1.0.22/utils/Makefile.in
+--- uClibc-ng-1.0.22.orig/utils/Makefile.in 2017-03-01 08:27:07.000000000 -0800
++++ uClibc-ng-1.0.22/utils/Makefile.in 2017-03-01 08:43:25.000000000 -0800
+@@ -117,15 +117,22 @@ $(hostutils_OBJ): $(utils_OUT)/%.host :
+ install-y += utils_install
+
+ # This installs both utils and hostutils, so doesn't depend on either.
++$(PREFIX)$(DEVEL_PREFIX)bin $(PREFIX)$(RUNTIME_PREFIX)sbin:
++ $(do_mkdir)
++
++utils_install: $(PREFIX)$(DEVEL_PREFIX)bin
++ifeq ($(HAVE_SHARED),y)
++utils_install: $(PREFIX)$(RUNTIME_PREFIX)sbin
++endif
+
+ utils_install: $(addsuffix $(DOTHOST), $(utils_OBJ) $(utils_LOCALE_OBJ))
+- $(Q)$(INSTALL) -D -m 755 $(utils_OUT)/getconf$(DOTHOST) $(PREFIX)$(DEVEL_PREFIX)bin/getconf
++ $(Q)$(INSTALL) -m 755 $(utils_OUT)/getconf$(DOTHOST) $(PREFIX)$(DEVEL_PREFIX)bin/getconf
+ ifeq ($(HAVE_SHARED),y)
+- $(Q)$(INSTALL) -D -m 755 $(utils_OUT)/ldd$(DOTHOST) $(PREFIX)$(DEVEL_PREFIX)bin/ldd
+- $(Q)$(INSTALL) -D -m 755 $(utils_OUT)/ldconfig$(DOTHOST) $(PREFIX)$(RUNTIME_PREFIX)sbin/ldconfig
++ $(Q)$(INSTALL) -m 755 $(utils_OUT)/ldd$(DOTHOST) $(PREFIX)$(DEVEL_PREFIX)bin/ldd
++ $(Q)$(INSTALL) -m 755 $(utils_OUT)/ldconfig$(DOTHOST) $(PREFIX)$(RUNTIME_PREFIX)sbin/ldconfig
+ endif
+ ifeq ($(UCLIBC_HAS_LOCALE),y)
+- $(Q)$(INSTALL) -D -m 755 $(utils_OUT)/iconv$(DOTHOST) $(PREFIX)$(DEVEL_PREFIX)bin/iconv
++ $(Q)$(INSTALL) -m 755 $(utils_OUT)/iconv$(DOTHOST) $(PREFIX)$(DEVEL_PREFIX)bin/iconv
+ $(Q)$(INSTALL) -m 755 $(utils_OUT)/locale$(DOTHOST) $(PREFIX)$(DEVEL_PREFIX)bin/locale
+ endif
+
diff --git a/packages/uClibc-ng/1.0.21/600-prefer-multilib.patch b/packages/uClibc-ng/1.0.21/600-prefer-multilib.patch
new file mode 100644
index 0000000..4338f9f
--- /dev/null
+++ b/packages/uClibc-ng/1.0.21/600-prefer-multilib.patch
@@ -0,0 +1,46 @@
+diff -urpN uClibc-ng-1.0.22.orig/ldso/ldso/dl-elf.c uClibc-ng-1.0.22/ldso/ldso/dl-elf.c
+--- uClibc-ng-1.0.22.orig/ldso/ldso/dl-elf.c 2017-03-14 12:17:57.754063532 -0700
++++ uClibc-ng-1.0.22/ldso/ldso/dl-elf.c 2017-03-14 17:14:21.846398236 -0700
+@@ -307,6 +307,19 @@ struct elf_resolve *_dl_load_shared_libr
+ }
+ }
+ #endif
++
++#ifdef LDSO_MULTILIB_DIR
++ /* If multilib directory is selected, search it before falling back to
++ standard lib directories. */
++ _dl_if_debug_dprint("\tsearching multilib lib path list\n");
++ tpnt1 = search_for_named_library(libname, rflags,
++ UCLIBC_RUNTIME_PREFIX LDSO_MULTILIB_DIR ":"
++ UCLIBC_RUNTIME_PREFIX "usr" LDSO_MULTILIB_DIR,
++ rpnt, NULL);
++ if (tpnt1 != NULL)
++ return tpnt1;
++#endif
++
+ #if defined SHARED && defined __LDSO_SEARCH_INTERP_PATH__
+ /* Look for libraries wherever the shared library loader
+ * was installed */
+@@ -315,6 +328,7 @@ struct elf_resolve *_dl_load_shared_libr
+ if (tpnt1 != NULL)
+ return tpnt1;
+ #endif
++
+ /* Lastly, search the standard list of paths for the library.
+ This list must exactly match the list in uClibc/ldso/util/ldd.c */
+ _dl_if_debug_dprint("\tsearching full lib path list\n");
+diff -urpN uClibc-ng-1.0.22.orig/ldso/ldso/Makefile.in uClibc-ng-1.0.22/ldso/ldso/Makefile.in
+--- uClibc-ng-1.0.22.orig/ldso/ldso/Makefile.in 2017-03-14 12:17:57.754063532 -0700
++++ uClibc-ng-1.0.22/ldso/ldso/Makefile.in 2017-03-14 15:35:35.277104175 -0700
+@@ -34,6 +34,11 @@ CFLAGS-$(DODEBUG)-ldso/ldso := -O2 -g
+
+ CFLAGS-ldso.c := -DLDSO_ELFINTERP=\"$(TARGET_ARCH)/elfinterp.c\"
+
++# Search non-default multilib directories
++ifneq ($(MULTILIB_DIR),lib)
++CFLAGS-ldso.c += -DLDSO_MULTILIB_DIR=\"$(MULTILIB_DIR)\"
++endif
++
+ ifeq ($(TARGET_ARCH),arc)
+ CFLAGS-ldso.c += -mno-long-calls
+ endif
diff --git a/packages/uClibc-ng/1.0.21/700-features.h-c11.patch b/packages/uClibc-ng/1.0.21/700-features.h-c11.patch
new file mode 100644
index 0000000..cb1d2a8
--- /dev/null
+++ b/packages/uClibc-ng/1.0.21/700-features.h-c11.patch
@@ -0,0 +1,61 @@
+From 5b0f49037e8ea8500b05c8f31ee88529ccac4cee Mon Sep 17 00:00:00 2001
+From: Waldemar Brodkorb <wbx@openadk.org>
+Date: Sun, 7 May 2017 16:28:14 +0200
+Subject: sync features.h with GNU C library, fixes gcc 7.1 toolchain creation
+
+---
+ include/features.h | 17 ++++++++++++-----
+ 1 file changed, 12 insertions(+), 5 deletions(-)
+
+diff --git a/include/features.h b/include/features.h
+index e76bbba..f982079 100644
+--- a/include/features.h
++++ b/include/features.h
+@@ -55,6 +55,7 @@
+ These are defined by this file and are used by the
+ header files to decide what to declare or define:
+
++ __USE_ISOC11 Define ISO C11 things.
+ __USE_ISOC99 Define ISO C99 things.
+ __USE_ISOC95 Define ISO C90 AMD1 (C95) things.
+ __USE_POSIX Define IEEE Std 1003.1 things.
+@@ -91,6 +92,7 @@
+
+
+ /* Undefine everything, so we get a clean slate. */
++#undef __USE_ISOC11
+ #undef __USE_ISOC99
+ #undef __USE_ISOC95
+ #undef __USE_POSIX
+@@ -151,6 +153,8 @@
+ #ifdef _GNU_SOURCE
+ # undef _ISOC99_SOURCE
+ # define _ISOC99_SOURCE 1
++# undef _ISOC11_SOURCE
++# define _ISOC11_SOURCE 1
+ # undef _POSIX_SOURCE
+ # define _POSIX_SOURCE 1
+ # undef _POSIX_C_SOURCE
+@@ -223,11 +227,14 @@
+ # define _SVID_SOURCE 1
+ #endif
+
+-/* This is to enable the ISO C99 extension. Also recognize the old macro
+- which was used prior to the standard acceptance. This macro will
+- eventually go away and the features enabled by default once the ISO C99
+- standard is widely adopted. */
+-#if (defined _ISOC99_SOURCE || defined _ISOC9X_SOURCE \
++/* This is to enable the ISO C11 extension. */
++#if (defined _ISOC11_SOURCE \
++ || (defined __STDC_VERSION__ && __STDC_VERSION__ >= 201112L))
++# define __USE_ISOC11 1
++#endif
++
++/* This is to enable the ISO C99 extension. */
++#if (defined _ISOC99_SOURCE || defined _ISOC11_SOURCE \
+ || (defined __STDC_VERSION__ && __STDC_VERSION__ >= 199901L))
+ # define __USE_ISOC99 1
+ #endif
+--
+cgit v0.11.2-3-g2eb4
+
diff --git a/packages/uClibc-ng/1.0.21/version.desc b/packages/uClibc-ng/1.0.21/version.desc
new file mode 100644
index 0000000..026d275
--- /dev/null
+++ b/packages/uClibc-ng/1.0.21/version.desc
@@ -0,0 +1 @@
+obsolete="yes"