summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-04-04 07:07:45 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-07 19:03:17 (GMT)
commit970811a1c58d22fad37d8cbe2233b8344f358e78 (patch)
tree414e1095de2ae795d543556e14e384f5567fce7e /Makefile.am
parentbb6c97551f7cfafea811367de0a6f382d9aec36b (diff)
Conditionally install bash completion
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index a331832..768a3c5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,8 +6,13 @@ include verbatim-data.mk
SUBDIRS = kconfig
bin_SCRIPTS = ct-ng
-CLEANFILES = $(bin_SCRIPTS)
-EXTRA_DIST = ct-ng.in bootstrap docs/ct-ng.1.in
+CLEANFILES = ct-ng ct-ng.comp docs/ct-ng.1
+EXTRA_DIST = bootstrap ct-ng.in ct-ng.comp.in docs/ct-ng.1.in maintainer
+
+if INSTALL_BASH_COMPLETION
+compdir = $(sysconfdir)/@BASH_COMPLETION_DIR@
+comp_SCRIPTS = ct-ng.comp
+endif
man1_MANS = docs/ct-ng.1
@@ -45,8 +50,11 @@ do_subst = ( @SED@ \
ct-ng: ct-ng.in Makefile
$(AM_V_GEN)$(do_subst) < $< >$@-t && chmod a-w,a+x $@-t && mv -f $@-t $@
-docs/ct-ng.1: docs/ct-ng.1.in
+docs/ct-ng.1: docs/ct-ng.1.in Makefile
$(AM_V_GEN)$(MKDIR_P) docs && $(do_subst) < $< >$@-t && mv -f $@-t $@
+ct-ng.comp: ct-ng.comp.in Makefile
+ $(AM_V_GEN)$(do_subst) < $< >$@-t && mv -f $@-t $@
+
dist-hook: maintainer/download-docs.sh
$< $(top_distdir) $(USER_MANUAL_FILES)