summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-04-03 07:01:17 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-07 19:03:17 (GMT)
commitbb6c97551f7cfafea811367de0a6f382d9aec36b (patch)
tree15291810af95d2e19be89a14be669a532f69c31b /Makefile.am
parent56d785bd006ab823caf39fc16e2ae6833ef2d780 (diff)
User manual installation
... when running from a release tarball. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 22 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e89523c..a331832 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,14 +7,33 @@ SUBDIRS = kconfig
bin_SCRIPTS = ct-ng
CLEANFILES = $(bin_SCRIPTS)
-EXTRA_DIST = ct-ng.in bootstrap
+EXTRA_DIST = ct-ng.in bootstrap docs/ct-ng.1.in
man1_MANS = docs/ct-ng.1
# paths.sh generated by configure
nobase_dist_pkgdata_DATA = $(verbatim_data) paths.sh
-
+USER_MANUAL_FILES = \
+ docs/manual/1_Introduction.md \
+ docs/manual/2_Installation.md \
+ docs/manual/3_Configuration.md \
+ docs/manual/4_Building.md \
+ docs/manual/5_Toolchain_Usage.md \
+ docs/manual/6_Toolchain_Types.md \
+ docs/manual/7_Contributing.md \
+ docs/manual/8_Internals.md \
+ docs/manual/9_Toolchain_Construction.md \
+ docs/manual/A_Credits.md \
+ docs/manual/B_Known_issues.md \
+ docs/manual/C_Setup_OS.md \
+ docs/manual/D_Tutorials_features.md
+
+if INSTALL_USER_MANUAL
+doc_DATA = $(USER_MANUAL_FILES)
+else
+doc_DATA = docs/MANUAL_ONLINE
+endif
do_subst = ( @SED@ \
-e 's,[@]docdir[@],$(docdir),g' \
@@ -30,4 +49,4 @@ docs/ct-ng.1: docs/ct-ng.1.in
$(AM_V_GEN)$(MKDIR_P) docs && $(do_subst) < $< >$@-t && mv -f $@-t $@
dist-hook: maintainer/download-docs.sh
- $< $(top_distdir)
+ $< $(top_distdir) $(USER_MANUAL_FILES)