summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-04-05 06:08:48 (GMT)
committerAlexey Neyman <stilor@att.net>2018-04-07 19:03:17 (GMT)
commitb670aaf1ad5ed2531079a7992b6feb87c0b3b9ea (patch)
tree7fd5eb039394dd936d89bf803bbaf951389f7693 /Makefile.am
parent970811a1c58d22fad37d8cbe2233b8344f358e78 (diff)
Install bash completion into new location
/share/bash-completion/completions rather than /etc/bash_completion.d Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 768a3c5..88ac882 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,12 +6,12 @@ include verbatim-data.mk
SUBDIRS = kconfig
bin_SCRIPTS = ct-ng
-CLEANFILES = ct-ng ct-ng.comp docs/ct-ng.1
-EXTRA_DIST = bootstrap ct-ng.in ct-ng.comp.in docs/ct-ng.1.in maintainer
+CLEANFILES = ct-ng bash-completion/ct-ng docs/ct-ng.1
+EXTRA_DIST = bootstrap ct-ng.in bash-completion/ct-ng.in docs/ct-ng.1.in maintainer
if INSTALL_BASH_COMPLETION
-compdir = $(sysconfdir)/@BASH_COMPLETION_DIR@
-comp_SCRIPTS = ct-ng.comp
+compdir = @BASH_COMPLETION_DIR@
+comp_SCRIPTS = bash-completion/ct-ng
endif
man1_MANS = docs/ct-ng.1
@@ -53,8 +53,8 @@ ct-ng: ct-ng.in Makefile
docs/ct-ng.1: docs/ct-ng.1.in Makefile
$(AM_V_GEN)$(MKDIR_P) docs && $(do_subst) < $< >$@-t && mv -f $@-t $@
-ct-ng.comp: ct-ng.comp.in Makefile
- $(AM_V_GEN)$(do_subst) < $< >$@-t && mv -f $@-t $@
+bash-completion/ct-ng: bash-completion/ct-ng.in Makefile
+ $(AM_V_GEN)$(MKDIR_P) bash-completion && $(do_subst) < $< >$@-t && mv -f $@-t $@
dist-hook: maintainer/download-docs.sh
$< $(top_distdir) $(USER_MANUAL_FILES)