summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-09-27 06:54:55 (GMT)
committerAlexey Neyman <stilor@att.net>2018-09-27 06:54:55 (GMT)
commitd573c1575825de8c47aaeca89db54226ff702924 (patch)
tree9be873831226a624216b0110f945d700b33771c9 /Makefile.am
parent29f0662c188e7126871fa84f6e6f854cda279c89 (diff)
Use 'chmod a-x' instead of 'chmod -x'
There is a subtle difference when executable bit is a part of the umask. And at least some versions (Debian/stretch) fail if the resulting mode would've been different if not for the umask setting. Fixes #998. Although, with such chmods/umasks it is likely that some package installation will break anyway. But I'll leave it until somebody complains. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 84bbe43..5fdee30 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -65,10 +65,10 @@ bash-completion/ct-ng: bash-completion/ct-ng.in Makefile
install-data-hook:
rm -f $(DESTDIR)$(man1dir)/$(ctng_progname).1.gz
gzip -9 $(DESTDIR)$(man1dir)/$(ctng_progname).1
- chmod +x $(DESTDIR)$(pkgdatadir)/scripts/config.guess
- chmod +x $(DESTDIR)$(pkgdatadir)/scripts/config.sub
+ chmod a+x $(DESTDIR)$(pkgdatadir)/scripts/config.guess
+ chmod a+x $(DESTDIR)$(pkgdatadir)/scripts/config.sub
if INSTALL_BASH_COMPLETION
- chmod -x $(DESTDIR)$(compdir)/$(ctng_progname)
+ chmod a-x $(DESTDIR)$(compdir)/$(ctng_progname)
endif
uninstall-hook: