summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-06-07 03:06:04 (GMT)
committerAlexey Neyman <stilor@att.net>2017-06-08 05:38:53 (GMT)
commit1b4e784a0ba636646def1db5ca012fd54ee7a81c (patch)
tree175814b416570817c9a16f3174276ea4cce78bbf /debian/rules
parent10089f3c9aa41bdf12f2ca1d85d052f347dd38d5 (diff)
Fix debuild warnings/errors
- Update .gitignore, do not place .gitignore into directories installed in bulk - Remove executable permissions and shebangs from the scripts that are supposed to be invoked only via ct-ng frontent; prepend them with $(bash). Despite what showSamples.sh said, it already has some bashisms. - Remove --with autotools-dev and override dh_update_autotools_config to avoid having config.{sub,guess} clobbered with older versions - Install bash completion where Debian (now) expects it - Update man page to use .\" as the comment delimiter, instead of undefined macro (."); also, minor text edits. - Install kconfig.mk without execute permission. - Remove shell wrappers from 170-localedef-fix-trampoline.patch, we do not use that for applying patches - Revoke execute permissions on 210-expat.sh - Get flags from dpkg-buildflags if available Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 9315284..b8fd445 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,7 +19,7 @@ include /usr/share/dpkg/default.mk
# main packaging script based on dh7 syntax
%:
- MAKELEVEL=0 dh $@ --with autotools-dev
+ MAKELEVEL=0 dh $@
# Make sure we call ./bootstrap before running dh_auto_configure
override_dh_auto_configure:
@@ -29,4 +29,7 @@ override_dh_auto_configure:
#Make sure to include bash completion file in the package
override_dh_auto_install:
MAKELEVEL=0 dh_auto_install
- install -D ct-ng.comp $$(pwd)/debian/crosstool-ng/etc/bash_completion.d/ct-ng.comp
+ install -D -m 0644 ct-ng.comp $$(pwd)/debian/crosstool-ng/usr/share/bash-completion/completions/ct-ng.comp
+
+override_dh_update_autotools_config:
+ @: