summaryrefslogtreecommitdiff
path: root/packages/gcc/11.2.0
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2022-02-14 08:11:42 (GMT)
committerGitHub <noreply@github.com>2022-02-14 08:11:42 (GMT)
commit681aaef1f1ff39c341fdc529e0db2c14639a58d8 (patch)
treece98c2b3d9648db065d27add325370392a35d584 /packages/gcc/11.2.0
parentba680a3e5b8c62a7c1554e71f6d09903dac95a2f (diff)
parent86c2982568de1ad4d4cc12a65b19231331484405 (diff)
Merge pull request #1674 from stilor/master
Updates to make `ct-ng build-all` pass
Diffstat (limited to 'packages/gcc/11.2.0')
-rw-r--r--packages/gcc/11.2.0/0005-libstdc-Add-nostdinc-for-c-17-sources-PR100017.patch15
-rw-r--r--packages/gcc/11.2.0/0009-Darwin-aarch64-Initial-support-for-the-self-host-dri.patch21
-rw-r--r--packages/gcc/11.2.0/chksum8
3 files changed, 13 insertions, 31 deletions
diff --git a/packages/gcc/11.2.0/0005-libstdc-Add-nostdinc-for-c-17-sources-PR100017.patch b/packages/gcc/11.2.0/0005-libstdc-Add-nostdinc-for-c-17-sources-PR100017.patch
index 8851e98..4a4daf6 100644
--- a/packages/gcc/11.2.0/0005-libstdc-Add-nostdinc-for-c-17-sources-PR100017.patch
+++ b/packages/gcc/11.2.0/0005-libstdc-Add-nostdinc-for-c-17-sources-PR100017.patch
@@ -43,15 +43,13 @@ libstdc++-v3/ChangeLog:
* src/c++17/Makefile.am (AM_CXXFLAGS): Add -nostdinc++.
* src/c++17/Makefile.in: Regenerate.
---
- libstdc++-v3/src/c++17/Makefile.am | 2 +-
- libstdc++-v3/src/c++17/Makefile.in | 2 +-
+ libstdc++-v3/src/c++17/Makefile.am | 2 +-
+ libstdc++-v3/src/c++17/Makefile.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
-diff --git a/libstdc++-v3/src/c++17/Makefile.am b/libstdc++-v3/src/c++17/Makefile.am
-index f08553a1dd78..3d53f652fac9 100644
--- a/libstdc++-v3/src/c++17/Makefile.am
+++ b/libstdc++-v3/src/c++17/Makefile.am
-@@ -79,7 +79,7 @@ endif
+@@ -79,7 +79,7 @@
# OPTIMIZE_CXXFLAGS on the compile line so that -O2 can be overridden
# as the occasion calls for it.
AM_CXXFLAGS = \
@@ -60,11 +58,9 @@ index f08553a1dd78..3d53f652fac9 100644
$(glibcxx_lt_pic_flag) $(glibcxx_compiler_shared_flag) \
$(XTEMPLATE_FLAGS) $(VTV_CXXFLAGS) \
$(WARN_CXXFLAGS) $(OPTIMIZE_CXXFLAGS) $(CONFIG_CXXFLAGS) \
-diff --git a/libstdc++-v3/src/c++17/Makefile.in b/libstdc++-v3/src/c++17/Makefile.in
-index 63984ecd52ad..8c02be6514f8 100644
--- a/libstdc++-v3/src/c++17/Makefile.in
+++ b/libstdc++-v3/src/c++17/Makefile.in
-@@ -455,7 +455,7 @@ libc__17convenience_la_SOURCES = $(sources) $(inst_sources)
+@@ -455,7 +455,7 @@
# OPTIMIZE_CXXFLAGS on the compile line so that -O2 can be overridden
# as the occasion calls for it.
AM_CXXFLAGS = \
@@ -73,6 +69,3 @@ index 63984ecd52ad..8c02be6514f8 100644
$(glibcxx_lt_pic_flag) $(glibcxx_compiler_shared_flag) \
$(XTEMPLATE_FLAGS) $(VTV_CXXFLAGS) \
$(WARN_CXXFLAGS) $(OPTIMIZE_CXXFLAGS) $(CONFIG_CXXFLAGS) \
---
-2.34.1
-
diff --git a/packages/gcc/11.2.0/0009-Darwin-aarch64-Initial-support-for-the-self-host-dri.patch b/packages/gcc/11.2.0/0009-Darwin-aarch64-Initial-support-for-the-self-host-dri.patch
index b237d9d..ab73edb 100644
--- a/packages/gcc/11.2.0/0009-Darwin-aarch64-Initial-support-for-the-self-host-dri.patch
+++ b/packages/gcc/11.2.0/0009-Darwin-aarch64-Initial-support-for-the-self-host-dri.patch
@@ -14,18 +14,16 @@ gcc/ChangeLog:
* config/aarch64/host-aarch64-darwin.c: New file.
* config/aarch64/x-darwin: New file.
---
- gcc/config.host | 7 ++++-
- gcc/config/aarch64/host-aarch64-darwin.c | 33 ++++++++++++++++++++++++
- gcc/config/aarch64/x-darwin | 3 +++
+ gcc/config.host | 7 +++++-
+ gcc/config/aarch64/host-aarch64-darwin.c | 33 +++++++++++++++++++++++++++++++
+ gcc/config/aarch64/x-darwin | 3 ++
3 files changed, 42 insertions(+), 1 deletion(-)
create mode 100644 gcc/config/aarch64/host-aarch64-darwin.c
create mode 100644 gcc/config/aarch64/x-darwin
-diff --git a/gcc/config.host b/gcc/config.host
-index 0a02c33cc80..81ff7ed1043 100644
--- a/gcc/config.host
+++ b/gcc/config.host
-@@ -99,7 +99,8 @@ case ${host} in
+@@ -99,7 +99,8 @@
esac
case ${host} in
@@ -35,7 +33,7 @@ index 0a02c33cc80..81ff7ed1043 100644
case ${target} in
aarch64*-*-*)
host_extra_gcc_objs="driver-aarch64.o"
-@@ -251,6 +252,10 @@ case ${host} in
+@@ -251,6 +252,10 @@
host_extra_gcc_objs="${host_extra_gcc_objs} driver-mingw32.o"
host_lto_plugin_soname=liblto_plugin.dll
;;
@@ -46,9 +44,6 @@ index 0a02c33cc80..81ff7ed1043 100644
i[34567]86-*-darwin* | x86_64-*-darwin*)
out_host_hook_obj="${out_host_hook_obj} host-i386-darwin.o"
host_xmake_file="${host_xmake_file} i386/x-darwin"
-diff --git a/gcc/config/aarch64/host-aarch64-darwin.c b/gcc/config/aarch64/host-aarch64-darwin.c
-new file mode 100644
-index 00000000000..d70f2df3bf1
--- /dev/null
+++ b/gcc/config/aarch64/host-aarch64-darwin.c
@@ -0,0 +1,33 @@
@@ -85,15 +80,9 @@ index 00000000000..d70f2df3bf1
+ exists just to include the generic config/host-darwin.h. */
+
+const struct host_hooks host_hooks = HOST_HOOKS_INITIALIZER;
-diff --git a/gcc/config/aarch64/x-darwin b/gcc/config/aarch64/x-darwin
-new file mode 100644
-index 00000000000..6d788d5e89c
--- /dev/null
+++ b/gcc/config/aarch64/x-darwin
@@ -0,0 +1,3 @@
+host-aarch64-darwin.o : $(srcdir)/config/aarch64/host-aarch64-darwin.c
+ $(COMPILE) $<
+ $(POSTCOMPILE)
---
-2.34.1
-
diff --git a/packages/gcc/11.2.0/chksum b/packages/gcc/11.2.0/chksum
index dcc5d1c..36a02f8 100644
--- a/packages/gcc/11.2.0/chksum
+++ b/packages/gcc/11.2.0/chksum
@@ -1,8 +1,8 @@
-md5 gcc-11.2.0.tar.gz dc6886bd44bb49e2d3d662aed9729278
-sha1 gcc-11.2.0.tar.gz 4d631f343fc3bca2097dbb115f3cb42309a09e22
-sha256 gcc-11.2.0.tar.gz f0837f1bf8244a5cc23bd96ff6366712a791cfae01df8e25b137698aca26efc1
-sha512 gcc-11.2.0.tar.gz 78318318bc2f19dfa9e0e23ffd132758b11785422761eeb7f5c2988cdd0560860d4580142496faa211ba80414bae9b7f3bc55ea968bdd5c1f713d4c5266e2fa3
md5 gcc-11.2.0.tar.xz 31c86f2ced76acac66992eeedce2fce2
sha1 gcc-11.2.0.tar.xz f902ccacecf8949978d6261e9f1d034cff73ffdb
sha256 gcc-11.2.0.tar.xz d08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b
sha512 gcc-11.2.0.tar.xz d53a0a966230895c54f01aea38696f818817b505f1e2bfa65e508753fcd01b2aedb4a61434f41f3a2ddbbd9f41384b96153c684ded3f0fa97c82758d9de5c7cf
+md5 gcc-11.2.0.tar.gz dc6886bd44bb49e2d3d662aed9729278
+sha1 gcc-11.2.0.tar.gz 4d631f343fc3bca2097dbb115f3cb42309a09e22
+sha256 gcc-11.2.0.tar.gz f0837f1bf8244a5cc23bd96ff6366712a791cfae01df8e25b137698aca26efc1
+sha512 gcc-11.2.0.tar.gz 78318318bc2f19dfa9e0e23ffd132758b11785422761eeb7f5c2988cdd0560860d4580142496faa211ba80414bae9b7f3bc55ea968bdd5c1f713d4c5266e2fa3