summaryrefslogtreecommitdiff
path: root/packages/ltrace/0.7.3
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
committerAlexey Neyman <stilor@att.net>2017-12-02 20:44:39 (GMT)
commit98bc4decdeab1361bdc585c86591718fb08c8ffb (patch)
tree4e048ed57988306696efa3c5b81a80d48030e913 /packages/ltrace/0.7.3
parent2a1935f3ad41d360dd3d96a1b0486083293651dd (diff)
Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/ltrace/0.7.3')
-rw-r--r--packages/ltrace/0.7.3/0000-avoid-libstdc++.patch (renamed from packages/ltrace/0.7.3/001-avoid-libstdc++.patch)15
-rw-r--r--packages/ltrace/0.7.3/0001-printf-p.patch (renamed from packages/ltrace/0.7.3/002-printf-p.patch)10
-rw-r--r--packages/ltrace/0.7.3/0002-alpha-debug.h.patch (renamed from packages/ltrace/0.7.3/003-alpha-debug.h.patch)8
-rw-r--r--packages/ltrace/0.7.3/0003-compile-warning.patch (renamed from packages/ltrace/0.7.3/004-compile-warning.patch)17
-rw-r--r--packages/ltrace/0.7.3/0004-sparc-ftbfs.patch (renamed from packages/ltrace/0.7.3/005-sparc-ftbfs.patch)13
-rw-r--r--packages/ltrace/0.7.3/0005-unexpected-breakpoint.patch (renamed from packages/ltrace/0.7.3/006-unexpected-breakpoint.patch)10
-rw-r--r--packages/ltrace/0.7.3/0006-gcc-5.patch (renamed from packages/ltrace/0.7.3/007-gcc-5.patch)11
-rw-r--r--packages/ltrace/0.7.3/0007-glibc-2.24.patch (renamed from packages/ltrace/0.7.3/008-glibc-2.24.patch)11
8 files changed, 62 insertions, 33 deletions
diff --git a/packages/ltrace/0.7.3/001-avoid-libstdc++.patch b/packages/ltrace/0.7.3/0000-avoid-libstdc++.patch
index 9cbf557..300fa3a 100644
--- a/packages/ltrace/0.7.3/001-avoid-libstdc++.patch
+++ b/packages/ltrace/0.7.3/0000-avoid-libstdc++.patch
@@ -5,8 +5,13 @@ Description: avoid warning from dpkg-shlibdeps:
Last-Update: 2013-12-30
---- a/configure.ac 2013-09-17 01:04:28.000000000 +0200
-+++ b/configure.ac 2013-12-30 12:24:20.000000000 +0100
+---
+ configure | 9 +++++++++
+ configure.ac | 9 +++++++++
+ 2 files changed, 18 insertions(+)
+
+--- a/configure.ac
++++ b/configure.ac
@@ -113,6 +113,15 @@
libstdcxx_LIBS=""])
AC_SUBST(libstdcxx_LIBS)
@@ -23,9 +28,9 @@ Last-Update: 2013-12-30
dnl Check security_get_boolean_active availability.
AC_CHECK_HEADERS(selinux/selinux.h)
---- a/configure 2013-09-17 01:07:46.000000000 +0100
-+++ b/configure 2013-12-30 12:34:23.000000000 +0100
-@@ -11826,6 +11826,15 @@
+--- a/configure
++++ b/configure
+@@ -11750,6 +11750,15 @@
diff --git a/packages/ltrace/0.7.3/002-printf-p.patch b/packages/ltrace/0.7.3/0001-printf-p.patch
index 10631d9..6f2b59f 100644
--- a/packages/ltrace/0.7.3/002-printf-p.patch
+++ b/packages/ltrace/0.7.3/0001-printf-p.patch
@@ -5,9 +5,13 @@ Forwarded: http://lists.alioth.debian.org/pipermail/ltrace-devel/2013-September/
Last-Update: 2014-01-02
---- ltrace-0.7.3.orig/printf.c
-+++ ltrace-0.7.3/printf.c
-@@ -168,7 +168,7 @@ form_next_param(struct param_enum *self,
+---
+ printf.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/printf.c
++++ b/printf.c
+@@ -168,7 +168,7 @@
type_init_pointer(infop, array, 1);
} else if (format_type == ARGTYPE_POINTER) {
diff --git a/packages/ltrace/0.7.3/003-alpha-debug.h.patch b/packages/ltrace/0.7.3/0002-alpha-debug.h.patch
index 237026d..f1f0fea 100644
--- a/packages/ltrace/0.7.3/003-alpha-debug.h.patch
+++ b/packages/ltrace/0.7.3/0002-alpha-debug.h.patch
@@ -5,8 +5,12 @@ Last-Update: 2014-01-02
Bug-Debian: http://bugs.debian.org/678721
---- ltrace-0.7.3.orig/sysdeps/linux-gnu/alpha/trace.c
-+++ ltrace-0.7.3/sysdeps/linux-gnu/alpha/trace.c
+---
+ sysdeps/linux-gnu/alpha/trace.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+--- a/sysdeps/linux-gnu/alpha/trace.c
++++ b/sysdeps/linux-gnu/alpha/trace.c
@@ -29,7 +29,6 @@
#include "proc.h"
diff --git a/packages/ltrace/0.7.3/004-compile-warning.patch b/packages/ltrace/0.7.3/0003-compile-warning.patch
index ad65829..44592c6 100644
--- a/packages/ltrace/0.7.3/004-compile-warning.patch
+++ b/packages/ltrace/0.7.3/0003-compile-warning.patch
@@ -4,9 +4,14 @@ Last-Update: 2014-01-02
Forwarded: not-needed
---- ltrace-0.7.3.orig/value.c
-+++ ltrace-0.7.3/value.c
-@@ -284,7 +284,7 @@ value_init_deref(struct value *ret_val,
+---
+ lens_default.c | 2 +-
+ value.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/value.c
++++ b/value.c
+@@ -284,7 +284,7 @@
/* We need "long" to be long enough to hold platform
* pointers. */
@@ -15,9 +20,9 @@ Forwarded: not-needed
value_common_init(ret_val, valp->inferior, valp,
valp->type->u.ptr_info.info, 0);
---- ltrace-0.7.3.orig/lens_default.c
-+++ ltrace-0.7.3/lens_default.c
-@@ -344,7 +344,7 @@ format_array(FILE *stream, struct value
+--- a/lens_default.c
++++ b/lens_default.c
+@@ -344,7 +344,7 @@
{
/* We need "long" to be long enough to cover the whole address
* space. */
diff --git a/packages/ltrace/0.7.3/005-sparc-ftbfs.patch b/packages/ltrace/0.7.3/0004-sparc-ftbfs.patch
index 266a8e6..270e95e 100644
--- a/packages/ltrace/0.7.3/005-sparc-ftbfs.patch
+++ b/packages/ltrace/0.7.3/0004-sparc-ftbfs.patch
@@ -3,8 +3,13 @@ Description: fixes compilation on sparc
Last-Update: 2014-01-02
---- ltrace-0.7.3.orig/sysdeps/linux-gnu/sparc/plt.c
-+++ ltrace-0.7.3/sysdeps/linux-gnu/sparc/plt.c
+---
+ sysdeps/linux-gnu/sparc/plt.c | 3 ++-
+ sysdeps/linux-gnu/sparc/trace.c | 2 ++
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+--- a/sysdeps/linux-gnu/sparc/plt.c
++++ b/sysdeps/linux-gnu/sparc/plt.c
@@ -19,8 +19,9 @@
*/
@@ -16,8 +21,8 @@ Last-Update: 2014-01-02
GElf_Addr
arch_plt_sym_val(struct ltelf *lte, size_t ndx, GElf_Rela * rela) {
---- ltrace-0.7.3.orig/sysdeps/linux-gnu/sparc/trace.c
-+++ ltrace-0.7.3/sysdeps/linux-gnu/sparc/trace.c
+--- a/sysdeps/linux-gnu/sparc/trace.c
++++ b/sysdeps/linux-gnu/sparc/trace.c
@@ -26,8 +26,10 @@
#include <sys/wait.h>
#include <signal.h>
diff --git a/packages/ltrace/0.7.3/006-unexpected-breakpoint.patch b/packages/ltrace/0.7.3/0005-unexpected-breakpoint.patch
index 443bee4..5827cd8 100644
--- a/packages/ltrace/0.7.3/006-unexpected-breakpoint.patch
+++ b/packages/ltrace/0.7.3/0005-unexpected-breakpoint.patch
@@ -4,9 +4,13 @@ Description: continue after unexpected breakpoint
Last-Update: 2014-01-03
---- ltrace-0.7.3.orig/handle_event.c
-+++ ltrace-0.7.3/handle_event.c
-@@ -656,9 +656,12 @@ handle_breakpoint(Event *event)
+---
+ handle_event.c | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+--- a/handle_event.c
++++ b/handle_event.c
+@@ -656,9 +656,12 @@
if ((sbp = address2bpstruct(leader, brk_addr)) != NULL)
breakpoint_on_hit(sbp, event->proc);
diff --git a/packages/ltrace/0.7.3/007-gcc-5.patch b/packages/ltrace/0.7.3/0006-gcc-5.patch
index 4c62f85..78b935d 100644
--- a/packages/ltrace/0.7.3/007-gcc-5.patch
+++ b/packages/ltrace/0.7.3/0006-gcc-5.patch
@@ -7,11 +7,13 @@ Subject: Fix conditions in elf_read_u{16,32,64}
The condition seems to have it all mixed, using both a ! and a
comparison.
-diff --git a/ltrace-elf.c b/ltrace-elf.c
-index 29c204f..0ecdc38 100644
+---
+ ltrace-elf.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
--- a/ltrace-elf.c
+++ b/ltrace-elf.c
-@@ -219,7 +219,7 @@ need_data(Elf_Data *data, GElf_Xword offset, GElf_Xword size)
+@@ -218,7 +218,7 @@
int \
NAME(Elf_Data *data, GElf_Xword offset, uint##SIZE##_t *retp) \
{ \
@@ -20,6 +22,3 @@ index 29c204f..0ecdc38 100644
return -1; \
\
if (data->d_buf == NULL) /* NODATA section */ { \
---
-cgit v0.10.2
-
diff --git a/packages/ltrace/0.7.3/008-glibc-2.24.patch b/packages/ltrace/0.7.3/0007-glibc-2.24.patch
index 85b008b..037376f 100644
--- a/packages/ltrace/0.7.3/008-glibc-2.24.patch
+++ b/packages/ltrace/0.7.3/0007-glibc-2.24.patch
@@ -1,7 +1,10 @@
-diff -urpN ltrace-0.7.3.orig/sysdeps/linux-gnu/proc.c ltrace-0.7.3/sysdeps/linux-gnu/proc.c
---- ltrace-0.7.3.orig/sysdeps/linux-gnu/proc.c 2013-01-02 06:24:46.000000000 -0800
-+++ ltrace-0.7.3/sysdeps/linux-gnu/proc.c 2016-11-13 11:24:32.760365875 -0800
-@@ -240,14 +240,18 @@ process_tasks(pid_t pid, pid_t **ret_tas
+---
+ sysdeps/linux-gnu/proc.c | 16 ++++++++++------
+ 1 file changed, 10 insertions(+), 6 deletions(-)
+
+--- a/sysdeps/linux-gnu/proc.c
++++ b/sysdeps/linux-gnu/proc.c
+@@ -240,14 +240,18 @@
size_t alloc = 0;
while (1) {