summaryrefslogtreecommitdiff
path: root/packages/make
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-09-27 22:10:27 (GMT)
committerAlexey Neyman <stilor@att.net>2018-09-28 18:47:57 (GMT)
commit6ad79d8932d10c77d4288009cf3063691fab6c34 (patch)
tree033cedad5d85a86f04294e89a4ac03ac6fce141a /packages/make
parent5f18c3ed4e3af50f18985def9d7d1f640fd9577f (diff)
Add globbing patches to make from upstream
Fixes #1004. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/make')
-rw-r--r--packages/make/4.2.1/0000-glob-v2.patch39
-rw-r--r--packages/make/4.2.1/0001-glob-v2-gl_lstat.patch64
2 files changed, 103 insertions, 0 deletions
diff --git a/packages/make/4.2.1/0000-glob-v2.patch b/packages/make/4.2.1/0000-glob-v2.patch
new file mode 100644
index 0000000..ad8ddd8
--- /dev/null
+++ b/packages/make/4.2.1/0000-glob-v2.patch
@@ -0,0 +1,39 @@
+commit 48c8a116a914a325a0497721f5d8b58d5bba34d4
+Author: Paul Smith <psmith@gnu.org>
+Date: Sun Nov 19 15:09:16 2017 -0500
+
+ * configure.ac: Support GLIBC glob interface version 2
+
+---
+ configure | 3 +--
+ configure.ac | 3 +--
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -399,10 +399,9 @@
+ #include <glob.h>
+ #include <fnmatch.h>
+
+-#define GLOB_INTERFACE_VERSION 1
+ #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
+ # include <gnu-versions.h>
+-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
++# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
+ gnu glob
+ # endif
+ #endif],
+--- a/configure
++++ b/configure
+@@ -11481,10 +11481,9 @@
+ #include <glob.h>
+ #include <fnmatch.h>
+
+-#define GLOB_INTERFACE_VERSION 1
+ #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
+ # include <gnu-versions.h>
+-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
++# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
+ gnu glob
+ # endif
+ #endif
diff --git a/packages/make/4.2.1/0001-glob-v2-gl_lstat.patch b/packages/make/4.2.1/0001-glob-v2-gl_lstat.patch
new file mode 100644
index 0000000..ae755e3
--- /dev/null
+++ b/packages/make/4.2.1/0001-glob-v2-gl_lstat.patch
@@ -0,0 +1,64 @@
+commit 193f1e81edd6b1b56b0eb0ff8aa4b41c7b4257b4
+Author: Paul Eggert <eggert@cs.ucla.edu>
+Date: Sun Sep 24 09:12:58 2017 -0400
+
+ glob: Do not assume glibc glob internals.
+
+ It has been proposed that glibc glob start using gl_lstat,
+ which the API allows it to do. GNU 'make' should not get in
+ the way of this. See:
+ https://sourceware.org/ml/libc-alpha/2017-09/msg00409.html
+
+ * dir.c (local_lstat): New function, like local_stat.
+ (dir_setup_glob): Use it to initialize gl_lstat too, as the API
+ requires.
+
+---
+ dir.c | 29 +++++++++++++++++++++++++++--
+ 1 file changed, 27 insertions(+), 2 deletions(-)
+
+--- a/dir.c
++++ b/dir.c
+@@ -1299,15 +1299,40 @@
+ }
+ #endif
+
++/* Similarly for lstat. */
++#if !defined(lstat) && !defined(WINDOWS32) || defined(VMS)
++# ifndef VMS
++# ifndef HAVE_SYS_STAT_H
++int lstat (const char *path, struct stat *sbuf);
++# endif
++# else
++ /* We are done with the fake lstat. Go back to the real lstat */
++# ifdef lstat
++# undef lstat
++# endif
++# endif
++# define local_lstat lstat
++#elif defined(WINDOWS32)
++/* Windows doesn't support lstat(). */
++# define local_lstat local_stat
++#else
++static int
++local_lstat (const char *path, struct stat *buf)
++{
++ int e;
++ EINTRLOOP (e, lstat (path, buf));
++ return e;
++}
++#endif
++
+ void
+ dir_setup_glob (glob_t *gl)
+ {
+ gl->gl_opendir = open_dirstream;
+ gl->gl_readdir = read_dirstream;
+ gl->gl_closedir = free;
++ gl->gl_lstat = local_lstat;
+ gl->gl_stat = local_stat;
+- /* We don't bother setting gl_lstat, since glob never calls it.
+- The slot is only there for compatibility with 4.4 BSD. */
+ }
+
+ void