summaryrefslogtreecommitdiff
path: root/packages/make/4.2.1/0000-glob-v2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/make/4.2.1/0000-glob-v2.patch')
-rw-r--r--packages/make/4.2.1/0000-glob-v2.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/make/4.2.1/0000-glob-v2.patch b/packages/make/4.2.1/0000-glob-v2.patch
new file mode 100644
index 0000000..ad8ddd8
--- /dev/null
+++ b/packages/make/4.2.1/0000-glob-v2.patch
@@ -0,0 +1,39 @@
+commit 48c8a116a914a325a0497721f5d8b58d5bba34d4
+Author: Paul Smith <psmith@gnu.org>
+Date: Sun Nov 19 15:09:16 2017 -0500
+
+ * configure.ac: Support GLIBC glob interface version 2
+
+---
+ configure | 3 +--
+ configure.ac | 3 +--
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -399,10 +399,9 @@
+ #include <glob.h>
+ #include <fnmatch.h>
+
+-#define GLOB_INTERFACE_VERSION 1
+ #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
+ # include <gnu-versions.h>
+-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
++# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
+ gnu glob
+ # endif
+ #endif],
+--- a/configure
++++ b/configure
+@@ -11481,10 +11481,9 @@
+ #include <glob.h>
+ #include <fnmatch.h>
+
+-#define GLOB_INTERFACE_VERSION 1
+ #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
+ # include <gnu-versions.h>
+-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
++# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
+ gnu glob
+ # endif
+ #endif