summaryrefslogtreecommitdiff
path: root/packages/binutils/2.36.1/0008-poison-system-directories.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/binutils/2.36.1/0008-poison-system-directories.patch')
-rw-r--r--packages/binutils/2.36.1/0008-poison-system-directories.patch26
1 files changed, 13 insertions, 13 deletions
diff --git a/packages/binutils/2.36.1/0008-poison-system-directories.patch b/packages/binutils/2.36.1/0008-poison-system-directories.patch
index 126e99c..545a1a3 100644
--- a/packages/binutils/2.36.1/0008-poison-system-directories.patch
+++ b/packages/binutils/2.36.1/0008-poison-system-directories.patch
@@ -85,7 +85,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
--- a/ld/configure
+++ b/ld/configure
-@@ -828,6 +828,7 @@ with_lib_path
+@@ -828,6 +828,7 @@
enable_targets
enable_64_bit_bfd
with_sysroot
@@ -93,7 +93,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
enable_gold
enable_got
enable_compressed_debug_sections
-@@ -1496,6 +1497,8 @@ Optional Features:
+@@ -1496,6 +1497,8 @@
--disable-largefile omit support for large files
--enable-targets alternative target configurations
--enable-64-bit-bfd 64-bit support (on hosts with narrower word sizes)
@@ -102,7 +102,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
--enable-gold[=ARG] build gold [ARG={default,yes,no}]
--enable-got=<type> GOT handling scheme (target, single, negative,
multigot)
-@@ -15841,7 +15844,18 @@ else
+@@ -15841,7 +15844,18 @@
fi
@@ -123,7 +123,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
if test "${enable_got+set}" = set; then :
--- a/ld/configure.ac
+++ b/ld/configure.ac
-@@ -94,6 +94,16 @@ AC_SUBST(use_sysroot)
+@@ -94,6 +94,16 @@
AC_SUBST(TARGET_SYSTEM_ROOT)
AC_SUBST(TARGET_SYSTEM_ROOT_DEFINE)
@@ -142,7 +142,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
dnl "installed_linker" is the installed BFD linker name.
--- a/ld/ld.h
+++ b/ld/ld.h
-@@ -161,6 +161,14 @@ typedef struct
+@@ -161,6 +161,14 @@
/* If set, display the target memory usage (per memory region). */
bfd_boolean print_memory_usage;
@@ -159,7 +159,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
in the linker script. */
--- a/ld/ld.texi
+++ b/ld/ld.texi
-@@ -2810,6 +2810,18 @@ string identifying the original linked f
+@@ -2810,6 +2810,18 @@
Passing @code{none} for @var{style} disables the setting from any
@code{--build-id} options earlier on the command line.
@@ -180,7 +180,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
@c man end
--- a/ld/ldfile.c
+++ b/ld/ldfile.c
-@@ -117,6 +117,23 @@ ldfile_add_library_path (const char *nam
+@@ -117,6 +117,23 @@
new_dirs->name = concat (ld_sysroot, name + strlen ("$SYSROOT"), (const char *) NULL);
else
new_dirs->name = xstrdup (name);
@@ -206,7 +206,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
/* Try to open a BFD for a lang_input_statement. */
--- a/ld/ldlex.h
+++ b/ld/ldlex.h
-@@ -161,6 +161,8 @@ enum option_values
+@@ -161,6 +161,8 @@
OPTION_CTF_VARIABLES,
OPTION_NO_CTF_VARIABLES,
OPTION_CTF_SHARE_TYPES,
@@ -217,7 +217,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
/* The initial parser states. */
--- a/ld/ldmain.c
+++ b/ld/ldmain.c
-@@ -323,6 +323,8 @@ main (int argc, char **argv)
+@@ -323,6 +323,8 @@
command_line.warn_mismatch = TRUE;
command_line.warn_search_mismatch = TRUE;
command_line.check_section_addresses = -1;
@@ -228,7 +228,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
COLLECT_NO_DEMANGLE. The gcc collect2 program will demangle the
--- a/ld/lexsup.c
+++ b/ld/lexsup.c
-@@ -591,6 +591,14 @@ static const struct ld_option ld_options
+@@ -591,6 +591,14 @@
" <method> is: share-unconflicted (default),\n"
" share-duplicated"),
TWO_DASHES },
@@ -243,7 +243,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
};
#define OPTION_COUNT ARRAY_SIZE (ld_options)
-@@ -603,6 +611,7 @@ parse_args (unsigned argc, char **argv)
+@@ -603,6 +611,7 @@
int ingroup = 0;
char *default_dirlist = NULL;
char *shortopts;
@@ -251,7 +251,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
struct option *longopts;
struct option *really_longopts;
int last_optind;
-@@ -1633,6 +1642,14 @@ parse_args (unsigned argc, char **argv)
+@@ -1633,6 +1642,14 @@
}
break;
@@ -266,7 +266,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
case OPTION_PUSH_STATE:
input_flags.pushed = xmemdup (&input_flags,
sizeof (input_flags),
-@@ -1778,6 +1795,10 @@ parse_args (unsigned argc, char **argv)
+@@ -1778,6 +1795,10 @@
command_line.soname = NULL;
}