summaryrefslogtreecommitdiff
path: root/packages/binutils/2.36.1
diff options
context:
space:
mode:
Diffstat (limited to 'packages/binutils/2.36.1')
-rw-r--r--packages/binutils/2.36.1/0000-sh-conf.patch4
-rw-r--r--packages/binutils/2.36.1/0001-ld_makefile_patch.patch4
-rw-r--r--packages/binutils/2.36.1/0002-check_ldrunpath_length.patch4
-rw-r--r--packages/binutils/2.36.1/0003-MinGW-w64-winpthreads-doesnt-have-pthread_mutexattr_settype.patch2
-rw-r--r--packages/binutils/2.36.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch18
-rw-r--r--packages/binutils/2.36.1/0006-Darwin-Two-fixes-from-Android-NDK-PTHREAD_ONCE_INIT-wcsncasecmp.patch4
-rw-r--r--packages/binutils/2.36.1/0007-sysroot.patch2
-rw-r--r--packages/binutils/2.36.1/0008-poison-system-directories.patch26
8 files changed, 32 insertions, 32 deletions
diff --git a/packages/binutils/2.36.1/0000-sh-conf.patch b/packages/binutils/2.36.1/0000-sh-conf.patch
index 83d40a0..39a56e1 100644
--- a/packages/binutils/2.36.1/0000-sh-conf.patch
+++ b/packages/binutils/2.36.1/0000-sh-conf.patch
@@ -12,7 +12,7 @@ inept targets than that one, really. Go look, I promise).
--- a/configure
+++ b/configure
-@@ -3887,7 +3887,7 @@ case "${target}" in
+@@ -3887,7 +3887,7 @@
nvptx*-*-*)
noconfigdirs="$noconfigdirs target-libssp target-libstdc++-v3 target-libobjc"
;;
@@ -23,7 +23,7 @@ inept targets than that one, really. Go look, I promise).
;;
--- a/configure.ac
+++ b/configure.ac
-@@ -1177,7 +1177,7 @@ case "${target}" in
+@@ -1177,7 +1177,7 @@
nvptx*-*-*)
noconfigdirs="$noconfigdirs target-libssp target-libstdc++-v3 target-libobjc"
;;
diff --git a/packages/binutils/2.36.1/0001-ld_makefile_patch.patch b/packages/binutils/2.36.1/0001-ld_makefile_patch.patch
index 1c03d02..7c49085 100644
--- a/packages/binutils/2.36.1/0001-ld_makefile_patch.patch
+++ b/packages/binutils/2.36.1/0001-ld_makefile_patch.patch
@@ -5,7 +5,7 @@
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
-@@ -50,7 +50,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CLFAGS)
+@@ -50,7 +50,7 @@
# We put the scripts in the directory $(scriptdir)/ldscripts.
# We can't put the scripts in $(datadir) because the SEARCH_DIR
# directives need to be different for native and cross linkers.
@@ -16,7 +16,7 @@
EMULATION_OFILES = @EMULATION_OFILES@
--- a/ld/Makefile.in
+++ b/ld/Makefile.in
-@@ -561,7 +561,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CLFAGS)
+@@ -561,7 +561,7 @@
# We put the scripts in the directory $(scriptdir)/ldscripts.
# We can't put the scripts in $(datadir) because the SEARCH_DIR
# directives need to be different for native and cross linkers.
diff --git a/packages/binutils/2.36.1/0002-check_ldrunpath_length.patch b/packages/binutils/2.36.1/0002-check_ldrunpath_length.patch
index d54e656..bf30ca9 100644
--- a/packages/binutils/2.36.1/0002-check_ldrunpath_length.patch
+++ b/packages/binutils/2.36.1/0002-check_ldrunpath_length.patch
@@ -4,7 +4,7 @@
--- a/ld/ldelf.c
+++ b/ld/ldelf.c
-@@ -1248,6 +1248,8 @@ ldelf_after_open (int use_libpath, int n
+@@ -1248,6 +1248,8 @@
&& command_line.rpath == NULL)
{
path = (const char *) getenv ("LD_RUN_PATH");
@@ -13,7 +13,7 @@
if (path
&& ldelf_search_needed (path, &n, force,
is_linux, elfsize))
-@@ -1608,6 +1610,8 @@ ldelf_before_allocation (char *audit, ch
+@@ -1608,6 +1610,8 @@
rpath = command_line.rpath;
if (rpath == NULL)
rpath = (const char *) getenv ("LD_RUN_PATH");
diff --git a/packages/binutils/2.36.1/0003-MinGW-w64-winpthreads-doesnt-have-pthread_mutexattr_settype.patch b/packages/binutils/2.36.1/0003-MinGW-w64-winpthreads-doesnt-have-pthread_mutexattr_settype.patch
index c712df5..99dee96 100644
--- a/packages/binutils/2.36.1/0003-MinGW-w64-winpthreads-doesnt-have-pthread_mutexattr_settype.patch
+++ b/packages/binutils/2.36.1/0003-MinGW-w64-winpthreads-doesnt-have-pthread_mutexattr_settype.patch
@@ -4,7 +4,7 @@
--- a/gold/gold-threads.cc
+++ b/gold/gold-threads.cc
-@@ -101,7 +101,7 @@ Lock_impl_threads::Lock_impl_threads()
+@@ -101,7 +101,7 @@
int err = pthread_mutexattr_init(&attr);
if (err != 0)
gold_fatal(_("pthead_mutexattr_init failed: %s"), strerror(err));
diff --git a/packages/binutils/2.36.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch b/packages/binutils/2.36.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch
index 5332426..67bac1f 100644
--- a/packages/binutils/2.36.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch
+++ b/packages/binutils/2.36.1/0004-Dont-link-to-libfl-as-its-unnecessary.patch
@@ -9,7 +9,7 @@
--- a/binutils/configure
+++ b/binutils/configure
-@@ -12811,6 +12811,7 @@ fi
+@@ -12811,6 +12811,7 @@
done
test -n "$YACC" || YACC="yacc"
@@ -17,7 +17,7 @@
for ac_prog in flex lex
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
-@@ -12974,6 +12975,8 @@ esac
+@@ -12974,6 +12975,8 @@
if test "$LEX" = :; then
LEX=${am_missing_run}flex
fi
@@ -28,7 +28,7 @@
# If we haven't got the data from the intl directory,
--- a/binutils/configure.ac
+++ b/binutils/configure.ac
-@@ -110,7 +110,10 @@ if test -z "$host" ; then
+@@ -110,7 +110,10 @@
fi
AC_PROG_YACC
@@ -41,7 +41,7 @@
ZW_GNU_GETTEXT_SISTER_DIR
--- a/gas/configure
+++ b/gas/configure
-@@ -13558,6 +13558,7 @@ fi
+@@ -13558,6 +13558,7 @@
done
test -n "$YACC" || YACC="yacc"
@@ -49,7 +49,7 @@
for ac_prog in flex lex
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
-@@ -13721,6 +13722,8 @@ esac
+@@ -13721,6 +13722,8 @@
if test "$LEX" = :; then
LEX=${am_missing_run}flex
fi
@@ -60,7 +60,7 @@
# If we haven't got the data from the intl directory,
--- a/gas/configure.ac
+++ b/gas/configure.ac
-@@ -931,7 +931,10 @@ AC_DEFINE_UNQUOTED(TARGET_VENDOR, "${tar
+@@ -931,7 +931,10 @@
AC_DEFINE_UNQUOTED(TARGET_OS, "${target_os}", [Target OS.])
AC_PROG_YACC
@@ -73,7 +73,7 @@
ZW_GNU_GETTEXT_SISTER_DIR
--- a/ld/configure
+++ b/ld/configure
-@@ -16623,6 +16623,7 @@ fi
+@@ -16623,6 +16623,7 @@
done
test -n "$YACC" || YACC="yacc"
@@ -81,7 +81,7 @@
for ac_prog in flex lex
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
-@@ -16786,6 +16787,8 @@ esac
+@@ -16786,6 +16787,8 @@
if test "$LEX" = :; then
LEX=${am_missing_run}flex
fi
@@ -92,7 +92,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable maintainer-specific portions of Makefiles" >&5
--- a/ld/configure.ac
+++ b/ld/configure.ac
-@@ -269,7 +269,10 @@ AM_PO_SUBDIRS
+@@ -269,7 +269,10 @@
AC_EXEEXT
AC_PROG_YACC
diff --git a/packages/binutils/2.36.1/0006-Darwin-Two-fixes-from-Android-NDK-PTHREAD_ONCE_INIT-wcsncasecmp.patch b/packages/binutils/2.36.1/0006-Darwin-Two-fixes-from-Android-NDK-PTHREAD_ONCE_INIT-wcsncasecmp.patch
index 87d047c..6d86900 100644
--- a/packages/binutils/2.36.1/0006-Darwin-Two-fixes-from-Android-NDK-PTHREAD_ONCE_INIT-wcsncasecmp.patch
+++ b/packages/binutils/2.36.1/0006-Darwin-Two-fixes-from-Android-NDK-PTHREAD_ONCE_INIT-wcsncasecmp.patch
@@ -15,7 +15,7 @@ Change-Id: I69204a72f853f5263dffedc448379d75ed4eca2e
--- a/bfd/peXXigen.c
+++ b/bfd/peXXigen.c
-@@ -3589,6 +3589,28 @@ u16_mbtouc (wchar_t * puc, const unsigne
+@@ -3589,6 +3589,28 @@
}
#endif /* HAVE_WCHAR_H and not Cygwin/Mingw */
@@ -46,7 +46,7 @@ Change-Id: I69204a72f853f5263dffedc448379d75ed4eca2e
rsrc_cmp (bfd_boolean is_name, rsrc_entry * a, rsrc_entry * b)
--- a/gold/gold-threads.cc
+++ b/gold/gold-threads.cc
-@@ -284,9 +284,18 @@ Condvar::~Condvar()
+@@ -284,9 +284,18 @@
class Once_initialize
{
public:
diff --git a/packages/binutils/2.36.1/0007-sysroot.patch b/packages/binutils/2.36.1/0007-sysroot.patch
index c98f147..0140fe8 100644
--- a/packages/binutils/2.36.1/0007-sysroot.patch
+++ b/packages/binutils/2.36.1/0007-sysroot.patch
@@ -11,7 +11,7 @@ http://sourceware.org/bugzilla/show_bug.cgi?id=10340
--- a/ld/ldfile.c
+++ b/ld/ldfile.c
-@@ -340,18 +340,25 @@ ldfile_open_file_search (const char *arc
+@@ -340,18 +340,25 @@
directory first. */
if (!entry->flags.maybe_archive)
{
diff --git a/packages/binutils/2.36.1/0008-poison-system-directories.patch b/packages/binutils/2.36.1/0008-poison-system-directories.patch
index 126e99c..545a1a3 100644
--- a/packages/binutils/2.36.1/0008-poison-system-directories.patch
+++ b/packages/binutils/2.36.1/0008-poison-system-directories.patch
@@ -85,7 +85,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
--- a/ld/configure
+++ b/ld/configure
-@@ -828,6 +828,7 @@ with_lib_path
+@@ -828,6 +828,7 @@
enable_targets
enable_64_bit_bfd
with_sysroot
@@ -93,7 +93,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
enable_gold
enable_got
enable_compressed_debug_sections
-@@ -1496,6 +1497,8 @@ Optional Features:
+@@ -1496,6 +1497,8 @@
--disable-largefile omit support for large files
--enable-targets alternative target configurations
--enable-64-bit-bfd 64-bit support (on hosts with narrower word sizes)
@@ -102,7 +102,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
--enable-gold[=ARG] build gold [ARG={default,yes,no}]
--enable-got=<type> GOT handling scheme (target, single, negative,
multigot)
-@@ -15841,7 +15844,18 @@ else
+@@ -15841,7 +15844,18 @@
fi
@@ -123,7 +123,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
if test "${enable_got+set}" = set; then :
--- a/ld/configure.ac
+++ b/ld/configure.ac
-@@ -94,6 +94,16 @@ AC_SUBST(use_sysroot)
+@@ -94,6 +94,16 @@
AC_SUBST(TARGET_SYSTEM_ROOT)
AC_SUBST(TARGET_SYSTEM_ROOT_DEFINE)
@@ -142,7 +142,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
dnl "installed_linker" is the installed BFD linker name.
--- a/ld/ld.h
+++ b/ld/ld.h
-@@ -161,6 +161,14 @@ typedef struct
+@@ -161,6 +161,14 @@
/* If set, display the target memory usage (per memory region). */
bfd_boolean print_memory_usage;
@@ -159,7 +159,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
in the linker script. */
--- a/ld/ld.texi
+++ b/ld/ld.texi
-@@ -2810,6 +2810,18 @@ string identifying the original linked f
+@@ -2810,6 +2810,18 @@
Passing @code{none} for @var{style} disables the setting from any
@code{--build-id} options earlier on the command line.
@@ -180,7 +180,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
@c man end
--- a/ld/ldfile.c
+++ b/ld/ldfile.c
-@@ -117,6 +117,23 @@ ldfile_add_library_path (const char *nam
+@@ -117,6 +117,23 @@
new_dirs->name = concat (ld_sysroot, name + strlen ("$SYSROOT"), (const char *) NULL);
else
new_dirs->name = xstrdup (name);
@@ -206,7 +206,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
/* Try to open a BFD for a lang_input_statement. */
--- a/ld/ldlex.h
+++ b/ld/ldlex.h
-@@ -161,6 +161,8 @@ enum option_values
+@@ -161,6 +161,8 @@
OPTION_CTF_VARIABLES,
OPTION_NO_CTF_VARIABLES,
OPTION_CTF_SHARE_TYPES,
@@ -217,7 +217,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
/* The initial parser states. */
--- a/ld/ldmain.c
+++ b/ld/ldmain.c
-@@ -323,6 +323,8 @@ main (int argc, char **argv)
+@@ -323,6 +323,8 @@
command_line.warn_mismatch = TRUE;
command_line.warn_search_mismatch = TRUE;
command_line.check_section_addresses = -1;
@@ -228,7 +228,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
COLLECT_NO_DEMANGLE. The gcc collect2 program will demangle the
--- a/ld/lexsup.c
+++ b/ld/lexsup.c
-@@ -591,6 +591,14 @@ static const struct ld_option ld_options
+@@ -591,6 +591,14 @@
" <method> is: share-unconflicted (default),\n"
" share-duplicated"),
TWO_DASHES },
@@ -243,7 +243,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
};
#define OPTION_COUNT ARRAY_SIZE (ld_options)
-@@ -603,6 +611,7 @@ parse_args (unsigned argc, char **argv)
+@@ -603,6 +611,7 @@
int ingroup = 0;
char *default_dirlist = NULL;
char *shortopts;
@@ -251,7 +251,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
struct option *longopts;
struct option *really_longopts;
int last_optind;
-@@ -1633,6 +1642,14 @@ parse_args (unsigned argc, char **argv)
+@@ -1633,6 +1642,14 @@
}
break;
@@ -266,7 +266,7 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
case OPTION_PUSH_STATE:
input_flags.pushed = xmemdup (&input_flags,
sizeof (input_flags),
-@@ -1778,6 +1795,10 @@ parse_args (unsigned argc, char **argv)
+@@ -1778,6 +1795,10 @@
command_line.soname = NULL;
}