summaryrefslogtreecommitdiff
path: root/packages/make/4.2.1/0000-glob-v2.patch
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-09-27 22:10:27 (GMT)
committerAlexey Neyman <stilor@att.net>2018-09-28 18:47:57 (GMT)
commit6ad79d8932d10c77d4288009cf3063691fab6c34 (patch)
tree033cedad5d85a86f04294e89a4ac03ac6fce141a /packages/make/4.2.1/0000-glob-v2.patch
parent5f18c3ed4e3af50f18985def9d7d1f640fd9577f (diff)
Add globbing patches to make from upstream
Fixes #1004. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/make/4.2.1/0000-glob-v2.patch')
-rw-r--r--packages/make/4.2.1/0000-glob-v2.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/make/4.2.1/0000-glob-v2.patch b/packages/make/4.2.1/0000-glob-v2.patch
new file mode 100644
index 0000000..ad8ddd8
--- /dev/null
+++ b/packages/make/4.2.1/0000-glob-v2.patch
@@ -0,0 +1,39 @@
+commit 48c8a116a914a325a0497721f5d8b58d5bba34d4
+Author: Paul Smith <psmith@gnu.org>
+Date: Sun Nov 19 15:09:16 2017 -0500
+
+ * configure.ac: Support GLIBC glob interface version 2
+
+---
+ configure | 3 +--
+ configure.ac | 3 +--
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -399,10 +399,9 @@
+ #include <glob.h>
+ #include <fnmatch.h>
+
+-#define GLOB_INTERFACE_VERSION 1
+ #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
+ # include <gnu-versions.h>
+-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
++# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
+ gnu glob
+ # endif
+ #endif],
+--- a/configure
++++ b/configure
+@@ -11481,10 +11481,9 @@
+ #include <glob.h>
+ #include <fnmatch.h>
+
+-#define GLOB_INTERFACE_VERSION 1
+ #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
+ # include <gnu-versions.h>
+-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
++# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
+ gnu glob
+ # endif
+ #endif